Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361509 - media-video/motion-3.2.11.1[v4l] fails to build with linux-headers-2.6.38
Summary: media-video/motion-3.2.11.1[v4l] fails to build with linux-headers-2.6.38
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
: 376019 (view as bug list)
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-03-31 18:27 UTC by Samuli Suominen
Modified: 2011-11-14 03:20 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuli Suominen gentoo-dev 2011-03-31 18:27:56 UTC
Happens with USE="v4l":

x86_64-pc-linux-gnu-gcc -march=core2 -O2 -msse4.1 -pipe -D_REENTRANT -DMOTION_V4L2 -DMOTION_V4L2_OLD -DTYPE_32BIT="int" -DHAVE_BSWAP    -Wall -DVERSION=\""3.2.11.1"\" -Dsysconfdir=\"/etc\"    -c -o netcam.o netcam.c
In file included from jpegutils.c:31:0:
motion.h:43:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.


If you build with USE="-v4l", then motion will only support IP based cameras. But the package *DOES HAVE* v4l2 (videodev2.h) support too, so it just means the v4lv1 and v4lv2 needs to be separate into their own configure flags etc. in the sources
Comment 1 David 2011-05-18 22:25:35 UTC
Is there any update/workaround to solve this issue?

Cheers
Comment 2 Neil Bothwick 2011-05-18 22:54:22 UTC
According to http://www.lavrsen.dk/foswiki/bin/view/Motion/BugReport2011x04x06x071405 a patch to separate v4l and v4l2 in configure is in svn but not yet in a release. For now, I have to work around this by masking >=linux-headers-2.6.28.
Comment 3 David 2011-05-19 14:39:25 UTC
Understood! Thanks for the quick reply.
Comment 4 Samuli Suominen gentoo-dev 2011-05-19 22:48:51 UTC
Worked around in 3.2.12's ebuild.   Feel free to open a new bug for requesting adding motion svn snapshot to tree...
Comment 5 Neil Bothwick 2011-05-24 10:52:29 UTC
I wasn't suggesting an svn ebuild, but hoping that this particular fix could be implemented in 3.1.12. the current fix merely brute forces all V4L and V4L2 support off.
Comment 6 Samuli Suominen gentoo-dev 2011-07-24 14:44:33 UTC
*** Bug 376019 has been marked as a duplicate of this bug. ***
Comment 7 Ciprian Ciubotariu 2011-11-14 03:20:00 UTC
I believe this bug should be reopened, and the v4l flag be removed/masked for the appropriate ebuild. The warning placed at the end of the ebuild is not at all sufficient.

 I have been trying to get my camera working with motion the whole evening.