Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359747 - media-video/mjpegtools-1.9.0-r1 won't compile against linux-headers 2.6.38 due to V4L1 removal
Summary: media-video/mjpegtools-1.9.0-r1 won't compile against linux-headers 2.6.38 du...
Status: RESOLVED DUPLICATE of bug 359491
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-03-21 13:03 UTC by Billy DeVincentis
Modified: 2011-03-21 13:21 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2011-03-21 13:03:31 UTC
checking for getopt_long... yes
checking return type of signal handlers... void
configure: The host is x86_64-pc-linux-gnu  x86_64  pc  linux-gnu .
checking for alpha architecture... no
checking linux/videodev.h usability... no
checking linux/videodev.h presence... no
checking for linux/videodev.h... no
configure: error: videodev.h not found - please install the linux kernel headers

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-video/mjpegtools-1.9.0-r1/work/mjpegtools-1.9.0/config.log
 * ERROR: media-video/mjpegtools-1.9.0-r1 failed (compile phase):
 *   econf failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 2896:  Called econf '--with-x' '--enable-xfree-ext' '--with-libquicktime' '--with-libpng' '--with-v4l' '--with-gtk' '--with-sdl' '--with-libdv=/usr' '--enable-simd-accel' '--enable-largefile' '--without-jpeg-mmx'
 *     ebuild.sh, line  557:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 * 
 * If you need support, post the output of 'emerge --info =media-video/mjpegtools-1.9.0-r1',
 * the complete build log and the output of 'emerge -pqv =media-video/mjpegtools-1.9.0-r1'.
 * The complete build log is located at '/var/tmp/portage/media-video/mjpegtools-1.9.0-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/mjpegtools-1.9.0-r1/temp/environment'.
 * S: '/var/tmp/portage/media-video/mjpegtools-1.9.0-r1/work/mjpegtools-1.9.0'

>>> Failed to emerge media-video/mjpegtools-1.9.0-r1, Log file:

>>>  '/var/tmp/portage/media-video/mjpegtools-1.9.0-r1/temp/build.log'
 * 
 * The following package has failed to build or install:
 * 
 *  (media-video/mjpegtools-1.9.0-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-video/mjpegtools-1.9.0-r1/temp/build.log'


Reproducible: Always




emerge --info
Portage 2.2.0_alpha28 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_870_@_2.93GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 20 Mar 2011 11:00:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo miscellaneous
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi aften akonadi alsa amarok amd64 amrnb archive ares arts artworkextra audio audiofile automount avahi bash-completion berkdb bidi binary-drivers bittorrent bluetooth bookmarks branding bzip2 cairo calendar cdda cddb cdio cdr chm clamav clamd cleartype cli clucene consolekit corefonts cpudetection cracklib crypt css cups curl cxx dbus deprecated designer-plugin device-mapper devil dga directfb discouraged distribution divx dns doc dri dts dv dvb dvd dvdnav dvdr dvdread ebook eds elisp emacs emboss emerald encode esd eselect etc-proposals evo examples exif expat extra-tools extraicons extras fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash fltk foomaticdb fortran ftp fts3 fuse gcj gd gdbm gdu gedit ggi gif gimp glep glib glitz gmedia gnome gnutls google google-gadgets gphoto2 gpm gstreamer gtk gtkhtml handbook hddtemp hfs hpcups hpijs html htmlhandbook httpd hyperestraier iconv idn ieee1394 imagemagick imlib inkjar inotify ipv6 isdnlog jack jadetex java java6 jfs joystick jpeg jpeg2k kde kdehiddenvisibility kdrive kerberos konqueror kpathsea lame lcms ldap libcaca libnotify libsamplerate lirc live lm_sensors logrotate mad mail matroska md5sum mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono mozilla mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls npp nptl nptlonly nsplugin ntfs nvidia objc odbc offensive ogg ole openal openexr opengl openmp osdmenu pam pango parport pcre pdf perl pipechan plasma pmu png policykit postgres ppds pppd pulseaudio python qt3support qt4 quicktime raptor rar rdesktop readline realmedia reflection regex reiser4 reiserfs reports samba sametime scanner sdl secure-delete semantic-desktop servletapi session sip skins slang slp smbclient smp sndfile snmp sound sounds speex spell spl sql sqlite sse sse2 ssl startup-notification static-ppds stream subversion svg swat sysfs syslog tcpd templates theora thesaurus threads thumbnail thunderbird tidy tiff timidity tk tools truetype type1 udev unicode unsupported usb userlocales utempter utils v4l vcd vdpau vdr video vlm voice vorbis vram wav wavpack weather webkit wmf wmp wordperfect wxwindows x264 xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xulrunner xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2011-03-21 13:21:21 UTC

*** This bug has been marked as a duplicate of bug 359491 ***