Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 361709 - media-video/cinelerra-20101104 with linux-headers-2.6.38 - vdevicebuz.C:48:28: fatal error: linux/videodev.h: No such file or directory
Summary: media-video/cinelerra-20101104 with linux-headers-2.6.38 - vdevicebuz.C:48:28...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-04-02 18:57 UTC by James
Modified: 2011-04-27 18:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Failed build log using upstream patch (build.log,926.10 KB, text/plain)
2011-04-05 21:13 UTC, James
Details
Patch to make cinelerra build (cinelerra-20101104-remove-support-v4l-buzz-k2-6-38.diff,5.28 KB, patch)
2011-04-05 21:57 UTC, James
Details | Diff
Ebuild using above patch (cinelerra-20101104.ebuild,2.21 KB, text/plain)
2011-04-05 21:58 UTC, James
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James 2011-04-02 18:57:46 UTC
The general linux/videodev.h missing errors.  The Ubuntu devs have reported it to upstream:  http://permalink.gmane.org/gmane.comp.video.cinelerra-cv.general/12514

Reproducible: Always

Steps to Reproduce:
1.emerge -v cinelerra
2.crash
3.
Actual Results:  
x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I.. -I../guicast -I../quicktime -I../libmpeg3   -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_FIREWIRE     -DHAVE_ALSA   -I/usr/include/mjpegtools -I/usr/include/mjpegtools/mpeg2enc -I/usr/include/mjpegtools/mplex   -pthread -I/usr/include/OpenEXR    -I/usr/include/libavcodec -I/usr/include/libswscale -DHAVE_SWSCALER -DPLUGIN_DIR=\"/usr/lib64/cinelerra\" -march=amdfam10 -O2 -pipe -D__STDC_CONSTANT_MACROS -c -o vdeviceprefs.o vdeviceprefs.C
vdevicebuz.C:48:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[3]: *** [vdevicebuz.o] Error 1
make[3]: *** Waiting for unfinished jobs....
In file included from ../guicast/guicast.h:42:0,
                 from vdevicebase.h:29,
                 from vdevicedvb.h:28,
                 from vdevicedvb.C:26:
../guicast/bcpot.h: In member function ‘virtual char* BC_Pot::get_caption()’:
../guicast/bcpot.h:56:39: warning: deprecated conversion from string constant to ‘char*’
In file included from ../guicast/guicast.h:42:0,
                 from channelpicker.h:25,
                 from vdeviceprefs.C:24:
../guicast/bcpot.h: In member function ‘virtual char* BC_Pot::get_caption()’:
../guicast/bcpot.h:56:39: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C: In destructor ‘VDevicePrefs::~VDevicePrefs()’:
vdeviceprefs.C:69:55: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C: In member function ‘int VDriverMenu::create_objects()’:
vdeviceprefs.C:531:50: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:536:52: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:537:42: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:539:46: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:540:48: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:542:42: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:546:43: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:547:46: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:551:51: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:553:43: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:555:48: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:556:47: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C:557:49: warning: deprecated conversion from string constant to ‘char*’
vdeviceprefs.C: In constructor ‘VDriverItem::VDriverItem(VDriverMenu*, char*, int)’:
vdeviceprefs.C:565:20: warning: deprecated conversion from string constant to ‘char*’
make[3]: Leaving directory `/var/tmp/portage/media-video/cinelerra-20101104/work/cinelerra-20101104/cinelerra'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/cinelerra-20101104/work/cinelerra-20101104/cinelerra'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/cinelerra-20101104/work/cinelerra-20101104'
make: *** [all] Error 2
emake failed
 * ERROR: media-video/cinelerra-20101104 failed (compile phase):
 *   emake failed
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_compile
 *   environment, line 3144:  Called _eapi2_src_compile
 *     ebuild.sh, line  665:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 * 
 * If you need support, post the output of 'emerge --info =media-video/cinelerra-20101104',
 * the complete build log and the output of 'emerge -pqv =media-video/cinelerra-20101104'.
 * The complete build log is located at '/var/tmp/portage/media-video/cinelerra-20101104/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/cinelerra-20101104/temp/environment'.
 * S: '/var/tmp/portage/media-video/cinelerra-20101104/work/cinelerra-20101104'

Expected Results:  
compile cleanly

emerge --info
Portage 2.1.9.45 (!/usr/portage/profiles/default/linux/amd64/10.0/desktop/kde/, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo-r1 x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-r1-x86_64-AMD_Phenom-tm-_II_X4_840_Processor-with-gentoo-2.0.2
Timestamp of tree: Sat, 02 Apr 2011 13:15:01 +0000
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.4_p6-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* PUEL"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=amdfam10 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=amdfam10 -O2 -pipe"
DISTDIR="/mnt/nfs_portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="assume-digests binpkg-logs ccache distlocks fixlafiles fixpackages metadata-transfer news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.netnitco.net http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/ http://gentoo.mirrors.tds.net/gentoo http://www.cyberuse.com/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/mnt/nfs_portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/nfs_portage"
PORTDIR_OVERLAY="/var/lib/layman/mozilla /var/lib/layman/x11 /var/lib/layman/piczu /var/lib/layman/gamerlay /var/lib/layman/mt-mythtv /var/lib/layman/kde /var/lib/layman/sunrise /var/lib/layman/arduino /usr/local/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 audiofile avahi avi bluetooth branding bzip2 cairo ccache cdda cddb cdio cdr cdrkit cli consolekit cracklib crypt css cups cxx dbus divx4linux dlloader dri dts dv dvb dvd dvdnav dvdr dvdread emboss enca encode exif extras fam ffmpeg firefox flac fortran gdbm gif gimp glut gpm gtk gzip iconv ieee1394 imagemagick java jpeg json kde kerberos kontact ladspa lame lcms ldap libnotify live lm_sensors lv2 mad melt midi mikmod mjpeg mmx mmx2 mmxext mng modules mp2 mp3 mp4 mpeg mplayer mpm-worker mtp mudflap multilib musepack mythtv ncurses nls nptl nptlonly nsplugin nvidia ogg oggvorbis openal opengl openmp pam pango pcre pda pdf pdflib perl plasma png policykit posix ppds pppd pulseaudio python qt3support qt4 readline reflection scanner sdl semantic-desktop session smp sockets spell spl srt sse sse2 ssl startup-notification subtitles svg swat sysfs szip tcpd theora threads tiff truetype unicode usb vcd vim-syntax vorbis webkit wxwidgets x264 xanim xcb xine xinerama xml xorg xulrunner xv xvid xvmc zlib" ALSA_CARDS="hda_intel usb_audio" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" RUBY_TARGETS="ruby18" SANE_BACKENDS="hp umax" USERLAND="GNU" VIDEO_CARDS="nvidia vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Dominique Michel 2011-04-04 00:26:58 UTC
I try to apply the remove-support-v4l-buzz-k2-6-38.diff patch from here: http://bugs.cinelerra.org/ticket/949 but I get the following error:

make[3]: *** No rule to make target `vdevicebuz.h', needed by `all-am'.  Stop.
make[3]: Leaving directory `/var/tmp/portage/media-video/cinelerra-20101104/work/cinelerra-20101104/cinelerra'
Comment 2 Audiodef 2011-04-05 19:54:51 UTC
Putting linux-headers-2.6.38 in package.mask allowed me to emerge Cinelerra. Maybe 2.6.38 is just a buggy version. I suspect not using this version will clear up some other things, too.
Comment 3 James 2011-04-05 21:13:40 UTC
Created attachment 268639 [details]
Failed build log using upstream patch

No, 2.6.38 is not buggy, the kernel developers just did what they had been promising to do for quite some time now, they removed v4l1 support from the kernel, it has been deprecated for quite some time now.  Sadly the upstream developers have not been heeding this promise and providing a way to compile without it.
I attempted the same patch that Dominique mentioned, with similar results.  I even downloaded the git head and patched that, with broken results as well.  Both seem to be having difficulties with vdevicebuz.h, which is mentioned in the ticket upstream as being broken by a lack of v4l1, and should be removed by that patch, apparently it doesn't do all that is needed.
I will attach a build log for the patched 29191104 version (from the portage tree).
Comment 4 James 2011-04-05 21:16:38 UTC
(In reply to comment #3)
> Created attachment 268639 [details]
> Failed build log using upstream patch
> 
> No, 2.6.38 is not buggy, the kernel developers just did what they had been
> promising to do for quite some time now, they removed v4l1 support from the
> kernel, it has been deprecated for quite some time now.  Sadly the upstream
> developers have not been heeding this promise and providing a way to compile
> without it.
> I attempted the same patch that Dominique mentioned, with similar results.  I
> even downloaded the git head and patched that, with broken results as well. 
> Both seem to be having difficulties with vdevicebuz.h, which is mentioned in
> the ticket upstream as being broken by a lack of v4l1, and should be removed by
> that patch, apparently it doesn't do all that is needed.
> I will attach a build log for the patched 29191104 version (from the portage
> tree).

sorry, the 20101104 version
Comment 5 James 2011-04-05 21:34:29 UTC
I Got it to Build!  I found that the Makefile Makefile.am and Makefile.in in
the cinelerra build directory (cinelerra-20101104/work/cinelerra) contained
references to vdevicebuz.h and vdevicev4l.h, having removed them, it compiled
correctly!
Comment 6 James 2011-04-05 21:57:31 UTC
Created attachment 268651 [details, diff]
Patch to make cinelerra build

Upstream patch with the offending lines removed from the makefile
Comment 7 James 2011-04-05 21:58:10 UTC
Created attachment 268653 [details]
Ebuild using above patch
Comment 8 Torsten Kurbad 2011-04-17 08:31:27 UTC
(In reply to comment #7)
> Ebuild using above patch

Works for me.

James, please note that you must not put "unpack ${A}" into the src_prepare() section. That is done (automatically) by src_unpack(). Also, "cd ${S}" isn't needed. Portage does that automatically, too.

Regards,
Torsten
Comment 9 Alexis Ballier gentoo-dev 2011-04-27 18:08:01 UTC
applied, thanks