Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 359743 - media-tv/tvtime-1.0.2-r2 won't compile against linux-headers-2.6.38 due to V4L1 removal
Summary: media-tv/tvtime-1.0.2-r2 won't compile against linux-headers-2.6.38 due to V4...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: linux-headers-2.6.38
  Show dependency tree
 
Reported: 2011-03-21 12:58 UTC by Billy DeVincentis
Modified: 2011-12-04 21:02 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild folder for overlay (tvtime.tar.gz,8.00 KB, application/x-gzip)
2011-03-31 22:03 UTC, Billy DeVincentis
Details
Ebuild folder for overlay (tvtime.tar.gz,5.18 KB, application/x-gzip)
2011-05-01 09:27 UTC, Billy DeVincentis
Details
Fixes dependency on deprecated V4L1 (tvtime-1.0.2-v4l1.patch,15.75 KB, patch)
2011-05-03 01:18 UTC, cjcart
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Billy DeVincentis 2011-03-21 12:58:42 UTC
DFIFODIR="\"/tmp\"" -D_LARGEFILE64_SOURCE -DLOCALEDIR="\"/usr/share/locale\"" -I../plugins  -I/usr/include/libxml2   -march=native  -pipe -O3 -fomit-frame-pointer -std=gnu99 -MT tvtime-tvtimeosd.o -MD -MP -MF .deps/tvtime-tvtimeosd.Tpo -c -o tvtime-tvtimeosd.o `test -f 'tvtimeosd.c' || echo './'`tvtimeosd.c
x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..    `/usr/bin/freetype-config --cflags`  -Wall -pedantic -I. -DDATADIR="\"/usr/share/tvtime\"" -DCONFDIR="\"/etc/tvtime\"" -DFIFODIR="\"/tmp\"" -D_LARGEFILE64_SOURCE -DLOCALEDIR="\"/usr/share/locale\"" -I../plugins  -I/usr/include/libxml2   -march=native  -pipe -O3 -fomit-frame-pointer -std=gnu99 -MT tvtime-input.o -MD -MP -MF .deps/tvtime-input.Tpo -c -o tvtime-input.o `test -f 'input.c' || echo './'`input.c
videoinput.c:38:28: fatal error: linux/videodev.h: No such file or directory
compilation terminated.
make[2]: *** [tvtime-videoinput.o] Error 1
make[2]: *** Waiting for unfinished jobs....
tvtimeosd.c: In function ‘tvtime_osd_set_audio_mode’:
tvtimeosd.c:561:5: warning: format not a string literal and no format arguments
tvtimeosd.c:561:5: warning: format not a string literal and no format arguments
mv -f .deps/tvtime-pngoutput.Tpo .deps/tvtime-pngoutput.Po
mv -f .deps/tvtime-input.Tpo .deps/tvtime-input.Po
tvtimeconf.c: In function ‘config_new’:
tvtimeconf.c:856:13: warning: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result
tvtimeconf.c:864:13: warning: ignoring return value of ‘asprintf’, declared with attribute warn_unused_result
rtctimer.c: In function ‘rtctimer_next_tick’:
rtctimer.c:110:9: warning: ignoring return value of ‘read’, declared with attribute warn_unused_result
mv -f .deps/tvtime-mixer.Tpo .deps/tvtime-mixer.Po
mv -f .deps/tvtime-rtctimer.Tpo .deps/tvtime-rtctimer.Po
mv -f .deps/tvtime-osdtools.Tpo .deps/tvtime-osdtools.Po
mv -f .deps/tvtime-tvtimeosd.Tpo .deps/tvtime-tvtimeosd.Po
mv -f .deps/tvtime-leetft.Tpo .deps/tvtime-leetft.Po
mv -f .deps/tvtime-tvtimeconf.Tpo .deps/tvtime-tvtimeconf.Po
make[2]: Leaving directory `/var/tmp/portage/media-tv/tvtime-1.0.2-r2/work/tvtime-1.0.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-tv/tvtime-1.0.2-r2/work/tvtime-1.0.2'
make: *** [all] Error 2
emake failed
 * ERROR: media-tv/tvtime-1.0.2-r2 failed (compile phase):
 *   compile problem
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_compile
 *   environment, line 2771:  Called die
 * The specific snippet of code:
 *       emake || die "compile problem"
 * 
 * If you need support, post the output of 'emerge --info =media-tv/tvtime-1.0.2-r2',
 * the complete build log and the output of 'emerge -pqv =media-tv/tvtime-1.0.2-r2'.
 * This ebuild is from a repository named 'miscellaneous'
 * The complete build log is located at '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/environment'.
 * S: '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/work/tvtime-1.0.2'

>>> Failed to emerge media-tv/tvtime-1.0.2-r2, Log file:

>>>  '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/build.log'
 * 
 * The following package has failed to build or install:
 * 
 *  (media-tv/tvtime-1.0.2-r2::miscellaneous, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/media-tv/tvtime-1.0.2-r2/temp/build.log'
 * 


Reproducible: Always




emerge --info
Portage 2.2.0_alpha28 (default/linux/amd64/10.0/desktop, gcc-4.5.2, glibc-2.13-r2, 2.6.38-gentoo x86_64)
=================================================================
System uname: Linux-2.6.38-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_870_@_2.93GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 20 Mar 2011 11:00:01 +0000
app-shells/bash:     4.2_p8
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.7.1-r1, 3.1.3-r1
dev-util/cmake:      2.8.4
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.7.0
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.6.3-r1, 1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
virtual/os-headers:  2.6.38 (sys-kernel/linux-headers)
Repositories: gentoo miscellaneous
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"
FEATURES="assume-digests binpkg-logs buildpkg distlocks fixlafiles fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/miscellaneous"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow S3TC X a52 aac aalib accessibility acl acpi aften akonadi alsa amarok amd64 amrnb archive ares arts artworkextra audio audiofile automount avahi bash-completion berkdb bidi binary-drivers bittorrent bluetooth bookmarks branding bzip2 cairo calendar cdda cddb cdio cdr chm clamav clamd cleartype cli clucene consolekit corefonts cpudetection cracklib crypt css cups curl cxx dbus deprecated designer-plugin device-mapper devil dga directfb discouraged distribution divx dns doc dri dts dv dvb dvd dvdnav dvdr dvdread ebook eds elisp emacs emboss emerald encode esd eselect etc-proposals evo examples exif expat extra-tools extraicons extras fam fat fax fbcon fbcondecor fbsplash ffmpeg firefox flac flash fltk foomaticdb fortran ftp fts3 fuse gcj gd gdbm gdu gedit ggi gif gimp glep glib glitz gmedia gnome gnutls google google-gadgets gphoto2 gpm gstreamer gtk gtkhtml handbook hddtemp hfs hpcups hpijs html htmlhandbook httpd hyperestraier iconv idn ieee1394 imagemagick imlib inkjar inotify ipv6 isdnlog jack jadetex java java6 jfs joystick jpeg jpeg2k kde kdehiddenvisibility kdrive kerberos konqueror kpathsea lame lcms ldap libcaca libnotify libsamplerate lirc live lm_sensors logrotate mad mail matroska md5sum mdnsresponder-compat mikmod mime mjpeg mmx mmxext mng modules mono mozilla mp2 mp3 mp4 mpeg mplayer mudflap multilib musepack musicbrainz mysql nas nautilus ncurses networking new-login nforce2 nls npp nptl nptlonly nsplugin ntfs nvidia objc odbc offensive ogg ole openal openexr opengl openmp osdmenu pam pango parport pcre pdf perl pipechan plasma pmu png policykit postgres ppds pppd pulseaudio python qt3support qt4 quicktime raptor rar rdesktop readline realmedia reflection regex reiser4 reiserfs reports samba sametime scanner sdl secure-delete semantic-desktop servletapi session sip skins slang slp smbclient smp sndfile snmp sound sounds speex spell spl sql sqlite sse sse2 ssl startup-notification static-ppds stream subversion svg swat sysfs syslog tcpd templates theora thesaurus threads thumbnail thunderbird tidy tiff timidity tk tools truetype type1 udev unicode unsupported usb userlocales utempter utils v4l vcd vdpau vdr video vlm voice vorbis vram wav wavpack weather webkit wmf wmp wordperfect wxwindows x264 xattr xcb xcomposite xforms xfs xine xml xorg xpm xprint xscreensaver xulrunner xv xvid xvmc zeroconf zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev joystick keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" PHP_TARGETS="php5-3" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Billy DeVincentis 2011-03-21 22:49:47 UTC
These guys have updated tvtime but I'm not sure of how to apply their work to our ebuilds

http://www.kernellabs.com/hg/~dheitmueller
Comment 2 Billy DeVincentis 2011-03-31 22:02:51 UTC
I have got this going just a bit. Here's what I did.

1- Took the patched sources from these guys and upped the version to 1.0.3.
http://www.kernellabs.com/hg/~dheitmueller/tvtime

2- Fixed their sources by adding in autotools patch manually and upped the changelog and configure.ac to reflect the new revision and repackaged it. It's available at http://hotfile.com/dl/112828694/045a4ef/tvtime-1.0.3.tar.gz.html

3- Cleaned up the ebuild a bit as some of the patches we had no longer apply to these new sources. What worked I left in.

4- nls use flag doesn't work with these sources. Disable it in package.use
media-tv/tvtime -nls
Comment 3 Billy DeVincentis 2011-03-31 22:03:50 UTC
Created attachment 268043 [details]
Ebuild folder for overlay
Comment 4 James Lockie 2011-04-01 03:07:14 UTC
Is there an overlay for tvtime?
Comment 5 Billy DeVincentis 2011-04-01 03:12:35 UTC
No. Unfortunately this happens to be a package I really needed for my box for a simple tv player so I spent the better part of my day off today figuring out how to get it working. Download the tarball from the link I put in the previous comment and put it in /usr/portage/distfiles , then download the ebuild folder from the attachment above and extract the contents and put them in your local overlay. Update package.use to disable nls and emerge tvtime. Please let me know if it works on your box.
Comment 6 Nikos Chantziaras 2011-04-03 02:09:24 UTC
tvtime is dead upstream. The only real solution is to drop the current tvtime from portage and switch to the KernelLabs version of tvtime, which is maintained and pretty much alive.
Comment 7 James Lockie 2011-05-01 02:44:06 UTC
I finally got around to it. :-)

An error:
/bin/sh: .././mkinstalldirs: No such file or directory
make[1]: *** [install-data-yes] Error 127
make[1]: Leaving directory `/var/tmp/portage/media-tv/tvtime-1.0.3/work/tvtime-1.0.3/po'
make: *** [install-recursive] Error 1
 * ERROR: media-tv/tvtime-1.0.3 failed (install phase):
 *   make install failed
 * 
 * Call stack:
 *     ebuild.sh, line  56:  Called src_install
 *   environment, line 2759:  Called die
 * The specific snippet of code:
 *       make DESTDIR="${D}" install || die "make install failed";
 * 
 * If you need support, post the output of 'emerge --info =media-tv/tvtime-1.0.3',
 * the complete build log and the output of 'emerge -pqv =media-tv/tvtime-1.0.3'.
 * This ebuild is from an overlay named 'geki-overlay': '/var/lib/layman/openoffice-geki/'
 * The complete build log is located at '/var/tmp/portage/media-tv/tvtime-1.0.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-tv/tvtime-1.0.3/temp/environment'.
 * S: '/var/tmp/portage/media-tv/tvtime-1.0.3/work/tvtime-1.0.3'
Comment 8 Billy DeVincentis 2011-05-01 07:47:54 UTC
Did you download the sources and ebuild folder from the above links? I emerged my entire system last night and this still compiles fine for me.
Comment 9 Billy DeVincentis 2011-05-01 07:50:18 UTC
You have to manually download the sources I uploaded from 
http://hotfile.com/dl/112828694/045a4ef/tvtime-1.0.3.tar.gz.html and place it in /usr/portage/distfiles otherwise it will not build.
Comment 10 Billy DeVincentis 2011-05-01 09:27:03 UTC
Created attachment 271735 [details]
Ebuild folder for overlay

I have made this now auto download sources. Just place in overlay and emerge.
Comment 11 James Lockie 2011-05-01 15:27:14 UTC
I created a media-tv directory in an existing overlay:
/var/lib/layman/openoffice-geki/media-tv

I downloaded http://hotfile.com/dl/112828694/045a4ef/tvtime-1.0.3.tar.gz.html and place it in /usr/portage/distfiles.

$ sudo emerge -pv tvtime

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-tv/tvtime-1.0.3 [1.0.2-r2] USE="nls xinerama" 0 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/openoffice-geki


/etc/make.conf has no 'nls' yet it is trying to use it. :-(
I put "=media-tv/tvtime-1* -nls" in /usr/portage/profiles/default/linux/package.use


$ sudo emerge -pv tvtime

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-tv/tvtime-1.0.3 [1.0.2-r2] USE="xinerama -nls*" 0 kB [0=>1]                                                                               

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/openoffice-geki

It worked. :-)
Comment 12 Billy DeVincentis 2011-05-01 16:23:11 UTC
Glad to hear it. I spent the time to fix this because it really has no substitute. Mythtv works but it's WAY too much to just watch tv. Xawtv works but not as well.
Comment 13 James Lockie 2011-05-02 15:53:39 UTC
Thanks for fixing it, I agree about mythtv being overkill.
Comment 14 Sascha Wuestemann 2011-05-02 23:41:27 UTC
I can confirm building with the attached ebuild folder worked fine here. I have set up a local layman repo:

# emerge -av tvtime

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] media-tv/tvtime-1.0.3 [1.0.2-r2] USE="xinerama* -nls*" 3,851 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 3,851 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

I must have done something wrong with my local repo setup, though. The sources were downloaded from extern sources despite I have had downloaded it:

>>> Downloading 'http://ompldr.org/vOGk0aA/tvtime-1.0.3.tar.gz'
--2011-05-03 01:24:01--  http://ompldr.org/vOGk0aA/tvtime-1.0.3.tar.gz
Resolving ompldr.org... 178.63.66.150
Connecting to ompldr.org|178.63.66.150|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3943276 (3.8M) [application/x-gzip]
Saving to: `/usr/portage/distfiles/tvtime-1.0.3.tar.gz'

They were identical, so I compiled and everything was fine. The tvtime application works as expected, too.

So, what do you think, can v1.0.3 be put to puplic?

Here is my emerge --info:

Portage 2.1.9.46 (default/linux/amd64/10.0/desktop, gcc-4.5.2, libc-0-r0, 2.6.35-vs2.3.0.36.32-gentoo x86_64)
=================================================================
System uname: Linux-2.6.35-vs2.3.0.36.32-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_330_@_1.60GHz-with-gentoo-2.0.2
Timestamp of tree: Mon, 02 May 2011 04:45:01 +0000
ccache version 3.1.4 [enabled]
app-shells/bash:     4.2_p8-r1
dev-java/java-config: 2.1.11-r3
dev-lang/python:     2.6.6-r2, 2.7.1-r1, 3.1.3-r1
dev-util/ccache:     3.1.4
dev-util/cmake:      2.8.4-r1
sys-apps/baselayout: 2.0.2
sys-apps/openrc:     0.8.2-r1
sys-apps/sandbox:    2.5
sys-devel/autoconf:  2.13, 2.68
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1-r1
sys-devel/binutils:  2.21
sys-devel/gcc:       4.5.2
sys-devel/gcc-config: 1.4.1-r1
sys-devel/libtool:   2.4-r1
sys-devel/make:      3.82
sys-kernel/linux-headers: 2.6.38
sys-libs/glibc:      2.13-r2
virtual/os-headers:  0
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=core2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.2/ext-active/ /etc/php/cgi-php5.2/ext-active/ /etc/php/cli-php5.2/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O3 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache collision-protect distlocks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.netcologne.de/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ "
LANG="C"
LDFLAGS="-Wl,--hash-style=gnu,-O1 -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j1 -l 10"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus dga dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gdu gif gpm grub gstreamer gtk gtk2 iconv imagemagick imap ipv6 java jpeg lame lcms ldap libnotify mad maildir memlimit mmap mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl nptlonly offensive ogg opengl openmp pam pango pcre pda pdf perl png policykit portaudio posix ppds pppd python qt3support qt4 readline rtsp sdl seamonkey session sharedmem smp socks5 spell sse sse2 ssl startup-notification svg sysfs tcpd threads tiff truetype type3 udev unicode usb v4l2 vorbis x264 xcb xinerama xml xorg xulrunner xv xvid zlib" ALSA_CARDS="ICH7" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 ppc ppc64 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel i810 i813 mach64 r128 vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 15 Billy DeVincentis 2011-05-03 00:59:54 UTC
After James had difficulty emerging this as can be seen from the above comments, I modified the ebuild and uploaded the sources to another public server where it could be downloaded with the ebuild automatically. I didn't want anyone else having any confusion.
Comment 16 cjcart 2011-05-03 01:18:05 UTC
Created attachment 271933 [details, diff]
Fixes dependency on deprecated V4L1

This patch removes deprecated V4L1 code if linux/videodev.h is not present on the user's system. It should be applied after tvtime-1.0.2+linux-headers-2.6.18.patch.
Comment 17 Billy DeVincentis 2011-05-03 12:02:26 UTC
No such patch is necessary because the sources were already modified to remove deprecated code. Upstream is dead. Closest support we have for this now comes from kernellabs.
Comment 18 James Lockie 2011-05-20 18:03:13 UTC
How do we get this added to portage?
Comment 19 Alex Legler (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-05-29 22:13:43 UTC
This should be fixed in tvtime-1.0.2_p20110131, thanks for your ebuild suggestions.

There is no indication in the source code that it is a 1.0.3 release, so I'm not following your suggested naming. Also, USE=nls works after some more patching.
Please test and report any issues.
Comment 20 Billy DeVincentis 2011-05-31 01:53:02 UTC
Glad to see that someone finally took the time to fix this. Alex, as far as the renaming, it was necessary for me to rename it in order for the ebuild to not redownload tvtime 1.0.2 sources from the gentoo mirrors. Choosing to go with the naming from kernellabs is surely the best option since there will undoubtedly be future modifications that will require revision bumps of the sources.
Comment 21 Nikos Chantziaras 2011-06-16 03:32:04 UTC
Gah. Unfortunately, this version of tvtime has a nasty problem: when it runs, it locks up ALSA and no application can open the ALSA sound device until tvtime is closed.  Example:

$ aplay
ALSA lib pcm_dmix.c:1018:(snd_pcm_dmix_open) unable to open slave
aplay: main:660: audio open error: Device or resource busy
Comment 22 Alexander Koryushkin 2011-12-02 00:29:37 UTC
(In reply to comment #21)
> Gah. Unfortunately, this version of tvtime has a nasty problem: when it runs,
> it locks up ALSA and no application can open the ALSA sound device until tvtime
> is closed.  

Try <option name="AlsaOutputDev" value="disabled"/> in ~/tvtime/tvtime.xml
Comment 23 Nikos Chantziaras 2011-12-04 21:02:30 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > Gah. Unfortunately, this version of tvtime has a nasty problem: when it runs,
> > it locks up ALSA and no application can open the ALSA sound device until tvtime
> > is closed.  
> 
> Try <option name="AlsaOutputDev" value="disabled"/> in ~/tvtime/tvtime.xml

That helped. Thank you! A very annoying problem solved.