Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 520404 (runtime-paths) - [TRACKER] Ebuild that install into paths that should be created at runtime
Summary: [TRACKER] Ebuild that install into paths that should be created at runtime
Status: CONFIRMED
Alias: runtime-paths
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Quality Assurance Team
URL:
Whiteboard:
Keywords: Tracker
Depends on: 513374 516388 520482 520522 520558 520572 520582 520584 520594 520612 585976 587492 605374 605448 605450 638586 655566 670530 677182 681812 693332 706764 753293 499444 508930 520408 520456 520458 520460 520462 520464 520484 520490 520500 520510 520512 520514 520552 520566 520570 520576 520592 520598 520600 520604 520610 520622 520624 520626 520630 520634 528844 545970 554672 554902 599146 605352 605362 605364 605366 605398 605452 605488 605490 605492 605496 605512 605514 605520 605544 608116 650246 670286 670416 670434 670440 670514 677180 677212 677268 677270 677288 677290 677312 677318 677322 677336 677370 677378 681366 681546 681766 681826 681948 682070 701430 716984 725468
Blocks: keepdir-var-run_lock
  Show dependency tree
 
Reported: 2014-08-21 13:50 UTC by Agostino Sarubbo
Modified: 2020-11-06 08:29 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2014-08-21 13:50:37 UTC
As usual, please open a new bug and block this tracker.

The warning should be like this:

 * QA Notice: This ebuild installs into paths that should be created at runtime.
 *  To fix, simply do not install into these directories.  Instead, your package
 *  should create dirs on the fly at runtime as needed via init scripts/etc...
Comment 1 SpanKY gentoo-dev 2015-10-01 22:13:43 UTC
probably should merge bug 332633 into this, but for now at least add a blocker