Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 449220 - GNOME 3.6 (re)keywording request
Summary: GNOME 3.6 (re)keywording request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
: 379649 379651 379657 390345 411761 441692 447426 447432 447854 448364 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-29 18:03 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2013-02-18 19:47 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
keywording list (gnome-3.6-keywording-list.txt,33.88 KB, text/plain)
2012-12-29 18:03 UTC, Alexandre Rostovtsev (RETIRED)
Details
complete keywording list (gnome-3.6-keywording-list.txt,59.07 KB, text/plain)
2012-12-31 07:50 UTC, Alexandre Rostovtsev (RETIRED)
Details
Patch to build on fbsd (webkitbsd.patch,853 bytes, patch)
2013-01-29 01:49 UTC, Alexis Ballier
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:03:29 UTC
Created attachment 333694 [details]
keywording list

This is the (re)keywording request for gnome-3.6 and the libraries that it brings - gtk+-3.6, libsecret, webkit-gtk-1.10, etc.

Since alpha, arm, ia64, ppc, ppc64, sparc currently have gnome-base/gnome-2.32.1-r2 keyworded, I am giving the full set of packages that would need to be (re)keyworded there for gnome-3.6. However, since I realize that arch maintainers would need a fair bit of time to go through list immediately, I've marked the most important keywording requests - ones that should be done as soon as possible, and can be finished independently of all the rest - as "high priority".

These high-priority packages are yelp-tools, pango, gtk+, gnome-themes-standard, libsecret, webkit-gtk, and their dependencies.

For sh and amd64-fbsd, the keywording request covers only the high-priority packages listed above, plus any ebuilds where we had to drop your keywords for the gnome-3.6 bump.
Comment 1 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:05:43 UTC
*** Bug 448364 has been marked as a duplicate of this bug. ***
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:06:12 UTC
*** Bug 447854 has been marked as a duplicate of this bug. ***
Comment 3 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:06:39 UTC
*** Bug 447432 has been marked as a duplicate of this bug. ***
Comment 4 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:06:59 UTC
*** Bug 441692 has been marked as a duplicate of this bug. ***
Comment 5 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:07:12 UTC
*** Bug 447426 has been marked as a duplicate of this bug. ***
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:07:38 UTC
*** Bug 411761 has been marked as a duplicate of this bug. ***
Comment 7 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:07:54 UTC
*** Bug 390345 has been marked as a duplicate of this bug. ***
Comment 8 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-31 07:50:34 UTC
Created attachment 333834 [details]
complete keywording list

Agostino Sarubbo asked for a complete list of ebuilds to keyword, even including dependencies which are not maintained by gnome/gstreamer/freesktop. Here it is.
Comment 9 Agostino Sarubbo gentoo-dev 2012-12-31 14:45:48 UTC
ppc done
Comment 10 Agostino Sarubbo gentoo-dev 2012-12-31 16:01:16 UTC
ppc64 done
Comment 11 Agostino Sarubbo gentoo-dev 2012-12-31 16:51:21 UTC
*** Bug 379649 has been marked as a duplicate of this bug. ***
Comment 12 Agostino Sarubbo gentoo-dev 2012-12-31 16:51:26 UTC
*** Bug 379651 has been marked as a duplicate of this bug. ***
Comment 13 Agostino Sarubbo gentoo-dev 2012-12-31 16:51:31 UTC
*** Bug 379657 has been marked as a duplicate of this bug. ***
Comment 14 Agostino Sarubbo gentoo-dev 2013-01-01 12:57:17 UTC
ia64 done
Comment 15 Agostino Sarubbo gentoo-dev 2013-01-01 15:00:23 UTC
alpha done
Comment 16 Agostino Sarubbo gentoo-dev 2013-01-06 11:25:39 UTC
sparc done
Comment 17 Alexis Ballier gentoo-dev 2013-01-29 01:49:27 UTC
Created attachment 337178 [details, diff]
Patch to build on fbsd

amd64-fbsd all done except webkit-gtk: it needs the attached patch for definitions of WIFEXITED; it seems POSIX documents this in stdlib.h as optional, and is defined there on linux, but on FreeBSD it is not, so we need to include sys/wait.h where POSIX mandates it to be.

Mind if I apply it? Want me to submit it upstream ?
Comment 18 Gilles Dartiguelongue gentoo-dev 2013-01-29 08:08:59 UTC
I think this is not the first time we need a patch for WIFEXIT, but I don't remember how it was solved last time.

Feel free to apply it as the change is minimal.
Comment 19 Alexis Ballier gentoo-dev 2013-01-29 12:36:32 UTC
(In reply to comment #18)
> I think this is not the first time we need a patch for WIFEXIT, but I don't
> remember how it was solved last time.
> 
> Feel free to apply it as the change is minimal.

done and keywords added
Comment 20 Agostino Sarubbo gentoo-dev 2013-02-08 15:01:07 UTC
arm done
Comment 21 Agostino Sarubbo gentoo-dev 2013-02-08 15:02:30 UTC
sh will skip until there will be user requests.
Comment 22 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-10 21:05:55 UTC
(In reply to comment #21)
> sh will skip until there will be user requests.

If you do not keyword pango-1.32 on sh, then after pango-1.30.1 is removed from the tree, sh will have lots of broken dependencies (remember, pango is required for gtk+!).

And yelp-tools is needed on sh because it's the upstream replacement for gnome-doc-utils (which is keyworded on sh); keywording yelp-tools avoids dropping the sh keyword when bumping packages that require gnome-doc-utils now but will use yelp-tools in the next version.

Please either do the keywording for sh, or drop sh keywords from all versions of x11-libs/pango, x11-libs/gtk+, and reverse dependencies (meaning almost anything gnome- or gtk-related).
Comment 23 Alexandre Rostovtsev (RETIRED) gentoo-dev 2013-02-10 21:09:22 UTC
(In reply to comment #22)
Sorry for the noise; I didn't notice that everything was already keyworded correctly.
Comment 24 Agostino Sarubbo gentoo-dev 2013-02-18 19:47:43 UTC
(In reply to comment #23)
> (In reply to comment #22)
> Sorry for the noise; I didn't notice that everything was already keyworded
> correctly.

np, was my bad.