Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 447854 - >=x11-libs/pango-1.32 re-keywording request
Summary: >=x11-libs/pango-1.32 re-keywording request
Status: RESOLVED DUPLICATE of bug 449220
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords: KEYWORDREQ
Depends on:
Blocks:
 
Reported: 2012-12-19 17:15 UTC by Alexandre Rostovtsev (RETIRED)
Modified: 2012-12-29 18:06 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-19 17:15:56 UTC
Due to the new dependency on media-libs/harfbuzz, we've had to drop many keywords from >=x11-libs/pango-1.32. Please test and (re-)keyword these packages:

=media-libs/harfbuzz-0.9.9
=x11-libs/pango-1.32.5
=x11-libs/pangox-compat-0.0.2
Comment 1 Rafał Mużyło 2012-12-19 18:56:17 UTC
I think it would be better to wait.
While harfbuzz author claimed that the API should be fairly stable by now, see i.e. http://cgit.freedesktop.org/harfbuzz/commit/?id=ac064a2db2b7a010d99527e183145286215aea81 - so - effectively - it's still unstable with no library major version bump.
Comment 2 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-19 20:04:13 UTC
(In reply to comment #1)
That just means we will have to remember to bump harfbuzz and pango in sync, and not stabilize until the API settles down. But renaming a function should not affect whether or not harfbuzz builds on ppc64 :)
Comment 3 Rafał Mużyło 2012-12-19 20:15:43 UTC
The thing is that such API change as above is also an ABI break.
My note was a general one, not just limited to listed arches.
Comment 4 Agostino Sarubbo gentoo-dev 2012-12-23 20:56:41 UTC
ppc64 done
Comment 5 Jeroen Roovers gentoo-dev 2012-12-24 04:07:39 UTC
Marked ~hppa.
Comment 6 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-12-29 18:06:12 UTC

*** This bug has been marked as a duplicate of bug 449220 ***