Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 424157 - >=kde-base/kdelibs-4.9.0 and related: Update UDisks2 patch and remove UDisks1 support as obsolete
Summary: >=kde-base/kdelibs-4.9.0 and related: Update UDisks2 patch and remove UDisks1...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 439624
  Show dependency tree
 
Reported: 2012-06-29 19:44 UTC by Christian Loosli
Modified: 2013-08-12 13:12 UTC (History)
19 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
udisks2 journal (udisks-start.journal,75.39 KB, text/plain)
2012-12-07 08:38 UTC, Kirill Elagin
Details
kdelibs-4.9.4.ebuild (kdelibs-4.9.4.ebuild,8.79 KB, text/plain)
2012-12-07 11:43 UTC, Franz Trischberger
Details
kdelibs-udisks2-backend.patch (kdelibs-udisks2-backend.patch,138.22 KB, text/plain)
2012-12-07 11:43 UTC, Franz Trischberger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Loosli 2012-06-29 19:44:30 UTC
With the udisks2 patch included in 4.9  (which is, as far as I am informed, not officially part of 4.9), I face the following regressions: 

- Dolphin takes around 4 seconds to start up. There are no messages on stderr which would explain this, but udisks deaemon peaks with regards to CPU usage during this time 

- K3b no longer recognizes any optical drive in the system 

- Audio CDs no longer show up in the device notifier 

Rebuilding kdelibs with this patch removed solves all the above issues. 

As long as gentoo still offers udisk 1.0.*, I wonder whether the inofficial udisks2 patch should be used as long as these issues are not resolved. 

Gentoo on x86_64,  KDE 4.8.95  (4.9 RC1) from the kde overlay, udisks 1.98.0 (not working) and  1.0.4-r2 (working) 

Portage 2.2.0_alpha114 (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r2, 3.4.4-gentoo x86_64)
=================================================================
System uname: Linux-3.4.4-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_M_620_@_2.67GHz-with-gentoo-2.1
Timestamp of tree: Fri, 29 Jun 2012 12:15:01 +0000
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo mozilla qt seden multimedia kde localportage
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=core2 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ http://mirror.switch.ch/ftp/mirror/gentoo/ "
LANG="de_CH.UTF-8"
LC_ALL="de_CH.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/mozilla /var/lib/layman/qt /var/lib/layman/seden /var/lib/layman/multimedia /var/lib/layman/kde /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi aim alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt css cups cxx dbus development divx dri dts dv dvd dvdnavi dvdr dvdread emboss encode exif fam fame ffmpeg firefox flac fortran ftp gdbm gif gimpprint gpm gtk htmlhandbook iconv icq ieee1394 imagemagick ipv6 irc jabber java joystick jpeg kde kde4 kipi lcms ldap libnotify logitech-mouse logrotate lzma mad mbox mmx mng modules mp2 mp3 mp4 mpeg msn mudflap multilib ncurses networkmanager nls nptl nsplugin ogg openal opengl openmp oss pam pango pcre pdf perl plasma png policykit ppds pppd pulseaudio python qt qt3 qt3support qt4 quicktime radio rar readline samba scanner sdl semantic-desktop session sip social-desktop spell sse sse2 ssl ssse3 startup-notification stream svg tcpd theora tiff truetype udev udisks unicode upower usb userlocales v4l v4l2 vaapi vcd vdpau vorbis wifi wxwidgets x264 xattr xcb xine xinerama xml xorg xscreensaver xulrunner xv xvid zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template toshiba_pdrm11" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev joystick synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Andreas K. Hüttel gentoo-dev 2012-06-30 23:29:26 UTC
We'll keep watching the situation and stay in touch with the Fedora guys who maintain the patch. 

I can confirm the delays. You'll see a lot of messages related to it in ~/.xsession-errors.

If the situation does not improve, we'll remove the patch again before KDE 4.9.0 enters the main tree. (Which means the dependency on udisks:0 will be restored.)
Comment 2 Kamil Kuduk 2012-07-01 12:05:51 UTC
Just to confirm, I noticed exactly the same issues, mostly with krunner, compiling kdelibs against udisks-1.0.4 resolves the issue for me.
Comment 3 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2012-07-02 04:02:52 UTC
I've hit 3 issues with this patch:

1. long delays in the open dialog
2. no CD detection on k3b
3. solid doesn't detect luks partitions

I've moved the patch behind the udisks2 use flag.
Comment 4 Volker Hemmann 2012-07-02 16:37:36 UTC
please, pretty please remove this patch. Waiting almost 10 seconds until gwenview displays anything sucks.
Comment 5 Samuli Suominen gentoo-dev 2012-07-02 16:42:59 UTC
Any errors in messages or auth.log? 
What if you run 'polkitd' without the --no-debug switch in terminal to get more verbose output?
Someone needs to debug a bit futher before outright dismissing the patch that's working for so many.
Comment 6 Samuli Suominen gentoo-dev 2012-07-02 16:43:39 UTC
(In reply to comment #4)
> please, pretty please remove this patch. Waiting almost 10 seconds until
> gwenview displays anything sucks.

You can simply disable USE="udisks2" and enable USE="udisks" in the overlay per latest commits
No need to edit anything
Comment 7 Christian Loosli 2012-07-02 19:42:21 UTC
(In reply to comment #5)

> Someone needs to debug a bit futher before outright dismissing the patch
> that's working for so many.

Is there actually someone here (note that maybe not "so many" use the kde overlay and a RC KDE) who could not reproduce these problems? 

If so, it would be great to have a look at what's different on these systems.
Comment 8 AE 2012-07-02 20:16:57 UTC
The bug bit me too... Some info (ask if you need more):

>>>KDE-Version:
4.8.95

>>> Hardware:
Thinkpad T410s, Toshiba THNS128G SSD

>>> emerge --info:
Portage 2.2.0_alpha114 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.14.1-r3, 3.4.4-gentoo x86_64)
=================================================================
System uname: Linux-3.4.4-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_M_520_@_2.40GHz-with-gentoo-2.1
Timestamp of tree: Mon, 02 Jul 2012 19:30:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.6
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo kde java-netbeans java-binary aeoverlay
Installed sets: @mykde, @networking, @portageutils, @toolbox
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=core2 -pipe"
DISTDIR="/data/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de"
MAKEOPTS="-j5"
PKGDIR="/data/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/kde /data/portage/java-netbeans /data/portage/java-binary /data/portage/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa amd64 apng bzip2 cairo cdda cdr cli clucene consolekit cracklib crypt cups cxx dbus declarative device-mapper dri dts dvb dvd dvdr dvdread encode exif firefox flac foomaticdb gif gles gles1 gles2 glut glx gps hou iconv icu inotify irda java6 javadoc javasrc jpeg kde kipi kpathsea latex libnotify mmx modules mp3 mp4 mpeg mudflap multilib ncurses nepomuk netbeans-integration netbeans-library networkmanager nls nptl nptlonly ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds private-headers python3 qt3support quicktime rdp readline sasl scanner semantic-desktop session sou spell sse sse2 ssl startup-notification strigi svg system-sqlite systemjava tcpd theora threads tiff truetype udev udisks unicode upower usb userlocales v4l vorbis wayland x264 xcb xcomposite xetex xinerama xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="*" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 9 Andreas Sturmlechner gentoo-dev 2012-07-07 09:39:17 UTC
I got the same delay when starting dolphin, but didn't try out gwenview or k3b. Now with kdelibs-4.8.95 rebuilt without udisks2 patch, dolphin starts within its usual second.

I've got quite a similar system hardware/software-wise as in Comment #8 but have a (mostly) regular HDD installed.
Comment 10 Johannes Huber gentoo-dev 2012-08-04 15:50:34 UTC
Just for the record.

+  26 Jul 2012; Johannes Huber <johu@gentoo.org> package.use.mask:
+  Mask experimental udisks2 support for kde-base/kdelibs, bug #424157.
Comment 11 Robert Malek 2012-08-06 09:14:26 UTC
# Johannes Huber <johu@gentoo.org> (23 Mar 2012)
# Broken dep upnp, see bug #389833.
# Experimental udisks2 patch, see bug #424157
kde-base/kdelibs upnp udisks2
?!

After unmasking udisk2 in kdelibs, i'v got these error in dolphin:

"/org/freedesktop/UDisks2/drives/WDC_WD5000BMVV_11GNWS0_WD_WX21A80F8816" has new interfaces: ("org.freedesktop.UDisks2.Drive", "org.freedesktop.UDisks2.Drive.Ata") 
"/org/freedesktop/UDisks2/block_devices/sdc" has new interfaces: ("org.freedesktop.UDisks2.Block", "org.freedesktop.UDisks2.PartitionTable") 
"/org/freedesktop/UDisks2/block_devices/sdc1" has new interfaces: ("org.freedesktop.UDisks2.Block", "org.freedesktop.UDisks2.Encrypted", "org.freedesktop.UDisks2.Partition") 
Failed to call the SolidUiServer, D-Bus said: QDBusError("org.freedesktop.DBus.Error.ServiceUnknown", "The name org.kde.kded5 was not provided by any .service files")

also see Bug 424157
Comment 12 Robert Malek 2012-08-06 09:57:52 UTC
sorry.

These Bug:

Bug 429618
Comment 13 Franz Trischberger 2012-08-29 13:31:11 UTC
A try of a analysis:
https://bugs.gentoo.org/show_bug.cgi?id=400755#c4
I really can't imagine why 1451 udisks2::Device-instances need to be created...
Comment 14 Chris Mayo 2012-10-29 20:04:57 UTC
Replacing the two 4.8.95-udisks2 patches with:
http://pkgs.fedoraproject.org/cgit/kdelibs.git/tree/kdelibs-udisks2-backend.patch?h=f17

on kdelibs-4.9.2 means k3b can find my optical drives with only udisks-2.0.0 installed.
Comment 15 Samuli Suominen gentoo-dev 2012-11-03 06:18:59 UTC
Removing sys-fs/udisks:0 as a dependency is not only eventually required, but in fact recommended action to do starting from this month, thus, adding blockers to bug 439624.

@KDE: Please update to latest Fedora UDisks2 patchset and remove UDisks1 support in a revision targeted for ~arch. 

Stabilization of UDisks2 is happening as soon as we figure out the last blockers for >=sys-fs/udev-180 stabilization. We have all the required bugs open already.
Comment 16 Alexander Holler 2012-11-29 14:04:14 UTC
Unmasking and enabling udisks2 while removing udisks-1.* worked here without any problems.

I don't see any delays when starting gwenview or dolphin (kde 4.9.3).

Thanks a lot.
Comment 17 Franz Trischberger 2012-12-03 14:40:45 UTC
Tried with the linked f17 udisks-backend.patch.
Uninstalled udisks:0.
Nothing really helped, dolphin takes ages to startup, even without optical disk inserted!
Comment 18 Kirill Elagin 2012-12-07 08:38:05 UTC
Created attachment 331712 [details]
udisks2 journal

I'm with you guys.

Acer 4810TG laptop. udev-196-r1, system booted with systemd-196, just moved to latest stable kde-4.9.3 and rebuilt kdelibs with udisks2.
Dolphin takes something like 6 seconds to start, open dialogs take 10 seconds.

I have attached udisks2 (without --no-debug) journal entries (in JSON) from current boot. There are no new log entries genereated when starting Dolphin.

BTW, at https://bugzilla.redhat.com/show_bug.cgi?id=868530 they say delay in open/say dialogs was fixed in kdelibs-4.9.4-2.fc18. Has anyone tried this yet?
Comment 19 Franz Trischberger 2012-12-07 11:43:06 UTC
Created attachment 331730 [details]
kdelibs-4.9.4.ebuild

Taken the ebuild from the tree, removed udisks:0-references, added a call to cmake-utils_use_with to enable udisks2-support.
Comment 20 Franz Trischberger 2012-12-07 11:43:46 UTC
Created attachment 331732 [details]
kdelibs-udisks2-backend.patch

The most recent udisks2-patch for fedora18.
Comment 21 Franz Trischberger 2012-12-07 11:51:50 UTC
The experience:
Optical Disks still spin up for each dialog/dolphin window (once for each process, like with udisks:0)
Tried to launch qdbusviewer, which caused X to use 100% CPU - Yeah.

So overall no changes since udisks:0, let's look if the X-hang can be reprodeuced in some way.
Comment 22 Simon Siemonsma 2012-12-17 15:18:29 UTC
Looks like udisks2 support will be part of kde 4.10.
https://bugs.kde.org/show_bug.cgi?id=310335.
As 4.10 is scheduled for release on January 23 I guess most practical is to wait a bit.
Comment 23 Paolo Pedroni 2013-01-31 13:10:10 UTC
(In reply to comment #20)
> Created attachment 331732 [details]
> kdelibs-udisks2-backend.patch
> 
> The most recent udisks2-patch for fedora18.

This patch solves all problems for me: now dolphin and gwenview start up without delays and k3b can see my DVD writer, why isn't this in tree?
Comment 24 Michael Palimaka (kensington) gentoo-dev 2013-01-31 14:19:28 UTC
KDE/4.10 indeed does have udisks2 support integrated, and is what we will be building.

http://git.overlays.gentoo.org/gitweb/?p=proj/kde.git;a=commit;h=590f914e42ae092e1a5ef628c0092a16a1a1393d
Comment 25 Franz Trischberger 2013-01-31 16:20:20 UTC
The current kdelibs-4.9.98.ebuild might cause trouble:
Upstream forces to either use udisks:2 or udisks:0. This needs a patch to turn off udisks completely, or add sth. like !udisks? ( sys-fs/udisks:0 ) to the deps.
1) would be the best to leave people the possibility to use a polkit(consolekit/systemd-free desktop, and 2) because may really confuse them.

And:
I finally can confirm that this is solved: but only for udisks:2, and only in kdelibs-4.9.98. (Now that I switched to gnome3 (because of this) and started to like it.... fine :()
Comment 26 Michael Palimaka (kensington) gentoo-dev 2013-01-31 16:22:17 UTC
I saw your comment on the upstream bug and have forced udisks:2 only for now (since there is effort to remove :0 from the tree.)

We can watch if upstream makes changes or patch it ourself later if it causes too much upset.
Comment 27 Michael Palimaka (kensington) gentoo-dev 2013-02-07 15:00:00 UTC
Someone suggested in #-kde that since that since the backend doesn't actually appear to link to udisks, we could build udisks2 support unconditionally and just let it fail at runtime if udisks is missing.

Is anyone able to test and see what happens? (having kdelibs-4.10.0 installed and udisks not should be all that's required)
Comment 28 Michael Palimaka (kensington) gentoo-dev 2013-02-07 15:11:34 UTC
(In reply to comment #27)
> Someone suggested in #-kde that since that since the backend doesn't
> actually appear to link to udisks, we could build udisks2 support
> unconditionally and just let it fail at runtime if udisks is missing.
> 
> Is anyone able to test and see what happens? (having kdelibs-4.10.0
> installed and udisks not should be all that's required)

CCing Duncan since I think he is running like this.
Comment 29 Michael Palimaka (kensington) gentoo-dev 2013-02-07 16:17:49 UTC
(In reply to comment #27)
> Someone suggested in #-kde that since that since the backend doesn't
> actually appear to link to udisks, we could build udisks2 support
> unconditionally and just let it fail at runtime if udisks is missing.
> 
> Is anyone able to test and see what happens? (having kdelibs-4.10.0
> installed and udisks not should be all that's required)

Unfortunately this approach will cause bugs like bug #456010.
Comment 30 Duncan 2013-02-07 17:31:44 UTC
(In reply to comment #29)
> (In reply to comment #27)
> > Someone suggested in #-kde that since that since the backend doesn't
> > actually appear to link to udisks, we could build udisks2 support
> > unconditionally and just let it fail at runtime if udisks is missing.
> > 
> > Is anyone able to test and see what happens? (having kdelibs-4.10.0
> > installed and udisks not should be all that's required)
> 
> Unfortunately this approach will cause bugs like bug #456010.

Thanks for CCing me.  See bug 455792.  Yes, I'm running without udisks of any sort (package.provided so portage doesn't protest, but USE=udev and udev is actually installed, USE=-upower and it's not installed) and kdelibs-4.9.98/4.10.0 (at least) have built just fine, and run just fine as far as I can see.

Also note that udisks is an rdep, not a dep, so even as-is, it's not necessarily there for the build, only at runtime.

So at least with udev, udisks support should be find to build unconditionally.  I'm not sure about bug 456010, building without udev, however, but that's a different bug.

Thus I'd suggest letting the udisk flag(s) pull in the rdep (providing runtime support), but at buildtime, either build the support unconditionally, or let the udev flag control udisks(2) support build as well, depending on how 456010 is resolved.

(Looks like further bug dependencies are possible; there's certainly some interrelation.)

Duncan
Comment 31 Samuli Suominen gentoo-dev 2013-03-05 12:32:36 UTC
Try if =sys-fs/udisks-2.0.92 works better, like with the delay problem
Comment 32 Samuli Suominen gentoo-dev 2013-03-07 12:19:48 UTC
So kdelibs-4.10.1 only deps on udisks:2 and the delay problem people have had with it should be fixed by using udisks-2.0.92 instead of .91
Nothing left to do here then, I'll close this
Comment 33 Franz Trischberger 2013-03-07 12:41:38 UTC
(In reply to comment #32)
> So kdelibs-4.10.1 only deps on udisks:2 and the delay problem people have
> had with it should be fixed by using udisks-2.0.92 instead of .91
> Nothing left to do here then, I'll close this
Huh? Two days in the middle of the week to leave people for testing?
Quite short, isn't it?

It definitely does NOT fix the delays. The only thing that may fix it is a daemon that caches the values. And this is done with soliddiskscan:

https://github.com/sanya-m/solid-disk-prober

The README.md there mentions my overlay from which you can get patched kdelibs (4.10.0 and 4.10.1) + kde-misc/soliddiskscan (comes as PDEPEND for kdelibs[udisks]). And that really finally fixes the delay issues.
Comment 34 Samuli Suominen gentoo-dev 2013-03-07 12:45:28 UTC
(In reply to comment #33)
> (In reply to comment #32)
> > So kdelibs-4.10.1 only deps on udisks:2 and the delay problem people have
> > had with it should be fixed by using udisks-2.0.92 instead of .91
> > Nothing left to do here then, I'll close this
> Huh? Two days in the middle of the week to leave people for testing?
> Quite short, isn't it?
> 
> It definitely does NOT fix the delays. The only thing that may fix it is a
> daemon that caches the values. And this is done with soliddiskscan:
> 
> https://github.com/sanya-m/solid-disk-prober
> 
> The README.md there mentions my overlay from which you can get patched
> kdelibs (4.10.0 and 4.10.1) + kde-misc/soliddiskscan (comes as PDEPEND for
> kdelibs[udisks]). And that really finally fixes the delay issues.

This bug was about converting udisks:0 dependency with udisks:2 in the ebuild which has been done
This bug is not about the delays, but I've just wanted to mention it here that .92 solves part of the issues as per
http://forums.gentoo.org/viewtopic-t-951786-highlight-.html
If you wish to push soliddiskscan and patched kdelibs in tree, you propably want to open first an upstream bug and then new gentoo bug with a reference to the upstream bug
Collecting multiple issues here isn't that good idea
Comment 35 Florian Manschwetus 2013-08-09 09:35:36 UTC
I use kde-base/kdelibs-4.10.5-r1 and udisks 2.1.0 and I have this issue, so what is wrong?
Comment 36 Michael Palimaka (kensington) gentoo-dev 2013-08-12 13:12:29 UTC
(In reply to Florian Manschwetus from comment #35)
> I use kde-base/kdelibs-4.10.5-r1 and udisks 2.1.0 and I have this issue, so
> what is wrong?

Please file a new bug, it's too difficult to track on an old bug like this.