Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 429618 - udev-187-2: dolphin fails to mount LUKS encrypted devices
Summary: udev-187-2: dolphin fails to mount LUKS encrypted devices
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: udev maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-03 09:34 UTC by Sebastian Rose
Modified: 2012-08-09 15:12 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Rose 2012-08-03 09:34:15 UTC
When trying to mount a LUKS encrypted harddisk with Dolphin on KDE 4.9 the operation fails with the following error message:

The requested operation has failed.: Error unlocking device: timeout (10s) waiting for cleartext device to show up

The cleartext device gets set up though, under /dev/mapper/udisks-luks-uuid-$UUID. When I mount the cleartext device manually with "udisks --mount /dev/mapper/udisks-luks-uuid-$UUID" it works fine.

Reproducible: Always

Steps to Reproduce:
1. Try to mount an encrypted device with Dolphin, KDE 4.9
2.
3.
Actual Results:  
Mount failure

Expected Results:  
Mount success

Portage 2.2.0_alpha120 (default/linux/amd64/10.0, gcc-4.6.3, glibc-2.15-r2, 3.5.0-gentoo x86_64)
=================================================================
System uname: Linux-3.5.0-gentoo-x86_64-AMD_Phenom-tm-_II_X6_1090T_Processor-with-gentoo-2.1
Timestamp of tree: Thu, 02 Aug 2012 07:30:02 +0000
ccache version 3.1.7 [enabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.12
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/ccache:          3.1.7
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.27
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.2
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.6.3, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo own_overlay proaudio
Installed sets: @kdebase, @kdeutils, @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="-va --with-bdeps=y --quiet-build=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="ftp://mirror.netcologne.de/gentoo/ http://de-mirror.org/distro/gentoo/ http://mirror.leaseweb.com/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
LANG="en_GB.UTF8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US en_GB"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/pro-audio"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 apm atm bash-completion berkdb bzip2 cairo caps cdda cdparanoia cdr cli cracklib crypt css cups cxx dbus doc dri dts dv dvd dvdr encode exif ffmpeg fftw flac fortran ftp gcj gdbm gif gimp glut gnutls gphoto2 gpm hddtemp iconv icq icu ieee1394 imagemagick imap ipv6 jack java java6 javascript jit jpeg kde ladspa lame lash latex libedit libnotify libsamplerate lm_sensors lua lzo mad matroska mime mmx modules mp3 mpeg mplayer mudflap multilib musepack ncurses nls nptl nsplugin offensive ogg openal openexr opengl openmp oscar pam pcre pdf perl php png policykit pppd python qt4 quicktime readline samba sdl semantic-desktop session smp sndfile source sse sse2 ssl subversion svg syslog taglib tcpd theora threads tiff timidity truetype udev unicode usb vcd vim-syntax vorbis wavpack wxwindows x264 xcomposite xine xinerama xml xscreensaver xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US en_GB" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Johannes Huber gentoo-dev 2012-08-03 22:12:55 UTC
Please report this upstream and link back here.
Comment 2 Ulenrich 2012-08-04 11:32:30 UTC
Yes, 
/dev/mapper/LINK is created and luksOpen has happend. 
Only misses the mount of the decrypted device ...

This the only bug I have encountered I am really happy with Kde-4.9.0 ! 
Thanx to maintainers for your effort! And Kde-overlay users talking back.
Comment 3 Johannes Huber gentoo-dev 2012-08-06 06:46:51 UTC
Do you have unmasked the udisks2 use flag in kdelibs?
Comment 4 Robert Malek 2012-08-06 09:55:51 UTC
It dosn't help anything!

See  Bug 424157
Comment 5 Ulenrich 2012-08-06 14:54:31 UTC
I added my additional info to Sebastians upstream bug:
https://bugs.kde.org/show_bug.cgi?id=304540
Comment 6 Ulenrich 2012-08-06 14:59:22 UTC
qlist -Iv udisk  #gives my installed udisks packages:
sys-fs/udisks-1.0.4-r2
sys-fs/udisks-1.99.0

emerge udisks 

These are the packages that would be merged, in order:

Calculating dependencies  .... done!
[ebuild     U  ] sys-fs/udisks-1.99.0-r1 [1.99.0] USE="crypt gptfdisk -debug -introspection -systemd"
-----
should I update with introspection enabled? I thought this wasn't Kde related?
Comment 7 Ulenrich 2012-08-06 17:43:18 UTC
Bug is solved for me by the next Gentoo revisions, Changelog was:
"Use udev.pc pkg-config file to determine udevhelperdir and udevrulesdir.
Dummy revision bump for UDisks2 because it has the same logic for
--with-udevdir= in configure.ac."

sys-fs/udisks-1.0.4-r3
sys-fs/udisks-1.99.0-r1

(At least solved me only using device notifier)
Though I don't know which udisks-1 or udisks-1.99 is really needed for Kde.
It doesn't matter to not have -intorspection...
Comment 8 Ulenrich 2012-08-06 17:51:09 UTC
This surely was related to me using unstable sys-fs/udev-187-r1
Comment 9 Sebastian Rose 2012-08-07 08:16:33 UTC
This is solved by updating to udisks sys-fs/udisks-1.0.4-r3
Comment 10 Sebastian Rose 2012-08-09 07:10:24 UTC
Okay, this one is back from the dead.

(In reply to comment #8)
> This surely was related to me using unstable sys-fs/udev-187-r1

I thought it was fixed by updating udisks but it seems that you are right. The bug came back with udev-187-r2.
Comment 11 Johannes Huber gentoo-dev 2012-08-09 07:17:11 UTC
(In reply to comment #10)
> Okay, this one is back from the dead.
> 
> (In reply to comment #8)
> > This surely was related to me using unstable sys-fs/udev-187-r1
> 
> I thought it was fixed by updating udisks but it seems that you are right.
> The bug came back with udev-187-r2.

Re-assigning then.
Comment 12 Samuli Suominen gentoo-dev 2012-08-09 08:30:54 UTC
- After upgrading to -r1, -r2, or -r3 one needs to rebuild udisks:
  # emerge -1 udisks:0 udisks:2

- -r3 has a patch to search udev helpers also in /usr/lib/udev/

So if according to Comment #10 the bug remanifested when moving from -r1 to -r2, then this is solved now by -r3 and propably duplicate of bug 430412.
Comment 13 Samuli Suominen gentoo-dev 2012-08-09 11:36:29 UTC
(In reply to comment #12)
> - After upgrading to -r1, -r2, or -r3 one needs to rebuild udisks:
>   # emerge -1 udisks:0 udisks:2
> 
> - -r3 has a patch to search udev helpers also in /usr/lib/udev/

meant /lib/udev/ here...
Comment 14 Sebastian Rose 2012-08-09 15:12:28 UTC
I can confirm it is solved by udev-187-r3. Thanks.