Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 456010 - =kde-base/kdelibs[-udev] fails to link
Summary: =kde-base/kdelibs[-udev] fails to link
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-07 13:31 UTC by Christopher Schwan
Modified: 2013-02-08 16:26 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
(compressed) Build log (build.log.gz,127.82 KB, application/x-gzip)
2013-02-07 13:53 UTC, Christopher Schwan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Schwan 2013-02-07 13:31:47 UTC
`MAKEOPTS=-j1 USE="-udev -upower" emerge -1 =kde-base/kdelibs-4.10.0` fails to link at a certain stage. Compiling with my default MAKEOPTS=-j8 fails as well, but there is no useful error message displayed (?).

Compiling with USE=udev 'solves' the problem but I really would like to have a KDE without udev and also without udisks (but thats been mentioned already at bug #455792).

Build.log will follow shortly.

Reproducible: Always

Steps to Reproduce:
MAKEOPTS=-j1 USE="-udev -upower" emerge -1 =kde-base/kdelibs-4.10.0

Actual Results:  
Portage 2.1.11.31 (default/linux/amd64/10.0/no-multilib, gcc-4.6.3, glibc-2.15-r3, 3.6.11-gentoo x86_64)
=================================================================
System uname: Linux-3.6.11-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_740_@_1.73GHz-with-gentoo-2.1
Timestamp of tree: Thu, 07 Feb 2013 08:30:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo sage-on-gentoo cschwan-overlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xorg.conf.d /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--keep-going"                                                                                                                                                              
FCFLAGS="-O2 -pipe"                                                                                                                                                                             
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"                                                                                                                                             
FFLAGS="-O2 -pipe"                                                                                                                                                                              
GENTOO_MIRRORS="http://distfiles.gentoo.org"                                                                                                                                                    
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                                                               
MAKEOPTS="-j8"                                                                                                                                                                                  
PKGDIR="/usr/portage/packages"                                                                                                                                                                  
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/cschwan/projects/sage-on-gentoo /home/cschwan/projects/cschwan-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="alsa amd64 bzip2 cli cracklib crypt cxx dri iconv minimal mmx modules mudflap ncurses nls nptl openmp pam pcre readline semantic-desktop session sse sse2 ssl unicode xorg zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="sheets" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DVB_CARDS="usb-af9015" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" SANE_BACKENDS="snapscan" USERLAND="GNU" VIDEO_CARDS="radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Christopher Schwan 2013-02-07 13:53:40 UTC
Created attachment 338230 [details]
(compressed) Build log
Comment 2 Michael Palimaka (kensington) gentoo-dev 2013-02-08 16:26:22 UTC
Thanks for the report. This broke because udisks2 requires udev, and udisks2 was not optional.

 07 Feb 2013; Michael Palimaka <kensington@gentoo.org>
 +files/kdelibs-4.10.0-udisks.patch, kdelibs-4.10.0.ebuild:
 Add patch by Franz Fellner <alpine.art.de@googlemail.com> to make udisks
 support optional, wrt bug #455792.