Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!

Bug 500368

Summary: Xorg stabilization list for March
Product: Gentoo Linux Reporter: Chí-Thanh Christopher Nguyễn <chithanh>
Component: [OLD] Keywording and StabilizationAssignee: Gentoo X packagers <x11>
Status: RESOLVED FIXED    
Severity: enhancement CC: alexander, kroemmelbein, mattst88, nikoli, onigino, pacho, xarthisius, xoma
Priority: Normal Keywords: STABLEREQ
Version: unspecified   
Hardware: All   
OS: Linux   
Whiteboard:
Package list:
Runtime testing required: ---
Bug Depends on: 447342, 459306, 469208, 472054, 472224, 486154, 486512, 487564, 488216, 490092, 491018, 492934, 494970, 498812, 499442, 500178, 500792, 504252, 504298    
Bug Blocks: 499098, 499954, 500372, 501442, 505170, 512012    
Attachments: x11_stable.list v1
x11_stable.list
x11_stable.list v3
x11_stable.list v4
x11_stable.list v5
x11_stable.list v6
x11_stable.list v7
x11_stable.list v8
x11_stable.list v8
x11_stable.list v9
x11_stable.list v10

Description Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-05 13:17:39 UTC
Created attachment 369592 [details]
x11_stable.list v1

This bug is for stabilization of x11 packages.

No talking here, please. If you find a regression that should block stabilization: report a separate bug and make it block this bug.

To generate the keywords list for your arch, run
# awk '/YOURARCHHERE/ {print "="$1}' x11_stable.list > x11_stable.keywords
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-05 13:20:02 UTC
*** Bug 490148 has been marked as a duplicate of this bug. ***
Comment 2 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-05 13:23:10 UTC
*** Bug 499680 has been marked as a duplicate of this bug. ***
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-10 20:39:40 UTC
*** Bug 500912 has been marked as a duplicate of this bug. ***
Comment 4 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-23 11:42:50 UTC
*** Bug 502214 has been marked as a duplicate of this bug. ***
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-24 20:33:47 UTC
Created attachment 371186 [details]
x11_stable.list

x11_stable.list v2

* new stabilization targets for libclc, mesa, xcb-util-wm
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-24 20:57:09 UTC
Created attachment 371190 [details]
x11_stable.list v3

* Add xf86-video-geode
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-03 09:44:41 UTC
Created attachment 371632 [details]
x11_stable.list v4

* drop libva-vdpau-driver which cannot go stable yet
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-03 18:07:22 UTC
Created attachment 371654 [details]
x11_stable.list v5

* drop xvba-video which cannot go stable at this time either
Comment 9 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-03 18:15:12 UTC
ia64: you can ignore the dep on bug 461394 as there is already a stable libunwind.
Comment 10 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2014-03-05 06:17:44 UTC
I'm getting the following errors:

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-base/xorg-server-1.15.0[-minimal]
# required by x11-drivers/xf86-input-synaptics-1.7.3
# required by =x11-drivers/xf86-input-synaptics-1.7.3 (argument)
=media-libs/mesa-10.0.3 ~x86

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by x11-base/xorg-server-1.15.0[-minimal]
# required by x11-drivers/xf86-input-synaptics-1.7.3
# required by =x11-drivers/xf86-input-synaptics-1.7.3 (argument)
# /usr/portage/profiles/package.mask:
# Ch��-Thanh Christopher Nguy���n <chithanh@gentoo.org> (10 Nov 2013)
# Causes build failures, bug #492800
=media-libs/mesa-10.0.3
Comment 11 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-05 13:21:35 UTC
x11-base/xorg-server has only >=media-libs/mesa-9.2.0[nptl=] in dependencies, it must be caused by something else. (I think bug 419381 causes portage to blame the wrong package)
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-16 20:05:03 UTC
*** Bug 504806 has been marked as a duplicate of this bug. ***
Comment 13 Matt Turner gentoo-dev 2014-03-19 20:16:59 UTC
Created attachment 373052 [details]
x11_stable.list v6

mesa-9.2.5-r1 -> mesa-10.0.4
Comment 14 Agostino Sarubbo gentoo-dev 2014-03-23 12:18:00 UTC
This stable request can't be completed because of the following repoman's error(s):

  dependency.bad                18
   dev-libs/wayland/wayland-1.4.0.ebuild: DEPEND: amd64(default/linux/amd64/13.0) 
['dev-libs/expat[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]', 
'virtual/libffi[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?]']


In case you are the maintainer of the needed package(s), please authorize the stabilization and edit the summary of this bug.
In case you are not the maintainer of the needed package(s), please open the necessary bug(s) and make a block for this bug.

To find the full list, feel free to follow this article: http://blogs.gentoo.org/ago/2012/07/06/repoman-check-before-file-stable-request
Comment 15 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-25 15:09:30 UTC
Created attachment 373510 [details]
x11_stable.list v7

* drop wayland/weston per comment 14
* opencl appears broken on ppc in mesa-10, drop it too
* update stabilization targets of xf86-video-vmware and xf86-input-synaptics
Comment 16 Alexander Tsoy 2014-03-25 15:29:14 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #15)
> * drop wayland/weston per comment 14

Err.. Is that really a problem?

$ egrep 'virtual/libffi|dev-libs/expat' /usr/portage/profiles/default/linux/amd64/13.0/package.use.stable.mask
dev-libs/expat abi_x86_32
virtual/libffi abi_x86_32
$ egrep 'virtual/libffi|dev-libs/expat' /usr/portage/profiles/hardened/linux/amd64/package.use.stable.mask 
dev-libs/expat abi_x86_32
virtual/libffi abi_x86_32
Comment 17 Gino McCarty 2014-03-25 20:50:15 UTC
(In reply to Alexander Tsoy from comment #16)
> (In reply to Chí-Thanh Christopher Nguyễn from comment #15)
> > * drop wayland/weston per comment 14
> 
> Err.. Is that really a problem?
> 
> $ egrep 'virtual/libffi|dev-libs/expat'
> /usr/portage/profiles/default/linux/amd64/13.0/package.use.stable.mask
> dev-libs/expat abi_x86_32
> virtual/libffi abi_x86_32
> $ egrep 'virtual/libffi|dev-libs/expat'
> /usr/portage/profiles/hardened/linux/amd64/package.use.stable.mask 
> dev-libs/expat abi_x86_32
> virtual/libffi abi_x86_32

FWIW - my system seems fine

Calculating dependencies... done!
[ebuild     U ~] dev-libs/expat-2.1.0-r4 [2.1.0-r3] USE="unicode -examples -static-libs" ABI_X86="32* (64) (-x32)" 0 kB
[ebuild     U ~] dev-libs/libffi-3.0.13-r1 [3.0.11] USE="-debug -pax_kernel% -static-libs {-test}" ABI_X86="32%* (64%*) (-x32)" 826 kB
[ebuild     U ~] virtual/libffi-3.0.13-r1 [3.0.11] ABI_X86="32%* (64%*) (-x32)" 0 kB
[ebuild   R   ~] dev-libs/wayland-1.4.0  USE="-doc" ABI_X86="32* (64) (-x32)" 0 kB
[blocks B      ] app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]" is blocking dev-libs/expat-2.1.0-r4, dev-libs/libffi-3.0.13-r1)
Comment 18 Alexander Tsoy 2014-03-25 21:02:27 UTC
(In reply to Alexander Tsoy from comment #16)
> (In reply to Chí-Thanh Christopher Nguyễn from comment #15)
> > * drop wayland/weston per comment 14
> 
> Err.. Is that really a problem?
> 
> $ egrep 'virtual/libffi|dev-libs/expat'
> /usr/portage/profiles/default/linux/amd64/13.0/package.use.stable.mask
> dev-libs/expat abi_x86_32
> virtual/libffi abi_x86_32
> ...

Ouch. Probably 'dev-libs/wayland abi_x86_32' should be added to package.use.stable.mask to silent repoman. Sorry for the noise.
Comment 19 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-03-26 09:41:09 UTC
Created attachment 373566 [details]
x11_stable.list v8

* Re-add wayland/weston now that repoman is shut up by masking the abi_x86_32 flag per comment 17
Comment 20 Agostino Sarubbo gentoo-dev 2014-03-27 11:20:02 UTC
amd64 stable
Comment 21 Andrius Štikonas 2014-03-27 23:02:59 UTC
(In reply to Agostino Sarubbo from comment #20)
> amd64 stable

Shouldn't libxshmfence have abi_x86_32 masked too?
Comment 22 Matt Turner gentoo-dev 2014-03-27 23:33:15 UTC
(In reply to Andrius Štikonas from comment #21)
> (In reply to Agostino Sarubbo from comment #20)
> > amd64 stable
> 
> Shouldn't libxshmfence have abi_x86_32 masked too?

libxshmfence hasn't ever been part of emul-linux-x86-xlibs and doesn't depend on anything, so there shouldn't be any reason to mask abi_x86_32 on it. This applies presentproto too.
Comment 23 Fulong Sun 2014-03-28 00:50:52 UTC
(In reply to Agostino Sarubbo from comment #20)
> amd64 stable

I'm using Core2 T7200, which not support SSE4.1, compile failure with:

/usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/include/smmintrin.h:31:3: error: #error "SSE4.1 instruction set not enabled"
Comment 24 Jeroen Roovers gentoo-dev 2014-03-28 02:02:24 UTC
Stable for HPPA.
Comment 25 Matt Turner gentoo-dev 2014-03-28 02:59:45 UTC
(In reply to Fulong Sun from comment #23)
> (In reply to Agostino Sarubbo from comment #20)
> > amd64 stable
> 
> I'm using Core2 T7200, which not support SSE4.1, compile failure with:
> 
> /usr/lib/gcc/x86_64-pc-linux-gnu/4.7.3/include/smmintrin.h:31:3: error:
> #error "SSE4.1 instruction set not enabled"

Bug 503828.
Comment 26 Andrius Štikonas 2014-03-28 11:21:46 UTC
(In reply to Matt Turner from comment #22)
> libxshmfence hasn't ever been part of emul-linux-x86-xlibs and doesn't
> depend on anything, so there shouldn't be any reason to mask abi_x86_32 on
> it. This applies presentproto too.

I think this is incorrect. libxshmfence depends on xproto which has abi_x86_32 masked:
configure: error: Package requirements (xproto) were not met:
No package 'xproto' found
Comment 27 Rafał Mużyło 2014-03-29 13:58:38 UTC
You've missed a spot - see bug 496682.
Comment 28 Rafał Mużyło 2014-03-29 15:09:26 UTC
(In reply to Rafał Mużyło from comment #27)
> You've missed a spot - see bug 496682.

Never mind - I've misread something.
Comment 29 Matt Turner gentoo-dev 2014-03-29 20:52:35 UTC
Created attachment 373852 [details]
x11_stable.list v8

I've stabilized what I'm comfortable with on alpha without firing up a system with a video card in it.
Comment 30 Agostino Sarubbo gentoo-dev 2014-04-08 20:09:23 UTC
ppc stable
Comment 31 Agostino Sarubbo gentoo-dev 2014-04-16 09:29:01 UTC
ppc64 stable
Comment 32 Agostino Sarubbo gentoo-dev 2014-04-18 19:04:19 UTC
alpha/ia64 stable
Comment 33 Agostino Sarubbo gentoo-dev 2014-04-20 08:23:29 UTC
sparc stable
Comment 34 Agostino Sarubbo gentoo-dev 2014-04-20 08:52:41 UTC
x86 stable
Comment 35 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-05-25 21:30:09 UTC
Created attachment 377632 [details]
x11_stable.list v9

* Change arm stabilization target of xf86-input-wacom to 0.24.0 for bug 504298
Comment 36 Agostino Sarubbo gentoo-dev 2014-05-31 10:18:12 UTC
What we should do with:

  dependency.bad                1
   x11-base/xorg-drivers/xorg-drivers-1.15.ebuild: PDEPEND: arm(default/linux/arm/13.0) ['x11-drivers/xf86-video-freedreno']

?
Comment 37 Pacho Ramos gentoo-dev 2014-06-01 11:02:07 UTC
(will be needed for wayland support in gtk+-3.12 for arm)
Comment 38 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-06-02 13:21:32 UTC
Created attachment 378068 [details]
x11_stable.list v10

* Add xf86-video-freedreno-1.0.0 to stabilization list, to address comment #36.
Comment 39 Agostino Sarubbo gentoo-dev 2014-06-08 09:26:08 UTC
arm stable.