Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 492934 - =media-libs/mesa-9.2.4[xorg] with =x11-base/xorg-server-1.14.99.903 - glxinfo: Error: couldn't find RGB GLX visual or fbconfig
Summary: =media-libs/mesa-9.2.4[xorg] with =x11-base/xorg-server-1.14.99.903 - glxinfo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 500368
  Show dependency tree
 
Reported: 2013-11-30 10:17 UTC by Dennis Schridde
Modified: 2014-02-24 19:43 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Schridde 2013-11-30 10:17:20 UTC
There seems to be something broken with the combination =media-libs/mesa-9.2.4[xorg] and =x11-base/xorg-server-1.14.99.903.

When trying to run glxinfo, it reported "Error: couldn't find RGB GLX visual or fbconfig" in the first lines and nothing about OpenGL support (i.e. no version, nothing, just a list of visuals). Other OpenGL applications did not work either.

When disabling the xorg useflag for mesa, rebuilding it and then restarting X, everything was back to normal.

I assume that the current xorg-server does not support the xorg state tracker of mesa anymore, and thus it fails silently? If that is true, I think the dependencies of mesa[xorg] should be adjusted, so people notice.

emerge --info, below, was taken after disabling the xorg useflag of mesa.

Reproducible: Always




Portage 2.2.7 (default/linux/amd64/13.0/desktop/kde, gcc-4.8.2, glibc-2.17, 3.12.1-gentoo x86_64)
=================================================================
System uname: Linux-3.12.1-gentoo-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5000+-with-gentoo-2.2
KiB Mem:     6107608 total,   1763908 free
KiB Swap:    7813116 total,   7813004 free
Timestamp of tree: Sat, 30 Nov 2013 08:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.2rc1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.5-r4, 3.2.5-r3, 3.3.3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo systemd sage-on-gentoo mrueg qt local kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-pipe -O2 -march=athlon64-sse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--depclean-lib-check=n --keep-going --nospinner"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildsyspkg compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.spline.inf.fu-berlin.de/mirrors/gentoo/ http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://distfiles.gentoo.org"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu"
MAKEOPTS="-j3"
PKGDIR="/var/cache/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/var/cache/portage/gentoo"
PORTDIR_OVERLAY="/var/lib/layman/systemd /var/lib/layman/sage-on-gentoo /var/lib/layman/mrueg /var/lib/layman/qt /var/cache/portage/local /var/cache/portage/overlays/kde"
[...]
USE="3dnow 3dnowext X a52 aac acl acpi alsa amd64 avahi bash-completion berkdb bluetooth branding bzip2 cairo caps cdda cdr cjk cli cracklib crypt cups cxx dbus declarative dri dts dvb dvd dvdr egl emboss encode exif fam ffmpeg firefox flac fortran gdbm gif gles gles1 gles2 gmp gpm gstreamer gtk ibus iconv ipv6 jpeg jpeg2k kde kipi latex lcms ldap libnotify mad mmx mmxext mng modules mp3 mp4 mpeg mplayer mudflap multilib mysql ncurses networkmanager nls nptl ogg openal openexr opengl openmp opus pam pango pch pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline real samba sdl semantic-desktop session speex spell sse sse2 sse3 ssl startup-notification subversion svg systemd tcpd theora threads tiff truetype udev udisks unicode upnp upower usb v4l vaapi vdpau vorbis vpx wayland x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="stage words flow sheets" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs systemd" ELIBC="glibc" ENLIGHTENMENT_MODULES="*" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" LIRC_DEVICES="devinput" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18 ruby20" USERLAND="GNU" VIDEO_CARDS="radeon r600" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

media-libs/mesa-9.2.4 was built with the following:
USE="egl gallium gbm gles1 gles2 llvm llvm-shared-libs nptl opencl osmesa r600-llvm-compiler vdpau wayland xa xvmc -bindist -classic -debug -openvg -pax_kernel -pic (-selinux) -xorg" ABI_X86="32 64 -x32" VIDEO_CARDS="radeon -freedreno -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeonsi -vmware"
CFLAGS="-pipe -O2 -march=athlon64-sse3 -g"
CXXFLAGS="-pipe -O2 -march=athlon64-sse3 -g"


x11-base/xorg-server-1.14.99.903 was built with the following:
USE="ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -tslib -xnest -xvfb"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,-z,lazy"
Comment 1 jospezial 2013-11-30 15:38:45 UTC
Have you been able to re-emerge mesa after update to xorg-server-1.14.99.903 ?

Possible dup of https://bugs.gentoo.org/show_bug.cgi?id=492838
Comment 2 Dennis Schridde 2013-11-30 17:03:32 UTC
(In reply to jospezial from comment #1)
> Have you been able to re-emerge mesa after update to xorg-server-1.14.99.903
> ?

Yes, mesa was built against that version of xorg-server.

> Possible dup of https://bugs.gentoo.org/show_bug.cgi?id=492838

I think this one is different, because it happens that at runtime it does not work, while in the other bug it does not build in the first place. But then -- maybe the fix for the other bug is wrong and causes this behaviour...
Comment 3 Paul de Vrieze (RETIRED) gentoo-dev 2014-02-03 19:56:31 UTC
It appears related to https://bugs.freedesktop.org/show_bug.cgi?id=70706

It also only seems to happen with the ati driver kI use the r600 driver).
Comment 4 Paul de Vrieze (RETIRED) gentoo-dev 2014-02-03 23:12:14 UTC
Disabling glamor through a useflag on the driver fixes this.
Comment 5 Eugene Shalygin 2014-02-05 17:32:10 UTC
In my case disabling glamor does not help.

X.Org X Server 1.15.0
xf86-vide0-ati, module version = 7.3.99
Mesa 10.1.0-devel (git-023a50d), r600g driver
Comment 6 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-23 12:24:28 UTC
Patches have been posted to the upstream mailing list:

http://patchwork.freedesktop.org/patch/20458/
http://patchwork.freedesktop.org/patch/20464/
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-24 19:43:37 UTC
Fixed in 9.2.5-r1

As >=mesa-10 no longer has USE=xorg, I skipped that version.