Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 496682 - x11-drivers/xf86-video-intel-2.21.15 USE=sna with xorg-server-1.15.0 - .../work/xf86-video-intel-2.21.15/src/sna/sna_accel.c:15226:3: error: too many arguments to function 'DamageUnregister'
Summary: x11-drivers/xf86-video-intel-2.21.15 USE=sna with xorg-server-1.15.0 - .../wo...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 506126 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-01 16:01 UTC by Andreas Sturmlechner
Modified: 2014-03-29 13:58 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
x11-drivers:xf86-video-intel-2.21.15:20140101-152256.log (x11-drivers:xf86-video-intel-2.21.15:20140101-152256.log,123.90 KB, text/plain)
2014-01-01 16:01 UTC, Andreas Sturmlechner
Details
xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch (xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch,902 bytes, patch)
2014-01-01 16:52 UTC, Andreas Sturmlechner
Details | Diff
xf86-video-intel-2.21.15.ebuild.diff (xf86-video-intel-2.21.15.ebuild.diff,386 bytes, patch)
2014-01-01 16:55 UTC, Andreas Sturmlechner
Details | Diff
xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch (xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch,781 bytes, patch)
2014-01-01 17:06 UTC, Andreas Sturmlechner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Sturmlechner gentoo-dev 2014-01-01 16:01:54 UTC
Created attachment 366694 [details]
x11-drivers:xf86-video-intel-2.21.15:20140101-152256.log

USE="uxa" does work, glamor wasn't tested.
Comment 1 Andreas Sturmlechner gentoo-dev 2014-01-01 16:52:26 UTC
Created attachment 366696 [details, diff]
xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch

produced a simple patch based on the works of:

http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=524a45da56e2a052ffafa3887891caa90ba39f76
https://bugs.freedesktop.org/show_bug.cgi?id=71110

seems to work fine for me.
Comment 2 Andreas Sturmlechner gentoo-dev 2014-01-01 16:55:32 UTC
Created attachment 366698 [details, diff]
xf86-video-intel-2.21.15.ebuild.diff

ebuild makes use of the patch
Comment 3 Andreas Sturmlechner gentoo-dev 2014-01-01 17:06:07 UTC
Created attachment 366700 [details, diff]
xf86-video-intel-2.21.15-handle-updates-to-DamageUnregister-API.patch

actually, the Intel patch works just as well for 2.21.15. Next time I'll try first ;)
Comment 4 David Heidelberg (okias) 2014-01-01 18:47:06 UTC
Fixed in ::x11 overlay, feel free to retest (no Intel hardware by hand)
Comment 5 Rafał Mużyło 2014-01-01 20:14:45 UTC
(In reply to David Heidelberger (okias) from comment #4)
> Fixed in ::x11 overlay, feel free to retest (no Intel hardware by hand)

Well, the patch from the previous comment *is* from the upstream repo and I've already had tested something with the same effect, so it should go into the tree ASAP (as 1.15.0 isn't masked).
Comment 6 David Heidelberg (okias) 2014-01-01 23:28:19 UTC
I have commit access only to x11 overlay, so it's all I can do.
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-26 18:03:10 UTC
Fixed in CVS.
Comment 8 Rafał Mużyło 2014-03-29 13:58:26 UTC
*** Bug 506126 has been marked as a duplicate of this bug. ***