Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 499442 - x11-libs/glamor-0.6.0[xv] - .../work/glamor-egl-0.6.0/src/glamor_xv.c:445:1: error: implicit declaration of function 'DamageDamageRegion' [-Werror=implicit-function-declaration]
Summary: x11-libs/glamor-0.6.0[xv] - .../work/glamor-egl-0.6.0/src/glamor_xv.c:445:1: ...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
Depends on: 416069
Blocks: werror gcc-4.8 500368
  Show dependency tree
Reported: 2014-01-27 11:08 UTC by Helmut Jarausch
Modified: 2014-02-24 20:17 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

build log (,73.93 KB, text/plain)
2014-01-27 11:08 UTC, Helmut Jarausch
glamor_xv.i (xz-compressed) (glamor_xv.i.xz,100.81 KB, application/x-xz)
2014-02-11 08:31 UTC, Helmut Jarausch
0001-glamor_xv-add-missing-include.patch (0001-glamor_xv-add-missing-include.patch,888 bytes, patch)
2014-02-11 11:22 UTC, Chí-Thanh Christopher Nguyễn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Helmut Jarausch 2014-01-27 11:08:18 UTC
Created attachment 368864 [details]
build log

x11-libs/glamor-0.6.0 fails to compile :
error: implicit declaration of function 
'DamageDamageRegion' [-Werror=implicit-function-declaration]
 DamageDamageRegion(port_priv->pDraw, &port_priv->clip);

emerge --info x11-libs/glamor
Portage 2.2.8_p15 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.18-r1, 3.13.0-gentoo x86_64)
                         System Settings
System uname: Linux-3.13.0-gentoo-x86_64-AMD_Phenom-tm-_II_X4_955_Processor-with-gentoo-2.2
KiB Mem:     7907792 total,   3948320 free
KiB Swap:    1048572 total,    999656 free
Timestamp of tree: Mon, 27 Jan 2014 07:15:01 +0000
ld GNU ld (GNU Binutils) 2.24
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3, 3.4_pre20131110::progress
dev-util/ccache:          3.1.9-r3
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.13.4, 1.14.1
sys-devel/binutils:       2.24-r2
sys-devel/gcc:            4.6.4, 4.7.3-r1, 4.8.2-r1, 4.9.0_pre9999::local
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo local sunrise
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-mtune=native -march=native -O2 -msse3 -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/lib/neatx/home"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-mtune=native -march=native -O2 -msse3 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/portage/layman/sunrise"
USE="3dnow 3dnowext 3dnowprefetch X a52 aac acl acpi alsa amd64 avahi berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emacs emboss encode exif fam ffmpeg fftw firefox flac fortran fuse gdbm gfortran gif gimp gnome gpm gtk gtk2 iconv ipv6 jpeg kde lapack lcms libnotify mad mmx mmxext mng modules mp3 mp4 mpeg multilib ncurses nls nptl nptlonly ogg opengl openmp openrc pam pango pcre pdf png policykit ppds qt qt3support qt4 readline sdl session smp spell sqlite sqlite3 sse sse2 sse3 sse4a ssl startup-notification svg tcl tcpd threads tiff tk truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="btrfs systemd" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en de" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="radeonhd radeon fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-01-28 16:19:52 UTC
Does it make a difference whether you set eselect opengl to xorg-x11 or ati?
Comment 2 Tamas Jantvik 2014-02-04 21:32:42 UTC
I have the same problem. The latest intel drivers require glamor 0.6.0 for USE=glamor. And I don't have any ati opengl drivers as I have an intel graphics chip.
Comment 3 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-04 21:48:33 UTC
And does it still fail if you build glamor with the xv USE flag disabled?
Comment 4 Helmut Jarausch 2014-02-05 10:40:32 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #3)
> And does it still fail if you build glamor with the xv USE flag disabled?
No, it builds just fine with USE=-xv here.
Many thanks,
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-10 22:25:40 UTC
I suspect that the issue is due to missing #include <xorg/damage.h> in glamor_xv.c but I have been unable to reproduce this issue so far.

Could someone who sees this bug please add -save-temps to CFLAGS and attach /var/tmp/portage/x11-libs/glamor-0.6.0/work/glamor-egl-0.6.0/src/glamor_xv.i ?
Comment 6 Helmut Jarausch 2014-02-11 08:31:18 UTC
Created attachment 370128 [details]
glamor_xv.i (xz-compressed)
Comment 7 Tamas Jantvik 2014-02-11 09:18:15 UTC
It doesn't build for me even with USE="gles -xv", but I run a stable system with just some packages keyworded, so I probably miss a dependency. I suspect it needs mesa-9.2, but keywording that seems to be a bit non-trivial. So I'll have to leave it as it is for now.
Comment 8 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-11 09:58:58 UTC
Ok, I think I got it:

 # 1 "/usr/include/xorg/scrnintstr.h" 1
 # 40 "/usr/include/xorg/xf86str.h" 2
 # 1 "/usr/include/xorg/pixmapstr.h" 1
-# 54 "/usr/include/xorg/pixmapstr.h"
+# 53 "/usr/include/xorg/pixmapstr.h"
+# 1 "/usr/include/xorg/damage.h" 1
+# 30 "/usr/include/xorg/damage.h"

looking at commit history of pixmapstr.h it seems that #include "damage.h" was added in
So all xorg-server before 1.13 (which do not contain this commit) will fail with glamor[xv], and later versions work by accident due to inclusion of damage.h in pixmapstr.h.

(In reply to Tamas Jantvik from comment #7)
Then your bug is something else. Please open a new bug report and attach the relevant logs.
Comment 9 Helmut Jarausch 2014-02-11 11:12:36 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #8)
> So all xorg-server before 1.13 (which do not contain this commit) will fail
> with glamor[xv], and later versions work by accident due to inclusion of
> damage.h in pixmapstr.h.

I have to stick to xorg-server-1.12.4-r2 since I need ati-drivers[legacy]
The only ati-drivers[legacy] is 13.1_pre897  which blocks all versions of
xorg-server higher than 1.12.49.

So, what can I do to fix the issue (or does anybody know a more recent ati-drivers[legacy]) ?

Comment 10 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-11 11:22:04 UTC
Created attachment 370142 [details, diff]

Patch which should fix the problem, also sent upstream.
Comment 11 Helmut Jarausch 2014-02-11 11:49:22 UTC
(In reply to Chí-Thanh Christopher Nguyễn from comment #10)
> Created attachment 370142 [details, diff] [details, diff]
> 0001-glamor_xv-add-missing-include.patch
> Patch which should fix the problem, also sent upstream.

Thanks, works just fine!
Comment 12 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-02-11 12:08:33 UTC
Fixed in 0.6.0 without a revbump.