Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 346809 (gcc-4.6) - [tracker] GCC 4.6 porting
Summary: [tracker] GCC 4.6 porting
Status: RESOLVED FIXED
Alias: gcc-4.6
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GCC Porting (show other bugs)
Hardware: All Linux
: High normal with 14 votes (vote)
Assignee: Please assign to toolchain
URL:
Whiteboard:
Keywords: Tracker
: 382107 407293 (view as bug list)
Depends on: 346825 349170 353733 354051 354277 357175 357305 358021 360503 360513 360517 361057 361069 361421 361461 361783 361811 361869 362037 362047 362061 362207 362251 362261 362265 362299 362303 362307 362365 362367 362369 362371 362377 362379 362381 362391 362499 362501 362545 PR48335 362591 362599 362625 362633 362639 362661 362667 362669 362671 362673 362675 362733 362735 362739 362815 362823 362825 362829 362839 362841 362843 362863 362865 362867 362991 363009 363011 363017 363109 363161 363165 363167 363223 363225 363227 363229 363235 363243 363259 363317 363355 363459 363463 363465 363467 363477 363485 363487 363489 363531 363535 363539 363721 363723 363725 363727 363729 363731 363935 364077 364229 364231 364283 364285 364303 364319 364335 364339 364779 364781 364783 364805 364917 364961 365015 365017 365069 365109 365115 365117 365195 365219 365797 365855 365919 365921 365925 366013 366067 366093 366097 366191 366199 366201 366399 367261 367491 367497 367865 367883 367903 368339 368713 369121 369445 369639 369705 369761 369887 370015 370029 370047 370471 371001 371239 373759 374383 374407 374651 374657 374803 375755 376445 376567 377837 377997 378179 379845 380289 380439 380697 380767 381005 382001 382409 382439 384291 387483 389323 391427 393105 395989 401561 404931 404957 PR52999 414265 421539 421903 424475 425182 452694
Blocks: gcc-4.6-stable
  Show dependency tree
 
Reported: 2010-11-26 01:43 UTC by Ryan Hill (RETIRED)
Modified: 2013-02-19 17:39 UTC (History)
55 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Hill (RETIRED) gentoo-dev 2010-11-26 01:43:15 UTC
This bug is used for the tracking of packages broken by the upcoming GCC 4.6, which has now entered the pre-release stage.

 - File a NEW bug for each issue and make it BLOCK this one.  Assign these bugs
to the maintainer of the package in question, NOT gcc-porting@g.o please.
 - Bugs filed without patches will be closed as INVALID.
 - Don't use this bug for issues in GCC 4.6 itself.  File a new bug and assign
it to the toolchain team.
 - Please keep this tracker free from comments.  Discussion should take place
on the relevant bugs.
Comment 1 Alexey Shvetsov gentoo-dev 2011-03-26 17:51:56 UTC
GCC 4.6.0 released 
http://gcc.gnu.org/gcc-4.6/changes.html
Comment 2 Jan Psota 2011-03-27 00:42:08 UTC
gcc-4.6.1 released
Comment 3 Alexey Shvetsov gentoo-dev 2011-03-27 09:18:25 UTC
(In reply to comment #2)
> gcc-4.6.1 released

No. Only gcc-4.6.0 released according to http://gcc.gnu.org/
Comment 4 Fabio Correa 2011-06-27 15:24:53 UTC
gcc-4.6.1 released, according to gcc.gnu.org
Comment 5 Ryan Hill (RETIRED) gentoo-dev 2011-06-28 00:56:24 UTC
See the comment about no comments.
Comment 6 Mike Gilbert gentoo-dev 2011-09-07 03:57:11 UTC
*** Bug 382107 has been marked as a duplicate of this bug. ***
Comment 7 Ryan Hill (RETIRED) gentoo-dev 2011-11-03 03:51:47 UTC
I just realized we need gcc-config-1.5 keyworded for Go support.  Can we do that or should I backport it to 1.4?
Comment 8 Jeroen Roovers (RETIRED) gentoo-dev 2012-03-07 16:18:42 UTC
*** Bug 407293 has been marked as a duplicate of this bug. ***
Comment 9 Guillaume ZITTA 2012-05-22 14:53:43 UTC
Why ~amd64 keyword is not present in ebuilds
I don't see amd64 specific bugs...
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2012-05-23 01:41:10 UTC
grub.
Comment 11 Killian De Volder 2012-06-01 10:08:00 UTC
app-office/calligra-2.4.1 also fails: 
calligra-2.4.1/filters/words/msword-odf/wv2/src/textconverter.cpp:65:5: error: 'iconv_t' does not name a type
alligra-2.4.1/filters/words/msword-odf/wv2/src/textconverter.cpp: In constructor 'wvWare::TextConverter::Private::Private(const string&, const string&)':
calligra-2.4.1/filters/words/msword-odf/wv2/src/textconverter.cpp:44:53: error: class 'wvWare::TextConverter::Private' does not have any field named 'm_iconv'
Comment 12 gpiez 2012-11-22 10:01:52 UTC
I just stumbled accross the gcc site and see that gcc-4.5 is no longer maintained. Maybe there is a way to make software packages, which refuse to compile with an recent version of gcc, require a older gcc, while unmasking a newer one for default?
Comment 13 Ryan Hill (RETIRED) gentoo-dev 2013-01-07 05:33:13 UTC
Done.