Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 421903 - dev-db/mysql++ fails to build with gcc 4.7
Summary: dev-db/mysql++ fails to build with gcc 4.7
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL: https://tinderboxlogs.s3.amazonaws.co...
Whiteboard:
Keywords:
: 425506 (view as bug list)
Depends on:
Blocks: gcc-4.6 gcc-4.7
  Show dependency tree
 
Reported: 2012-06-19 09:35 UTC by Diego Elio Pettenò (RETIRED)
Modified: 2013-03-04 20:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed patch to the mysql++ sources (mysql++-3.0.9-gcc-4.7.patch,344 bytes, patch)
2012-07-12 19:19 UTC, Guido Winkelmann
Details | Diff
Proposed patch to the ebuild (patch,360 bytes, patch)
2012-07-12 19:20 UTC, Guido Winkelmann
Details | Diff
Patch trhat uses cstddef for size_t (gcc-4.7.patch,232 bytes, patch)
2012-10-18 14:52 UTC, Gianni Rossi
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Diego Elio Pettenò (RETIRED) gentoo-dev 2012-06-19 09:35:43 UTC
Portage 2.2.0_alpha110 (default/linux/amd64/10.0, gcc-4.7.1, glibc-2.15-r2, 3.4.2-hardened x86_64)
=================================================================
System uname: Linux-3.4.2-hardened-x86_64-AMD_Opteron-TM-_Processor_6272-with-gentoo-2.1
Timestamp of tree: Sat, 16 Jun 2012 07:30:01 +0000
app-shells/bash:          4.2_p29
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.8-r3
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.10.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.11.5, 1.12.1
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.3-r2, 4.7.1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.4 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
Installed sets: 
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -ggdb -march=native -ftracer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -ggdb -march=native -ftracer"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict test test-fail-continue unknown-features-warn unmerge-orphans userfetch userpriv usersandbox"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j24"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/var/cache/portage/tree"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowex acl amd64 berkdb bzip2 cli cracklib crypt cups cxx dri ffmpeg fortran gdbm gpm iconv ipv6 mmx modules mudflap multilib ncurses nls nptl openmp pam pcre pppd qt3support readline session sse sse2 sse3 sse4 ssl ssse3 tcpd unicode vhosts xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 jruby ruby19 ree18" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Diego Elio Pettenò (RETIRED) gentoo-dev 2012-07-10 16:15:40 UTC
*** Bug 425506 has been marked as a duplicate of this bug. ***
Comment 2 Guido Winkelmann 2012-07-12 19:19:47 UTC
Created attachment 318022 [details, diff]
Proposed patch to the mysql++ sources
Comment 3 Guido Winkelmann 2012-07-12 19:20:27 UTC
Created attachment 318024 [details, diff]
Proposed patch to the ebuild
Comment 4 Guido Winkelmann 2012-07-12 19:22:26 UTC
With the two attached patches, the packages builds fine for me.
Comment 5 Guido Winkelmann 2012-07-16 14:47:56 UTC
BTW, this bug does not appear to be specific to GCC 4.7, I'm using 4.6 and I'm still seeing it.
Comment 6 Gianni Rossi 2012-10-18 14:51:17 UTC
Actually, from gcc's docs, the correct include should be <cstddef>
Comment 7 Gianni Rossi 2012-10-18 14:52:05 UTC
Created attachment 326844 [details, diff]
Patch trhat uses cstddef for size_t
Comment 8 urcindalo 2013-01-14 09:50:32 UTC
I'm alos seeing this bug after the stable amd64 compiler update to gcc-4.6.3.

Since 4.6.3 is the default stable gcc compiler version now I think this issue needs to be resolved or otherwise the dev-db/mysql++-3.0.9 ebuild in the tree will be useless.

=====

/var/tmp/portage/dev-db/mysql++-3.0.9/work/mysql++-3.0.9/bk-deps x86_64-pc-linux-gnu-g++ -c -o mysqlpp_sql_buffer.o -I. -fPIC -DPIC -pthread -I/usr/include/mysql -march=core2 -mtune=core2 -O2 -pipe -msse4.1 ./lib/sql_buffer.cpp
In file included from ./lib/sql_buffer.h:31:0,
                 from ./lib/sql_buffer.cpp:26:
./lib/refcounted.h:258:2: error: 'size_t' does not name a type
./lib/refcounted.h: In constructor 'mysqlpp::RefCountedPointer<T, Destroyer>::RefCountedPointer()':
./lib/refcounted.h:89:2: error: class 'mysqlpp::RefCountedPointer<T, Destroyer>' does not have any field named 'refs_'
./lib/refcounted.h: In constructor 'mysqlpp::RefCountedPointer<T, Destroyer>::RefCountedPointer(T*)':
./lib/refcounted.h:100:2: error: class 'mysqlpp::RefCountedPointer<T, Destroyer>' does not have any field named 'refs_'
./lib/refcounted.h:104:4: error: 'refs_' was not declared in this scope
./lib/refcounted.h:104:16: error: expected type-specifier before 'size_t'
./lib/refcounted.h:104:16: error: expected ';' before 'size_t'
./lib/refcounted.h: In constructor 'mysqlpp::RefCountedPointer<T, Destroyer>::RefCountedPointer(const ThisType&)':
./lib/refcounted.h:112:2: error: class 'mysqlpp::RefCountedPointer<T, Destroyer>' does not have any field named 'refs_'
./lib/refcounted.h:115:8: error: 'refs_' was not declared in this scope
./lib/refcounted.h: In destructor 'mysqlpp::RefCountedPointer<T, Destroyer>::~RefCountedPointer()':
./lib/refcounted.h:125:7: error: 'refs_' was not declared in this scope
./lib/refcounted.h: In member function 'void mysqlpp::RefCountedPointer<T, Destroyer>::swap(mysqlpp::RefCountedPointer<T, Destroyer>::ThisType&)':
./lib/refcounted.h:246:13: error: 'refs_' was not declared in this scope
make: *** [mysqlpp_sql_buffer.o] Error 1
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: dev-db/mysql++-3.0.9 failed (compile phase):
 *   unable to make
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 2044:  Called die
 * The specific snippet of code:
 *       emake || die "unable to make"
====
Comment 9 Brian Evans Gentoo Infrastructure gentoo-dev 2013-02-19 18:49:29 UTC
This is really a duplicate of bug 378921 and is not limited to gcc 4.6 or 4.7.

It should be about gcc 4.3+

I've attached a fixed build and patch to bug 378921 which includes fixes to five open mysql++ bugs.
Comment 10 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2013-03-04 20:24:15 UTC
InCVS. Thanks to Brian Evans.