Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67692 - libtool error: unable to infer tagged configuration
Summary: libtool error: unable to infer tagged configuration
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
: 67901 68063 68083 68151 68360 69053 69225 69375 69569 69582 69650 69710 69724 69820 69942 70066 74153 75275 76489 76633 76765 88661 106075 106422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-10-15 11:30 UTC by Craig Duquette
Modified: 2008-12-09 06:04 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for ttmkfdir-3.0.9-r2.ebuild (AA1,415 bytes, patch)
2005-01-19 11:26 UTC, Sven Vermeulen (RETIRED)
Details | Diff
ttmkfdir-3.0.9-libtooltag.patch (AA2,546 bytes, patch)
2005-01-19 11:27 UTC, Sven Vermeulen (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Duquette 2004-10-15 11:30:13 UTC
When I try to emerge ttmkfdir I get this error:

>>> Source unpacked.
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2  -march=pentium4 -ftracer -pipe -fomit-frame-pointer -mfpmath=sse -ffast-math -o ttmkfdir.o -c ttmkfdir.cpp
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2  -march=pentium4 -ftracer -pipe -fomit-frame-pointer -mfpmath=sse -ffast-math -o directory.o -c directory.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [ttmkfdir.o] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [directory.o] Error 1

!!! ERROR: x11-misc/ttmkfdir-3.0.9-r2 failed.
!!! Function src_compile, Line 39, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.

I'm totally stumped I haven't see this error anywhere before.


Reproducible: Always
Steps to Reproduce:
1. su
2. emerge -pv ttmkfdir
3. emerge ttmkfdir

Actual Results:  
Failed to compile

Expected Results:  
..

Portage 2.0.51_rc9 (default-linux/x86/2004.2/gcc34/2.6, gcc-3.4.2,
glibc-2.3.4.20041006-r0, 2.6.8.1-cko8 i686)
=================================================================
System uname: 2.6.8.1-cko8 i686 Mobile Intel(R) Pentium(R) 4     CPU 3.06GHz
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=pentium4 -O2 -ftracer -pipe -fomit-frame-pointer -mfpmath=sse
-ffast-math"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium4 -O2 -ftracer -pipe -fomit-frame-pointer -mfpmath=sse
-ffast-math -fvisibility-inlines-hidden"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://mirror.datapipe.net/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X alsa apm avi berkdb bitmap-fonts cdr cups encode esd f77 fam flac
foomaticdb gdbm gif glx gnome gpm gstreamer gtk gtk2 imlib java jpeg junit
libg++ libwww mad mikmod motif mozilla moznocompose moznoirc moznomail mpeg
ncurses network nls no_wxgtk1 nptl oggvorbis opengl oss pam pdflib perl png ppds
python quicktime readline samba sdl slang spell sse ssl svga tcpd tiff truetype
truetype-fonts type1-fonts x86 xml2 xprint xv zlib"
Comment 1 Akos Keresztes 2004-10-15 14:53:06 UTC
Same here.

I wanted to emerge -e system, and it fails on ttmkfdir.
Comment 2 Phil Richards 2004-10-20 02:45:56 UTC
Same here.

Previously this version compiled fine with gcc 3.3.4, but now fails
with 3.4.2 and (having just gcc-config'd back to 3.3.4) it now fails
with 3.3.4.)  This looks to be the same problem as bug #68151.
(I was rebuilding "world" with gcc 3.4.2, and this was one of only
two failures.)

Phil

Portage 2.0.51_rc10 (default-x86-2004.2, gcc-3.4.2, glibc-2.3.4.20041006-r0, 2.6.8-gentoo-r10 i686)
=================================================================
System uname: 2.6.8-gentoo-r10 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/src/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox"
GENTOO_MIRRORS="ftp://ftp.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://www.ibiblio.org/pub/Linux/distributions/gentoo http://gentoo.oregonstate.edu"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/usr/src/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups encode esd f77 foomaticdb gdbm gif gnome gpm gtk gtk2 imlib java jpeg kde libg++ libwww mad mikmod mmx motif mozilla mpeg ncurses nls nptl nptlonly offensive oggvorbis opengl oss pam pdflib perl png python qt quicktime readline sdl slang spell sse ssl svga tcltk tcpd tetex truetype x86 xml2 xmms xprint xv zlib video_cards_i810 video_cards_i915"
Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-20 11:03:23 UTC
guys, can yuo try re-emerging libtool and then trying this?
Comment 4 Craig Duquette 2004-10-20 11:23:13 UTC
I tried reemerging libtool-1.5.2-r5 and ttmkdir still fails.. same error msg.
Comment 5 Phil Richards 2004-10-20 12:50:47 UTC
No improvement here, either.  Still fails.
(Just completed a "emerge sync" to make sure, too.)
Comment 6 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-20 13:14:17 UTC
SpankY, seems like a libtool error happening over here.  Got any input for us?
Comment 7 SpanKY gentoo-dev 2004-10-20 13:23:20 UTC
*** Bug 67901 has been marked as a duplicate of this bug. ***
Comment 8 SpanKY gentoo-dev 2004-10-20 13:23:54 UTC
*** Bug 68063 has been marked as a duplicate of this bug. ***
Comment 9 SpanKY gentoo-dev 2004-10-20 13:24:21 UTC
*** Bug 68083 has been marked as a duplicate of this bug. ***
Comment 10 SpanKY gentoo-dev 2004-10-20 13:24:51 UTC
*** Bug 68151 has been marked as a duplicate of this bug. ***
Comment 11 SpanKY gentoo-dev 2004-10-20 13:27:38 UTC
http://bugs.gentoo.org/show_bug.cgi?id=68063#c2

this comment looks insightful ... everyone seems to be running ~x86 meaning they probably have gcc-config meaning they probably dont have CC=gcc force in their environment anymore

if you guys do `export CC=gcc CXX=g++` and then try emerging the package that fails, does it work fine ?
Comment 12 SpanKY gentoo-dev 2004-10-20 13:29:17 UTC
this seems to get back to Bug 42718
Comment 13 jbooth 2004-10-20 13:40:21 UTC
mauve mail # export CC=gcc CXX=g++
mauve mail # echo $CC
gcc
mauve mail # emerge librep rep-gtk

leads to success. (or at least, rep-gtk didn't instantly bomb out with libtool errors -- I presume the compiled result will work -- no testing done)
Comment 14 Craig Duquette 2004-10-20 13:57:01 UTC
You can also add 

CC="i686-pc-linux-gnu-gcc"

to your /etc/make.conf and everything works again. Can we make changes to the default /etc/make.conf file to add CC flags and (unrelated) LD flags?
Comment 15 Matteo Spreafico 2004-10-20 14:13:50 UTC
For sys-apps/apmd-3.2.1_p4 comments #13 and #14 don't work on my system
Comment 16 Craig Duquette 2004-10-20 14:22:59 UTC
Did you try reemerging libtool first?
Comment 17 Matteo Spreafico 2004-10-20 14:46:17 UTC
After reemerging libtool, it works. Thanks
Comment 18 SpanKY gentoo-dev 2004-10-21 05:40:57 UTC
*** Bug 68360 has been marked as a duplicate of this bug. ***
Comment 19 Ioannis Aslanidis (RETIRED) gentoo-dev 2004-10-22 05:18:42 UTC
I advise adding a note before emerging any of the mentioned packages. Something like:

"If you are using GCC 3.4 and this build fails to compile with
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
please, reemerge libtool, and it should work fine."
Comment 20 Phil Richards 2004-10-22 10:12:52 UTC
Unfortunately, re-emerging libtool doesn't make the problem go away
unless you set CC and CXX correctly.  Setting them to gcc and g++
didn't work for me - it had to be the full blown i686-pc-linux-gnu-gcc.

And none of these solutions worked with apmd, because it appears apmd
overrides the CC setting and puts "gcc" back in (from apmd Makefile):

...
CC=gcc
CFLAGS=-O -g
...

It seems wrong to have to put this stuff into /etc/make.conf - gcc should
be invocable as "gcc" without this hackery (and I thought that was what
gcc-config was there for).

I sometimes use libtool for stuff I write - does this mean I'll have to use
"i686-pc-linux-gnu-gcc" now?  I hope not!

Maybe I'm missing something here.

phil
Comment 21 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-26 19:07:41 UTC
*** Bug 69053 has been marked as a duplicate of this bug. ***
Comment 22 John Nilsson 2004-10-27 15:30:31 UTC
So is this an ebuild bug or package bug?
Comment 23 SpanKY gentoo-dev 2004-10-28 05:30:22 UTC
*** Bug 69225 has been marked as a duplicate of this bug. ***
Comment 24 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-29 02:29:51 UTC
*** Bug 69375 has been marked as a duplicate of this bug. ***
Comment 25 Michel van Kessel 2004-10-30 18:05:58 UTC
looks like I am the first ~amd64 user here with same error. Tried to re-emerge libtool, no luck.. I discovered this error while I was performing emerge -eDv world 
here is my emerge info:
Portage 2.0.51-r2 (default-linux/amd64/2004.3, gcc-3.4.2, glibc-2.3.4.20041021-r0, 2.6.9-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.9-gentoo-r1 x86_64 Mobile AMD Athlon(tm) 64 Processor 2800+
Gentoo Base System version 1.6.4
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -frename-registers"
CHOST="x86_64-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer -frename-registers"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa amd64 apache2 apm arts avi berkdb bitmap-fonts bootsplash cdr cdrw crypt divx4linux doc dvd dvdr encode esd ethereal exif f77 fam flac foomaticdb ftp gd gdbm gif gnutls gphoto2 gpm gtk gtk2 hal icq imagemagick imlib ipv6 java joystick jp2 jpeg kde libg++ libwww lzw lzw-tiff maildir mailwrapper mbox mikmod mime motif mozilla mpeg msn multilib mysql mysqli ncurses nls nogcj nptl nptlonly odbc oggvorbis opengl oss pam pdflib perl php png python qt quicktime readline samba sdl slang sockets spell spl ssl tcltk tcpd tiff truetype usb userlocales vhosts xine xlmrpc xml xml2 xmms xpm xrandr xsl xv xvid zlib"
Comment 26 Michel van Kessel 2004-10-30 18:20:07 UTC
export CC=gcc CXX=g++
echo $CC
gcc
re-emerge libtool
re-emerge ttmkfdir
worked for me on AMD64

but I guess I cannot add CC="i686-pc-linux-gnu-gcc" to my /etc/make.conf. maybe CC="x86_64-pc-linux-gnu" ?
Comment 27 SpanKY gentoo-dev 2004-10-30 19:53:59 UTC
*** Bug 69569 has been marked as a duplicate of this bug. ***
Comment 28 SpanKY gentoo-dev 2004-10-31 11:23:37 UTC
*** Bug 69582 has been marked as a duplicate of this bug. ***
Comment 29 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-31 11:38:09 UTC
*** Bug 69650 has been marked as a duplicate of this bug. ***
Comment 30 Grzegorz Kulewski 2004-10-31 11:59:13 UTC
For me (~x86) it is working after setting CC="gcc" and CXX="g++" in /etc/make.conf and then emerge libtool ttmkfdir.
Comment 31 SpanKY gentoo-dev 2004-11-01 06:59:37 UTC
*** Bug 69710 has been marked as a duplicate of this bug. ***
Comment 32 SpanKY gentoo-dev 2004-11-02 05:55:41 UTC
*** Bug 69820 has been marked as a duplicate of this bug. ***
Comment 33 SpanKY gentoo-dev 2004-11-02 05:55:52 UTC
*** Bug 69724 has been marked as a duplicate of this bug. ***
Comment 34 Phil Richards 2004-11-03 08:05:28 UTC
Ok, I take it back.  Or maybe something else has changed recently, I dunno.

I have tried:
  CC=gcc CXX=g++ emerge --oneshot libtool apmd
and it worked.
Interestingly (or maybe not),
  emerge --oneshot ttmkfdir apmd
(*without* setting CC or CXX for these emerge's)
works, so it appears that it is the important thing is emerge'ing libtool with
CC and CXX explicitly set to gcc/g++.

Don't know if this adds anything to the picture, but it got things working
for me :-)

Phil
Comment 35 Seemant Kulleen (RETIRED) gentoo-dev 2004-11-03 14:01:13 UTC
*** Bug 69942 has been marked as a duplicate of this bug. ***
Comment 36 Jamie Lokier 2004-11-03 18:55:17 UTC
For me, "emerge libtool" does not fix it.

Subsequently, "CC=gcc CXX=g++ emerge ttmkfdir" still doesn't work.

However, "CC=i386-pc-linux-uclibc-gcc CXX=i386-pc-linux-uclibc-g++ emerge ttmkfdir" does work.

Note, this is *without* setting CC for merging libtool, as comment 34 suggests is required.
Comment 37 Jamie Lokier 2004-11-03 19:10:40 UTC
Following a suggestion, I tried rebuilding libtool with:
   CC=i386-pc-linux-uclibc-gcc CXX=i386-pc-linux-uclibc-g++ emerge -av libtool

That worked as expected.

After that, both of the following two command still _fail_:
   emerge -av ttmkfdir
   CC=gcc CXX=g++ emerge -av ttmkfdir

The long settings for CC and CXX are still required, after rebuilding libtool with those settings, contrary to the suggestion that rebuilding libtool with them would fix the problem.


Comment 38 SpanKY gentoo-dev 2004-11-03 21:11:45 UTC
could you guys test out libtool-1.5.2-r6 and see if that resolves this ?
Comment 39 Phil Richards 2004-11-04 09:17:30 UTC
Well, mixed results with libtool-1.5.2-r6.

ttmkfdir now compiles cleanly, but apmd still fails with the same error as before:

Calculating dependencies ...done!
>>> emerge (1 of 1) sys-apps/apmd-3.2.1_p4 to /
>>> md5 src_uri ;-) apmd_3.2.1.orig.tar.gz
>>> md5 src_uri ;-) apmd_3.2.1-4.diff.gz
>>> Unpacking source...
>>> Unpacking apmd_3.2.1.orig.tar.gz to /usr/src/tmp/portage/apmd-3.2.1_p4/work
>>> Unpacking apmd_3.2.1-4.diff.gz to /usr/src/tmp/portage/apmd-3.2.1_p4/work
 * Applying apmd_3.2.1-4.diff ...                                         [ ok ]X
>>> Source unpacked.
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apmlib.c
libtool --quiet --mode=compile gcc -c  -O -g -Wall -pipe -I. -I/usr/src/linux/include -I/usr/src/linux-2.2/include -I /usr/src/linux-2.0/include -DVERSION=\"3.2.1\" -DDEFAULT_PROXY_NAME=\"/etc/apmd_proxy\" apm.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [apmlib.lo] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [apm.o] Error 1
derisoft ~ # equery list libtool
[ Searching for package 'libtool' in all categories among: ]
 * installed packages
[I--] [  ] sys-devel/libtool-1.5.2-r6 (0)
Comment 40 Phil Richards 2004-11-04 09:21:08 UTC
Jamie,

what is suggested in comment #34 is to set CC=gcc CXX=g++ for the emerge
of libtool itself, not for ttmkfdir or apmd.  Doing that meant that nothing
special seemed to be needed extra for ttmkfdir and apmd.  (I too tried all
various other combinations and had mixed success, but that seemed to be the
least effort approach).

Btw, long time, no see.  Weird place to meet up, really.

Phil (aka pihl)
Comment 41 Aaron Walker (RETIRED) gentoo-dev 2004-11-04 10:15:05 UTC
*** Bug 70066 has been marked as a duplicate of this bug. ***
Comment 42 Neil Bothwick 2004-11-05 01:35:55 UTC
I've just seen this error when trying to upgrade dev-libs/cdk-4.9.11.20031210-r1 on ~amd64. Emerging libtool-1.5.2-r6 made no difference, but emerging it with CC=gcc CXX=g++ seems to have fixed it and cdk has now compiled.
Comment 43 SpanKY gentoo-dev 2004-11-05 08:59:54 UTC
sync up in a bit and try -r6 again ... i fixed the patch to work with CC tag guessing (which is what cdk/apm needs)
Comment 44 Olaf Freyer 2004-11-05 17:18:47 UTC
using -r6 cdk emerges just fine for me (on ~x86)

thx for this fine fix
Comment 45 SpanKY gentoo-dev 2004-11-05 22:18:48 UTC
thanks for testing, added 1.5.2-r6 to unstable
Comment 46 Ramon Casha 2004-12-09 21:50:05 UTC
I've just started a new install on AMD-K6 and encountered the same error as soon as it got to ttmkfdir. I fixed it by downgrading libtool from 1.5.2-r7 to 1.5.2-r5 (was that wise?) because that's the version I have on another system. That was before I saw this thread with its various proposed fixes.
Comment 47 Donnie Berkholz (RETIRED) gentoo-dev 2004-12-11 18:57:48 UTC
*** Bug 74153 has been marked as a duplicate of this bug. ***
Comment 48 Donnie Berkholz (RETIRED) gentoo-dev 2004-12-22 09:46:59 UTC
*** Bug 75275 has been marked as a duplicate of this bug. ***
Comment 49 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-03 12:00:54 UTC
*** Bug 76489 has been marked as a duplicate of this bug. ***
Comment 50 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-04 14:05:23 UTC
*** Bug 76633 has been marked as a duplicate of this bug. ***
Comment 51 Carsten Lohrke (RETIRED) gentoo-dev 2005-01-05 09:16:56 UTC
*** Bug 76765 has been marked as a duplicate of this bug. ***
Comment 52 SpanKY gentoo-dev 2005-01-16 10:25:25 UTC
*** Bug 77921 has been marked as a duplicate of this bug. ***
Comment 53 Douglas R. Hoffman 2005-01-18 14:21:20 UTC
I hope I'm not stepping on anbody's toes here, but this problem still persists.

since Bug 77921 was marked a duplicate of this bug, the main line documentation does not include the workaround as standard operating procedure as best I can tell, I'm going to try and reopen this and hope someone can figure out why 'emerge system' is building a broken/misconfigured libtool...

-Doug
Comment 54 Michiel de Bruijne 2005-01-18 15:55:59 UTC
I can confirm that on new installed systems with a current tree this problem still occurs.

So it seems that this problem isn't solved yet.
Comment 55 Dan Check 2005-01-19 11:19:29 UTC
I'm encountering this problem on x86 with the stable libtool (1.5.2-r7) while emerging ttmkfdir.  Setting CC and CXX environmental variables for libtool and ttmkfdir seems to have to no discernable effect.  I've also tried it with CFLAGS unset, and that, as well, has no discerable effect.  I'm NPTL enabled, if that's important.  Should I add this as a new bug, or should this one be reopened?

Complete emerge is:
>>> emerge (1 of 1) x11-misc/ttmkfdir-3.0.9-r2 to /
>>> md5 src_uri ;-) ttmkfdir-3.0.9.tar.bz2
>>> Unpacking source...
>>> Unpacking ttmkfdir-3.0.9.tar.bz2 to /var/tmp/portage/ttmkfdir-3.0.9-r2/work
 * Applying ttmkfdir-3.0.9-cpp.patch ...                                  [ ok ]
 * Applying ttmkfdir-3.0.9-zlib.patch ...                                 [ ok ]
 * Applying ttmkfdir-3.0.9-gcc34.patch ...                                [ ok ]
 * Applying ttmkfdir-3.0.9-encoding.patch ...                             [ ok ]
 * Applying ttmkfdir-3.0.9-freetype_new_includes.patch ...                [ ok ]
>>> Source unpacked.
libtool --mode=compile i686-pc-linux-gnu-g++ -Wall -pedantic -I/usr/include/freetype2  -march=pentium4 -fomit-frame-pointer -pipe -o ttmkfdir.o -c ttmkfdir.cpp
libtool --mode=compile i686-pc-linux-gnu-g++ -Wall -pedantic -I/usr/include/freetype2  -march=pentium4 -fomit-frame-pointer -pipe -o directory.o -c directory.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [ttmkfdir.o] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [directory.o] Error 1

!!! ERROR: x11-misc/ttmkfdir-3.0.9-r2 failed.
!!! Function src_compile, Line 44, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.

Comment 56 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-19 11:26:30 UTC
Created attachment 48983 [details, diff]
patch for ttmkfdir-3.0.9-r2.ebuild

Patch which applies another patch to the ttmkfdir package
Comment 57 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-19 11:27:26 UTC
Created attachment 48984 [details, diff]
ttmkfdir-3.0.9-libtooltag.patch

Patch used in the updated ebuild.

It's rather simple, just add "--tag=CXX" to the Makefile for libtool. Compiles
fine then (didn't before).
Comment 58 Sven Vermeulen (RETIRED) gentoo-dev 2005-01-19 11:29:08 UTC
Reopening, I had the same issue with libtool 1.5.2 (x86):

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.5, glibc-2.3.4.20040808-r1, 2.6.9 i686)
=================================================================
System uname: 2.6.9 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.4.16
distcc 2.16 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r2
Libtools: sys-devel/libtool-1.5.2-r7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=athlon-xp -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="ftp://ftp.belnet.be/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/home/swift/work/gentoo/ebuilds"
SYNC="rsync://rsync3.be.gentoo.org/gentoo-portage"
USE="X alsa apm arts avi berkdb bitmap-fonts cdr crypt cups encode esd f77 fam font-server foomaticdb fortran gdbm gif gnome gpm gtk gtk2 imagemagick imlib ipv6 java jpeg junit kde libg++ libwww mad mikmod motif mpeg mysql ncurses nls oggvorbis opengl oss pam pdflib perl png python qt quicktime readline ruby sdl slang spell ssl svga tcpd tetex tiff truetype truetype-fonts type1-fonts x86 xml2 xmms xv zlib"
Comment 59 SpanKY gentoo-dev 2005-01-19 11:47:02 UTC
this is already being handled at Bug 77921

i have a patch for libtool to fix it, i just havent committed it yet
Comment 60 Patrick Lauer gentoo-dev 2005-01-26 12:35:52 UTC
*** Bug 79624 has been marked as a duplicate of this bug. ***
Comment 61 Adam 2005-02-06 09:37:38 UTC
I just built gentoo from scratch and ran into this bug again
(building sawfish/rep-gtk).  This is the latest libtool-1.5.10-r4.
What's worse is the old workarounds listed (CC=gcc or CC="i686-pc-linux-gnu-gcc")
no longer work.  I suppose I could go in and fix the Makefile and
ebuild by hand but since I am new to gentoo I am hesitant to do this.
Can someone please verify and reopen the bug?
Comment 62 Andrew D. Keyser (aka Legoguy) 2005-04-01 13:13:15 UTC
Seeing this bug again with pam-0.78-r2.

Remerging libtool with nothing special did not work
Remerging libtool with CC=gcc CXX=g++ did not work
Emerging pam with CC=gcc CXX=g++ DID WORK

Portage 2.0.51.19 (default-linux/x86/2005.0, gcc-3.4.3-20050110, glibc-2.3.4.20050125-r1, 2.6.10-gentoo-r7 i686)
=================================================================
System uname: 2.6.10-gentoo-r7 i686 Pentium II (Deschutes)
Gentoo Base System version 1.6.10
Python:              dev-lang/python-2.3.5 [2.3.5 (#1, Feb 25 2005, 17:00:31)]
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
dev-lang/python:     2.3.5
sys-devel/autoconf:  2.59-r6, 2.13
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.5, 1.4_p6, 1.6.3, 1.9.5
sys-devel/binutils:  2.15.92.0.2-r7
sys-devel/libtool:   1.5.14
virtual/os-headers:  2.6.8.1-r4
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium2 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O2 -march=pentium2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache distcc distlocks sandbox sfperms"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X alsa apm arts audiofile avi bash-completion bitmap-fonts bmp bzlib cairo cdparanoia crypt cscope cups curl dga dio divx4linux emboss encode esd esound fam ffmpeg fftw flac foomaticdb fortran freetype ftp gd gif gnome gpm gstreamer gtk gtk2 gtkhtml hal imagemagick imlib java jpeg kde libcaca libg++ libwww lm_sensors mikmod mmap mmx motif mozilla mp3 mpeg ncurses nls nptl nptlonly ogg oggvorbis opengl pam pdflib perl php png ppds python qt quicktime readline real samba sdl sharedmem spell ssl svg svga theora threads tiff truetype truetype-fonts type1-fonts unicode usb userlocales utf8 vim wifi wxwindows xgetdefault xine xml xml2 xmms xosd xpm xrandr xv xvid zlib"
Unset:  ASFLAGS, CBUILD, CTARGET, LANG, LC_ALL, LDFLAGS, PORTDIR_OVERLAY
Comment 63 SpanKY gentoo-dev 2005-04-26 16:10:22 UTC
*** Bug 88661 has been marked as a duplicate of this bug. ***
Comment 64 Michael Crawford (ali3nx) 2005-05-05 18:03:33 UTC
Spanky could you post yuor patch for libtool as an attachment? I have a pile of systems affected by this bug with pam and some are refusing to allow pam to work considering the current dep structure of openssh-4.0_p1-r1 in both ~amd64 and ~x86. With both libtool-1.5.14 and libtool-1.5.16 pam-0.78* are refusing to finish econfig..
Comment 65 Jakub Moc (RETIRED) gentoo-dev 2005-09-19 23:42:18 UTC
*** Bug 106422 has been marked as a duplicate of this bug. ***
Comment 66 Kenyon Ralph 2005-09-29 09:58:59 UTC
*** Bug 106075 has been marked as a duplicate of this bug. ***
Comment 67 Kristjan 2005-11-10 06:49:07 UTC
I fought this bug the whole morning and I noticed an interesting thing.
By me this bug appears only when I'm running distcc.
When i quoted distcc out from make.conf and stopped distccd, things compiled.
Maybe the problem isn't in libtool but in distcc?
Comment 68 SpanKY gentoo-dev 2005-11-10 07:10:43 UTC
no, it isnt
Comment 69 Russell Harmon 2008-12-08 16:07:19 UTC
Still seeing this problem


Portage 2.2_rc16 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.28-rc3-zen1 x86_64)
=================================================================
System uname: Linux-2.6.28-rc3-zen1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_L7500_@_1.60GHz-with-glibc2.2.5
Timestamp of tree: Tue, 02 Dec 2008 20:19:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p48
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ABI="amd64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-O2 -pipe"
CFLAGS_x86="-m32"
CG_COMPILER_EXE="/usr/bin/cgc"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLLISION_IGNORE="/lib/modules"
COLORTERM="rxvt-xpm"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CVS_RSH="ssh"
CXXFLAGS="-O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="-v"
EMERGE_WARNING_DELAY="10"
FEATURES="candy distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict test unmerge-orphans userfetch userpriv usersandbox"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
GCCCFLAGS="-O2 -pipe -march=native -fomit-frame-pointer"
GCCCXXFLAGS="-O2 -pipe -march=native -fomit-frame-pointer"
GCCLDFLAGS="-Wl,-O1,--as-needed"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://gentoo.mirrors.pair.com/"
GUILE_LOAD_PATH="/usr/share/guile/1.8"
HOME="/root"
ICCCFLAGS="-O2 -xT -march=core2 -gcc -fomit-frame-pointer"
ICCCXXFLAGS="-O2 -xT -march=core2 -gcc -fomit-frame-pointer"
ICCLDFLAGS="-Wl,-O1"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.19/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/info"
INPUT_DEVICES="keyboard mouse evdev"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LADSPA_PATH="/usr/lib64/ladspa"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="en_US.UTF8"
LDFLAGS="-Wl,-O1"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_x86="lib32"
LIBXCB_ALLOW_SLOPPY_LOCK="1"
LINGUAS="en en_US"
LOGNAME="root"
LS_COLORS="rs=0:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j5"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.19/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.3.2/man:/opt/intel/cce/10.1.018/man:/etc/java-config/system-vm/man/"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATCH_OVERLAY="/etc/portage/patches"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.2:/opt/intel/cce/10.1.018/bin"
PKGDIR="/usr/portage/packages"
PLUGINS_DIR="/etc/portage/bashrc.plugins"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_COUNTER_HASH="a550e2d4fc0ef8599eeb2d952c233df6"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/pcsx2-overlay /usr/portage/local/layman/sunrise /usr/portage/local/layman/mozilla /usr/portage/local/layman/java-overlay /usr/portage/local/overlay /usr/portage/local/shared"
PRELINK_PATH_MASK="/opt:/usr/lib64/klibc"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PROMPT_COMMAND="echo -ne "\033_${USER}@${HOSTNAME%%.*}:${PWD/$HOME/~}\033\\"; todo --global; todo"
PWD="/root"
PYTHONDOCS="/usr/share/doc/python-docs-2.5.2/html/lib"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O "${DISTDIR}/${FILE}" "${URI}""
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.3.2:/opt/intel/cce/10.1.018/bin"
RPMDIR="/usr/portage/rpm"
SHELL="/bin/bash"
SHLVL="1"
SSH_AGENT_PID="7077"
SSH_AUTH_SOCK="/tmp/ssh-hvClKT7076/agent.7076"
STAGE1_USE="multilib nptl nptlonly unicode"
SUDO_COMMAND="/bin/bash"
SUDO_GID="1000"
SUDO_UID="1000"
SUDO_USER="russ"
SYMLINK_LIB="yes"
SYNC="rsync://rsync21.us.gentoo.org/gentoo-portage"
TERM="screen"
USE="X a52 aac acl acpi alsa amd64 bash-completion berkdb bluetooth branding bzip2 cairo cddb cdr cli cracklib crypt cups curl cxx dbus djvu doc dri dts dv dvd dvdr dvdread emboss encode evo exif expat fam fbcon ffmpeg firefox flac fontconfig fortran ftp gcj gd gdbm gif glitz gmp gnutls gpm graphviz hal iconv imlib ipv6 isdnlog jabber java java5 java6 javascript jbig jpeg jpeg2k kde ladspa lcms libedit libffi libnotify lzo mad matroska midi mikmod mmap mmx modplug mp3 mpeg mpi mudflap multilib musepack ncurses nptl nptlonly nsplugin odbc ogg openal openexr opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime raw readline reflection sasl session smp socks5 speex spell spl sqlite sqlite3 sse sse2 sse3 ssl ssse3 startup-notification svg sysfs taglib tcpd theora threads tiff truetype unicode usb vcd vim-syntax vorbis wmf x264 xcb xinetd xml xorg xosd xpm xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_US" USERLAND="GNU" VIDEO_CARDS="intel"
USER="root"
USERLAND="GNU"
USERNAME="root"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="intel"
_="/usr/bin/emerge"
Comment 70 SpanKY gentoo-dev 2008-12-09 06:04:04 UTC
and it's still not a bug in libtool.  fix the package that's failing.