Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 70066 - cdk-4.9.11.20031210-r1 fails to build (due to some libtool problems)
Summary: cdk-4.9.11.20031210-r1 fails to build (due to some libtool problems)
Status: RESOLVED DUPLICATE of bug 67692
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-11-04 09:42 UTC by Olaf Freyer
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olaf Freyer 2004-11-04 09:42:24 UTC
creating include/cdk_config.h
/usr/bin/libtool  --mode=compile gcc -O3 -march=i686 -funroll-loops -pipe  -DHAVE_CONFIG_H -I./include -I./include  -c alphalist.c
/usr/bin/libtool  --mode=compile gcc -O3 -march=i686 -funroll-loops -pipe  -DHAVE_CONFIG_H -I./include -I./include  -c binding.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [alphalist.lo] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [binding.lo] Error 1

!!! ERROR: dev-libs/cdk-4.9.11.20031210-r1 failed.
!!! Function src_compile, Line 24, Exitcode 2
!!! make failed!
!!! If you need support, post the topmost build error, NOT this status message.

root (pvpgn/src):                                      

root (pvpgn/src): emerge info
Portage 2.0.51-r2 (default-linux/x86/2004.0, gcc-3.4.2, glibc-2.3.4.20041021-r0, 2.6.9-gentoo-r2 i686)
=================================================================
System uname: 2.6.9-gentoo-r2 i686 Pentium III (Coppermine)
Gentoo Base System version 1.6.5
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-2.15.92.0.2-r1
Headers:  sys-kernel/linux26-headers-2.6.8.1-r1
Libtools: sys-devel/libtool-1.5.2-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=i686 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.1/share/config /usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -march=i686 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache distlocks sandbox sfperms"
GENTOO_MIRRORS="http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://mir.zyrianes.net/gentoo/ http://gentoo.inode.at/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa apache2 arts avi berkdb bitmap-fonts boundschecking cdb cdr crypt cups dba encode esd f77 fam fbcon flac foomaticdb gd gd-external gdbm gif gphoto2 gpm gtk2 icc imagemagick imlib java jikes jpeg junit kde libg++ libwww mad mcal mikmod mmx motif mpeg mysql ncurses nls oggvorbis opengl oss pam pcmcia pdflib perl png pnp postgres python qt quicktime readlinesamba sdl slang spell sse ssl svga tcltk tcpd tetex tiff truetype usb x86 xml2 xprint xv zlib linguas_de"



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Gregorio Guidi (RETIRED) gentoo-dev 2004-11-04 09:49:59 UTC
see bug 67692
Comment 2 Aaron Walker (RETIRED) gentoo-dev 2004-11-04 10:15:05 UTC

*** This bug has been marked as a duplicate of 67692 ***
Comment 3 Colin Tinker 2004-11-04 10:16:55 UTC
CC=gcc CXX=g++ emerge --oneshot libtool cdk

The above worked for me but surely this requires resolving?