Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 69053 - emerge ttmkfdir fails: libtool complains about tags
Summary: emerge ttmkfdir fails: libtool complains about tags
Status: RESOLVED DUPLICATE of bug 67692
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2004-10-26 12:20 UTC by merle
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description merle 2004-10-26 12:20:27 UTC
When I try to emerge the below package (which I need for X) it stops with the following error:

>>> emerge (1 of 1) x11-misc/ttmkfdir-3.0.9-r2 to /
>>> md5 src_uri ;-) ttmkfdir-3.0.9.tar.bz2
>>> Unpacking source...
>>> Unpacking ttmkfdir-3.0.9.tar.bz2 to /var/tmp/portage/ttmkfdir-3.0.9-r2/work
 * Applying ttmkfdir-3.0.9-cpp.patch ... [ ok ]
 * Applying ttmkfdir-3.0.9-zlib.patch ... [ ok ]
 * Applying ttmkfdir-3.0.9-gcc34.patch ... [ ok ]
 * Applying ttmkfdir-3.0.9-encoding.patch ... [ ok ]
>>> Source unpacked.
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2  -march=k6-2 -pipe -fomit-frame-pointer -o ttmkfdir.o -c ttmkfdir.cpp
libtool --mode=compile g++ -Wall -pedantic -I/usr/include/freetype2  -march=k6-2 -pipe -fomit-frame-pointer -o directory.o -c directory.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [ttmkfdir.o] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [directory.o] Error 1

!!! ERROR: x11-misc/ttmkfdir-3.0.9-r1 failed.
!!! Function src_compile, Line 38, Exitcode 2
!!! emake failed

Reproducible: Always
Steps to Reproduce:
- emerge ttmkfdir
- emerge =ttmkfdir-3.0.9
- emerge =ttmkfdir-3.0.9-r1
- CFLAGS="" emerge ttmkfdir
- CFLAGS="" emerge =ttmkfdir-3.0.9
- CFLAGS="" emerge =ttmkfdir-3.0.9-r1
Actual Results:  
It gave the same error

Expected Results:  
It should have emerged...

Portage 2.0.51-r2 (default-x86-2004.2, gcc-3.4.2, glibc-,
2.6.9-mm1-06 i586)
System uname: 2.6.9-mm1-06 i586 AMD-K6(tm) 3D processor
Gentoo Base System version 1.5.3
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.22
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-O2 -march=k6-2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=k6-2 -pipe -fomit-frame-pointer"
FEATURES="autoaddcvs ccache distlocks sandbox"
USE="3dnow X alsa apm arts avi berkdb bitmap-fonts crypt cups dvd encode f77
foomaticdb gdbm gif gpm gtk2 imlib jpeg libg++ libwww mad mikmod mmx motif mpeg
ncurses nls oggvorbis opengl oss pam pdflib perl png python quicktime readline
samba sdl slang spell ssl svga tcpd truetype x86 xml2 xmms xprint xv xvid zlib"
Comment 1 Radoslaw Szkodzinski 2004-10-26 12:50:54 UTC
Confirming. Easy fix: change ${gcc-getCXX} to ${tc-getCXX}.
Comment 2 merle 2004-10-26 14:33:34 UTC
That seems to have fixed it, thanks a bunch.
Comment 3 Seemant Kulleen (RETIRED) gentoo-dev 2004-10-26 19:07:41 UTC

*** This bug has been marked as a duplicate of 67692 ***