Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 67901 - attr-2.4.19 emerge fails with a libtool error
Summary: attr-2.4.19 emerge fails with a libtool error
Status: RESOLVED DUPLICATE of bug 67692
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
Depends on:
Reported: 2004-10-17 10:03 UTC by Alexander Hsia
Modified: 2005-07-17 13:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Hsia 2004-10-17 10:03:29 UTC
config.status: creating include/builddefs
config.status: creating include/config.h
=== include ===
gmake[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
rm -f attr
ln -s . attr
=== libmisc ===
gmake[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make rule.
/usr/bin/libtool --mode=compile i686-pc-linux-gnu-gcc -march=athlon -O3 -march=athlon -O3 -DNDEBUG -funsigned-char -fno-strict-aliasing -Wall -DVERSION=\"2.4.19\" -DLOCALEDIR=\"/usr/share/locale\" -DPACKAGE=\"attr\" -I./include -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64  -march=athlon -O3 -DNDEBUG -funsigned-char -fno-strict-aliasing -Wall -DVERSION=\"2.4.19\" -DLOCALEDIR=\"/usr/share/locale\" -DPACKAGE=\"attr\" -I../include -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64   -c quote.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
gmake[1]: *** [quote.lo] Error 1
make: *** [default] Error 2

!!! ERROR: sys-apps/attr-2.4.19 failed.
!!! Function src_compile, Line 57, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

Reproducible: Always
Steps to Reproduce:
1. emerge attr

Actual Results:  
Errors out with above message

Expected Results:  
Completed compilation and merge

emerge info returns:
Portage 2.0.51_rc9 (default-x86-2004.0, gcc-3.4.2, glibc-,
2.6.8-gentoo-r8 i686)
System uname: 2.6.8-gentoo-r8 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.5.3
distcc 2.18 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux26-headers-
Libtools: sys-devel/libtool-1.5.2-r5
CFLAGS="-march=athlon -O3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config
/usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref
/usr/share/config /usr/share/texmf/dvipdfm/config/
/usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/
/usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon -O3"
FEATURES="autoaddcvs ccache distlocks sandbox"
USE="3dnow 3dnowex X acl acpi acpi4linux aim alsa apm atlas avi berkdb
bitmap-fonts blas bonobo cairo cddb cdparanoia cdr cdrom chroot clisp crypt
cscope cups dio directfb divx4linux djbfft dnd dts dv dvd dvdr dvdread eds
encode erandom evms2 evo exif f77 faac faad fam fastcgi fbcon ffmpeg fftw flac
foomaticdb freetype ftp gb gd gdbm gif gimp gimpprint ginac gnome gnomedb
gnuplot gphoto2 gpm gsl gstreamer gtk gtk2 gtkhtml guile hal hbci hdf5 icq
ieee1394 imagemagick imap imlib ipv6 irda jabber jack jack-tmpfs java javascript
jikes joystick jpeg kde lcms libwww lirc lufsusermount mad maildir matroska mcal
mikmod mime mmap mmx mmx2 motif mozilla mozsvg mp3 mpeg mpeg4 mpi mplayer mysql
ncurses nls nptl nvidia odbc ofx oggvorbis openal opengl opie oss pam pcre pda
pdf pdflib perl pic plotutils png posix postgres ppds python qt quicktime quotes
readline rtc samba scanner sdl slang sndfile snortsam spamassassin spell sse ssl
stroke svg svga tcpd tetex theora tiff transcode truetype usb v4l v4l2 vnc wmf
x86 xfs xine xinerama xml xml2 xmms xosd xprint xrandr xsl xv xvid xvmc zlib"
Comment 1 SpanKY gentoo-dev 2004-10-18 07:16:51 UTC
try re-emerging libtool then attr
Comment 2 Martin Wegner 2004-10-19 01:59:24 UTC
This is not a problem special to attr, it also happened with xfsprogs and dmapi here. Remerging libtool solved this issue for me. So why does it need to be remerged?
Comment 3 Alexander Hsia 2004-10-20 07:10:11 UTC
Re-emerging libtools worked as suggested. attr now emerges without erroring out.

Comment 4 SpanKY gentoo-dev 2004-10-20 13:23:19 UTC

*** This bug has been marked as a duplicate of 67692 ***