Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 76489 - ttmkfdir ebuilds 3.0.9 to 3.0.9-r2 wont compile
Summary: ttmkfdir ebuilds 3.0.9 to 3.0.9-r2 wont compile
Status: RESOLVED DUPLICATE of bug 67692
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2005-01-03 01:05 UTC by Rene Androsch
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Pass --tag=CXX to libtool (ttmkfdir-3.0.9-libtool.patch,546 bytes, patch)
2005-01-03 08:34 UTC, Sergio Gelato
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Androsch 2005-01-03 01:05:25 UTC
After 2004.3 install (stage2, just to get system booting), I can't emerge x11-misc/ttmkfdir (for xorg-x11 and kde)

Since there are only ebuilds for 3.0.9, 3.0.9-r1, 3.0.9-r2 and I tried them all - I can't emerge X or KDE :(

Reproducible: Always
Steps to Reproduce:
1. emerge -vD ttmkfdir

Actual Results:  
emerge -vD ttmkfdir
Calculating dependencies ...done!
>>> emerge (1 of 1) x11-misc/ttmkfdir-3.0.9-r2 to /
>>> md5 src_uri ;-) ttmkfdir-3.0.9.tar.bz2
>>> Unpacking source...
>>> Unpacking ttmkfdir-3.0.9.tar.bz2 to /var/tmp/portage/ttmkfdir-3.0.9-r2/work
 * Applying ttmkfdir-3.0.9-cpp.patch ...                                       
                        [ ok ]
 * Applying ttmkfdir-3.0.9-zlib.patch ...                                      
                        [ ok ]
 * Applying ttmkfdir-3.0.9-gcc34.patch ...                                     
                        [ ok ]
 * Applying ttmkfdir-3.0.9-encoding.patch ...                                  
                        [ ok ]
 * Applying ttmkfdir-3.0.9-freetype_new_includes.patch ...                     
                        [ ok ]
>>> Source unpacked.
libtool --mode=compile i686-pc-linux-gnu-g++ -Wall -pedantic
-I/usr/include/freetype2  -pipe -fomit-frame-pointer -ffast-math -mcpu=pentium4
-march=pentium4 -o ttmkfdir.o -c ttmkfdir.cpp
libtool --mode=compile i686-pc-linux-gnu-g++ -Wall -pedantic
-I/usr/include/freetype2  -pipe -fomit-frame-pointer -ffast-math -mcpu=pentium4
-march=pentium4 -o directory.o -c directory.cpp
libtool --mode=compile i686-pc-linux-gnu-g++ -Wall -pedantic
-I/usr/include/freetype2  -pipe -fomit-frame-pointer -ffast-math -mcpu=pentium4
-march=pentium4 -o commandline.o -c commandline.cpp
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [directory.o] Error 1
make: *** Waiting for unfinished jobs....
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [ttmkfdir.o] Error 1
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag'
make: *** [commandline.o] Error 1

!!! ERROR: x11-misc/ttmkfdir-3.0.9-r2 failed.
!!! Function src_compile, Line 44, Exitcode 2
!!! emake failed
!!! If you need support, post the topmost build error, NOT this status message.

Portage 2.0.51-r3 (default-linux/x86/2004.3, gcc-3.3.4, glibc-,
2.6.9-gentoo-r13 i686)
System uname: 2.6.9-gentoo-r13 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.00GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r5
Automake: sys-devel/automake-1.8.5-r1
Binutils: sys-devel/binutils-
Headers:  sys-kernel/linux-headers-2.4.21-r1
Libtools: sys-devel/libtool-1.5.2-r7
CFLAGS="-O3 -pipe -fomit-frame-pointer -ffast-math -mcpu=pentium4 -march=pentium4 "
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3/share/config
/usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -pipe -fomit-frame-pointer -ffast-math -mcpu=pentium4
-march=pentium4 "
FEATURES="autoaddcvs autoconfig ccache distlocks fixpackages sandbox sfperms"
USE="x86 X aac acl acpi alsa apache2 apm arts async audiofile avantgo avi
bash-completion berkdb bitmap-fonts blender-game bootsplash bzip2 bzlib calendar
cdparanoia cdr codecs cracklib crypt css cups divx4linux dlloader dnsdb droproot
dvd dvdr dvdread eds encode escreen ethereal evo exif font-server foomaticdb
fortran gd gdbm geoip gif gphoto2 gpm icq idea imagemagick imap insecure-drivers
irda java jce jpeg jpeg2k kde kdexdeltas laptop libgd libwww lzo lzw lzw-tiff
mad md5sum memlimit mhash mikmod mime mjpeg mmap mmx mng motif mp3 mpeg mplayer
mythtv ncurses network nls nntp nvidia odbc oggvorbis opengl oss pam pcap pda
pdf pdflib perl php png povray python qt quicktime readline recode samba scanner
sdl secure server session sha1 smime soap sockets spamassassin spell sqlite sse
sse2 ssl svg svga tcpd tcpmd5 tga tiff transcode truetype truetype-fonts
type1-fonts usb userlocales vnc wavelan wifi wma123 wmf xanim xine xinerama xml
xml2 xmlrpc xmms xosd xpm xrandr xscreensaver xv xvid xvmc zlib"
Comment 1 Rene Androsch 2005-01-03 01:07:42 UTC
Even doing an

CFLAGS="" CXXFLAGS="" USE="-*" emerge -vD ttmkfdir

causes this kind of problem :(
Comment 2 Rene Androsch 2005-01-03 01:21:31 UTC
Oh my god!

The solution was the re-emerge libtool.

Does this mean that everyone using the 2004.3-r1 install has this problem?
Comment 3 Sergio Gelato 2005-01-03 08:34:17 UTC
Created attachment 47489 [details, diff]
Pass --tag=CXX to libtool
Comment 4 Sergio Gelato 2005-01-03 08:37:35 UTC
The problem is that CXX is being set to a long-winded compiler name which libtool
does not recognise. Maybe it's better to add a gentoo-specific patch to libtool
instead, but for the sake of discussion please see my proposed Makefile patch.
Comment 5 Aaron Kulbe (RETIRED) gentoo-dev 2005-01-03 11:09:26 UTC
I have attempted both fixes, remerging libtool and applying the proposed patch.  Neither of them worked.

C++ compile errors on encoding.cpp
Comment 6 Donnie Berkholz (RETIRED) gentoo-dev 2005-01-03 12:00:54 UTC

*** This bug has been marked as a duplicate of 67692 ***