Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 340287 - sys-apps/portage-2.2_rc91: --keep-going sometimes fails to work
Summary: sys-apps/portage-2.2_rc91: --keep-going sometimes fails to work
Status: CONFIRMED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: High normal with 2 votes (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 373807
  Show dependency tree
 
Reported: 2010-10-09 20:15 UTC by Martin von Gagern
Modified: 2018-08-22 18:47 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
PV output (log,22.61 KB, text/plain)
2011-09-04 08:31 UTC, dE
Details
Portage --debug output. (portage_keepgoing.tar.xz,303.46 KB, application/x-xz)
2014-08-03 16:29 UTC, dE
Details
--debug output of the latest portage (as of the current time). (emerge_debug_output.txt.xz,825.85 KB, application/x-xz)
2018-08-22 10:20 UTC, dE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin von Gagern 2010-10-09 20:15:37 UTC
Today I've encountered two instances of an emerge that failed to keep going. The command was "emerge -uaND --keep-going -j5 @system @world" in each case. The first time I had another command immediately after the update which filled my scrollback buffer. The second time I found that it did encounter one build error and recover from it, but later on it encountered another build error after which it printed package messages instead of properly continuing.

...
>>> Emerging (11 of 236) dev-python/matplotlib-1.0.0
>>> Failed to emerge dev-python/matplotlib-1.0.0, Log file:
>>>  '/var/log/portage/dev-python:matplotlib-1.0.0:20101009-184725.log'
>>> Jobs: 10 of 236 complete, 1 failed              Load avg: 1.23, 1.49, 1.67
*** Resuming merge...
Calculating dependencies... done!
>>> Starting parallel fetch
>>> Emerging (1 of 225) kde-base/khelpcenter-4.5.2
...
>>> Emerging (46 of 225) kde-base/kreadconfig-4.5.2
>>> Emerging (47 of 225) kde-base/kuiserver-4.5.2
>>> Emerging (48 of 225) kde-base/kfile-4.5.2
>>> Installing (44 of 225) kde-base/konsole-4.5.2
>>> Jobs: 43 of 225 complete, 5 running             Load avg: 4.55, 4.67, 3.63!!! post install failed; exiting.
>>> Failed to emerge kde-base/kreadconfig-4.5.2, Log file:
>>>  '/var/log/portage/kde-base:kreadconfig-4.5.2:20101009-190948.log'
>>> Installing (47 of 225) kde-base/kuiserver-4.5.2
>>> Installing (45 of 225) kde-base/kwrited-4.5.2
>>> Installing (48 of 225) kde-base/kfile-4.5.2
>>> Installing (38 of 225) kde-base/kde-l10n-4.5.2
>>> Jobs: 47 of 225 complete, 1 failed              Load avg: 2.45, 4.00, 3.49
*** Resuming merge...
Calculating dependencies... done!

 * Messages for package app-text/poppler-0.14.4:
...

I haven't encountered anything like this before, and the fact that I do so now makes me consider it likely that this behaviour might be due to a fairly new bug, probably introduced somewhere between rc88 and rc91.

After I read the elog mail about the first error (which is due to bug #339775 by the way) I added "=dev-python/matplotlib-1.0.0 -doc" to a file in my /etc/portage/package.use directory. I don't know if this kind of change to the portage configuration could have anything to do with this issue. I don't think I did any such modification during my first world update attempt.
Comment 1 Cyprien Nicolas (fulax) 2010-10-13 11:52:42 UTC
I have the same issue here, --keep-going simply doesn't work:

sita-exp ~ # emerge -DuNa world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] gnome-extra/yelp-2.30.1-r1 [2.28.1-r2] USE="-beagle -debug lzma" 0 kB [0]
[ebuild     U ] dev-java/sun-jdk-1.6.0.22 [1.6.0.21] USE="X alsa derby doc examples -jce nsplugin odbc" 0 kB [0]
[ebuild     U ] gnome-base/gnome-light-2.30.2 [2.28.2] USE="automount" 0 kB [0]
[ebuild     U ] dev-java/icedtea-6.1.9.1 [6.1.9-r1] USE="-cacao -debug -doc -examples hs19 javascript -nio2 -nsplugin nss -pulseaudio -systemtap xrender -zero" 0 kB [1]
[ebuild     U ] app-text/acroread-9.4.0 [9.3.4] USE="cups ldap -minimal -nsplugin" LINGUAS="-de en -fr -ja" 0 kB [0]

Total: 5 packages (5 upgrades), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /var/lib/layman/java-overlay

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 5) gnome-extra/yelp-2.30.1-r1


(Here yelp fails during configure because of bug #330847)


>>> Failed to emerge gnome-extra/yelp-2.30.1-r1, Log file:

>>>  '/var/log/portage/build/gnome-extra/yelp-2.30.1-r1:20101013-114341.log'
*** Resuming merge...

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * One or more packages are either masked or have missing dependencies:
 * 
 *   >=gnome-extra/yelp-2.30.1 pulled in by:
 *     (gnome-base/gnome-light-2.30.2::gentoo, ebuild scheduled for merge)
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 * 
 * The following package has failed to build or install:
 * 
 *  (gnome-extra/yelp-2.30.1-r1::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/log/portage/build/gnome-extra/yelp-2.30.1-r1:20101013-114341.log'
 * 
===============================================================================

I expect --keep-going to ignore gnome-light and continue to process with the other packages which does not depend on yelp and/or gnome-light, and as far as I remember, it always did it before (but I can't tell the version)

I think that failing packages used to be moved at the end of a new emerge process, but it seems that it is no longer the case anymore.

I can paste my emerge --info if needed, but I don't want to make that comment too long.
Comment 2 Dennis Schridde 2011-05-23 12:41:54 UTC
Same issue with sys-apps/portage-2.2.0_alpha35, keep-going currently never works for me.

emerge always aborts after a failed merge, like here:

>>> Failed to emerge x11-drivers/xf86-video-virtualbox-4.0.8, Log file:

>>>  '/var/tmp/portage/x11-drivers/xf86-video-virtualbox-4.0.8/temp/build.log'
*** Resuming merge...
Calculating dependencies... done!

 * Messages for package app-emulation/virtualbox-4.0.8:
Comment 3 Dennis Schridde 2011-06-19 09:24:42 UTC
Possible duplicates: bug #263630, bug #312467, bug #312789, bug #340287, bug #342713, bug #362355
Comment 4 Dennis Schridde 2011-07-02 10:15:26 UTC
Please have a look at the possible duplicates bug #263630, bug #312467, bug #312789, bug #340287, bug #342713, bug #362355, and then raise the priority of the appropriate bugs. This issue is really annoying me by now, because it prevents a proper update of @world since months.
Comment 5 Zac Medico gentoo-dev 2011-07-11 20:15:55 UTC
(In reply to comment #1)
>  * One or more packages are either masked or have missing dependencies:
>  * 
>  *   >=gnome-extra/yelp-2.30.1 pulled in by:
>  *     (gnome-base/gnome-light-2.30.2::gentoo, ebuild scheduled for merge)

The above symptom might be fixed by the following commit:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=5d8804712e9f49308f17f7fbb889edb048fa6c3a

See bug 374583, comment #6.

I don't see a "One or more packages are either masked or have missing dependencies" message in comment #0 or comment #2, so maybe that's a different issue.
Comment 6 dE 2011-09-04 08:31:02 UTC
Created attachment 285491 [details]
PV output
Comment 7 dE 2011-09-04 08:33:15 UTC
Another e.g. - 

This's what actually happens - 

>>> Verifying ebuild manifests
>>> Running pre-merge checks for kde-base/kdelibs-4.6.5-r1
>>> Starting parallel fetch
>>> Jobs: 0 of 148 complete, 1 running              Load avg: 0.82, 0.43, 0.40
>>> Emerging (1 of 148) sys-boot/grub-9999
>>> Jobs: 0 of 148 complete, 1 running              Load avg: 0.82, 0.43, 0.40
>>> Failed to emerge sys-boot/grub-9999, Log file:
>>> Jobs: 0 of 148 complete, 1 running              Load avg: 0.83, 0.44, 0.40
>>>  '/tmp/portage/sys-boot/grub-9999/temp/build.log'
>>> Jobs: 0 of 148 complete, 1 running              Load avg: 0.83, 0.44, 0.40
>>> Jobs: 0 of 148 complete, 1 running, 1 failed    Load avg: 0.83, 0.44, 0.40
>>> Jobs: 0 of 148 complete, 1 failed               Load avg: 0.83, 0.44, 0.40

*** Resuming merge...
>>> Starting parallel fetch
>>> Jobs: 0 of 147 complete, 1 running              Load avg: 0.80, 0.45, 0.41
>>> Emerging (1 of 147) net-misc/networkmanager-0.8.4.0-r2
>>> Jobs: 0 of 147 complete, 1 running              Load avg: 0.80, 0.45, 0.41
>>> Failed to emerge net-misc/networkmanager-0.8.4.0-r2, Log file:
>>> Jobs: 0 of 147 complete, 1 running              Load avg: 0.75, 0.45, 0.41
>>>  '/tmp/portage/net-misc/networkmanager-0.8.4.0-r2/temp/build.log'
>>> Jobs: 0 of 147 complete, 1 running              Load avg: 0.75, 0.45, 0.41
>>> Jobs: 0 of 147 complete, 1 running, 1 failed    Load avg: 0.75, 0.45, 0.41
>>> Jobs: 0 of 147 complete, 1 failed               Load avg: 0.75, 0.45, 0.41

*** Resuming merge...
 * Messages for package sys-boot/grub-9999:
 * ERROR: sys-boot/grub-9999 failed (unpack phase):
 *   bzr.eclass: can't branch from http://bzr.savannah.gnu.org/r/grub/trunk/grub/
 * 
 * Call stack:
 *     ebuild.sh, line   56:  Called src_unpack
 *   environment, line 3484:  Called bzr_src_unpack
 *   environment, line  742:  Called bzr_fetch
 *   environment, line  709:  Called bzr_initial_fetch 'http://bzr.savannah.gnu.org/r/grub/trunk/grub/' '/usr/portage/distfiles/bzr-src/grub'
 *   environment, line  734:  Called die
 * The specific snippet of code:
 *       ${EBZR_FETCH_CMD} ${EBZR_OPTIONS} "${repo_uri}" "${branch_dir}" || die "${EBZR}: can't branch from ${repo_uri}"
 * 
 * If you need support, post the output of 'emerge --info =sys-boot/grub-9999',
 * the complete build log and the output of 'emerge -pqv =sys-boot/grub-9999'.
 * The complete build log is located at '/tmp/portage/sys-boot/grub-9999/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/sys-boot/grub-9999/temp/environment'.
 * S: '/tmp/portage/sys-boot/grub-9999/work/grub-9999'
 * Messages for package net-misc/networkmanager-0.8.4.0-r2:
 * Please disable SYSFS_DEPRECATED_V2 support in your kernel config and recompile your kernel
 * or NetworkManager will not work correctly.
 * See http://bugs.gentoo.org/333639 for more info.
 * ERROR: net-misc/networkmanager-0.8.4.0-r2 failed (setup phase):
 *   CONFIG_SYSFS_DEPRECATED_V2 support detected!
 * 
 * Call stack:
 *                          ebuild.sh, line  56:  Called pkg_setup
 *   networkmanager-0.8.4.0-r2.ebuild, line  66:  Called sysfs_deprecated_check
 *   networkmanager-0.8.4.0-r2.ebuild, line  57:  Called die
 * The specific snippet of code:
 *              die "CONFIG_SYSFS_DEPRECATED_V2 support detected!"
 * 
 * If you need support, post the output of 'emerge --info =net-misc/networkmanager-0.8.4.0-r2',
 * the complete build log and the output of 'emerge -pqv =net-misc/networkmanager-0.8.4.0-r2'.
 * The complete build log is located at '/tmp/portage/net-misc/networkmanager-0.8.4.0-r2/temp/build.log'.
 * The ebuild environment file is located at '/tmp/portage/net-misc/networkmanager-0.8.4.0-r2/temp/die.env'.
 * S: '/tmp/portage/net-misc/networkmanager-0.8.4.0-r2/work/NetworkManager-0.8.4.0'




 * One or more packages are either masked or have missing dependencies:
 * 
 *   >=net-misc/networkmanager-0.8.4 pulled in by:
 *     (gnome-extra/nm-applet-0.8.4::gentoo, ebuild scheduled for merge)
 * 
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.
 * 
 * The following 2 packages have failed to build or install:
 * 
 *  (sys-boot/grub-9999::gentoo, ebuild scheduled for merge), Log file:
 *   '/tmp/portage/sys-boot/grub-9999/temp/build.log'
 *  (net-misc/networkmanager-0.8.4.0-r2::gentoo, ebuild scheduled for merge), Log file:
 *   '/tmp/portage/net-misc/networkmanager-0.8.4.0-r2/temp/build.log'
 *

Attached is the PV output.
Comment 8 Zac Medico gentoo-dev 2011-09-04 09:16:30 UTC
(In reply to comment #6)
> Created attachment 285491 [details]
> PV output

When posting information like this, please include the portage version. There have been recent fixes in the relevant code (bug 374583 and bug 378187).
Comment 9 Thomas Capricelli 2014-05-03 01:15:29 UTC
i've had this pb for months if not more. I've used --keep-going since it exists and it used to work well.

Two examples today on ~amd64 with sys-apps/portage-2.2.10, command is
      sudo emerge -qvta --keep-going -j 4 --load-average=7 -u world


1st :
-----------------------------------------------------------------------------------------
[ebuild     U ] dev-qt/qtserialport-5.3.9999 [5.2.9999] USE="-debug {-test}" 
[ebuild  N    ] kde-frameworks/khtml-9999  USE="X -debug -doc {-test}" 
[ebuild  N    ] kde-frameworks/kimageformats-9999  USE="jpeg2k openexr -debug -doc -eps {-test}" 
[ebuild  N    ] kde-frameworks/kdelibs4support-9999  USE="X -debug -doc {-test}" 
[ebuild  N    ] kde-frameworks/krunner-9999  USE="-debug -doc {-test}" 
[ebuild     U ] kde-base/kdm-4.11.9-r1 [4.11.8] USE="consolekit pam (-aqua) -debug -handbook -kerberos -systemd" 
[ebuild     U ] app-office/libreoffice-4.2.3.3-r1 [4.2.1.1] USE="bluetooth branding cups dbus gstreamer java kde opengl vba (-aqua) -debug -eds (-firebird) -gnome -gtk -gtk3 -jemalloc -mysql -odk -postgres -telepathy {-test} -vlc -webdav" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 -python3_3" 
[ebuild     U ] app-office/skrooge-1.9.0 [1.8.0] USE="(-aqua) -debug -handbook" LINGUAS="fr it -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -fi -ga -gl -hu -ia% -ja -ko -lt -mr -ms -nb -nds -nl -pl -pt -pt_BR -ro -ru -sk -sv -tr -ug -uk -zh_CN -zh_TW" 
[ebuild     U ] app-text/calibre-1.34 [1.29] USE="udisks" 
[ebuild     U ] www-plugins/adobe-flash-11.2.202.356 [11.2.202.346] USE="kde sse2 (-debug) (-selinux)" ABI_X86="64 -32 (-x32)" 
[ebuild     U ] media-video/mpv-0.3.9 [0.3.7] USE="X alsa cdio dvd enca encode iconv jack joystick jpeg ladspa lcms libass lua mpg123 opengl postproc quvi sdl%* shm v4l vaapi vcd vdpau wayland xinerama xscreensaver xv -bluray -bs2b -doc-pdf -dvb -dvdnav -libcaca -libguess -lirc -luajit -openal -oss -portaudio -pulseaudio -pvr -radio -samba (-selinux) -vf-dlopen" 
[ebuild     U ] www-client/chromium-35.0.1916.86 [34.0.1847.92] USE="cups tcmalloc -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-neon) -pulseaudio (-selinux) {-test} (-aura%)" LINGUAS="fr it -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 
[ebuild     U ] dev-qt/linguist-tools-5.3.0_beta [5.2.1] USE="qml -debug {-test}" 
[ebuild     U ] net-misc/openssh-6.6.1_p1 [6.6_p1-r1] USE="X hpn pam tcpd -X509 -bindist -kerberos -ldap -ldns -libedit (-selinux) -skey -static" 
[ebuild    fU ] app-emulation/emul-linux-x86-java-1.7.0.55 [1.7.0.51] USE="X alsa nsplugin -pax_kernel" 
[ebuild     U ] net-misc/openvpn-2.3.3 [2.3.2] USE="lzo pam plugins ssl -down-root -examples -iproute2 -passwordsave -pkcs11 (-polarssl) (-selinux) -static" 
[ebuild     U ] net-analyzer/wireshark-1.10.7 [1.10.6] USE="caps crypt filecaps geoip gtk3* ipv6 lua netlink pcap ssl zlib -adns -doc -doc-pdf -gtk2 -kerberos -libadns -portaudio -qt4* (-selinux) -smi" 
[ebuild     U ] www-client/firefox-bin-29.0 [28.0-r1] USE="startup-notification" LINGUAS="fr it -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -ja -kk -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -tr -uk -vi -zh_CN -zh_TW -zu" 
[ebuild     U ] dev-python/matplotlib-1.3.1-r99 [1.3.1] USE="cairo gtk latex qt4 -doc -examples -excel -fltk -gtk3 -pyside {-test} -tk -wxwidgets" PYTHON_TARGETS="python2_7 (-python2_6) -python3_2 -python3_3" 
[ebuild     U ] media-video/mkvtoolnix-6.9.1 [6.7.0] USE="pch qt5%* wxwidgets -debug (-qt4%)" 
[ebuild     U ] dev-vcs/git-cola-2.0.2 [2.0.1] USE="-doc {-test}" PYTHON_SINGLE_TARGET="python2_7 (-python2_6) -python3_3" PYTHON_TARGETS="python2_7 (-python2_6) -python3_3" 
[ebuild     U ] sys-boot/unetbootin-603 [585] LINGUAS="fr it -am -ar -ast -be -bg -bn -ca -cs -da -de -el -eo -es -et -eu -fa -fi -fo -gl -he -hr -hu -id -ja -lt -lv -ml -ms -nan -nb -nl -nn -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sv -sw -tr -uk -ur -vi -zh_CN -zh_TW" 
[ebuild     U ] dev-libs/weston-9999 [1.4.0] USE="X dbus drm egl examples fbdev launch opengl rdp resize-optimization suid view wayland-compositor xwayland -colord -editor (-gles2) -headless (-rpi) -static-libs -systemd {-test} -unwind" 
[ebuild     U ] kde-base/systemsettings-4.11.9 [4.11.8] USE="opengl semantic-desktop usb (-aqua) -debug -gtk -handbook {-test}" 
[ebuild     U ] mail-client/thunderbird-24.5.0 [24.3.0] USE="alsa crypt dbus gstreamer jit libnotify lightning minimal startup-notification wifi -bindist -custom-cflags -custom-optimization -debug -ldap -mozdom -pulseaudio (-selinux) -system-cairo -system-icu -system-jpeg -system-sqlite" LINGUAS="fr it -ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -en_GB -es_AR -es_ES -et -eu -fi -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW" 
[ebuild     U ] app-office/dia-0.97.3_pre20140417 [0.97.2-r2] USE="cairo python -debug -doc" PYTHON_SINGLE_TARGET="python2_7 (-python2_6)" PYTHON_TARGETS="python2_7 (-python2_6)" 
[ebuild     U ] sys-apps/gawk-4.1.1-r1 [4.1.0] USE="nls readline -mpfr" 
[ebuild     U ] sys-apps/kbd-2.0.1-r1 [2.0.1] USE="nls pam {-test}" 
[ebuild     U ] sys-apps/man-pages-3.65 [3.63] USE="nls" LINGUAS="fr it -da -de -ja -nl -pl -ro -ru -zh_CN" 
[nomerge      ] net-wireless/bluedevil-2.0_rc1-r1 [2.0_rc1] USE="(-aqua) -debug" LINGUAS="fr it -ar -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -hu -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 
[blocks b     ]  app-mobilephone/obex-data-server ("app-mobilephone/obex-data-server" is blocking net-wireless/bluedevil-2.0_rc1-r1)
[uninstall    ]   app-mobilephone/obex-data-server-0.4.6  USE="usb -debug -gtk -imagemagick" 
[blocks b     ]  app-mobilephone/obexd ("app-mobilephone/obexd" is blocking net-wireless/bluedevil-2.0_rc1-r1)
[uninstall    ]   app-mobilephone/obexd-0.46  USE="usb -eds -nokia -server" 
[ebuild     U ] net-wireless/bluedevil-2.0_rc1-r1 [2.0_rc1] USE="(-aqua) -debug" LINGUAS="fr it -ar -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -hu -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 
[ebuild  N    ] kde-frameworks/plasma-9999  USE="X opengl -debug -doc -egl {-test}" 
[ebuild     U ]  dev-qt/qtquick1-5.3.0_beta [5.2.1] USE="opengl webkit xml -debug {-test}" 
[ebuild     U ] dev-qt/designer-5.3.9999 [5.2.9999] USE="webkit -debug {-test}" 
[ebuild     U ]  dev-qt/qtwebkit-5.3.9999 [5.2.9999] USE="gstreamer multimedia opengl qml udev webp widgets -debug -libxml2 {-test} -xslt" 
[nomerge      ] kde-base/kdebase-meta-4.13.0  USE="wallpapers (-aqua)" 
[ebuild     U ]  kde-base/kwin-4.11.9 [4.11.8] USE="gles opengl wayland (-aqua) -debug" 
[ebuild     U ] dev-qt/qtmultimedia-5.3.9999 [5.2.9999] USE="alsa gstreamer qml -debug -openal -pulseaudio {-test}" 
[nomerge      ] kde-base/kdm-4.11.9-r1 [4.11.8] USE="consolekit pam (-aqua) -debug -handbook -kerberos -systemd" 
[ebuild     U ]  kde-base/kcheckpass-4.11.9 [4.11.8] USE="pam (-aqua) -debug" 
[ebuild     U ]  kde-base/libkworkspace-4.11.9 [4.11.8] USE="(-aqua) -debug" 
[ebuild     U ] app-editors/vim-7.4.273 [7.4.193] USE="X acl gpm lua nls python -cscope -debug -luajit -minimal -perl -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_SINGLE_TARGET="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" 
[nomerge      ] media-video/mpv-0.3.9 [0.3.7] USE="X alsa cdio dvd enca encode iconv jack joystick jpeg ladspa lcms libass lua mpg123 opengl postproc quvi sdl%* shm v4l vaapi vcd vdpau wayland xinerama xscreensaver xv -bluray -bs2b -doc-pdf -dvb -dvdnav -libcaca -libguess -lirc -luajit -openal -oss -portaudio -pulseaudio -pvr -radio -samba (-selinux) -vf-dlopen" 
[ebuild  N    ]  media-libs/libsdl2-2.0.2-r1  USE="3dnow X alsa audio dbus gles joystick mmx opengl sse sse2 static-libs threads udev video xinerama xscreensaver (-altivec) (-custom-cflags) -fusionsound -haptic -nas -oss -pulseaudio -tslib" ABI_X86="(64) -32 (-x32)" 
[ebuild     U ]   media-libs/mesa-10.1.1 [10.1.0] USE="classic dri3 egl gallium gbm gles2 llvm nptl pic vdpau wayland xvmc -bindist -debug -gles1 -opencl -openvg -osmesa -pax_kernel -r600-llvm-compiler (-selinux) -xa (-llvm-shared-libs%*)" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="r600 radeon (-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -radeonsi -vmware" 
[nomerge      ] kde-frameworks/kitemmodels-9999  USE="-debug -doc {-test}" 
[ebuild  N    ]  kde-frameworks/kf-env-1 
[ebuild     U ] media-gfx/jpegoptim-1.3.1 [1.3.0]
[ebuild     U ] app-crypt/kencfs-1.3.1 [1.3.0] LINGUAS="(-it%*) (-ro%)" 
[ebuild     U ] www-client/qupzilla-1.6.5 [1.6.3] USE="dbus kde -debug -gnome-keyring -nonblockdialogs" LINGUAS="fr_FR it_IT -ar_SA -bg_BG -ca_ES -cs_CZ -de_DE -el_GR -es_ES -es_VE -eu_ES -fa_IR -gl_ES -he_IL -hu_HU -id_ID -ja_JP -ka_GE -lg -nl_NL -nqo -pl_PL -pt_BR -pt_PT -ro_RO -ru_RU -sk_SK -sr_BA -sr_BA@latin -sr_RS -sr_RS@latin -sv_SE -uk_UA -zh_CN -zh_TW" 
[nomerge      ] kde-base/kdebase-meta-4.13.0  USE="wallpapers (-aqua)" 
[ebuild     U ]  kde-base/liboxygenstyle-4.11.9 [4.11.8] USE="(-aqua) -debug" 
[ebuild     U ]  kde-base/kephal-4.11.9 [4.11.8] USE="(-aqua) -debug" 
[ebuild     U ] media-video/mediainfo-0.7.68 [0.7.67] USE="-curl -mms -wxwidgets" 
[ebuild     U ] app-admin/hddtemp-0.3_beta15-r25 [0.3_beta15-r24] USE="nls -network-cron" 
[nomerge      ] app-editors/vim-7.4.273 [7.4.193] USE="X acl gpm lua nls python -cscope -debug -luajit -minimal -perl -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_SINGLE_TARGET="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" 
[ebuild     U ]  app-editors/vim-core-7.4.273 [7.4.193] USE="acl nls -minimal" 
[nomerge      ] media-video/mediainfo-0.7.68 [0.7.67] USE="-curl -mms -wxwidgets" 
[ebuild     U ]  media-libs/libmediainfo-0.7.68 [0.7.67] USE="static-libs -curl -doc -mms" 
[ebuild     U ] games-board/stockfish-20131129 [2.1.1] USE="sse%*" 
[ebuild     U ] app-text/tree-1.7.0 [1.6.0-r1]

Would you like to merge these packages? [Yes/No] >>> Verifying ebuild manifests
>>> Running pre-merge checks for mail-client/thunderbird-24.5.0
 * Checking for at least 4 GiB disk space at "/var/tmp/notmpfs/portage/mail-client/thunderbird-24.5.0/temp" ...                                                        [ ok ]
>>> Running pre-merge checks for dev-vcs/git-cola-2.0.2
>>> Running pre-merge checks for media-video/mkvtoolnix-6.9.1
>>> Running pre-merge checks for app-office/libreoffice-4.2.3.3-r1
 * Checking for at least 512 MiB RAM ...                                                                                                                               [ ok ]
 * Checking for at least 6 GiB disk space at "/var/tmp/notmpfs/portage/app-office/libreoffice-4.2.3.3-r1/temp" ...                                                     [ ok ]
>>> Emerging (1 of 53) app-text/tree-1.7.0::gentoo
>>> Emerging (2 of 53) games-board/stockfish-20131129::hasufell
>>> Emerging (3 of 53) media-libs/libmediainfo-0.7.68::gentoo
>>> Emerging (4 of 53) app-editors/vim-core-7.4.273::gentoo
>>> Installing (1 of 53) app-text/tree-1.7.0
>>> Installing (2 of 53) games-board/stockfish-20131129
>>> Jobs: 2 of 53 complete, 1 running               Load avg: 3.93, 2.92, 1.89
>>> Installing (3 of 53) media-libs/libmediainfo-0.7.68
>>> Installing (4 of 53) app-editors/vim-core-7.4.273
>>> Emerging (5 of 53) app-admin/hddtemp-0.3_beta15-r25::gentoo
>>> Emerging (6 of 53) media-video/mediainfo-0.7.68::gentoo
>>> Emerging (7 of 53) kde-base/kephal-4.11.9::gentoo
>>> Emerging (8 of 53) kde-base/liboxygenstyle-4.11.9::gentoo
>>> Installing (6 of 53) media-video/mediainfo-0.7.68
>>> Emerging (9 of 53) www-client/qupzilla-1.6.5::gentoo
>>> Emerging (10 of 53) app-crypt/kencfs-1.3.1::gentoo
>>> Installing (5 of 53) app-admin/hddtemp-0.3_beta15-r25
>>> Emerging (11 of 53) media-gfx/jpegoptim-1.3.1::gentoo
>>> Installing (8 of 53) kde-base/liboxygenstyle-4.11.9
>>> Emerging (12 of 53) kde-frameworks/kf-env-1::kde
>>> Installing (7 of 53) kde-base/kephal-4.11.9
>>> Emerging (13 of 53) media-libs/mesa-10.1.1::gentoo
>>> Installing (10 of 53) app-crypt/kencfs-1.3.1
>>> Installing (11 of 53) media-gfx/jpegoptim-1.3.1
>>> Installing (12 of 53) kde-frameworks/kf-env-1
>>> Failed to emerge www-client/qupzilla-1.6.5, Log file:
>>>  '/var/tmp/portage/www-client/qupzilla-1.6.5/temp/build.log'
>>> Installing (13 of 53) media-libs/mesa-10.1.1
>>> Jobs: 12 of 53 complete, 1 failed               Load avg: 3.16, 3.74, 3.11
*** Resuming merge...
 * Package:    www-client/qupzilla-1.6.5

<compile output of qupzilla skipped>

 * ERROR: www-client/qupzilla-1.6.5::gentoo failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=www-client/qupzilla-1.6.5::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=www-client/qupzilla-1.6.5::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/www-client/qupzilla-1.6.5/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/www-client/qupzilla-1.6.5/temp/environment'.
 * Working directory: '/var/tmp/portage/www-client/qupzilla-1.6.5/work/qupzilla-1.6.5'
 * S: '/var/tmp/portage/www-client/qupzilla-1.6.5/work/qupzilla-1.6.5'

!!! existing preserved libs found
-----------------------------------------------------------------------------------------
and nothing more ...
Comment 10 Thomas Capricelli 2014-05-03 01:15:49 UTC

2nd (restart after previous fail) :
-----------------------------------------------------------------------------------------
[ebuild     U ] dev-qt/qtserialport-5.3.9999 [5.2.9999] USE="-debug {-test}" 
[ebuild  N    ] kde-frameworks/khtml-9999  USE="X -debug -doc {-test}" 
[ebuild  N    ] kde-frameworks/kimageformats-9999  USE="jpeg2k openexr -debug -doc -eps {-test}" 
[ebuild  N    ] kde-frameworks/kdelibs4support-9999  USE="X -debug -doc {-test}" 
[ebuild  N    ] kde-frameworks/krunner-9999  USE="-debug -doc {-test}" 
[ebuild     U ] kde-base/kdm-4.11.9-r1 [4.11.8] USE="consolekit pam (-aqua) -debug -handbook -kerberos -systemd" 
[ebuild     U ] app-office/libreoffice-4.2.3.3-r1 [4.2.1.1] USE="bluetooth branding cups dbus gstreamer java kde opengl vba (-aqua) -debug -eds (-firebird) -gnome -gtk -gtk3 -jemalloc -mysql -odk -postgres -telepathy {-test} -vlc -webdav" LIBREOFFICE_EXTENSIONS="-nlpsolver -scripting-beanshell -scripting-javascript -wiki-publisher" PYTHON_SINGLE_TARGET="python2_7 -python3_3" PYTHON_TARGETS="python2_7 -python3_3" 
[ebuild     U ] app-office/skrooge-1.9.0 [1.8.0] USE="(-aqua) -debug -handbook" LINGUAS="fr it -bg -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -fi -ga -gl -hu -ia% -ja -ko -lt -mr -ms -nb -nds -nl -pl -pt -pt_BR -ro -ru -sk -sv -tr -ug -uk -zh_CN -zh_TW" 
[ebuild     U ] app-text/calibre-1.34 [1.29] USE="udisks" 
[ebuild     U ] www-plugins/adobe-flash-11.2.202.356 [11.2.202.346] USE="kde sse2 (-debug) (-selinux)" ABI_X86="64 -32 (-x32)" 
[ebuild     U ] media-video/mpv-0.3.9 [0.3.7] USE="X alsa cdio dvd enca encode iconv jack joystick jpeg ladspa lcms libass lua mpg123 opengl postproc quvi sdl%* shm v4l vaapi vcd vdpau wayland xinerama xscreensaver xv -bluray -bs2b -doc-pdf -dvb -dvdnav -libcaca -libguess -lirc -luajit -openal -oss -portaudio -pulseaudio -pvr -radio -samba (-selinux) -vf-dlopen" 
[ebuild     U ] www-client/chromium-35.0.1916.86 [34.0.1847.92] USE="cups tcmalloc -bindist -custom-cflags -gnome -gnome-keyring -kerberos (-neon) -pulseaudio (-selinux) {-test} (-aura%)" LINGUAS="fr it -am -ar -bg -bn -ca -cs -da -de -el -en_GB -es -es_LA -et -fa -fi -fil -gu -he -hi -hr -hu -id -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt_BR -pt_PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh_CN -zh_TW" 
[ebuild     U ] dev-qt/linguist-tools-5.3.0_beta [5.2.1] USE="qml -debug {-test}" 
[ebuild     U ] net-misc/openssh-6.6.1_p1 [6.6_p1-r1] USE="X hpn pam tcpd -X509 -bindist -kerberos -ldap -ldns -libedit (-selinux) -skey -static" 
[ebuild    fU ] app-emulation/emul-linux-x86-java-1.7.0.55 [1.7.0.51] USE="X alsa nsplugin -pax_kernel" 
[ebuild     U ] net-misc/openvpn-2.3.3 [2.3.2] USE="lzo pam plugins ssl -down-root -examples -iproute2 -passwordsave -pkcs11 (-polarssl) (-selinux) -static" 
[ebuild     U ] net-analyzer/wireshark-1.10.7 [1.10.6] USE="caps crypt filecaps geoip gtk3* ipv6 lua netlink pcap ssl zlib -adns -doc -doc-pdf -gtk2 -kerberos -libadns -portaudio -qt4* (-selinux) -smi" 
[ebuild     U ] www-client/firefox-bin-29.0 [28.0-r1] USE="startup-notification" LINGUAS="fr it -af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -csb -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -ja -kk -kn -ko -ku -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -tr -uk -vi -zh_CN -zh_TW -zu" 
[ebuild     U ] dev-python/matplotlib-1.3.1-r99 [1.3.1] USE="cairo gtk latex qt4 -doc -examples -excel -fltk -gtk3 -pyside {-test} -tk -wxwidgets" PYTHON_TARGETS="python2_7 (-python2_6) -python3_2 -python3_3" 
[ebuild     U ] media-video/mkvtoolnix-6.9.1 [6.7.0] USE="pch qt5%* wxwidgets -debug (-qt4%)" 
[ebuild     U ] dev-vcs/git-cola-2.0.2 [2.0.1] USE="-doc {-test}" PYTHON_SINGLE_TARGET="python2_7 (-python2_6) -python3_3" PYTHON_TARGETS="python2_7 (-python2_6) -python3_3" 
[ebuild     U ] sys-boot/unetbootin-603 [585] LINGUAS="fr it -am -ar -ast -be -bg -bn -ca -cs -da -de -el -eo -es -et -eu -fa -fi -fo -gl -he -hr -hu -id -ja -lt -lv -ml -ms -nan -nb -nl -nn -pl -pt -pt_BR -ro -ru -si -sk -sl -sr -sv -sw -tr -uk -ur -vi -zh_CN -zh_TW" 
[ebuild     U ] dev-libs/weston-9999 [1.4.0] USE="X dbus drm egl examples fbdev launch opengl rdp resize-optimization suid view wayland-compositor xwayland -colord -editor (-gles2) -headless (-rpi) -static-libs -systemd {-test} -unwind" 
[ebuild     U ] kde-base/systemsettings-4.11.9 [4.11.8] USE="opengl semantic-desktop usb (-aqua) -debug -gtk -handbook {-test}" 
[ebuild     U ] mail-client/thunderbird-24.5.0 [24.3.0] USE="alsa crypt dbus gstreamer jit libnotify lightning minimal startup-notification wifi -bindist -custom-cflags -custom-optimization -debug -ldap -mozdom -pulseaudio (-selinux) -system-cairo -system-icu -system-jpeg -system-sqlite" LINGUAS="fr it -ar -ast -be -bg -bn_BD -br -ca -cs -da -de -el -en_GB -es_AR -es_ES -et -eu -fi -fy_NL -ga_IE -gd -gl -he -hr -hu -hy_AM -id -is -ja -ko -lt -nb_NO -nl -nn_NO -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -sq -sr -sv_SE -ta_LK -tr -uk -vi -zh_CN -zh_TW" 
[ebuild     U ] app-office/dia-0.97.3_pre20140417 [0.97.2-r2] USE="cairo python -debug -doc" PYTHON_SINGLE_TARGET="python2_7 (-python2_6)" PYTHON_TARGETS="python2_7 (-python2_6)" 
[ebuild     U ] sys-apps/gawk-4.1.1-r1 [4.1.0] USE="nls readline -mpfr" 
[ebuild     U ] sys-apps/kbd-2.0.1-r1 [2.0.1] USE="nls pam {-test}" 
[ebuild     U ] sys-apps/man-pages-3.65 [3.63] USE="nls" LINGUAS="fr it -da -de -ja -nl -pl -ro -ru -zh_CN" 
[nomerge      ] net-wireless/bluedevil-2.0_rc1-r1 [2.0_rc1] USE="(-aqua) -debug" LINGUAS="fr it -ar -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -hu -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 
[blocks b     ]  app-mobilephone/obex-data-server ("app-mobilephone/obex-data-server" is blocking net-wireless/bluedevil-2.0_rc1-r1)
[uninstall    ]   app-mobilephone/obex-data-server-0.4.6  USE="usb -debug -gtk -imagemagick" 
[blocks b     ]  app-mobilephone/obexd ("app-mobilephone/obexd" is blocking net-wireless/bluedevil-2.0_rc1-r1)
[uninstall    ]   app-mobilephone/obexd-0.46  USE="usb -eds -nokia -server" 
[ebuild     U ] net-wireless/bluedevil-2.0_rc1-r1 [2.0_rc1] USE="(-aqua) -debug" LINGUAS="fr it -ar -bs -ca -ca@valencia -cs -da -de -el -en_GB -eo -es -et -eu -fa -fi -ga -gl -hu -ja -kk -km -ko -lt -mai -mr -ms -nb -nds -nl -pa -pl -pt -pt_BR -ro -ru -sk -sl -sr -sr@ijekavian -sr@ijekavianlatin -sr@latin -sv -th -tr -ug -uk -zh_CN -zh_TW" 
[nomerge      ] kde-base/kdebase-meta-4.13.0  USE="wallpapers (-aqua)" 
[ebuild     U ]  kde-base/kwin-4.11.9 [4.11.8] USE="gles opengl wayland (-aqua) -debug" 
[ebuild     U ]  kde-base/kcheckpass-4.11.9 [4.11.8] USE="pam (-aqua) -debug" 
[ebuild  N    ] kde-frameworks/plasma-9999  USE="X opengl -debug -doc -egl {-test}" 
[nomerge      ] kde-base/kdebase-meta-4.13.0  USE="wallpapers (-aqua)" 
[nomerge      ]  kde-base/powerdevil-4.11.8  USE="pm-utils (-aqua) -debug" 
[ebuild     U ]   kde-base/libkworkspace-4.11.9 [4.11.8] USE="(-aqua) -debug" 
[ebuild     U ] dev-qt/qtquick1-5.3.0_beta [5.2.1] USE="opengl webkit xml -debug {-test}" 
[ebuild     U ] dev-qt/designer-5.3.9999 [5.2.9999] USE="webkit -debug {-test}" 
[ebuild     U ]  dev-qt/qtwebkit-5.3.9999 [5.2.9999] USE="gstreamer multimedia opengl qml udev webp widgets -debug -libxml2 {-test} -xslt" 
[ebuild     U ]   dev-qt/qtmultimedia-5.3.9999 [5.2.9999] USE="alsa gstreamer qml -debug -openal -pulseaudio {-test}" 
[nomerge      ] media-video/mpv-0.3.9 [0.3.7] USE="X alsa cdio dvd enca encode iconv jack joystick jpeg ladspa lcms libass lua mpg123 opengl postproc quvi sdl%* shm v4l vaapi vcd vdpau wayland xinerama xscreensaver xv -bluray -bs2b -doc-pdf -dvb -dvdnav -libcaca -libguess -lirc -luajit -openal -oss -portaudio -pulseaudio -pvr -radio -samba (-selinux) -vf-dlopen" 
[ebuild  N    ]  media-libs/libsdl2-2.0.2-r1  USE="3dnow X alsa audio dbus gles joystick mmx opengl sse sse2 static-libs threads udev video xinerama xscreensaver (-altivec) (-custom-cflags) -fusionsound -haptic -nas -oss -pulseaudio -tslib" ABI_X86="(64) -32 (-x32)" 
[ebuild     U ] app-editors/vim-7.4.273 [7.4.193] USE="X acl gpm lua nls python -cscope -debug -luajit -minimal -perl -racket -ruby (-selinux) -tcl -vim-pager" PYTHON_SINGLE_TARGET="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" PYTHON_TARGETS="python2_7 (-python2_6) -python3_2 -python3_3 -python3_4" 

Would you like to merge these packages? [Yes/No] >>> Verifying ebuild manifests
>>> Running pre-merge checks for mail-client/thunderbird-24.5.0
 * Checking for at least 4 GiB disk space at "/var/tmp/notmpfs/portage/mail-client/thunderbird-24.5.0/temp" ...                                                        [ ok ]
>>> Running pre-merge checks for dev-vcs/git-cola-2.0.2
>>> Running pre-merge checks for media-video/mkvtoolnix-6.9.1
>>> Running pre-merge checks for app-office/libreoffice-4.2.3.3-r1
 * Checking for at least 512 MiB RAM ...                                                                                                                               [ ok ]
 * Checking for at least 6 GiB disk space at "/var/tmp/notmpfs/portage/app-office/libreoffice-4.2.3.3-r1/temp" ...                                                     [ ok ]
>>> Emerging (1 of 40) app-editors/vim-7.4.273::gentoo
>>> Installing (1 of 40) app-editors/vim-7.4.273
>>> Emerging (2 of 40) media-libs/libsdl2-2.0.2-r1::gentoo
>>> Emerging (3 of 40) dev-qt/qtmultimedia-5.3.9999::qt
>>> Emerging (4 of 40) kde-base/libkworkspace-4.11.9::gentoo
>>> Emerging (5 of 40) kde-base/kcheckpass-4.11.9::gentoo
>>> Installing (5 of 40) kde-base/kcheckpass-4.11.9
>>> Emerging (6 of 40) net-wireless/bluedevil-2.0_rc1-r1::gentoo
>>> Emerging (7 of 40) sys-apps/man-pages-3.65::gentoo
>>> Installing (4 of 40) kde-base/libkworkspace-4.11.9
>>> Emerging (8 of 40) kde-base/kwin-4.11.9::gentoo
>>> Installing (2 of 40) media-libs/libsdl2-2.0.2-r1
>>> Emerging (9 of 40) sys-apps/kbd-2.0.1-r1::gentoo
>>> Failed to emerge dev-qt/qtmultimedia-5.3.9999, Log file:
>>>  '/var/tmp/portage/dev-qt/qtmultimedia-5.3.9999/temp/build.log'
>>> Installing (6 of 40) net-wireless/bluedevil-2.0_rc1-r1
>>> Installing (8 of 40) kde-base/kwin-4.11.9
>>> Installing (7 of 40) sys-apps/man-pages-3.65
>>> Installing (9 of 40) sys-apps/kbd-2.0.1-r1
>>> Jobs: 8 of 40 complete, 1 failed                Load avg: 2.32, 3.10, 2.78
*** Resuming merge...
 * Package:    dev-qt/qtmultimedia-5.3.9999

<compile output of qupzilla skipped>

Makefile:40: recipe for target 'sub-src-make_first' failed
make: *** [sub-src-make_first] Error 2
 * ERROR: dev-qt/qtmultimedia-5.3.9999::qt failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=dev-qt/qtmultimedia-5.3.9999::qt'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtmultimedia-5.3.9999::qt'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtmultimedia-5.3.9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtmultimedia-5.3.9999/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtmultimedia-5.3.9999/work/qtmultimedia-5.3.9999_build'
 * S: '/var/tmp/portage/dev-qt/qtmultimedia-5.3.9999/work/qtmultimedia-5.3.9999'

!!! existing preserved libs found
-----------------------------------------------------------------------------------------
Comment 11 Thomas Capricelli 2014-05-03 01:17:17 UTC
I mean, both qupzilla and dev-qt/qtmultimedia-5.3.9999 are really unimportant stuff and "leafs" in the dep tree, they shouldn't prevent other packages to be emerged.
Comment 12 dE 2014-08-03 16:29:25 UTC
Created attachment 382146 [details]
Portage --debug output.
Comment 13 Eugene Shalygin 2016-04-24 00:11:08 UTC
My case: smart-live-rebuild produced the following command:
emerge --oneshot -1avq --keep-going kde-apps/kio-extras:5 kde-apps/messagelib:5 kde-apps/libkleo:5 kde-apps/calendarsupport:5 kde-apps/kdepim:5 kde-apps/kdepim-apps-libs:5 kde-apps/dolphin:5 kde-apps/akonadi:5 kde-apps/libksieve:5 kde-apps/kcalutils:5 kde-apps/kimap:5 kde-apps/kdepim-runtime:5 app-text/goldendict:0 app-text/kbibtex:5 net-libs/rb_libtorrent:0 net-libs/telepathy-qt:0 www-client/qupzilla:0 media-video/mpv:0 media-video/gpac:0 media-video/handbrake:0 media-gfx/ktikz:0 net-p2p/eiskaltdcpp:0

app-text/kbibtex fails to build and emerge stops.

portage 2.2.28
Comment 14 Zac Medico gentoo-dev 2016-04-24 00:19:28 UTC
(In reply to Thomas Capricelli from comment #11)
> I mean, both qupzilla and dev-qt/qtmultimedia-5.3.9999 are really
> unimportant stuff and "leafs" in the dep tree, they shouldn't prevent other
> packages to be emerged.

Typically, failed "leafs" can case a dependency calculation to fail because it results in the currently installed versions of those "leafs" to be pulled into the dependency graph, and those versions may now have unsatisfied dependencies due to other upgrades that have occurred.

(In reply to Eugene Shalygin from comment #13)
> app-text/kbibtex fails to build and emerge stops.

It's likely an issue like that described above.
Comment 15 Eugene Shalygin 2016-04-28 03:35:44 UTC
In my case the problem was the following. In the error printed by emerge when --keep-going failed I read that one of the packages (kbibtex) depends on an unavailable or masked package (dev-libs/qoauth:5). The strange thing is this package is installed. And why did emerge say not a word about at the start? Nevertheless, after reinstalling dev-libs/qoauth:5 --keep-going mode works. It looks like dependency resolution during --keep-going stage is not the same as at regular run?
Comment 16 dE 2018-08-22 10:20:51 UTC
Created attachment 544438 [details]
--debug output of the latest portage (as of the current time).

This has gotten worst with the latest portage of the current time (9999). Now it's getting very difficult to upgrade.

Attached is the --debug output
Comment 17 Zac Medico gentoo-dev 2018-08-22 18:47:02 UTC
(In reply to dE from comment #16)
> Created attachment 544438 [details]
> --debug output of the latest portage (as of the current time).
> 
> This has gotten worst with the latest portage of the current time (9999).
> Now it's getting very difficult to upgrade.
> 
> Attached is the --debug output
There haven't been changes to the relevant code lately, so it must be something about the state of your packages that triggers the behavior that you are seeing. Your debug log shows that you need to install sys-libs/readline:0/0:

>  * One or more packages are either masked or have missing dependencies:
>  * 
>  *   sys-libs/readline:0/0= pulled in by:
>  *     (dev-lang/spidermonkey-1.8.5-r6:0/mozjs185::gentoo, installed)