Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 374583 - sys-apps/portage-2.1.10.3: emerge unable to resume update with keep-going after build failure
Summary: sys-apps/portage-2.1.10.3: emerge unable to resume update with keep-going aft...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Dependencies (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 342713 362355 (view as bug list)
Depends on:
Blocks: 373807 373933
  Show dependency tree
 
Reported: 2011-07-09 19:39 UTC by Toralf Förster
Modified: 2011-07-13 00:53 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log (e.log,4.92 KB, text/plain)
2011-07-09 19:39 UTC, Toralf Förster
Details
fix regression from reposyntax changes (resume.patch,1.09 KB, patch)
2011-07-11 17:21 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2011-07-09 19:39:35 UTC
I'm wondering why "--keep-going" doesn't work as expected, when libkdeedu failed (bug #374563). I'm pretty sure that not all outstanding packages are based on KDE edu, isn't it ?

Reproducible: Always
Comment 1 Toralf Förster gentoo-dev 2011-07-09 19:39:51 UTC
Created attachment 279533 [details]
emerge log
Comment 2 Toralf Förster gentoo-dev 2011-07-10 08:10:57 UTC
FWIW, after I installed libkdeedu with "ebuild compile install qemerge", I could update to KDE 4.6.5 the remaining üpackages in one step althought kalzium and keography failed (bug #374609).
SO is this rather ea bug in portage ?
Comment 3 Pacho Ramos gentoo-dev 2011-07-10 17:53:47 UTC
Post emerge --info output please
Comment 4 Toralf Förster gentoo-dev 2011-07-10 18:29:14 UTC
(In reply to comment #3)
> Post emerge --info output please

tfoerste@n22 ~ $ emerge --info
Portage 2.1.10.3 (default/linux/x86/10.0/desktop/kde, gcc-4.4.5, glibc-2.12.2-r0, 2.6.39.3 i686)
=================================================================
System uname: Linux-2.6.39.3-i686-Intel-R-_Core-TM-2_Duo_CPU_P8600_@_2.40GHz-with-gentoo-2.0.2
Timestamp of tree: Sun, 10 Jul 2011 17:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:          4.1_p9
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.1-r1, 3.1.3-r1
dev-util/ccache:          2.4-r9
dev-util/cmake:           2.8.4-r1
dev-util/pkgconfig:       0.25-r2
sys-apps/baselayout:      2.0.2
sys-apps/openrc:          0.8.3-r1
sys-apps/sandbox:         2.4
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:       2.20.1-r1
sys-devel/gcc:            4.4.5
sys-devel/gcc-config:     1.4.1-r1
sys-devel/libtool:        2.2.10
sys-devel/make:           3.82
sys-kernel/linux-headers: 2.6.36.1 (virtual/os-headers)
sys-libs/glibc:           2.12.2
Repositories: gentoo x-portage
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="*"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -march=native -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache compress-build-logs distlocks ebuild-locks fixlafiles fixpackages news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://gentoo.mirror.dkm.cz/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://gentoo.mneisen.org/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://linux.rz.ruhr-uni-bochum.de/gentoo-portage"
USE="X a52 aac acl acpi alsa apache2 berkdb bluetooth branding bzip2 cairo cdda cdr classic cli consolekit cracklib crypt css cups cxx dbus declarative dri dts dvb dvd dvdr emboss encode exif fam fastbuild fat ffmpeg firefox flac fortran gdbm gdu gif git gmp gphoto2 gpm gtk hyphenation iconv ipv6 java jpeg kde kipi kqemu kvm lastfm lcms ldap libnotify logrotate mad mbox mmx mng modules mp3 mp4 mpeg mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntfs ogg opengl openmp pam pango pcre pdf perl phonon plasma png policykit ppds pppd python qt3support qt4 rdesktop readline sdl semantic-desktop session sieve spell sse sse2 sse3 ssl ssse3 startup-notification svg sysfs tcpd test thinkpad tiff tk truetype udev unicode usb vaapi vim-syntax vnc vorbis wmf x264 x86 xcb xcomposite xinerama xml xorg xpm xscreensaver xulrunner xv xvfb xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow karbon kexi kpresenter krita tables words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB" LIRC_DEVICES="devinput inputlirc" PHP_TARGETS="php5-3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Zac Medico gentoo-dev 2011-07-11 17:21:48 UTC
Created attachment 279783 [details, diff]
fix regression from reposyntax changes

Save as /tmp/resume.patch and apply as follows:

 patch /usr/lib/portage/pym/_emerge/depgraph.py /tmp/resume.patch
Comment 6 Zac Medico gentoo-dev 2011-07-11 20:03:11 UTC
Please test the attached patch if you can. It fixes an issue introduced in portage-2.2_rc90 by the fixes for bug 262038, but similar issues such as bug 312467 had been prior to portage-2.2_rc90. So, it doesn't necessarily fix the exact issue that you've experienced.
Comment 7 Toralf Förster gentoo-dev 2011-07-12 07:34:56 UTC
it works AFAICS - I rebuild my user mode linux image completely with gcc.4.6.1 and that patch - no problems seen so far.
Comment 8 Zac Medico gentoo-dev 2011-07-13 00:30:26 UTC
Thanks for testing. This is fixed in 2.1.10.5 and 2.2.0_alpha44.
Comment 9 Zac Medico gentoo-dev 2011-07-13 00:52:04 UTC
*** Bug 362355 has been marked as a duplicate of this bug. ***
Comment 10 Zac Medico gentoo-dev 2011-07-13 00:53:53 UTC
*** Bug 342713 has been marked as a duplicate of this bug. ***