Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 330847 - gnome-extra/yelp fails to configure with net-libs/xulrunner-2.0
Summary: gnome-extra/yelp fails to configure with net-libs/xulrunner-2.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL: https://bugzilla.gnome.org/show_bug.c...
Whiteboard:
Keywords:
: 331205 373911 378859 389879 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-02 15:12 UTC by Cyprien Nicolas (fulax)
Modified: 2011-11-08 22:23 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
/var/tmp/portage/gnome-extra/yelp-2.30.1-r1/work/yelp-2.30.1/config.log (config.log,61.90 KB, text/plain)
2010-08-02 15:15 UTC, Cyprien Nicolas (fulax)
Details
'emerge --info =gnome-extra/yelp-2.30.1-r1' (emerge.info,12.92 KB, text/plain)
2010-08-02 15:16 UTC, Cyprien Nicolas (fulax)
Details
Build log (gnome-extra:yelp-2.30.1-r1:20100802-151348.log,12.06 KB, text/plain)
2010-08-02 15:18 UTC, Cyprien Nicolas (fulax)
Details
yelp-xulrunner-20.patch (yelp-xulrunner20.patch,7.60 KB, patch)
2011-03-22 21:38 UTC, Pacho Ramos
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Cyprien Nicolas (fulax) 2010-08-02 15:12:30 UTC
Versions:
(installed) net-libs/xulrunner-2.0_beta3_pre-r2 (1.9) [1]
[1] "mozilla" /var/lib/layman/mozilla

# emerge -DuNp @world
Calculating dependencies... done!
[ebuild     U ] gnome-extra/yelp-2.30.1-r1 [2.28.1-r2] USE="-beagle -debug lzma" 0 kB
[ebuild     U ] gnome-base/gnome-light-2.30.2 [2.28.2] USE="automount" 0 kB

Total: 2 packages (2 upgrades), Size of downloads: 0 kB

Steps to reproduce:
1. Install xulrunner-2.0* from mozilla's overlay
2. Upgrade to or reinstall <=gnome-extra/yelp-2.30.1-r1
3. See the failure during configure

Failure:
...
checking which gecko to use... libxul-embedding
checking manual gecko home set... Package libxul-embedding-unstable was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxul-embedding-unstable.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxul-embedding-unstable' found
checking for compiler -fshort-wchar option... yes
checking whether to enable C++ RTTI... no
checking whether we have a gtk 2 gecko build... configure: error: This program needs a gtk 2 gecko build

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/gnome-extra/yelp-2.30.1-r1/work/yelp-2.30.1/config.log
 * ERROR: gnome-extra/yelp-2.30.1-r1 failed:
 *   econf failed
 * 
 * Call stack:
 *     ebuild.sh, line   48:  Called src_configure
 *   environment, line 3209:  Called gnome2_src_configure
 *   environment, line 2552:  Called econf '--with-gecko=libxul-embedding' '--enable-lzma' '--with-search=basic'
 *     ebuild.sh, line  538:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 *

Logs and informations attached in the first comments
Comment 1 Cyprien Nicolas (fulax) 2010-08-02 15:15:34 UTC
Created attachment 241087 [details]
/var/tmp/portage/gnome-extra/yelp-2.30.1-r1/work/yelp-2.30.1/config.log
Comment 2 Cyprien Nicolas (fulax) 2010-08-02 15:16:10 UTC
Created attachment 241089 [details]
'emerge --info =gnome-extra/yelp-2.30.1-r1'
Comment 3 Cyprien Nicolas (fulax) 2010-08-02 15:18:44 UTC
Created attachment 241091 [details]
Build log
Comment 4 Gilles Dartiguelongue gentoo-dev 2010-08-02 16:11:38 UTC
yelp checks for xulrunner-1.9 not 2.0, this is still beta so I don't think anything will be done to check compatibility at this point on gnome herd side. You are free to patch and report your findings upstream though, I'm sure any patches would end up in the gnome overlay sooner or later since it would probably be integrated in 2.31 dev cycle.
Comment 5 Jory A. Pratt gentoo-dev 2010-08-02 16:29:22 UTC
(In reply to comment #4)
> yelp checks for xulrunner-1.9 not 2.0, this is still beta so I don't think
> anything will be done to check compatibility at this point on gnome herd side.
> You are free to patch and report your findings upstream though, I'm sure any
> patches would end up in the gnome overlay sooner or later since it would
> probably be integrated in 2.31 dev cycle.
> 

There have been no changes just need to update configure to check for 2.0 as well. If gnome herd does not want to fix not gonna happen on our end. Gnome should make a proper check and not depend on a specific version being avliable.
Comment 6 Gilles Dartiguelongue gentoo-dev 2010-08-02 16:31:06 UTC
I guess upstream didn't want to risk guessing API compatibility upfront given xulrunner history :)
Comment 7 Jory A. Pratt gentoo-dev 2010-08-02 16:45:42 UTC
This is nothing more then an ebuild failure.  		--with-gecko=libxul-embedding ... this should be l		--with-gecko=libxul and compile would be fine.
Comment 8 Gilles Dartiguelongue gentoo-dev 2010-08-02 16:54:30 UTC
meh ? that's weird, I remember we had to change this months ago for the same reason (1.8 to 1.9 or 1.9 to 1.9.1, can't remember).
Comment 9 Jory A. Pratt gentoo-dev 2010-08-02 17:02:29 UTC
For now leave it closed failure will result either way. As we approach rc's we will reopen and worry about it then.
Comment 10 Cyprien Nicolas (fulax) 2010-08-03 08:07:04 UTC
(In reply to comment #4)
> yelp checks for xulrunner-1.9 not 2.0, this is still beta so I don't think
> anything will be done to check compatibility at this point on gnome herd side.
> You are free to patch and report your findings upstream though, I'm sure any
> patches would end up in the gnome overlay sooner or later since it would
> probably be integrated in 2.31 dev cycle.
> 

Hi Gilles, I think you are right about xulrunner, but not about yelp.

The Gnome devs drop support for gecko, in favor of webkit-gtk-1.3, so I'm afraid nothing will be done in the 2.31 for xulrunner.

I took a deep look at the gecko.m4 made by the Gnome devs for xulrunner detection, and it has been designed for xulrunner-1.[7-9].
So this is more an UPSTREAM Resolution: Gnome Bugzilla reference: https://bugzilla.gnome.org/show_bug.cgi?id=625910

A not really effective solution is to wait for xulrunner being slotted in 2.0, but I don't really want to have two xulrunners installed just for a feature I never use.
Comment 11 Gilles Dartiguelongue gentoo-dev 2010-08-04 15:40:15 UTC
*** Bug 331205 has been marked as a duplicate of this bug. ***
Comment 12 Jory A. Pratt gentoo-dev 2010-08-23 19:25:25 UTC
(In reply to comment #10)
> (In reply to comment #4)
> > yelp checks for xulrunner-1.9 not 2.0, this is still beta so I don't think
> > anything will be done to check compatibility at this point on gnome herd side.
> > You are free to patch and report your findings upstream though, I'm sure any
> > patches would end up in the gnome overlay sooner or later since it would
> > probably be integrated in 2.31 dev cycle.
> > 
> 
> Hi Gilles, I think you are right about xulrunner, but not about yelp.
> 
> The Gnome devs drop support for gecko, in favor of webkit-gtk-1.3, so I'm
> afraid nothing will be done in the 2.31 for xulrunner.
> 
> I took a deep look at the gecko.m4 made by the Gnome devs for xulrunner
> detection, and it has been designed for xulrunner-1.[7-9].
> So this is more an UPSTREAM Resolution: Gnome Bugzilla reference:
> https://bugzilla.gnome.org/show_bug.cgi?id=625910
> 
> A not really effective solution is to wait for xulrunner being slotted in 2.0,
> but I don't really want to have two xulrunners installed just for a feature I
> never use.
> 
2.0 will not create a new slot. There would be no point in it.
Comment 13 Hanno Böck gentoo-dev 2011-03-22 10:31:20 UTC
Seems nobody bothered to re-open in rc-phase, now we have ff 4 in tree and it still fails.
Comment 14 Cyprien Nicolas (fulax) 2011-03-22 10:46:47 UTC
See with upstream (in URL) bug was marked Won't Fix - too old
Comment 15 Pacho Ramos gentoo-dev 2011-03-22 21:38:51 UTC
Created attachment 266925 [details, diff]
yelp-xulrunner-20.patch

OpenSUSE patch porting yelp to xul-2.0, please try it
Comment 16 Gilles Dartiguelongue gentoo-dev 2011-03-23 07:58:47 UTC
Is xulrunner-2 really still slot 1.9 ?
Comment 17 Andreas Ots 2011-03-23 11:47:14 UTC
It seems to be.

$ grep SLOT /usr/portage/net-libs/xulrunner/*.ebuild /var/lib/layman/*/net-libs/xulrunner/*.ebuild
/usr/portage/net-libs/xulrunner/xulrunner-1.9.2.12.ebuild:SLOT="1.9"
/usr/portage/net-libs/xulrunner/xulrunner-1.9.2.13.ebuild:SLOT="1.9"
/usr/portage/net-libs/xulrunner/xulrunner-1.9.2.15.ebuild:SLOT="1.9"
/usr/portage/net-libs/xulrunner/xulrunner-2.0.ebuild:SLOT="1.9"
/var/lib/layman/mozilla/net-libs/xulrunner/xulrunner-2.0.ebuild:SLOT="1.9"
Comment 18 Jory A. Pratt gentoo-dev 2011-03-23 12:15:24 UTC
(In reply to comment #16)
> Is xulrunner-2 really still slot 1.9 ?

Actually xulrunner should never had been slotted. This was done before I returned to gentoo. The reason we left it in slot-1.9 is due to the fact it will take more work then it is worth to patch it to suppport multiple instances being installed. Eventually I will get around to drop the slot all together.
Comment 19 Andreas Ots 2011-03-23 14:16:34 UTC
(In reply to comment #15)
> Created attachment 266925 [details, diff]
> yelp-xulrunner-20.patch
> 
> OpenSUSE patch porting yelp to xul-2.0, please try it

Tried it. Seems to work. However:

>>> Installing (1 of 2) gnome-extra/yelp-2.30.2-r1
 * Installing GNOME 2 GConf schemas
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
WARNING: node <gettext_domain> not understood below <schema>
 * Reloading GConf schemas ... [ ok ]
 * Updating desktop mime database ...
 * Updating shared mime info database ...
 * Updating icons cache ... [ ok ]
Comment 20 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-23 14:34:55 UTC
(In reply to comment #15)
> Created attachment 266925 [details, diff]
> yelp-xulrunner-20.patch
> 
> OpenSUSE patch porting yelp to xul-2.0, please try it

With the patch, yelp compiles and runs. Browsing help also seems to work. I'm going to commit it.
Comment 21 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-03-23 14:38:41 UTC
This is now fixed in the tree, with 2.30.2-r2, thanks everyone!
Comment 22 Kobboi 2011-07-04 15:09:56 UTC
(In reply to comment #21)
> This is now fixed in the tree, with 2.30.2-r2, thanks everyone!

I still hit it:

checking which gecko to use... libxul-embedding
checking manual gecko home set... Package libxul-embedding-unstable was not found in the pkg-config search path.
Perhaps you should add the directory containing `libxul-embedding-unstable.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libxul-embedding-unstable' found
checking for compiler -fshort-wchar option... yes
checking whether to enable C++ RTTI... no
checking whether we have a gtk 2 gecko build... configure: error: This program needs a gtk 2 gecko build

* gnome-extra/yelp: 2.30.2-r5

* net-libs/xulrunner:

     Installed versions:  2.0.1-r1(1.9){tbz2}(23:38:26 06/19/11)(alsa crashreporter dbus ipc libnotify startup-notification webm -custom-optimization -debug -gconf -system-sqlite -wifi)
Comment 23 Michel Ganguin 2011-07-04 16:07:59 UTC
for me too, emerge yelp-2.30.2-r5 fails with xulrunner-20, this patch provided in this bug fixes the build, but yelp starts with error "Could not initialize gecko!"
Comment 24 Pacho Ramos gentoo-dev 2011-07-04 19:37:19 UTC
People running xul-2 need -r6 (these problems tends to occur when mixing stable and testing, when this occurs again, please try moving to testing the affected package)
Comment 25 Pacho Ramos gentoo-dev 2011-07-04 19:38:16 UTC
*** Bug 373911 has been marked as a duplicate of this bug. ***
Comment 26 Moritz Schlarb 2011-07-14 22:06:22 UTC
I want to confirm this bug with yelp-2.30.2-r5 and xulrunner-2.0.1-r1 and that using yelp-2.30.2-r6 fixes the configure failure.
Should be moved to stable quickly.
Comment 27 Pacho Ramos gentoo-dev 2011-08-12 12:33:01 UTC
*** Bug 378859 has been marked as a duplicate of this bug. ***
Comment 28 Nirbheek Chauhan (RETIRED) gentoo-dev 2011-08-14 03:15:20 UTC
(In reply to comment #26)
> I want to confirm this bug with yelp-2.30.2-r5 and xulrunner-2.0.1-r1 and that
> using yelp-2.30.2-r6 fixes the configure failure.
> Should be moved to stable quickly.

xulrunner-2 won't go to stable, so there's no point stabilizing it. The next stable firefox will be either 5.0 or 6.0, and both don't have any corresponding xulrunner versions.
Comment 29 Jess Haas 2011-09-30 06:48:03 UTC
Just ran in to this bug and I see a huge point in stabilizing yelp-2.30.2-r6 as currently the ebuild is broken for many users. If there is a reason to not stabilize it then the ebuild needs to be updated to require a 1.9 version of xulrunner.
Comment 30 Pacho Ramos gentoo-dev 2011-11-08 22:23:39 UTC
*** Bug 389879 has been marked as a duplicate of this bug. ***