Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 378187 - sys-apps/portage-2.1.10.10: emerge --keep-going does not handle unsatisfied dependencies of installed packages
Summary: sys-apps/portage-2.1.10.10: emerge --keep-going does not handle unsatisfied d...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Interface (emerge) (show other bugs)
Hardware: All All
: Normal enhancement (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS
: 312467 (view as bug list)
Depends on:
Blocks: 373807 373933
  Show dependency tree
 
Reported: 2011-08-08 08:07 UTC by Zac Medico
Modified: 2011-08-13 00:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log demonstrating this kind of failure (vim_keepgoing_failure.txt,60.27 KB, patch)
2011-08-08 08:12 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Zac Medico gentoo-dev 2011-08-08 08:07:45 UTC
Suppose that package Y depends on a specific version of package X. If you have an upgrade for both packages, and the package X upgrade succeeds but the package Y upgrade fails, it commonly triggers a state in which the installed instance of package Y has an unsatisfied dependency for the previous version of package X. This causes emerge --keep-going to bail out, but we really want it to just prune off the broken part(s) of the dependency graph and keep going.
Comment 1 Zac Medico gentoo-dev 2011-08-08 08:12:58 UTC
Created attachment 282523 [details, diff]
build log demonstrating this kind of failure
Comment 2 Zac Medico gentoo-dev 2011-08-11 03:32:47 UTC
This should fix some similar cases:

http://git.overlays.gentoo.org/gitweb/?p=proj/portage.git;a=commit;h=72137f634878c4b0ef54287dd4a33fa2240a68f7

This will fix your particular case only if (app-editors/vim-7.3.189::gentoo, installed) got pulled into the graph indirectly via a satisfied build-time dependency.
Comment 3 Zac Medico gentoo-dev 2011-08-11 03:39:10 UTC
For now, I'll just assume that this is fixed unless we can prove otherwise.
Comment 4 Zac Medico gentoo-dev 2011-08-12 12:59:26 UTC
This is fixed in 2.1.10.11 and 2.2.0_alpha51.
Comment 5 Zac Medico gentoo-dev 2011-08-13 00:36:42 UTC
*** Bug 312467 has been marked as a duplicate of this bug. ***