Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 288312 - x11-misc/shared-mime-info-0.70 breaks icons
Summary: x11-misc/shared-mime-info-0.70 breaks icons
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
: 267254 288415 288538 288865 289034 289194 289271 289289 289316 289346 289559 (view as bug list)
Depends on: 291046
Blocks:
  Show dependency tree
 
Reported: 2009-10-09 14:36 UTC by Federico Fissore
Modified: 2009-10-29 19:23 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Federico Fissore 2009-10-09 14:36:06 UTC
after upgrading shared-mime-info from 0.60 to 0.70, almost every icon disappeared from my gnome

downgrading to 0.60 fixed it

Reproducible: Always

Steps to Reproduce:
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-10-09 15:15:23 UTC
Reading glib-2.22.2 changelog suggests that cache-format might have changed again. Could you follow instruction for the > 0.30 migration again ? If that doesn't work, could you try installing glib from the gnome overlay ?
Comment 2 Samuli Suominen (RETIRED) gentoo-dev 2009-10-09 15:39:55 UTC
This is the message:

"The database format has changed between 0.30 and 0.40."
"You may need to update all your local databases and caches."
"To do so, please run the following commands:"
"(for each user) $ update-mime-database ~/.local/share/mime/"
"(as root)       # update-mime-database /usr/local/share/mime/"

Test above also for 0.60 to 0.70 migration, if it's required we can update the message for 0.70 ebuild.
Comment 3 Ian Abbott 2009-10-09 16:29:23 UTC
(In reply to comment #2)
> This is the message:
> 
> "The database format has changed between 0.30 and 0.40."
> "You may need to update all your local databases and caches."
> "To do so, please run the following commands:"
> "(for each user) $ update-mime-database ~/.local/share/mime/"
> "(as root)       # update-mime-database /usr/local/share/mime/"
> 
> Test above also for 0.60 to 0.70 migration, if it's required we can update the
> message for 0.70 ebuild.
> 
It worked for me except I had to do it (as root) for /usr/share/mime (I don't have a /usr/local/share/mime on my system, but I guess I'd have to do it for that one too if I did.)
Comment 4 Samuli Suominen (RETIRED) gentoo-dev 2009-10-09 16:54:30 UTC
(In reply to comment #3)
> It worked for me except I had to do it (as root) for /usr/share/mime (I don't
> have a /usr/local/share/mime on my system, but I guess I'd have to do it for
> that one too if I did.)

That doesn't make much sense since the end of emerge (postinst phase) for shared-mime-info is taking care of that already... so I'm still clueless what exactly worked for you :)
Comment 5 Samuli Suominen (RETIRED) gentoo-dev 2009-10-09 18:46:03 UTC
Updated message added.
Comment 6 Samuli Suominen (RETIRED) gentoo-dev 2009-10-09 18:46:28 UTC
Sorry...
Comment 7 Graham Murray 2009-10-10 11:54:13 UTC
*** Bug 288415 has been marked as a duplicate of this bug. ***
Comment 8 Samuli Suominen (RETIRED) gentoo-dev 2009-10-10 18:02:41 UTC
*** Bug 288461 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2009-10-11 11:14:27 UTC
*** Bug 288538 has been marked as a duplicate of this bug. ***
Comment 10 Man Shankar 2009-10-12 18:10:13 UTC
It seems to be a glib issue. The latest glib in tree is only 2.20.5, so can you reopen this.
Comment 11 Samuli Suominen (RETIRED) gentoo-dev 2009-10-12 18:14:56 UTC
(In reply to comment #10)
> It seems to be a glib issue. The latest glib in tree is only 2.20.5, so can you
> reopen this.
> 

Nope. New glib will enhance it's support, but it's fine with old glib too.
Comment 12 Man Shankar 2009-10-12 19:00:33 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > It seems to be a glib issue. The latest glib in tree is only 2.20.5, so can you
> > reopen this.
> > 
> 
> Nope. New glib will enhance it's support, but it's fine with old glib too.
> 

Sorry, if i missed something, but i followed the elog instructions and all files have icons of txt or executables. downgrading to 0.60 solved the issue. I don't have ~/.local/share/mime or /usr/local/share/mime. So like in Comment #3, i ran the command on /usr/share/mime. A google search pointed to 

https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/444962

where the last comments confirm the glib update as a fix.

Cheers!

Comment 13 Man Shankar 2009-10-13 07:14:00 UTC
(In reply to comment #11)
> (In reply to comment #10)
> > It seems to be a glib issue. The latest glib in tree is only 2.20.5, so can you
> > reopen this.
> > 
> 
> Nope. New glib will enhance it's support, but it's fine with old glib too.
> 

Yes, got around to installing glib-2.22.2 from the gnome-overlay. Didn't fix much. Then, i guessed the problem may be application specific. So installed thunar and icons where ok. Filed a bug against pcmanfm-0.5.1
https://bugs.gentoo.org/show_bug.cgi?id=288820

Sorry for the noise. Cheers.
Comment 14 Samuli Suominen (RETIRED) gentoo-dev 2009-10-13 12:25:38 UTC
*** Bug 288865 has been marked as a duplicate of this bug. ***
Comment 15 Samuli Suominen (RETIRED) gentoo-dev 2009-10-14 12:21:01 UTC
*** Bug 289034 has been marked as a duplicate of this bug. ***
Comment 16 Samuli Suominen (RETIRED) gentoo-dev 2009-10-15 10:20:55 UTC
*** Bug 289194 has been marked as a duplicate of this bug. ***
Comment 17 Samuli Suominen (RETIRED) gentoo-dev 2009-10-16 10:41:04 UTC
*** Bug 289289 has been marked as a duplicate of this bug. ***
Comment 18 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-16 13:21:03 UTC
*** Bug 289316 has been marked as a duplicate of this bug. ***
Comment 19 Harald van Dijk (RETIRED) gentoo-dev 2009-10-16 18:32:21 UTC
*** Bug 289346 has been marked as a duplicate of this bug. ***
Comment 20 Samuli Suominen (RETIRED) gentoo-dev 2009-10-17 12:05:19 UTC
*** Bug 289271 has been marked as a duplicate of this bug. ***
Comment 21 Gilles Dartiguelongue gentoo-dev 2009-10-18 10:37:00 UTC
*** Bug 289559 has been marked as a duplicate of this bug. ***
Comment 22 Vincent Le Ligeour 2009-10-18 10:57:31 UTC
Message still points to a wrong directory /usr/local/share/mime/ instead of /usr/share/mime/

For me message should be an ewarn since it break things and not just an elog.

According to the number of bugs marked as duplicated this one is maybe closed as the solution is known, but it is clearly not clear enough for gentoo users.
Comment 23 Rémi Cardona gentoo-dev 2009-10-18 11:50:44 UTC
(In reply to comment #22)
> Message still points to a wrong directory /usr/local/share/mime/ instead of
> /usr/share/mime/

No, no, no and no! Read the message. /usr/share/mime is done by the ebuild directly. The other 2 are left for _you_ to do because portage *is not allowed* to get anywhere near them.

> According to the number of bugs marked as duplicated this one is maybe closed
> as the solution is known, but it is clearly not clear enough for gentoo users.

If you find a better solution, let us know...
Comment 24 Vincent Le Ligeour 2009-10-18 14:33:03 UTC
(In reply to comment #23)
> (In reply to comment #22)
> > Message still points to a wrong directory /usr/local/share/mime/ instead of
> > /usr/share/mime/
> 
> No, no, no and no! Read the message. /usr/share/mime is done by the ebuild
> directly. The other 2 are left for _you_ to do because portage *is not allowed* to get anywhere near them.

ok, understood

> 
> > According to the number of bugs marked as duplicated this one is maybe closed
> > as the solution is known, but it is clearly not clear enough for gentoo users.
> 
> If you find a better solution, let us know...
> 

At least make the elog about this thing to be ewarn, this way it is summarized at the end of the emerge. Right now it is lost in the tons of log of an emerge world. Does it sound like a good idea ? (one duplicate nug each day is a lot)
Comment 25 Joël 2009-10-18 20:40:07 UTC
Yes, *please* add a serious warning to the ebuild, because the incompatible change of DB format results in major system breakage ! It's the first time that I waste 2 days on a bug that is _old news_ and by which nobody should get bitten anymore today.

PS: No hate at all for Gentoo - I know upstream was at fault here. But Gentoo should warn users !
Comment 26 Samuli Suominen (RETIRED) gentoo-dev 2009-10-22 18:47:24 UTC
*** Bug 267254 has been marked as a duplicate of this bug. ***
Comment 27 Paul de Vrieze (RETIRED) gentoo-dev 2009-10-29 09:52:56 UTC
I think we should seriously consider creating a patch to glib that, for ~/.local/share/mime updates the database automatically, if the database version is wrong.