Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 283761 - sys-devel/gcc[multilib] creates bad .la files for secondary arch
Summary: sys-devel/gcc[multilib] creates bad .la files for secondary arch
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
: 285884 289406 289492 289567 289571 289643 289646 289648 289653 289683 289782 289854 289894 289920 290149 290175 290176 290179 290182 290361 290887 291076 291144 291626 291868 305383 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-09-05 16:07 UTC by ferret
Modified: 2010-03-01 15:26 UTC (History)
21 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
fixup libtool files for secondary arch (toolchain-fix-multilib-libtool.patch,819 bytes, patch)
2009-09-06 12:36 UTC, Peter Alfredsen (RETIRED)
Details | Diff
POTENTIAL patch on toolchain.eclass, untested (tc.e.patch,1.00 KB, patch)
2009-09-06 18:35 UTC, ferret
Details | Diff
fixup libtool files for secondary arch v2 (toolchain-fix-multilib-libtool-v2.patch,1.16 KB, patch)
2009-09-06 20:04 UTC, Peter Alfredsen (RETIRED)
Details | Diff
/usr/lib/libMagickCore.la (libMagickCore.la,1.29 KB, text/plain)
2009-10-18 12:43 UTC, Thomas Bettler
Details
Transcode build.log (build.log,115.86 KB, text/plain)
2009-10-23 08:01 UTC, Silvio
Details
autotrace build.log (build.log,36.33 KB, text/plain)
2009-10-23 08:01 UTC, Silvio
Details
pstoedit build.log (build.log,65.73 KB, text/plain)
2009-10-23 08:02 UTC, Silvio
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ferret 2009-09-05 16:07:07 UTC
$ tail -n1 /usr/lib/gcc/x86_64-pc-linux-gnu/4.*/32/*.la
==> /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgomp.la <==
libdir='/usr/lib/../lib32'

==> /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflap.la <==
libdir='/usr/lib/../lib32'

==> /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflapth.la <==
libdir='/usr/lib/../lib32'

==> /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libsupc++.la <==
libdir='/usr/lib/../lib32'


The .so files are actually in /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/, not /usr/lib32, so when a libtool-aware 32-bit program tries to use it (say image-magick) it will create more invalid .la files and/or fail to compile.

The 64-bit .la files are correct:

$ tail -n1 /usr/lib/gcc/x86_64-pc-linux-gnu/4.*/libgomp.la
libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1'
Comment 1 ferret 2009-09-05 16:28:45 UTC
Portage 2.1.6.13 (default/linux/amd64/2008.0/desktop, gcc-4.4.1, glibc-2.10.1-r0, 2.6.30.5 x86_64)
=================================================================
System uname: Linux-2.6.30.5-x86_64-AMD_Turion-tm-_64_Mobile_ML-34-with-gentoo-2.0.1
Timestamp of tree: Mon, 31 Aug 2009 14:15:02 +0000
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.9
dev-lang/python:     2.6.2-r1, 3.1.1
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.4.3-r3
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="buildsyspkg collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://gentoo.mirror.sdv.fr http://ftp.heanet.ie/pub/gentoo/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/junk /usr/local/portage/multilib"
SYNC="cvs://anonymous@anoncvs.gentoo.org/var/cvsroot"
USE="3dnow 3dnowext X a52 aac aalib acpi alsa amd64 avi bash-completion berkdb bittorrent bluetooth branding bzip2 cairo cdparanoia cdr cleartype cli cracklib crypt curl divx dri dvd dvdnav dvdr eds emboss encode evo fam fbcon ffmpeg firefox flac flash ftp gdbm gif gmp gnutls gpm gtk gtk2 iconv id3 imap imlib java javascript jikes jpeg kpathsea lame lib32 libcaca libnl libnotify libwww lua lzo mad mikmod mmx mmxext mng motif mp3 mp4 mpeg mudflap multilib music ncurses nptl nptlonly nss ogg oggvorbis opengl openmp pcre pdf pdflib perl png ppds python quicktime readline reflection rtc samba sdl session spell spl sqlite sse sse2 ssl svg sysfs tcpd theora thunar tiff truetype unicode usb videos vim-syntax vorbis wmf x264 xft xml xml2 xorg xosd xulrunner xv xvid zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="ncurses text" LINGUAS="en_GB en" USERLAND="GNU" VIDEO_CARDS="radeon vesa"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2009-09-06 12:36:51 UTC
Created attachment 203264 [details, diff]
fixup libtool files for secondary arch

Patch toolchain eclass so it fixes the .la files for the secondary arch in the multilib scenario.

Results:
pa@loki ~/loki_overlay/eclass $ grep --include='*.la' -r "^libdir='" /var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libffi.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortran.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgomp.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflapth.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc_gc.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libsupc++.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflap.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortranbegin.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'

pa@loki ~/loki_overlay/eclass $ grep --include='*.la' -r "^libdir='" /usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libffi.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortran.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgomp.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflapth.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc_gc.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libsupc++.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflap.la:libdir='/usr/lib/../lib32'
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortranbegin.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
Comment 3 SpanKY gentoo-dev 2009-09-06 16:25:06 UTC
the patch starts down the right path, but ultimately is not correct.  you cant assume anything about the multilib names (i.e. "32" or "64" or ...).  you have to query gcc for them.

i.e. $(XGCC) -print-multi-lib
Comment 4 ferret 2009-09-06 18:35:25 UTC
Created attachment 203302 [details, diff]
POTENTIAL patch on toolchain.eclass, untested

Well, I looked at the eclass and noted that it said at the top of the function:

# make sure the libtool archives have libdir set to where they actually
# -are-, and not where they -used- to be.  also, any dependencies we have
# on our own .la files need to be updated.

It doesn't seem like it actually needs to know what multilib profiles are available for this, provided it finds the subdirectory .la files and changes them to point to the directory they're in.

So I wrote a patch to make it do that; above.  It's an idea for an approach rather than a definite solution; I'm not going to use it on my system until you guys have looked at it.  In particular, the
   $(find ./${PREFIX}/lib* ...
bit makes me nervous.
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-09-06 20:04:15 UTC
Created attachment 203315 [details, diff]
fixup libtool files for secondary arch v2

Ok, second try, using the "for loop" in gcc_movelibs to ensure the right voodoo is observed.

Output:
pa@loki ~/loki_overlay/eclass $ grep --include='*.la' -r libdir=  /var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libffi.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortran.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgomp.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflapth.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libobjc_gc.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libsupc++.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libmudflap.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
/var/tmp/portage/sys-devel/gcc-4.4.1/image/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32/libgfortranbegin.la:libdir='/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.1/32'
Comment 6 SpanKY gentoo-dev 2009-09-07 03:33:35 UTC
ah tricky.  just glancing quickly, but that looks like it should probably work.  i'll test it on my x86_64 in a bit and presumably commit after that.
Comment 7 SpanKY gentoo-dev 2009-09-08 02:50:03 UTC
works for me, thanks

http://sources.gentoo.org/eclass/toolchain.eclass?r1=1.406&r2=1.407
Comment 8 SpanKY gentoo-dev 2009-09-30 03:30:40 UTC
*** Bug 285884 has been marked as a duplicate of this bug. ***
Comment 9 Ryan Hill (RETIRED) gentoo-dev 2009-10-17 20:19:55 UTC
*** Bug 289492 has been marked as a duplicate of this bug. ***
Comment 10 Ryan Hill (RETIRED) gentoo-dev 2009-10-18 02:33:57 UTC
the first install of a new version is still broken, seen when upgrading to 4.4.2.  rebuilding fixes it.
Comment 11 Ryan Hill (RETIRED) gentoo-dev 2009-10-18 04:12:06 UTC
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.4.2/work/build'                                                                
/var/tmp/portage/sys-devel/gcc-4.4.2/temp/environment: line 2378: pushd: /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.2/.: No such file or directory                                                                                                                                       
sed: can't read .//var/tmp/portage/sys-devel/gcc-4.4.2/image/*.la: No such file or directory                                                
find: `.//usr/lib*': No such file or directory                                                                                              
sed: can't read .//var/tmp/portage/sys-devel/gcc-4.4.2/image/*.la: No such file or directory                                                
/var/tmp/portage/sys-devel/gcc-4.4.2/temp/environment: line 2385: popd: directory stack empty                                               
/var/tmp/portage/sys-devel/gcc-4.4.2/temp/environment: line 2378: pushd: /usr/lib/gcc/x86_64-unknown-linux-gnu/4.4.2/32: No such file or directory                                                                                                                                      
sed: can't read .//var/tmp/portage/sys-devel/gcc-4.4.2/image/*.la: No such file or directory                                                
find: `.//usr/lib*': No such file or directory                                                                                              
sed: can't read .//var/tmp/portage/sys-devel/gcc-4.4.2/image/*.la: No such file or directory                                                
/var/tmp/portage/sys-devel/gcc-4.4.2/temp/environment: line 2385: popd: directory stack empty                                               
find: `/var/tmp/portage/sys-devel/gcc-4.4.2/image//usr/lib/pkgconfig/': No such file or directory
Comment 12 Ryan Hill (RETIRED) gentoo-dev 2009-10-18 04:59:06 UTC
@@ -1966,6 +1966,7 @@
 				fi
 			fi
 		done
+		fix_libtool_libdir_paths "${LIBPATH}/${MULTIDIR}"
 	done
 


i think this needs to be prefixed with ${D}, testing with that change.
Comment 13 SpanKY gentoo-dev 2009-10-18 05:22:59 UTC
i dont think we want that.  how about:
@@ -2484,7 +2484,7 @@ disable_multilib_libjava() {
 fix_libtool_libdir_paths() {
        pushd "${D}" >/dev/null

-       pushd "${1}" >/dev/null
+       pushd "./${1}" >/dev/null
        local dir="${PWD#${D}}"
        local allarchives=$(echo *.la)
        allarchives="\(${allarchives// /\\|}\)"
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2009-10-18 06:42:12 UTC
yeah i missed that we popd before the sed.
Comment 15 SpanKY gentoo-dev 2009-10-18 07:25:02 UTC
done then, thanks

http://sources.gentoo.org/eclass/toolchain.eclass?r1=1.408&r2=1.409
Comment 16 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-18 11:12:43 UTC
*** Bug 289567 has been marked as a duplicate of this bug. ***
Comment 17 Thomas Bettler 2009-10-18 12:43:03 UTC
Created attachment 207480 [details]
/usr/lib/libMagickCore.la

Have synced && remerged gcc && built imagemagick two hours ago.

Now linking against libMagickCore fails (building transcode).

***PROMPT:***
/var/tmp/portage/media-video/transcode-1.0.7/work/transcode-1.0.7/import #
***INPUT:***
../libtool --mode=link i686-pc-linux-gnu-gcc  -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -march=pentium4 -pipe -DDCT_YUV_PRECISION=1  -Wl,-O1 -o import_im.la -rpath /usr/lib/transcode -module -avoid-version  import_im.lo -lMagickWand -lz -lm -lMagickCore -lm  -lm -lz -ldl
***OUTPUT:***
../libtool: line 6427: cd: usr/lib/gcc/i686-pc-linux-gnu/4.3.4: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `usr/lib/gcc/i686-pc-linux-gnu/4.3.4'
/bin/grep: usr/lib/gcc/i686-pc-linux-gnu/4.3.4/libgomp.la: No such file or directory
/bin/sed: can't read usr/lib/gcc/i686-pc-linux-gnu/4.3.4/libgomp.la: No such file or directory
libtool: link: `usr/lib/gcc/i686-pc-linux-gnu/4.3.4/libgomp.la' is not a valid libtool archive


Seems to be related ..?
Comment 18 Thomas Bettler 2009-10-18 12:46:21 UTC
the .la files are missing a leading slash before:
dependency_libs=[snip] [missing slash]usr/lib/gcc/i686-pc-linux-gnu/4.3.4 [snip]
Comment 19 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-18 13:52:33 UTC
*** Bug 289571 has been marked as a duplicate of this bug. ***
Comment 20 Sebastian Luther (few) 2009-10-18 21:22:13 UTC
*** Bug 289643 has been marked as a duplicate of this bug. ***
Comment 21 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-18 21:33:09 UTC
*** Bug 289646 has been marked as a duplicate of this bug. ***
Comment 22 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-18 21:38:21 UTC
*** Bug 289648 has been marked as a duplicate of this bug. ***
Comment 23 Sebastian Luther (few) 2009-10-18 22:10:24 UTC
*** Bug 289653 has been marked as a duplicate of this bug. ***
Comment 24 Ryan Hill (RETIRED) gentoo-dev 2009-10-19 02:36:42 UTC
(In reply to comment #18)
> the .la files are missing a leading slash before:
> dependency_libs=[snip] [missing slash]usr/lib/gcc/i686-pc-linux-gnu/4.3.4
> [snip]
> 

Should be fixed now.  Sync up again.


diff -u -r1.409 toolchain.eclass
--- toolchain.eclass    18 Oct 2009 07:24:58 -0000      1.409
+++ toolchain.eclass    19 Oct 2009 01:48:54 -0000
@@ -2485,7 +2485,7 @@
        pushd "${D}" >/dev/null

        pushd "./${1}" >/dev/null
-       local dir="${PWD#${D}}"
+       local dir="${PWD#${D%/}}"
        local allarchives=$(echo *.la)
        allarchives="\(${allarchives// /\\|}\)"
        popd >/dev/null
Comment 25 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-19 09:45:37 UTC
*** Bug 289683 has been marked as a duplicate of this bug. ***
Comment 26 Ondřej Súkup 2009-10-19 18:38:47 UTC
i upgrade gcc from 4.4.1 to 4.4.2 on ~amd64
use # fix_libtool_files.sh 4.4.1

and emerge transcode failed with :
./libtool: line 6427: cd: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2'
/bin/grep: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
/bin/sed: can't read usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
libtool: link: `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la' is not a valid libtool archive
make[2]: *** [export_im.la] Error 1

Comment 27 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-19 19:08:01 UTC
*** Bug 289782 has been marked as a duplicate of this bug. ***
Comment 28 Ryan Hill (RETIRED) gentoo-dev 2009-10-19 23:54:37 UTC
(In reply to comment #26)
> i upgrade gcc from 4.4.1 to 4.4.2 on ~amd64
> use # fix_libtool_files.sh 4.4.1
> 
> and emerge transcode failed with :
> ./libtool: line 6427: cd: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2: No such file
> or directory
> libtool: link: warning: cannot determine absolute directory name of
> `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2'
> /bin/grep: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or
> directory
> /bin/sed: can't read usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such
> file or directory
> libtool: link: `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la' is not a
> valid libtool archive
> make[2]: *** [export_im.la] Error 1

Rebuilding gcc again should do the trick.

Comment 29 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-20 11:08:37 UTC
*** Bug 289854 has been marked as a duplicate of this bug. ***
Comment 30 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-20 18:13:50 UTC
*** Bug 289894 has been marked as a duplicate of this bug. ***
Comment 31 DrSlony 2009-10-20 20:29:03 UTC
I get this error while emerging transcode-1.1.4 (and probably other packages) http://paste2.org/p/477072 
I'm using gcc-4.3.4.
What should I do?
Comment 32 Sebastian Luther (few) 2009-10-20 20:40:42 UTC
*** Bug 289406 has been marked as a duplicate of this bug. ***
Comment 33 G Reitsma 2009-10-20 20:51:36 UTC
(In reply to comment #28)
> 
> Rebuilding gcc again should do the trick.
> 
I've got the same issue still. I just ran the sync, I've rebuild gcc 4.4.2 as well as libtool. But still  get this error while compiling transcode:

libtool: link: ( cd ".libs" && rm -f "import_xml.la" && ln -s "../import_xml.la" "import_xml.la" )
libtool: link: ( cd ".libs" && rm -f "import_mpeg3.la" && ln -s "../import_mpeg3.la" "import_mpeg3.la" )
libtool: link: ( cd ".libs" && rm -f "import_mplayer.la" && ln -s "../import_mplayer.la" "import_mplayer.la" )
../libtool: line 6427: cd: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2'
/bin/grep: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
/bin/sed: can't read usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
libtool: link: `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la' is not a valid libtool archive
make[3]: *** [import_imlist.la] Error 1
libtool: link: ( cd ".libs" && rm -f "import_mov.la" && ln -s "../import_mov.la" "import_mov.la" )
libtool: link: ( cd ".libs" && rm -f "af6_decore.la" && ln -s "../af6_decore.la" "af6_decore.la" )
make[3]: Leaving directory `/var/tmp/portage/media-video/transcode-1.0.7/work/transcode-1.0.7/import'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/media-video/transcode-1.0.7/work/transcode-1.0.7/import'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-video/transcode-1.0.7/work/transcode-1.0.7'
make: *** [all] Error 2


Here's my current emerge --info
Portage 2.2_rc46 (default/linux/amd64/10.0/desktop, gcc-4.4.2, glibc-2.9_p20081201-r2, 2.6.30-gentoo-r5 x86_64)
=================================================================                                              
System uname: Linux-2.6.30-gentoo-r5-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9450_@_2.66GHz-with-gentoo-1.12.11.1  
Timestamp of tree: Tue, 20 Oct 2009 19:00:01 +0000                                                             
app-shells/bash:     4.0_p28                                                                                   
dev-java/java-config: 2.1.8-r1                                                                                 
dev-lang/python:     2.6.3, 3.1.1-r1                                                                           
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.4_p6, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -msse4.1 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=core2 -msse4.1 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests distfiles distlocks fixpackages news parallel-fetch preserve-libs sandbox sfperms strict unmerge-logs unmerge-orphans userfetch usersandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://gentoo.tiscali.nl/pub/mirror/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="nl en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/kde-testing /usr/local/portage/layman/emacs /usr/local/portage/layman/java-overlay /usr/local/portage/layman/science /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib accessibility acpi alsa amd64 apache2 apm auctex berkdb bidi bl blas bluetooth branding browserplugin bzip2 cairo caps cdda cddb cdparanoia cdr chardet cli consolekit contrast cracklib crypt cups daap dbus dga divx divx4linux dlna dri dts dvb dvd dvdnav dvdr dvdread edl eds emacs embedded emboss encode esd evdev evo examples exif fam fasttrack ffmpeg firefox flac fortran ftp gcj gd gdbm ggi gif gimp glib gmedia gnome gnutella gpm gs gstreamer gtk gtk+ hal hardware-carrier iconv ieee1394 ifp imagemagic imagemagick imap ipod ipv6 isdnlog jack java java6 javascript jpeg kde kde4 lame laptop latex ldap libcaca libffi libnotify lirc live lm_sensors lzo mad magic matr md5sum messenger mikmod mmx mmxext mng modplug modules mozcalendar mp2 mp3 mp3tunes mp4 mpeg mtp mudflap multilib muse musepack mysql mythtv nas ncurses nforce2 njb nls notify npp nptl nptlonly nsplugin ntpl nvidia objc ogg openexr opengl openmp oska pam pcre pdf perl php player pmu png pnm portaudio ppds pppd python qt qt-static qt3support qt4 quicktime radio rar raw readline realmedia reflection replytolist restrict-javascript rss rtc samba sdl session sid smp sms sndfile soup spell spl sql sqlite srt sse sse2 ssl ssse3 startup-notification svg sysfs taglib tcltk tcpd theora thumbnail thunar tiff timezone timidity tivo transcode transmitter treutype truetype twolame type1 unicode usb v41 v4l2 visualization vorbis wavpack webkit wma wmf wmp x264 xanim xcb xforms xinerama xml xorg xslt xspice xulrunner xv xvid xvmc yahoo zlib zoran" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita imagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam   jd11 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica  konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000  panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55  soundvision  spca50x sq905 stv0674 stv0680 sx330z template toshiba_pdrm11" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="lirc imon imonlcd" LINGUAS="nl en" LIRC_DEVICES="imon imon_knob imon_lcd imon_pad imon_rsc imon_24g" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 34 Herbert Wantesh 2009-10-20 21:56:38 UTC
same for me for transcode 

/bin/sh ../libtool --tag=CC   --mode=link x86_64-pc-linux-gnu-gcc  -Wall -Wstrict-prototypes -Wmissing-prototypes -march=athlon64 -O2 -pipe -module -avoid-version -Wl,-O1 -Wl,--as-needed -Wl,-z,now -Wl,--sort-common -o export_jpg.la -rpath /usr/lib64/transcode export_jpg_la-export_jpg.lo -L/usr/lib -ljpeg  -lm -lm -lz -ldl
../libtool: line 6427: cd: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2'
/bin/grep: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
/bin/sed: can't read usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
libtool: link: `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la' is not a valid libtool archive
make[2]: *** [export_im.la] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/export_jpg_la-export_jpg.o   -Wl,--as-needed -L/usr/lib /usr/lib64/libjpeg.so -lm -lz -ldl  -march=athlon64 -Wl,-O1 -Wl,-z -Wl,now -Wl,--sort-common   -Wl,-soname -Wl,export_jpg.so -o .libs/export_jpg.so
libtool: link: ( cd ".libs" && rm -f "export_ffmpeg.la" && ln -s "../export_ffmpeg.la" "export_ffmpeg.la" )
libtool: link: ( cd ".libs" && rm -f "export_jpg.la" && ln -s "../export_jpg.la" "export_jpg.la" )
make[2]: Leaving directory `/tmp/tmerge/portage/media-video/transcode-1.1.4/work/transcode-1.1.4/export'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/tmerge/portage/media-video/transcode-1.1.4/work/transcode-1.1.4'
make: *** [all] Error 2
 * ERROR: media-video/transcode-1.1.4 failed:
 *   emake failed
 *
 * Call stack:
 *     ebuild.sh, line   49:  Called src_compile
 *   environment, line 3148:  Called _eapi2_src_compile
 *     ebuild.sh, line  647:  Called die
 * The specific snippet of code:
 *              emake || die "emake failed"
 *
 * If you need support, post the output of 'emerge --info =media-video/transcode-1.1.4',
 * the complete build log and the output of 'emerge -pqv =media-video/transcode-1.1.4'.
 * The complete build log is located at '/tmp/portage/media-video:transcode-1.1.4:20091020-215251.log'.
 * The ebuild environment file is located at '/tmp/tmerge/portage/media-video/transcode-1.1.4/temp/environment'.
 * S: '/tmp/tmerge/portage/media-video/transcode-1.1.4/work/transcode-1.1.4'

>>> Failed to emerge media-video/transcode-1.1.4, Log file:

>>>  '/tmp/portage/media-video:transcode-1.1.4:20091020-215251.log'

emerge --info
Portage 2.2_rc46 (default/linux/amd64/10.0, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31.4 x86_64)
=================================================================                       
System uname: Linux-2.6.31.4-x86_64-AMD_Athlon-tm-64_X2_Dual_Core_Processor_4400+-with-gentoo-2.0.1
Timestamp of tree: Tue, 20 Oct 2009 21:30:01 +0000                                                 
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p28
dev-java/java-config: 2.1.8-r1
dev-lang/python:     2.6.2-r1, 3.1.1-r1
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.3/env /usr/kde/4.3/share/config /usr/kde/4.3/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en"
LDFLAGS="-Wl,-O1 -Wl,--as-needed -Wl,-z,now -Wl,--sort-common"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp/portage"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage/portage.overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 64bit X a52 aac accessibility acpi additions aften akonadi alsa amd64 amrnb amrwb apm archive aspell ass audio avi bash-completion browserplugin bzip2 cairo caps cdparanoia clucene commercial cracklib crypt css cups curl custom-cflags custom-optimization cvs cxx daemon dbus devil dga divx divx4linux djvu dri dts dvd dvdnav dvdr dvdread ebook encode enda exif faac faad fam ffmpeg firefox flac fortran ftp gcrypt gd gecko geoip gif gimp gimpprint glib glitz gpm gs gtk gtk2 hal iconv icu id3 id3tag imagemagick imlib irda jabber java jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kdeprefix kdrive kqemu lame lcms libsamplerate libvisual lm_sensors lzma lzo mad matroska midi mmx mmxext mng moznomail mp2 mp3 mpeg mplayer mudflap multilib musepack nas ncurses nemesi network nfs nls normalize nptl nptlonly nsplugin nvidia nxclient ogg openexr opengl openmp otr pam pcap pch pcre pdf perl plasma player png ppds privacy ps qt3support qt4 quicktime raptor rar readline realmedia redland replaygain rtc sasl schroedinger semantic-desktop server sesame2 slit smi smp socks5 speex spell sqlite srt sse sse2 ssl startup-notification stats subversion svg tcpd texteffect theora threads threadsafe thumbnail tiff tk toolbar tordns transcode trayicon tremor truetype twolame unicode usb userlocales utempter v4l v4l2 vcd vcdimager video vorbis wavpack webdav-neon webkit wma wmf wmp x264 xanim xcb xcomposite xft xine xinerama xml xmms xorg xprint xulrunner xv xvid xvmc zip zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" SANE_BACKENDS="hp5400" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 35 Dan Goodliffe 2009-10-20 21:57:39 UTC
I found the incorrect path had worked its way into other .la files. Notably those of ImageMagick. Try emerging imageimagick again.
Comment 36 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-20 22:10:41 UTC
*** Bug 289920 has been marked as a duplicate of this bug. ***
Comment 37 Herbert Wantesh 2009-10-20 22:29:15 UTC
remerginf imagemagick and then remerging transcode fixed the compile error .. thanks
Comment 38 G Reitsma 2009-10-20 22:38:31 UTC
(In reply to comment #35)
> Try emerging imageimagick again.
> 
Thanks! That did it!
Comment 39 DidgeriDude 2009-10-21 07:33:06 UTC
(In reply to comment #35)
> I found the incorrect path had worked its way into other .la files. Notably
> those of ImageMagick. Try emerging imageimagick again.
> 

Hi, thanks. This helped.

But how can we know which other .la files are concerned ? Is it the best way to recompile everything that had been updated since GCC upgrade ?

Thanks again.
Comment 40 SpanKY gentoo-dev 2009-10-21 08:37:14 UTC
look at the packages emerged since gcc was emerged, or just grep /usr/lib*/*.la for the broken path
Comment 41 DidgeriDude 2009-10-21 10:26:27 UTC
(In reply to comment #40)
> look at the packages emerged since gcc was emerged, or just grep /usr/lib*/*.la
> for the broken path
> 

Thanks a lot !
Comment 42 Samuli Suominen gentoo-dev 2009-10-22 17:56:47 UTC
*** Bug 290149 has been marked as a duplicate of this bug. ***
Comment 43 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-23 06:02:15 UTC
*** Bug 290175 has been marked as a duplicate of this bug. ***
Comment 44 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-23 06:02:26 UTC
*** Bug 290176 has been marked as a duplicate of this bug. ***
Comment 45 Timo Gurr (RETIRED) gentoo-dev 2009-10-23 07:45:35 UTC
*** Bug 290182 has been marked as a duplicate of this bug. ***
Comment 46 Silvio 2009-10-23 07:58:26 UTC
I 
remade fix_libtool_files.sh 4.4.1
for sude.

I reemerged imagemagick 

but:
- transcode
- autotrace
- pstoedit
doesn't compile yet.

Soon attachment of build.log of all three failure
Comment 47 Silvio 2009-10-23 08:01:04 UTC
Created attachment 207970 [details]
Transcode build.log
Comment 48 Silvio 2009-10-23 08:01:40 UTC
Created attachment 207971 [details]
autotrace build.log
Comment 49 Silvio 2009-10-23 08:02:46 UTC
Created attachment 207973 [details]
pstoedit build.log
Comment 50 Silvio 2009-10-23 08:03:16 UTC
emerge --info

Portage 2.2_rc46 (default/linux/x86/10.0, gcc-4.4.2, glibc-2.10.1-r0, 2.6.31-gentoo-r3 i686)
=================================================================                           
System uname: Linux-2.6.31-gentoo-r3-i686-Intel-R-_Core-TM-2_Duo_CPU_T7700_@_2.40GHz-with-gentoo-2.0.1
Timestamp of tree: Thu, 22 Oct 2009 19:00:01 +0000                                                    
ccache version 2.4 [enabled]                                                                          
app-shells/bash:     4.0_p33                                                                          
dev-java/java-config: 2.1.9-r1                                                                        
dev-lang/python:     2.4.6, 2.5.4-r3, 2.6.3, 3.1.1-r1                                                 
dev-util/ccache:     2.4-r8                                                                           
dev-util/cmake:      2.6.4-r3
sys-apps/baselayout: 2.0.1
sys-apps/openrc:     0.5.2-r1
sys-apps/sandbox:    2.1
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils:  2.20
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/fax /usr/share/X11/xkb /usr/share/config /var/lib/hsqldb /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests buildpkg ccache distlocks fixpackages news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://mirror.ovh.net/gentoo-distfiles/ http://ftp.heanet.ie/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ rsync://rsync3.it.gentoo.org/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gentoo/"
LANG="it_IT"
LC_ALL="it_IT"
LDFLAGS="-Wl,-O1"
LINGUAS="it en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/voyageur /usr/portage/local/layman/armagetron /usr/portage/local/layman/genstef /usr/portage/local/layman/sunrise /usr/portage/local/layman/trauma /usr/portage/local/layman/zugaina"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3ds X a52 aac acl acpi aiglx akode alias alsa amr ao apache apm audiofile autoreplace avi bash-completion berkdb bitmap-fonts bluetooth bmp browserplugin bzip bzip2 cairo cdaudio cdr cli connectionstatus contactnotes cracklib crypt cups dialup djvu dri dv dvd dvdr dvdread ebook ethereal exif fam fat ffmpeg firefox flac fluidsynth foomaticdb fortran freetds gdbm gif glib glitz gphoto2 gpm gps groupwise gtk gtk2 hal highlight history hvm i8x0 iconv ieee1394 imagemagick innodb ipod ipv6 irc isdnlog ithreads jack java javascript jingle jpeg jpeg2k kde kerberos kqemu lame laptop ldap lm_sensors lucene m4a midi mime mmx mmxext modules mozilla mp3 mp4 mpeg mpeg2 mplayer mssql mudflap mysql ncurses netmeeting nls nowlistening npt1 nptl nptlonly nsplugin ntfs nvidia odbc ogg openexr opengl openipmi openmp oss pam pcmcia pcre pda pdf perl pmu png portaudio postgres ppds pppd prelude python qt qt3support qt4 quicktime rar raw rdesktop readline reflection reiserfs samba sametime sdl semantic-desktop session smp sms speex spell spl sse sse2 ssl subtitles svg sysfs tcpd texteffect texteffects theora tidy tiff timidity translator truetype truetype-fonts twolame type1-fonts unicode usb utempter v4l v4l2 vcd vorbis webkit webpresence wifi win32codecs winpopup wlm wmf wxwindows x86 xcb xine xml xorg xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="snd_hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev joystick synaptics wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 51 Peter Alfredsen (RETIRED) gentoo-dev 2009-10-23 08:45:35 UTC
*** Bug 290179 has been marked as a duplicate of this bug. ***
Comment 52 Ryan Hill (RETIRED) gentoo-dev 2009-10-23 23:05:49 UTC
(In reply to comment #46)

You rebuilt gcc first, right?

Comment 53 Silvio 2009-10-24 06:36:40 UTC
(In reply to comment #52)
> (In reply to comment #46)
> 
> You rebuilt gcc first, right?
> 

I rebuild gcc this night, and everything now is ok. Sorry, reading this thred I did not understand I had to make both steps: recompile gcc and imagemagick.

So, for future reader: I solved the problem:

fix_libtool_files.sh 4.4.1
emerge =gcc-4.4.2
emerge imagemagick

I'm not sure everything in necessary but it works.

Thanks to all of you.




Comment 54 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-24 12:06:31 UTC
*** Bug 290361 has been marked as a duplicate of this bug. ***
Comment 55 Leonid.Raitchenok 2009-10-25 20:40:06 UTC
After emerging new gcc, it is necessary to switch:

gcc-config i686-pc-linux-gnu-4.4.2
source /etc/profile
Comment 56 Vasilis Lourdas 2009-10-27 20:49:17 UTC
Same here.
Comment 57 Vasilis Lourdas 2009-10-27 20:53:24 UTC
(In reply to comment #56)
> Same here.

Exact error message:

libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/xineplug_decode_theora_la-xine_theora_decoder.o   -Wl,-rpath -Wl,/var/tmp/portage/media-libs/xine-lib-1.1.16.3-r1/work/xine-lib-1.1.16.3/src/xine-engine/.libs -Wl,--as-needed ../../src/xine-engine/.libs/libxine.so -L/usr/lib64 -ldl -lm /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so -lz /usr/lib64/libexpat.so -lrt -lresolv -lnsl /usr/lib64/libtheora.so -logg  -march=core2 -Wl,--no-undefined -Wl,-O1 -Wl,--hash-style=gnu   -pthread -Wl,-soname -Wl,xineplug_decode_theora.so -o .libs/xineplug_decode_theora.so
../../libtool: line 6419: cd: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2: No such file or directory
libtool: link: warning: cannot determine absolute directory name of `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2'
/bin/grep: usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
/bin/sed: can't read usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la: No such file or directory
libtool: link: `usr/lib/gcc/x86_64-pc-linux-gnu/4.4.2/libgomp.la' is not a valid libtool archive
make[2]: *** [xineplug_decode_image.la] Error 1
make[2]: *** Waiting for unfinished jobs....
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/rgb.o   -Wl,-rpath -Wl,/var/tmp/portage/media-libs/xine-lib-1.1.16.3-r1/work/xine-lib-1.1.16.3/src/xine-engine/.libs -Wl,--as-needed ../../src/xine-engine/.libs/libxine.so -L/usr/lib64 -ldl -lm /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so -lz /usr/lib64/libexpat.so -lrt -lresolv -lnsl  -march=core2 -Wl,--no-undefined -Wl,-O1 -Wl,--hash-style=gnu   -pthread -Wl,-soname -Wl,xineplug_decode_rgb.so -o .libs/xineplug_decode_rgb.so
libtool: link: x86_64-pc-linux-gnu-gcc -shared  .libs/xineplug_decode_gdk_pixbuf_la-gdkpixbuf.o   -Wl,-rpath -Wl,/var/tmp/portage/media-libs/xine-lib-1.1.16.3-r1/work/xine-lib-1.1.16.3/src/xine-engine/.libs -Wl,--as-needed ../../src/xine-engine/.libs/libxine.so -L/usr/lib64 /usr/lib64/libfontconfig.so /usr/lib64/libfreetype.so -lz /usr/lib64/libexpat.so -lrt -lresolv -lnsl /usr/lib64/libgdk_pixbuf-2.0.so /usr/lib64/libgio-2.0.so -lm /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so  -march=core2 -Wl,--no-undefined -Wl,-O1 -Wl,--hash-style=gnu   -pthread -Wl,-soname -Wl,xineplug_decode_gdk_pixbuf.so -o .libs/xineplug_decode_gdk_pixbuf.so
libtool: link: ( cd ".libs" && rm -f "xineplug_decode_theora.la" && ln -s "../xineplug_decode_theora.la" "xineplug_decode_theora.la" )
libtool: link: ( cd ".libs" && rm -f "xineplug_decode_rgb.la" && ln -s "../xineplug_decode_rgb.la" "xineplug_decode_rgb.la" )
libtool: link: ( cd ".libs" && rm -f "xineplug_decode_gdk_pixbuf.la" && ln -s "../xineplug_decode_gdk_pixbuf.la" "xineplug_decode_gdk_pixbuf.la" )
bitplane.c:1578: warning: initialization discards qualifiers from pointer target type
make[2]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.16.3-r1/work/xine-lib-1.1.16.3/src/libxinevdec'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/media-libs/xine-lib-1.1.16.3-r1/work/xine-lib-1.1.16.3/src'
make: *** [all-recursive] Error 1
 * ERROR: media-libs/xine-lib-1.1.16.3-r1 failed:

I reemerged gcc 4.4.2, switched to it and sourced /etc/profile and the error with the xine-lib build is still there.
Comment 58 Dan Goodliffe 2009-10-27 21:10:27 UTC
grep -l "libdir='[^/]" /usr/lib/*.la

That will list the libraries that have bad paths in, you should re-emerge the owners of these libraries. 
Comment 59 Vasilis Lourdas 2009-10-28 08:21:14 UTC
(In reply to comment #58)
> grep -l "libdir='[^/]" /usr/lib/*.la
> 
> That will list the libraries that have bad paths in, you should re-emerge the
> owners of these libraries. 

Thanks, but grep returns nothing.
Comment 60 Lars Wendler (Polynomial-C) gentoo-dev 2009-10-28 15:20:10 UTC
*** Bug 290887 has been marked as a duplicate of this bug. ***
Comment 61 Miroslav Šulc gentoo-dev 2009-10-28 16:05:36 UTC
i have the same issue with xine-lib, and grep shows nothing too
Comment 62 Vasilis Lourdas 2009-10-28 16:17:54 UTC
(In reply to comment #61)
> i have the same issue with xine-lib, and grep shows nothing too

OK, after emerging libogg-1.1.4, elog shows that libogg-1.1.4 no longer creates .la files. Emerge dev-util/lafilefixer and run

# lafilefixer --justfixit

It might solve the problem with xine-lib.
Comment 63 Miroslav Šulc gentoo-dev 2009-10-28 20:40:32 UTC
thx, this fixed my problem
Comment 64 Sebastian Luther (few) 2009-10-30 07:52:38 UTC
*** Bug 291076 has been marked as a duplicate of this bug. ***
Comment 65 Sebastian Luther (few) 2009-10-30 12:07:34 UTC
*** Bug 291144 has been marked as a duplicate of this bug. ***
Comment 66 pierre 2009-10-30 15:32:57 UTC
(In reply to comment #65)
> *** Bug 291144 has been marked as a duplicate of this bug. ***
> 

Comment 67 Mark Knecht 2009-10-30 17:29:01 UTC
On one of my plain old, very vanilla x86 machines revdep-rebuild wanted to rebuild imagemagick so I let it but it didn't fix anything. For kicks I rebuilt gcc on that machine and then ran revdep-rebuild again and the problem was solved.

I don't think this is purely a multi-lib, x64 sort of problem...
Comment 68 Sebastian Luther (few) 2009-11-02 20:46:58 UTC
*** Bug 291626 has been marked as a duplicate of this bug. ***
Comment 69 a_tevelev 2009-11-03 00:07:16 UTC
I do not think the problem is limited to multilib. I have a pure 64-bit system and had an issue with libgomp.la asa described in bug 291626.
Comment 70 Ryan Hill (RETIRED) gentoo-dev 2009-11-03 05:02:04 UTC
yes we know.  the patch fixing this bug was broken which ended up causing issues for everyone.
Comment 71 Lars Wendler (Polynomial-C) gentoo-dev 2009-11-04 16:10:09 UTC
*** Bug 291868 has been marked as a duplicate of this bug. ***
Comment 72 Samuli Suominen gentoo-dev 2010-02-16 10:57:20 UTC
*** Bug 305383 has been marked as a duplicate of this bug. ***
Comment 73 Samuli Suominen gentoo-dev 2010-03-01 14:27:13 UTC
*** Bug 307313 has been marked as a duplicate of this bug. ***
Comment 74 Andreas Sturmlechner gentoo-dev 2010-03-01 15:26:09 UTC
Is this really fixed? I was only able to get it going by manually editing libgomp.la from 4.4.2 to 4.4.3

Rebuilding gcc or imagemagick didn't help.