Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 270983 - [kernel specs] set CONFIG_USB_HID to "y" to provide better keyboard support
Summary: [kernel specs] set CONFIG_USB_HID to "y" to provide better keyboard support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Release Media
Classification: Unclassified
Component: All ISO (show other bugs)
Hardware: All Linux
: High major with 1 vote (vote)
Assignee: Gentoo Release Team
URL:
Whiteboard:
Keywords: InVCS
: 271423 282097 296089 303781 318693 337080 365607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-23 20:03 UTC by Alan John Sorensen
Modified: 2011-08-19 20:57 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Modules List (modules_list.txt,193 bytes, text/plain)
2009-08-05 16:17 UTC, Jeremy Guitton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alan John Sorensen 2009-05-23 20:03:03 UTC
Both built-in keyboard and external keyboard connected via USB do not respond when booting from new install images. 2008.0 image does work.

Reproducible: Always

Steps to Reproduce:
1. Download and burn latest image from http://mirrors.kernel.org/gentoo/releases/amd64/current/
2. Boot using rEFIt
3. Keyboard(s) are unresponsive to key presses.

Actual Results:  
No response from built in keyboard. No response from external USB keyboard on second boot attempt.

Expected Results:  
Key presses should be responded to by system and should echo to current terminal as well.
Comment 1 Alan John Sorensen 2009-05-23 20:04:51 UTC
Using third generation laptop as described in the following link
http://en.gentoo-wiki.com/wiki/Apple_Macbook#Existing_Models

Comment 2 Andrew Gaffney (RETIRED) gentoo-dev 2009-05-25 18:04:34 UTC
I don't have the hardware to test this. Someone is going to have to track this down and let me know what the issue is.
Comment 3 Zsolti 2009-05-27 19:07:51 UTC
i have the same issue with macbook rev.2. tested version 20090521 and 20090507.
Comment 4 Andrew Gaffney (RETIRED) gentoo-dev 2009-08-05 15:53:04 UTC
*** Bug 271423 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Guitton 2009-08-05 16:17:11 UTC
Created attachment 200267 [details]
Modules List

This is list of modules that will be put in initramfs to solve the issue.
Comment 6 Jeremy Guitton 2009-08-05 16:31:07 UTC
I've forgotten to say that this modules must be add to the default genkernel.conf too !
Comment 7 Jeremy Guitton 2009-08-05 16:37:57 UTC
Oups, not genkernel.conf, but in the default kernel configuration of genkernel.
Comment 8 oosterwoud 2009-08-12 20:21:46 UTC
I also got this issue with a amd64 system.
I am able to choose the gentoo-nofb kernel ( so a that point my keyboard is working )

At the next point, where i have to choose a keyboard layout, the system just takes nothing from the keyboard.

I have a wireless keyboard : logitech ex 110
Comment 9 Andrew Gaffney (RETIRED) gentoo-dev 2009-08-21 15:29:56 UTC
*** Bug 282097 has been marked as a duplicate of this bug. ***
Comment 10 Yann Leprince 2009-10-17 07:34:15 UTC
(In reply to comment #5)
> Created an attachment (id=200267) [details]
> Modules List
> 
> This is list of modules that will be put in initramfs to solve the issue.
> 

I still have this problem with install-amd64-minimal-20091008.iso on a 3rd generation MacBook. Is there any plan that these modules be added soon?
Comment 11 Emmanuel Trillaud 2009-12-27 15:49:08 UTC
(In reply to comment #0)
I have the smae problem with a microsoft natural keyboard and the 
minimal install CD : install-amd64-minimal-20091203
Comment 12 Andrew Gaffney (RETIRED) gentoo-dev 2009-12-27 16:04:28 UTC
*** Bug 296089 has been marked as a duplicate of this bug. ***
Comment 13 Andrew Gaffney (RETIRED) gentoo-dev 2009-12-27 16:22:49 UTC
I've added modules to the MODULES_USB list in modules_load. I've also added these modules the default kernel-config in genkernel (which is unrelated to this issue here). For the installcd, the modules are already being built, but they're not being loaded by the initramfs.

As a temporary workaround, you can add 'doload=hid-apple' (or whichever one you need) to the kernel commandline.

Comment 14 Roger 2010-10-27 05:35:14 UTC
Bug #303781 seems to be a duplicate.

(Including maybe a couple of other keyboard bugs when searching open InstallCD related bugs.)
Comment 15 Roger 2010-10-27 06:26:08 UTC
After several more boots of the Gentoo Install CD, yup, looks like hid_microsoft is not being loaded as well for MS NEK4 USB keyboards.


Not only this, but I did try "gentoo doload=usbcore,usbhid,hid_microsoft,..." and found hid_microsoft was not still loading.  As a result of this is, we still get no keyboard action after the "boot:" prompt for those of us requiring hid_microsoft module.  It looks as if the hid_microsoft driver/module needs to be added to initramfs?

After booting though, I did notice lsmod listing all the other hid, ohci, uhci modules I specified.  (All except for hid_microsoft module/driver.)


(Makes me wonder how SystemRescueCD is working around detection as SystemRescueCD dated 2010-10-11 seems to work just fine here.)
Comment 16 Roger 2010-10-27 09:17:56 UTC
FYI: Just noticed cat /proc/config.gz |gzip -d |grep HID" shows HID_MICROSOFT on System Rescue CD 2010-10-11, as well as pretty much all other drivers listed are, compiled statically into the kernel.
Comment 17 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-10-27 10:45:54 UTC
*** Bug 303781 has been marked as a duplicate of this bug. ***
Comment 18 Roger 2010-10-27 11:09:19 UTC
I'm doing a little more research and now understand why hid_microsoft is likely not being included within initramfs, as well as some other keyboard drivers.

CONFIG_USB_HID has to be compiled statically or as module.  Once done, it then automatically includes the hid_microsoft driver as well as some other USB drivers silently.  ie. The kernel make menuconfig menu will not show the hid_microsoft driver, but will be included after the user selects the Device Drivers > HID Devices > "<*/M> USB Human Interface Device (full HID) support" option.

If I'm not mistaken, most USB keyboards just work with a generic USB driver not requiring any additional USB drivers.  But looking over a diff of the .config file before & after enabling CONFIG_USB_HID, I'm seeing a whole slew of keyboards (ie. hid_logitech, hid_belkin, hid_apple, ...).  A likely easier way to deal with this is probably just compile this puppy in statically -- similar to what systemrescuecd does now.

Booting the Gentoo Install CD using an emulator with the debug option got me to view the modules usb file, and it had entries for the basic USB drivers.

Hopefully this provides some useful insight and saves some footwork for the one making the fixes here. ;-)
Comment 19 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-11-15 23:59:53 UTC
*** Bug 337080 has been marked as a duplicate of this bug. ***
Comment 20 Sebastian Pipping gentoo-dev 2010-12-25 02:34:58 UTC
Andrew Gaffney has committed patch related to this bug earlier:

http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=commitdiff;h=1f46e1ac42336d9077e2e1938c586aa75e685b5b

As that commit is included with release 3.4.10.908 I am closing the bug.
If it turns out the patch didn't fix the bug, please re-open.
Comment 21 Roger 2010-12-25 04:49:02 UTC
Looking over the patch details, looks like that should do it.  I'm shocked there was an old patch floating around (dated Sun, 27 Dec 2009 16:20:30 +0000).

I didn't realize genkernel was used for minimal cd -- will this change be included within the next minimal install cd?
Comment 22 Ilya Volynets (RETIRED) gentoo-dev 2011-03-03 19:04:52 UTC
Minimal amd64 install CD as of 2011/02/25 still has this problem on MacBook Pro.
Comment 23 rasta 2011-03-12 23:13:03 UTC
(In reply to comment #22)
> Minimal amd64 install CD as of 2011/02/25 still has this problem on MacBook
> Pro.

I have the same issue. Can use the keyboard at the boot screen, but it's unusable at the keyboard select dialog.

I've tried with minimal amd64 install CD downloaded evening 2011/03/12 with MD5SUM:

00e93ce9d689795b73d5762b621c4b3a  install-amd64-minimal-20110303.iso

I have a MacBook 4,1 and have tried the doload=hid_apple,hid_.... (the whole list), but it didn't work. It seems the patch is not yet in the images. Can anyone confirm this, or is this a different issue?

Cheers
Comment 24 Thomas Eric 2011-04-06 01:10:53 UTC
Current build, 20110322 min-install cd still has issue with MacBook keyboard not working.
HOWEVER, I just tried to plug my usb Mac keyboard into my MacBook, it worked and the built-in keyboard worked thereafter. I had also loaded doscsi via command line.
Comment 25 Valentin 2011-05-01 19:35:55 UTC
Minimal amd64 install CD as of 2011/05/01 has the problem with Microsoft Natural Keyboard.
(In reply to comment #23)
> (In reply to comment #22)
> > Minimal amd64 install CD as of 2011/02/25 still has this problem on MacBook
> > Pro.
> 
> I have the same issue. Can use the keyboard at the boot screen, but it's
> unusable at the keyboard select dialog.
> 
> I've tried with minimal amd64 install CD downloaded evening 2011/03/12 with
> MD5SUM:
> 
> 00e93ce9d689795b73d5762b621c4b3a  install-amd64-minimal-20110303.iso
> 
> I have a MacBook 4,1 and have tried the doload=hid_apple,hid_.... (the whole
> list), but it didn't work. It seems the patch is not yet in the images. Can
> anyone confirm this, or is this a different issue?
> 
> Cheers
Comment 26 Roger 2011-05-05 05:22:53 UTC
Same here concerning minimal cd not loading usb modules for Microsoft USB keyboard.
Comment 27 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-13 21:10:58 UTC
*** Bug 318693 has been marked as a duplicate of this bug. ***
Comment 28 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-13 21:32:51 UTC
*** Bug 365607 has been marked as a duplicate of this bug. ***
Comment 29 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-05-25 04:09:39 UTC
I've fixed this on the amd64 and x86 kernel specs.
We need to fix the installcd building failures before we can get new a new iso using the updated specs.
Comment 30 Sebastian Pipping gentoo-dev 2011-06-13 19:30:30 UTC
(In reply to comment #29)
> I've fixed this on the amd64 and x86 kernel specs.

Where did you fix this?  (I don't see any new commits on genkernel's master branch.)
Comment 31 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-06-13 19:52:46 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > I've fixed this on the amd64 and x86 kernel specs.
> 
> Where did you fix this?  (I don't see any new commits on genkernel's master
> branch.)

I've been meaning to talk to you about this bug. I've fixed this on the kernel specs of the livecd[1]. Can you fix it for genkernel?

 [1] - http://sources.gentoo.org/cgi-bin/viewvc.cgi/releng/trunk/releases/weekly/kconfig/
Comment 32 Sebastian Pipping gentoo-dev 2011-06-13 20:04:36 UTC
I guess our web view is not synced yet: last change 2 weeks ago.  In any case please point me to concrete patches and instructions.  From the comments above I have no clear picture of the right fix myself, yet.
Comment 33 Sebastian Pipping gentoo-dev 2011-06-13 21:12:02 UTC
From IRC chat with jmbsvicetto and chithead there are two new related commits to genkernel now:

- Apply CONFIG_USB_HID=y to archs amd64/x86/default (bug #270983)
http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=commitdiff;h=b20494438aa689bb66677f6c6968c0ecbdfd769c

- Unset CONFIG_EMBEDDED on arch amd64
http://git.overlays.gentoo.org/gitweb/?p=proj/genkernel.git;a=commitdiff;h=6d6b5b7c2942af5b3213254fc1699777842ef031
Comment 34 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-08-19 03:58:04 UTC
This should be fixed now on the installcds and genkernel. Is anyone still being affected by this?
Comment 35 Fab 2011-08-19 07:29:28 UTC
(In reply to comment #34)
> This should be fixed now on the installcds and genkernel. Is anyone still being
> affected by this?

Tested with install-x86-minimal-20110809.iso, works fine now, thanks.
Comment 36 Roger 2011-08-19 20:30:29 UTC
(Marking this bug is present on X86 as well, as such, marked as "All".)

Yup. Tested 20110809 and works great.
Comment 37 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-08-19 20:57:17 UTC
Closing this bug then.
Feel free to reopen if you hit this again.