Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262491 - Stupid USE="doc" managment in gnome2.eclass
Summary: Stupid USE="doc" managment in gnome2.eclass
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Eclasses (show other bugs)
Hardware: All Linux
: High enhancement with 1 vote (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 247680 249279 262387 264157 265216 268380 280811 304701 347863 347903 353310 353313 364579 386099 411561 415079 415083 (view as bug list)
Depends on: 247680 249279 258759 262387 264157 265176 265216 268380 270704 347863
Blocks: 298560 239524 261701 279856 318475 347903 383901
  Show dependency tree
 
Reported: 2009-03-15 00:40 UTC by Gilles Dartiguelongue
Modified: 2013-01-20 12:43 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Patch adding GCONF_GTKDOC="no" to not add gtk-doc to GCONF (gnome2-gtkdoc.patch,469 bytes, patch)
2009-03-29 18:59 UTC, Mounir Lamouri (volkmar) (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gilles Dartiguelongue gentoo-dev 2009-03-15 00:40:09 UTC
Causes problems with packages having USE="doc" yet not having a gtk-doc but simply a gnome-doc-utils or doxygen kind of doc or simply something have --enable-docs.
Comment 1 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-03-29 18:59:37 UTC
Created attachment 186668 [details, diff]
Patch adding GCONF_GTKDOC="no" to not add gtk-doc to GCONF

This patch has the same of GCONF_DEBUG wich can be set to "no" to prevent adding --enable-debug=yes when debug is enabled.
Here, GCONF_GTKDOC set to "no" prevents adding --[enable|disable]-gtk-doc.

It has a backward compatibility and it prevents QA warnings for ebuild using gnome2 eclass without gtk-doc option (like ekiga-3 for me).
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-08-08 23:21:35 UTC
*** Bug 280811 has been marked as a duplicate of this bug. ***
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-10-28 19:53:42 UTC
Considering short meeting summary:

  - USE=doc management is inconsistent, and unflexible
    + It should atleast check for GTK_DOC_INIT before passing $(use_enable gtk-doc)
    + USE=doc means rebuilding of api-docs right now, advantages seem to be uncertain

--> dang was doing research

    + Consensus was to use USE=doc for api-docs, and install user documentation
      unconditionally


I approve of this patch with a few changes:
 * adding a default to the variable
 * adding eclass doc with it (at least for this variable)

@herd, next question is, do we really want to rebuild the docs with USE="doc" ? It seems like gtkdoc-rebase is what is really interesting for us when using doc pre-generated by upstream, and it looks like a self-contained perl script. Maybe we can split it and always depend on it when USE="doc" and forget about rebuilding all the docs which is time consuming both for users and for us as they often are not checked before a release.
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-10-28 20:12:32 UTC
This seems fine to me, assuming it can be reasonably done.  I'd prefer to have the option to install API docs without rebuilding them, so I can avoid all the dependencies.  gtkdoc-rebase sounds perfect.
Comment 5 Gilles Dartiguelongue gentoo-dev 2010-02-12 10:04:35 UTC
*** Bug 304701 has been marked as a duplicate of this bug. ***
Comment 6 Pacho Ramos gentoo-dev 2011-02-01 09:41:39 UTC
*** Bug 247680 has been marked as a duplicate of this bug. ***
Comment 7 Pacho Ramos gentoo-dev 2011-02-01 09:41:51 UTC
*** Bug 249279 has been marked as a duplicate of this bug. ***
Comment 8 Pacho Ramos gentoo-dev 2011-02-01 09:42:14 UTC
*** Bug 262387 has been marked as a duplicate of this bug. ***
Comment 9 Pacho Ramos gentoo-dev 2011-02-01 09:42:28 UTC
*** Bug 264157 has been marked as a duplicate of this bug. ***
Comment 10 Pacho Ramos gentoo-dev 2011-02-01 09:42:35 UTC
*** Bug 265216 has been marked as a duplicate of this bug. ***
Comment 11 Pacho Ramos gentoo-dev 2011-02-01 09:42:45 UTC
*** Bug 268380 has been marked as a duplicate of this bug. ***
Comment 12 Pacho Ramos gentoo-dev 2011-02-01 09:43:30 UTC
*** Bug 347863 has been marked as a duplicate of this bug. ***
Comment 13 Pacho Ramos gentoo-dev 2011-02-01 09:43:38 UTC
*** Bug 347903 has been marked as a duplicate of this bug. ***
Comment 14 Pacho Ramos gentoo-dev 2011-02-01 09:43:47 UTC
*** Bug 353313 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2011-02-01 09:48:07 UTC
*** Bug 353310 has been marked as a duplicate of this bug. ***
Comment 16 Pacho Ramos gentoo-dev 2011-04-25 08:36:17 UTC
*** Bug 364579 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-10-07 16:50:04 UTC
*** Bug 386099 has been marked as a duplicate of this bug. ***
Comment 18 Pacho Ramos gentoo-dev 2011-10-20 09:28:11 UTC
(In reply to comment #4)
> This seems fine to me, assuming it can be reasonably done.  I'd prefer to have
> the option to install API docs without rebuilding them, so I can avoid all the
> dependencies.  gtkdoc-rebase sounds perfect.

We should probably try to give a push to this and there are some problems related with rebuilding docs that could be avoided with this :-/
Comment 19 Pacho Ramos gentoo-dev 2012-04-14 09:00:17 UTC
*** Bug 411561 has been marked as a duplicate of this bug. ***
Comment 20 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-05-08 23:13:28 UTC
*** Bug 415079 has been marked as a duplicate of this bug. ***
Comment 21 Alexandre Rostovtsev (RETIRED) gentoo-dev 2012-05-08 23:38:16 UTC
*** Bug 415083 has been marked as a duplicate of this bug. ***
Comment 22 Pacho Ramos gentoo-dev 2013-01-20 12:43:46 UTC
This is better handled with eapi5