Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262387 - dev-python/pygobject-2.18.0-r1 configure: WARNING: unrecognized options: --disable-gtk-doc
Summary: dev-python/pygobject-2.18.0-r1 configure: WARNING: unrecognized options: --di...
Status: RESOLVED DUPLICATE of bug 262491
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All All
: Normal QA (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 283790 (view as bug list)
Depends on:
Blocks: 260063 262491
  Show dependency tree
 
Reported: 2009-03-13 21:08 UTC by Markus Meier
Modified: 2011-02-01 11:09 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Meier gentoo-dev 2009-03-13 21:08:24 UTC
>>> Compiling source in /var/tmp/portage/dev-python/pygobject-2.16.1/work/pygobject-2.16.1 ...
 * econf: updating pygobject-2.16.1/config.sub with /usr/share/gnuconfig/config.sub
 * econf: updating pygobject-2.16.1/config.guess with /usr/share/gnuconfig/config.guess
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/
var/lib --disable-docs --disable-gtk-doc --build=i686-pc-linux-gnu
configure: WARNING: unrecognized options: --disable-gtk-doc
Comment 1 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-03-14 15:45:05 UTC
(In reply to comment #0)
> >>> Compiling source in /var/tmp/portage/dev-python/pygobject-2.16.1/work/pygobject-2.16.1 ...
>  * econf: updating pygobject-2.16.1/config.sub with
> /usr/share/gnuconfig/config.sub
>  * econf: updating pygobject-2.16.1/config.guess with
> /usr/share/gnuconfig/config.guess
> ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
> --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
> --localstatedir=/
> var/lib --disable-docs --disable-gtk-doc --build=i686-pc-linux-gnu
> configure: WARNING: unrecognized options: --disable-gtk-doc
> 

The reason why this is showing up is as follows:

1. pygobject has an `inherit gnome2`
2. IUSE=doc in pygobject is used for $(use_enable doc docs)
3. If gnome2.eclass sees IUSE=doc, it appends $(use_enable doc gtk-doc) to G2CONF

=> CANTFIX without changing eclass and adding conditional code (IMO not worth it for a small warning)
Comment 2 Gilles Dartiguelongue gentoo-dev 2009-03-15 00:47:36 UTC
reopening per discussion with mart.
Comment 3 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-09-05 23:13:49 UTC
*** Bug 283790 has been marked as a duplicate of this bug. ***
Comment 4 David J Cozatt 2009-10-24 17:44:46 UTC
> configure: WARNING: unrecognized options: --disable-gtk-doc
> 

The reason why this is showing up is as follows:

1. pygobject has an `inherit gnome2`
2. IUSE=doc in pygobject is used for $(use_enable doc docs)
3. If gnome2.eclass sees IUSE=doc, it appends $(use_enable doc gtk-doc) to
G2CONF
 

something to do with the eclass mishandling autotools?
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-10-24 21:09:51 UTC
Yes we know, please check the bug in dependencies...
Comment 6 Pacho Ramos gentoo-dev 2011-02-01 09:42:14 UTC

*** This bug has been marked as a duplicate of bug 262491 ***