Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 235914 - www-apps/rt-4.0.2 version bump
Summary: www-apps/rt-4.0.2 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Low enhancement with 3 votes (vote)
Assignee: Gentoo Web Application Packages Maintainers
URL: http://bestpractical.com/rt/download....
Whiteboard:
Keywords:
: 351055 380769 (view as bug list)
Depends on: 235891 235895 235901 252824 381855 381859 381861 381863 381865 381871
Blocks:
  Show dependency tree
 
Reported: 2008-08-27 14:09 UTC by Nick Prater
Modified: 2012-03-01 16:25 UTC (History)
18 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
rt-3.8.1.ebuild (rt-3.8.1.ebuild,6.36 KB, text/plain)
2008-08-27 14:10 UTC, Nick Prater
Details
Diff from 3.6.7 ebuild (rt-3.6.7-to-3.8.1.diff,3.13 KB, text/plain)
2008-10-19 20:24 UTC, Nick Prater
Details
rt-3.8.2.ebuild (rt-3.8.2.ebuild,6.41 KB, text/plain)
2009-03-03 16:53 UTC, Disaster
Details
rt 3.8.5 ebuild (rt-3.8.5.ebuild,6.40 KB, text/plain)
2009-09-18 14:24 UTC, Andy Crook
Details
fixed 3.8.5 ebuild (rt-3.8.5.ebuild,6.42 KB, text/plain)
2009-09-22 10:43 UTC, Andy Crook
Details
slightly modified 3.8.5 ebuild (rt-3.8.5.ebuild,6.44 KB, text/plain)
2009-09-24 12:51 UTC, Andy Crook
Details
Ebuild for rt-3.8.8 (rt-3.8.8.ebuild,6.46 KB, text/plain)
2011-01-18 21:21 UTC, Eric Martin
Details
Manifest file (Manifest,2.32 KB, text/plain)
2011-01-18 21:21 UTC, Eric Martin
Details
files/config.layout-gentoo; specifies directories for this build (config.layout-gentoo,645 bytes, text/plain)
2011-01-18 21:22 UTC, Eric Martin
Details
Ebuild for rt-3.8.9 (rt-3.8.9.ebuild,6.46 KB, text/plain)
2011-02-17 20:57 UTC, Eric Martin
Details
new metadata.xml with Eric Martin as maintainer (metadata.xml.patch,117 bytes, patch)
2011-09-05 04:51 UTC, Eric Martin
Details | Diff
unified diff of metadata.xml (metadata.xml.patch,464 bytes, patch)
2011-09-05 11:57 UTC, Eric Martin
Details | Diff
new metadata.xml diff (metadata.xml.diff,794 bytes, patch)
2011-09-07 12:09 UTC, Eric Martin
Details | Diff
rt-3.8.10 ebuild (rt-3.8.10.ebuild.diff,3.65 KB, patch)
2011-09-08 19:38 UTC, Eric Martin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Prater 2008-08-27 14:09:36 UTC
RT: Request Tracker version 3.8.1 was released on 18 August 2008

I have prepared an e-build, which I will attach and which is working on my system.

This version has a number of new perl module dependencies. I have submitted bugs and e-builds where these are not already available in portage.

I make no claims to be an rt or ebuild expert. My ebuild will certainly benefit from more experienced eyes, so I feel it's best to share this now.

In particular I wonder if rt-3.8.1/var/mason_data/ and its subdirectories shoule be changed to be owned by [web server user]?

Any feedback is welcomed.

Many thanks.
Comment 1 Nick Prater 2008-08-27 14:10:07 UTC
Created attachment 163896 [details]
rt-3.8.1.ebuild
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-08-27 14:14:08 UTC
Is the ebuild just copied with a name change? Maybe a diff -u would show the differences better.
Comment 3 Christian van der Leeden 2008-10-18 09:50:09 UTC
Just tried to install this ebuild and I get the following error: (perl dependencies are all resolved), I've got rt 3.6.6 installed. 

All dependencies have been found.
/usr/bin/install -c -m 0755 -o rt -g rt -d NONE/etc	
/usr/bin/install -c -m 0440 -o rt -g rt  etc/RT_Config.pm NONE/etc/RT_Config.pm
[ -f NONE/etc/RT_SiteConfig.pm ] || /usr/bin/install -c -m 0640 -o rt -g rt etc/RT_SiteConfig.pm NONE/etc/RT_SiteConfig.pm 
Installed configuration. About to install RT in  NONE
/usr/bin/install -c -m 0755 -d 
/usr/bin/install: missing file operand
Try `/usr/bin/install --help' for more information.
make: *** [dirs] Error 1
 * 
 * ERROR: www-apps/rt-3.8.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2617:  Called die
 * The specific snippet of code:
 *       make install || die;
 *  The die message:
 *   (no error message)
 * 
Comment 4 Nick Prater 2008-10-19 20:24:59 UTC
Created attachment 169124 [details]
Diff from 3.6.7 ebuild

(In reply to comment #2)
> Is the ebuild just copied with a name change? Maybe a diff -u would show the
> differences better.

Sorry - only just seen this comment. I've now attached a diff.

There's more changed than just the name. To summarise the changes:

1) Updated/added perl dependencies

2) Refactored use of enable_extension_withonly - previous code was not generating correct configuration options on my system (perhaps I broke something in between changes)
Comment 5 Nick Prater 2008-10-19 20:42:47 UTC
(In reply to comment #3)
> Just tried to install this ebuild and I get the following error: (perl
> dependencies are all resolved), I've got rt 3.6.6 installed. 
> 
> All dependencies have been found.
> /usr/bin/install -c -m 0755 -o rt -g rt -d NONE/etc     
<snip>

If I understand correctly, it seems to be trying to install rt in a directory called NONE (which surely doesn't exist).

Could the problem be caused by missing/bad settings in
/etc/vhosts/webapp-config or by an old version of app-admin/webapp-config (I have version 1.50.16-r1 installed)?




Comment 6 Christian van der Leeden 2008-10-20 05:32:52 UTC
The problem is in the Makefile of RT. When I look at the Makefile in /var/tmp/portage/www-apps/rt-3.8.1/work/rt-3.8.1 it says on line 350: 
        $(INSTALL) -m 0755 -d $(DESTDIR)$(RT_LOG_PATH)
but, DESTDIR and RT_LOG_PATH are both empty. 

Also, the NONE comes from
RT_PATH                 =       NONE

My webapp-config is the same version as yours. Can you look at your Makefile and see if the DESTDIR is set or the RT_PATH something other than none?
Comment 7 Nick Prater 2008-10-20 09:48:43 UTC
(In reply to comment #6)
> My webapp-config is the same version as yours. Can you look at your Makefile
> and see if the DESTDIR is set or the RT_PATH something other than none?

I ran the following commands:
# rm -r /var/tmp/portage/www-apps/rt-3.8.1/work/rt-3.8.1
# ebuild ./rt-3.8.1.ebuild clean
# ebuild ./rt-3.8.1.ebuild unpack

Then, /var/tmp/portage/www-apps/rt-3.8.1/work/rt-3.8.1/Makefile contains:
DESTDIR                 =
RT_PATH                 =       /opt/rt3

Also, /var/tmp/portage/www-apps/rt-3.8.1/work/rt-3.8.1/config.layout contains a <Layout Gentoo> section

Then running:
# ebuild ./rt-3.8.1.ebuild compile

replaces each occurence of /opt/rt3 in the Makefile as follows:
DESTDIR                 =
RT_PATH                 =       /var/tmp/portage/www-apps/rt-3.8.1/image///usr/share/webapps/rt/3.8.1/hostroot/rt-3.8.1
RT_ETC_PATH             =       /var/tmp/portage/www-apps/rt-3.8.1/image///usr/share/webapps/rt/3.8.1/hostroot/rt-3.8.1/etc

... and so on ...
Comment 8 Christian van der Leeden 2008-10-20 19:25:29 UTC
Ah, I think I've got the problem, I've installed the ebuild into my portage overlay without copying the old files from the /usr/portage/www-apps/rt/files section. 

So to sum up the install instructions for other people as inexperienced as me:
 * get the ebuild for rt
 * get the perl modules (Bug #235904)
 * copy it into your portage overlay (perl-core/Encode/Encode-2.26.ebuild, virtual/perl-Encode/perl-Encode-2.26.ebuild, www-apps/rt/rt-3.8.1.ebuild)
 * Copy all files from the /usr/portage/www-apps/rt/files into the portage overlay
 * ebuild ... digest all ebuilds
 * emerge and install
Comment 9 Matthias Sch. 2008-12-09 08:04:34 UTC
hi!

what's the status of this bug?
is there any version bump in the portage planned?

thank you
Comment 10 Patrick Lauer gentoo-dev 2009-03-01 16:04:08 UTC
SOME DEPENDENCIES WERE MISSING.
CORE missing dependencies:     
        Encode >= 2.13...MISSING
                Encode version 2.13 required--this is only version 2.12 
MYSQL missing dependencies:                                             
        DBD::mysql >= 2.1018...MISSING                                  
make: *** [testdeps] Error 1                                            
 *                                                                      
 * ERROR: www-apps/rt-3.8.1 failed. 

(1) >=virtual/perl-Encode-2.13 doesn't seem to exist. Pointers where to find it appreciated :)
(2) looks like it is missing a DBD dep. Please try to narrow it down so n00bs like me can add it to the ebuild.

If that is fixed your chances of a version bump go up a lot :)

Thanks,

Patrick
Comment 11 Nick Prater 2009-03-01 22:07:13 UTC
(In reply to comment #10)

> (1) >=virtual/perl-Encode-2.13 doesn't seem to exist. Pointers where to find it
> appreciated :)

See comment #8. Added dependency on bug#235904 (perl-core/Encode-2.26 new ebuild)
Comment 12 Disaster 2009-03-03 16:53:58 UTC
Created attachment 183777 [details]
rt-3.8.2.ebuild

Bump for 3.8.2
Please note that it depends on 	>=dev-perl/text-template-1.45 and dev-perl/GraphViz
Also dev-perl/Module-Refresh is required if you want to enable "Development mode"
Comment 13 Łukasz Damentko (RETIRED) gentoo-dev 2009-03-20 23:42:32 UTC
Moving to herd since Renat isn't working on ebuilds anymore.
Comment 14 Andrey A. Ugolnik 2009-06-22 13:45:50 UTC
RT 3.8.4 is out.
Comment 15 Andy Crook 2009-09-18 14:24:04 UTC
Created attachment 204521 [details]
rt 3.8.5 ebuild

RT 3.8.5 version bump
made some changes in dependencies:
now it requires >= perl-5.8.9 (see bug #252824) instead of virtual/perl-Encode

will someone put it in the portage tree?
Comment 16 Andy Crook 2009-09-18 14:29:42 UTC
Nick, could you change dependencies from bug #235904 to bug #252824 ?
Comment 17 Nick Prater 2009-09-19 10:12:46 UTC
Dependencies changed: now depends on perl-5.8.9 rather than virtual/perl-Encode 
Comment 18 Andy Crook 2009-09-22 10:43:52 UTC
Created attachment 204907 [details]
fixed 3.8.5 ebuild

forgot mod_perl dependency if using apache :)
Comment 19 Andy Crook 2009-09-24 12:51:14 UTC
Created attachment 205108 [details]
slightly modified 3.8.5 ebuild

mod_perl again :)
added modperl USE flag for better dependecies handling
Comment 20 .:deadhead:. 2009-09-29 09:21:44 UTC
Maybe could be worth to change the subject to www-apps/rt-3.8.5 version bump and set as depends on bug #280724 .
Comment 21 Tais P. Hansen 2009-10-27 13:27:33 UTC
FYI 3.8.6 is out
Comment 22 Ianislav Trendafilov 2010-01-04 21:03:13 UTC
(In reply to comment #3)
> Just tried to install this ebuild and I get the following error: (perl
> dependencies are all resolved), I've got rt 3.6.6 installed. 
> 
> All dependencies have been found.
> /usr/bin/install -c -m 0755 -o rt -g rt -d NONE/etc     
> /usr/bin/install -c -m 0440 -o rt -g rt  etc/RT_Config.pm NONE/etc/RT_Config.pm
> [ -f NONE/etc/RT_SiteConfig.pm ] || /usr/bin/install -c -m 0640 -o rt -g rt
> etc/RT_SiteConfig.pm NONE/etc/RT_SiteConfig.pm 
> Installed configuration. About to install RT in  NONE
> /usr/bin/install -c -m 0755 -d 
> /usr/bin/install: missing file operand
> Try `/usr/bin/install --help' for more information.
> make: *** [dirs] Error 1
>  * 
>  * ERROR: www-apps/rt-3.8.1 failed.
>  * Call stack:
>  *               ebuild.sh, line   49:  Called src_install
>  *             environment, line 2617:  Called die
>  * The specific snippet of code:
>  *       make install || die;
>  *  The die message:
>  *   (no error message)
>  * 
> 

You should copy /usr/portage/www-apps/rt/files/ to your overlay. This will fix the problem
Comment 23 Bryan 2010-06-14 09:17:29 UTC
Hello,

I would just like to voice that I show interest in this project. I just got 3.6.7 merged and super happy but seeing it is so old has me worried now.

Bryan
Comment 24 Eric Martin 2010-06-22 17:25:56 UTC
(In reply to comment #23)
> Hello,
> 
> I would just like to voice that I show interest in this project. I just got
> 3.6.7 merged and super happy but seeing it is so old has me worried now.
> 
> Bryan
> 
Please vote for this bug as that is the best way to do what you posted in your comment.
Comment 25 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-09-01 12:54:24 UTC
RT-3.8.8 was released on May 5th, 2010.
Comment 26 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-01-08 06:25:45 UTC
*** Bug 351055 has been marked as a duplicate of this bug. ***
Comment 27 Eric Martin 2011-01-15 17:28:48 UTC
(In reply to comment #19)
> Created an attachment (id=205108) [details]
> slightly modified 3.8.5 ebuild
> 
> mod_perl again :)
> added modperl USE flag for better dependecies handling
> 
Thanks for the ebuild, I put it into my repository and it works great.  I'm trying to use it as a base for the rt-3.8.8 ebuild but I'm having a problem with the install although I haven't had much time to work on it lately.

The repository can be found here:
https://github.com/ericmartin/ejm_overlay/raw/master/overlay.xml

www-apps/rt-3.8.5 is on the master branch, and rt-3.8.8 is on the dev branch
Comment 28 Eric Martin 2011-01-18 21:21:26 UTC
Created attachment 260213 [details]
Ebuild for rt-3.8.8

Also needs config.layout-gentoo to function
Comment 29 Eric Martin 2011-01-18 21:21:50 UTC
Created attachment 260214 [details]
Manifest file
Comment 30 Eric Martin 2011-01-18 21:22:52 UTC
Created attachment 260215 [details]
files/config.layout-gentoo; specifies directories for this build

put this in www-apps/rt/files/
Comment 31 Eric Martin 2011-01-18 21:32:30 UTC
Fixed.  There is a new font directory and an extra line had to be added to the config.layout-gentoo file to make it all work.  I uploaded the modified files and www-apps/rt-3.8.8 is on the master branch of my overlay if people want to test / use it.


> Thanks for the ebuild, I put it into my repository and it works great.  I'm
> trying to use it as a base for the rt-3.8.8 ebuild but I'm having a problem
> with the install although I haven't had much time to work on it lately.
> 
> The repository can be found here:
> https://github.com/ericmartin/ejm_overlay/raw/master/overlay.xml
> 
> www-apps/rt-3.8.5 is on the master branch, and rt-3.8.8 is on the dev branch
> 

Comment 32 Eric Martin 2011-02-17 20:57:19 UTC
Created attachment 262867 [details]
Ebuild for rt-3.8.9

RT 3.8.9 is out.  I updated the ebuild to depend on >=dev-perl/HTTP-Server-Simple-Mason-0.14
Comment 33 Chris Smith 2011-05-18 22:01:20 UTC
RT: Request Tracker 4.0 was released last month. Any hope of a version bump?
Comment 34 Luca Lesinigo 2011-08-26 18:50:06 UTC
FYI, I just added a request for version 4 in bug #380769. If it were me, I'd skip 3.8 entirely.
Comment 35 Jeroen Roovers gentoo-dev 2011-08-27 14:48:28 UTC
*** Bug 380769 has been marked as a duplicate of this bug. ***
Comment 36 Eric Martin 2011-08-27 18:24:25 UTC
(In reply to comment #34)
> FYI, I just added a request for version 4 in bug #380769. If it were me, I'd
> skip 3.8 entirely.

I have an ebuild for 4.0.1 but I'm having a problem with a few of the paths.  It's in my overlay if anybody wants to take a look.
Comment 37 Eric Martin 2011-09-05 04:51:04 UTC
Created attachment 285565 [details, diff]
new metadata.xml with Eric Martin as maintainer

I am becoming a maintainer of this package with proxy commits and the patched metadata.xml reflects those changes.  Ebuilds for rt-3.8.8 and rt-3.8.9 are already in this bug as well as config.layout-gentoo (needed for rt-3.8.9).
Comment 38 Eric Martin 2011-09-05 06:57:04 UTC
www-apps/rt-4.0.x is dependent on multiple perl ebuilds not in gentoo or
perl-experimental.  I've added the following bugs that this bug depends on in
order to be closed:

Direct dependencies
bug #381855 dev-perl/CGI-Emulate-PSGI
bug #381859 dev-perl/Convert-Color
bug #381861 dev-perl/HTML-Mason-PSGIHandler
bug #381863 dev-perl/HTML-Quoted
bug #381865 dev-perl/Starlet
bug #381869 dev-perl/List-UtilsBy
bug #381871 dev-perl/Regexp-Common-net-CIDR

Indirect dependencies
bug #381867 dev-perl/Parallel-Prefork
bug #381857 dev-perl/Class-Accessor-Lite
Comment 39 Tim Harder gentoo-dev 2011-09-05 07:28:37 UTC
(In reply to comment #37)
> Created attachment 285565 [details, diff]
> new metadata.xml with Eric Martin as maintainer

When attaching patches, please use unified diffs against the file(s) you're changing.
Comment 40 Eric Martin 2011-09-05 11:57:46 UTC
Created attachment 285625 [details, diff]
unified diff of metadata.xml
Comment 41 Eric Martin 2011-09-07 12:09:25 UTC
Created attachment 285775 [details, diff]
new metadata.xml diff

Added modperl flag as well as description
Comment 42 Eric Martin 2011-09-08 19:38:02 UTC
Created attachment 285885 [details, diff]
rt-3.8.10 ebuild
Comment 43 Peter Volkov (RETIRED) gentoo-dev 2011-10-02 18:09:33 UTC
rt-3.8.10 was just added to the tree. Thank you Eric!
Comment 44 tarek 2011-10-08 04:59:59 UTC
(In reply to comment #38)
> www-apps/rt-4.0.x is dependent on multiple perl ebuilds not in gentoo or
> perl-experimental.  I've added the following bugs that this bug depends on in
> order to be closed:
> 
> Direct dependencies
> bug #381855 dev-perl/CGI-Emulate-PSGI
> bug #381859 dev-perl/Convert-Color
> bug #381861 dev-perl/HTML-Mason-PSGIHandler
> bug #381863 dev-perl/HTML-Quoted
> bug #381865 dev-perl/Starlet
> bug #381869 dev-perl/List-UtilsBy
> bug #381871 dev-perl/Regexp-Common-net-CIDR
> 
> Indirect dependencies
> bug #381867 dev-perl/Parallel-Prefork
> bug #381857 dev-perl/Class-Accessor-Lite

I needed a  few more than this to get RT-4.0.2 running :) (total of 17) :)

My full list or overlay ebuilds was:

CGI-PSGI                
HTML-Quoted      
Parallel-Prefork        
Server-Starter
Class-Accessor-Lite     
HTTP-Body        
Plack                   
Starlet
Convert-Color           
Hash-MultiValue  
Proc-Wait3              
Test-TCP
HTML-Mason-PSGIHandler  to avoid any ebuild related concerns. My first RT attempt was with the  main tree rt-3.6.7 which yielded a few non-functioning things like file-uploads. Seeme
List-UtilsBy     
Regexp-Common-net-CIDR  
Text-Password-Pronounceable
CGI-Emulate-PSGI


The good news was currently everything appears to be running perfectly in rt 4.02 with these in play.

I did a manual install for  RT-4.02 at present so unfortunately have no ebuild to offer.
Comment 45 Luca Lesinigo 2011-12-02 22:15:40 UTC
RT-4.0.4 was released on Nov 10th, 2011.
Comment 46 .:deadhead:. 2012-02-04 08:13:17 UTC
Eric, looks like there's nothing left to do, except committing the 4.0 ebuild, isn't it?

Have you tried to install 4.0.4? Does the ebuild works flawlessy?

thank you for your patient work!
Comment 47 Tim Harder gentoo-dev 2012-03-01 10:19:57 UTC
4.0.5 added to CVS.
Comment 48 Max Nokhrin 2012-03-01 16:25:41 UTC
It seems there's a dependency conflict with Perl, I've got 5.12 while rt requires 5.14? Tracker bug 356171 should perhaps be added as a blocker?