Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 225091 - Circular dependencies: hal-0.5.11-r1, xorg-server-1.4.0.90-r3 and pyxf86config-0.3.34-r1
Summary: Circular dependencies: hal-0.5.11-r1, xorg-server-1.4.0.90-r3 and pyxf86confi...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
: 229127 231388 233757 243858 (view as bug list)
Depends on:
Blocks: 222219 251832
  Show dependency tree
 
Reported: 2008-06-06 09:19 UTC by Ster0n
Modified: 2009-02-27 22:50 UTC (History)
12 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ster0n 2008-06-06 09:19:46 UTC
'emerge xorg-x11' ->>>>

Calculating dependencies ... done!
[nomerge      ] x11-drivers/nvidia-drivers-173.14.05  USE="acpi gtk (multilib) -custom-cflags"
[nomerge      ]  media-video/nvidia-settings-171.05
[nomerge      ]   x11-libs/gtk+-2.12.10  USE="X cups jpeg tiff -debug -doc -vim-syntax -xinerama"
[nomerge      ]    x11-base/xorg-server-1.4.0.90-r3  USE="dri hal ipv6 sdl xorg (-3dfx) -debug -dmx -kdrive -minimal (-nptl) -xprint" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nvidia -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) -i810 (-impact) (-imstt) -mach64 -mga -neomagic (-newport) (-nsc) -nv -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l (-vermilion) -vesa -vga -via -vmware -voodoo (-xgi)"
[ebuild  N    ]     sys-apps/hal-0.5.11-r1  USE="X acpi crypt -apm -debug -dell -disk-partition -doc -laptop (-selinux)"
[ebuild  N    ]      dev-python/pyxf86config-0.3.34-r1
[ebuild  N    ]       x11-base/xorg-server-1.4.0.90-r3  USE="dri hal ipv6 sdl xorg (-3dfx) -debug -dmx -kdrive -minimal (-nptl) -xprint" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nvidia -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) -i810 (-impact) (-imstt) -mach64 -mga -neomagic (-newport) (-nsc) -nv -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l (-vermilion) -vesa -vga -via -vmware -voodoo (-xgi)"
('ebuild', '/', 'sys-apps/hal-0.5.11-r1', 'merge') depends on
   ('ebuild', '/', 'dev-python/pyxf86config-0.3.34-r1', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') depends on
   ('ebuild', '/', 'sys-apps/hal-0.5.11-r1', 'merge') (hard)
('ebuild', '/', 'dev-python/pyxf86config-0.3.34-r1', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.4.0.90-r3', 'merge') (hard)
Comment 1 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-06 12:27:36 UTC
As hinted in red letters, "Gentoo Bugzilla" is not the correct product to file bugs regarding ebuilds. Please use "New -> Gentoo Linux -> Component: Ebuilds" in future.
Comment 2 Ster0n 2008-06-06 14:02:42 UTC
Ok.
It's my first report :)
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2008-06-24 17:10:03 UTC
*** Bug 229127 has been marked as a duplicate of this bug. ***
Comment 4 Yang Zhao 2008-06-30 15:58:22 UTC
xf86config is not listed as a dependency of HAL on its website, and is not checked for in its configure.in. There was no rationale given in HAL's changelog as to why this deviation from upstream exist.

If there is a valid reason for this dependency to exist, please explain.
Comment 5 Doug Goldstein (RETIRED) gentoo-dev 2008-06-30 16:04:31 UTC
(In reply to comment #4)
> xf86config is not listed as a dependency of HAL on its website, and is not
> checked for in its configure.in. There was no rationale given in HAL's
> changelog as to why this deviation from upstream exist.
> 
> If there is a valid reason for this dependency to exist, please explain.
> 

How about you read the changelog and commit history. There's no reason anyone should have to take time out of their day to explain this. Consider this a user exercise.
Comment 6 Yang Zhao 2008-06-30 16:50:51 UTC
(In reply to comment #5)
> How about you read the changelog and commit history...

I've stated that there was no rationale given in the ChangeLog, hence the request for explanation.
Comment 7 Carsten Lohrke (RETIRED) gentoo-dev 2008-07-10 10:47:52 UTC
*** Bug 231388 has been marked as a duplicate of this bug. ***
Comment 8 Pacho Ramos gentoo-dev 2008-07-18 17:13:52 UTC
Seems that it was added in 0.5.11, but I don't know why it's needed, and couldn't find anything in ChangeLog
Comment 9 Olivier Crete (RETIRED) gentoo-dev 2008-07-19 19:27:48 UTC
I plan to remove the pyxf86config dep on hal unless someone explains me why its needed ?
Comment 10 Steev Klimaszewski (RETIRED) gentoo-dev 2008-07-20 00:13:21 UTC
You know that thing about how the maintainers know more about the software than you do, and thats why they are the maintainer and you aren't?  This is one of those times.  It's compnerd's thing, he knows what its for, he is in the process of moving from an apartment to another.  You will need to ask him and not simply remove it.
Comment 11 Yang Zhao 2008-07-20 18:19:50 UTC
pyxf86config is required for migrate-xorg-to-fdi.py (contained in a patchset) to convert xorg.conf keyboard rules to a fdi file.

As it is not the case that a user would always have the relevant section defined in xorg.conf, it would be more appropriate to have the user run this utility manually and give appropriate instructions.
Comment 12 IL Idrissi Mohammed Amine 2008-10-24 18:43:15 UTC
*** Bug 243858 has been marked as a duplicate of this bug. ***
Comment 13 Doug Goldstein (RETIRED) gentoo-dev 2008-10-24 18:49:32 UTC
(In reply to comment #9)
> I plan to remove the pyxf86config dep on hal unless someone explains me why its
> needed ?
> 

You will hose every Gentoo user upgrading to a HAL-ified X server from a non-HAL-ified X server. pyxf86config is used to migrate a user's xorg.conf settings into HAL, where the X server now reads the settings from.
Comment 14 Ryan Hill (RETIRED) gentoo-dev 2008-11-03 05:41:52 UTC
> How about you read the changelog and commit history. There's no reason anyone
> should have to take time out of their day to explain this. Consider this a user
> exercise.

um.. there is zero mention of this in hal or pyxf86config's change/commitlogs.  am i looking in the right place?

anyways, any ideas how we can fix this?  it's blocking me from doing any gcc-porting work on packages that pull in xorg right now. :/


Comment 15 Pacho Ramos gentoo-dev 2008-11-03 07:50:17 UTC
Why is migrate-xorg-to-fdi.py done by xorg-server.ebuild instead of hal.ebuild? Maybe an option would be modify xorg-server ebuild for installing the script in /etc/hal/fdi/policy/10-x11-input.fdi and execute it instead of having hal ebuild doing this work
Comment 16 Andraž Vrhovec 2008-11-22 19:24:21 UTC
('ebuild', '/', 'sys-apps/hal-0.5.11-r4', 'merge') depends on
   ('ebuild', '/', 'dev-python/pyxf86config-0.3.34-r1', 'merge') (hard)
('ebuild', '/', 'dev-python/pyxf86config-0.3.34-r1', 'merge') depends on
   ('ebuild', '/', 'x11-base/xorg-server-1.5.2', 'merge') (hard)
('ebuild', '/', 'x11-base/xorg-server-1.5.2', 'merge') depends on
   ('ebuild', '/', 'sys-apps/hal-0.5.11-r4', 'merge') (hard)

Same on ~amd64 box. Anyone knows workaround?
Comment 17 Denis Pesotsky 2008-11-24 15:55:36 UTC
Just emerge xorg-x11 without hal use flag
USE="-hal" emerge -av xorg-x11
And then emerge -auDN world to enable hal on it
Comment 18 vltg0903 2009-01-04 15:05:49 UTC
(In reply to comment #15)
> Why is migrate-xorg-to-fdi.py done by xorg-server.ebuild instead of hal.ebuild?

As of hal-0.5.11-r1.ebuild migration is done by hal, and that's crap too, see
http://forums.gentoo.org/viewtopic-t-723323-highlight-xorg+hal.html
Why not install the migration script and docs with hal unconditionally, get rid of the X dependency, and move the actual migration stuff to xorg-server? Or, if anyone is worried of cluttering his system with three unnecessary files, why not create a x11-misc/hal-xorg-migration package that xorg-server depends upon via hal USE flag? This circular dependency is totally unnecessary.
Comment 19 Tony Vroon gentoo-dev 2009-02-03 14:17:12 UTC
I agree that this is messy. I'll take the bug with a view of fixing this for hal-0.5.11-r8. Right now I'm rolling a 0.5.11-r7 with the low-hanging fruit.

Moving the script back to X.Org seems better from a dependency point of view, but the real fix might be to PDEPEND on a migrate package from X.Org

I could use some X11 herd opinion on that.
Comment 20 Rémi Cardona gentoo-dev 2009-02-03 16:15:00 UTC
Maybe the script should be shipped with xorg-server when USE=hal?

Donnie, what do you say?

Thanks
Comment 21 Donnie Berkholz (RETIRED) gentoo-dev 2009-02-03 23:35:03 UTC
Sure. We'll need a hal revbump so we can depend on a new revision that no longer provides the migration script.

I vaguely recall that the original reasoning for putting it with hal was that older hal revisions (read: everything outside of gentopia overlay) didn't provide the x11-input fdi, there were weird issues going on with who provided it and such.
Comment 22 Tony Vroon gentoo-dev 2009-02-04 11:37:36 UTC
(In reply to comment #21)
> Sure. We'll need a hal revbump so we can depend on a new revision that no
> longer provides the migration script.

Certainly. Will drop the python script from the "4" patchset and the dependency for -r7.
Comment 23 Tony Vroon gentoo-dev 2009-02-04 12:46:51 UTC
+*hal-0.5.11-r7 (04 Feb 2009)
+
+  04 Feb 2009; <chainsaw@gentoo.org> metadata.xml, +hal-0.5.11-r7.ebuild:
+  Avoid circular dependencies between HAL and X by dropping migration script
+  and py86 dependency, closes bug #225091 by Ster0n <er0trashbox@gmail.com>.
+  Properly ignore Dell recovery partitions, patch supplied by Pacho Ramos
+  <pacho@condmat1.ciencias.uniovi.es> in bug #236784. Stop hiding unmounted
+  partitions, as suggested by Kirill Igorevich Cherniy
+  <kirill_i_cherniy@rambler.ru> in bug #247025. Upstream patch identified by
+  Rafael <rktspm@gmail.com> fixes detection of partitions over ~1.2TB in
+  size, closes bug #253815 by Yar Odin <yarodin@gmail.com>. Cease using
+  deprecated keys in our installed examples, as pointed out by Sebastian
+  Günther <samson@guenther-roetgen.de> in bug #256304.
Comment 24 Donnie Berkholz (RETIRED) gentoo-dev 2009-02-04 18:08:19 UTC
(In reply to comment #20)
> Maybe the script should be shipped with xorg-server when USE=hal?

Looks like we'll want to ship the script in a separate package that xorg-server PDEPENDs on. As mentioned on IRC, xorg-server can't depend on pyxf86config being installed by pkg_postinst (where the script would run) because pyxf86config depends on a library provided by xorg-server.
Comment 25 Tony Vroon gentoo-dev 2009-02-04 19:27:27 UTC
*** Bug 233757 has been marked as a duplicate of this bug. ***
Comment 26 Rémi Cardona gentoo-dev 2009-02-27 22:50:44 UTC
We decided to break the circle by dropping the migration script entirely. HAL now no longer deps on X at all (the X useflag only installs example FDI files for Xorg input handling). We'll write a proper Xorg/HAL configuration guide instead.

Closing fixed.