Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 247025 - sys-apps/hal-0.5.11-r4 - All unmounted partitions are hidden
Summary: sys-apps/hal-0.5.11-r4 - All unmounted partitions are hidden
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-11-16 08:06 UTC by Kirill Igorevich Cherniy
Modified: 2009-02-05 07:50 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Igorevich Cherniy 2008-11-16 08:06:32 UTC
by default hal-0.5.11-r4 hides all not-hotplugable and not-removable devices.
i.e. it hides fat,ntfs and other partitions.

Reproducible: Always

Actual Results:  
any app using hal (dolphin,nautilus, etc.) shows only mounted partitions.

Expected Results:  
It shows all partitions except service partitions and /, /boot, /home

This problem is due to policy in /usr/share/hal/fdi/policy/10osvendor/99-storage-policy-fixed-drives.fdi file.
Comment 1 subs 2008-12-27 23:25:13 UTC
I have found that if you just add this to /etc/hal/fdi/policy/99-storage-policy-fixed-drives.fdi all works as expected. This basically just removes the policy enforced by /usr/share/hal/fdi/policy/10osvendor/99-storage-policy-fixed-drives.fdi 

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- --> 

<deviceinfo version="0.2">
<device>
  <match key="@block.storage_device:storage.hotpluggable" bool="false">
    <match key="@block.storage_device:storage.removable" bool="false">
      <merge key="volume.ignore" type="bool">false</merge>
    </match>
  </match>
</device>
</deviceinfo>
Comment 2 Tony Vroon gentoo-dev 2009-02-04 11:31:38 UTC
Thank you for your bug report, this does indeed seem a bit annoying. I have incorporated your change in patchset "4" as patch number 13.
Comment 3 Tony Vroon gentoo-dev 2009-02-04 12:46:55 UTC
+*hal-0.5.11-r7 (04 Feb 2009)
+
+  04 Feb 2009; <chainsaw@gentoo.org> metadata.xml, +hal-0.5.11-r7.ebuild:
+  Avoid circular dependencies between HAL and X by dropping migration script
+  and py86 dependency, closes bug #225091 by Ster0n <er0trashbox@gmail.com>.
+  Properly ignore Dell recovery partitions, patch supplied by Pacho Ramos
+  <pacho@condmat1.ciencias.uniovi.es> in bug #236784. Stop hiding unmounted
+  partitions, as suggested by Kirill Igorevich Cherniy
+  <kirill_i_cherniy@rambler.ru> in bug #247025. Upstream patch identified by
+  Rafael <rktspm@gmail.com> fixes detection of partitions over ~1.2TB in
+  size, closes bug #253815 by Yar Odin <yarodin@gmail.com>. Cease using
+  deprecated keys in our installed examples, as pointed out by Sebastian
+  Günther <samson@guenther-roetgen.de> in bug #256304.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-02-04 13:22:07 UTC
To sum up upstream's argument about this policy, partitions on local drives should either be mounted or not shown because unmounted partitions are assumed to not contain anything the user would actually want to (or should) see. Please argument for why it should be shown ?

I'm actually far more annoyed by not having nautilus show my nfs mount point anymore but that's another issue.
Comment 5 Pacho Ramos gentoo-dev 2009-02-04 19:25:19 UTC
I am against this change (also please note that I am the one suggested previous behavior in bug #232195 ) 

I don't want to get partitions that I won't use automounted because they are a lot, I won't use them and their mount add a delay in gnome login
Comment 6 Mike Auty gentoo-dev 2009-02-04 20:05:35 UTC
Since this is user configurable, perhaps all that's needed is an ewarn with a link to this bug?
Comment 7 Tony Vroon gentoo-dev 2009-02-04 20:24:54 UTC
I can add an einfo with a suggestion to override it in /etc, yes. If the two bug reporters could figure out between themselves who is right please, I will not be playing ping-pong with this default.
Comment 8 Tony Vroon gentoo-dev 2009-02-04 22:55:41 UTC
Kirill, sorry to report that I have to revert an earlier decision. Applying this patch starts automounting various recovery partitions that we worked hard to keep hidden. Also, several users dislike the performance penalty that this entails. However, you should be able to override the default using an .fdi file in /etc.
Comment 9 Tony Vroon gentoo-dev 2009-02-04 22:56:07 UTC
This will not be the default.