Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 253815 - sys-apps/hal-0.5.11-r4 can't get sizes of partitions >1Tb
Summary: sys-apps/hal-0.5.11-r4 can't get sizes of partitions >1Tb
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
: 233187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-01-05 09:18 UTC by Yar Odin
Modified: 2009-02-04 12:46 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
New ebuild with patch solving this problem (hal-0.5.11-r4_hal-0.5.11-r5.diff,13.86 KB, patch)
2009-01-05 09:19 UTC, Yar Odin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Yar Odin 2009-01-05 09:18:07 UTC
hal-0.5.11-r4 can't get sizes of partitions >1Tb
Testeted on Segeate 1.5Tb

Reproducible: Always

Steps to Reproduce:
1. Try to automount fixed or removable device with partition size >1Tb
Comment 1 Yar Odin 2009-01-05 09:19:36 UTC
Created attachment 177449 [details, diff]
New ebuild with patch solving this problem
Comment 2 Rafael 2009-01-09 18:37:44 UTC
Is it the same error wich was fixed in the hal git repository a while ago (see the link below) and still hasn't made its way into portage?

http://gitweb.freedesktop.org/?p=hal.git;a=commit;h=f7d7779d0fd2438479c9de4b8dd76f986941f0a4

If this fix could be applied to the package which is available in portage it would also solve bug 233187.
Comment 3 Yar Odin 2009-01-09 19:15:24 UTC
(In reply to comment #2)
> Is it the same error wich was fixed in the hal git repository a while ago (see
> the link below) and still hasn't made its way into portage?
> 
> http://gitweb.freedesktop.org/?p=hal.git;a=commit;h=f7d7779d0fd2438479c9de4b8dd76f986941f0a4
> 

OMG, it's the same problem and still hasn't fixed at portage.

> If this fix could be applied to the package which is available in portage it
> would also solve bug 233187.
> 
It would be wonderfull ;]
Comment 4 Tony Vroon gentoo-dev 2009-02-03 13:43:01 UTC
Adding this to the new "4" patchset as patch number 10. Thank you for your bug report. Rafael, thank you for linking the upstream commit, I have taken that fix.
Comment 5 Tony Vroon gentoo-dev 2009-02-03 14:56:37 UTC
*** Bug 233187 has been marked as a duplicate of this bug. ***
Comment 6 Tony Vroon gentoo-dev 2009-02-04 12:46:57 UTC
+*hal-0.5.11-r7 (04 Feb 2009)
+
+  04 Feb 2009; <chainsaw@gentoo.org> metadata.xml, +hal-0.5.11-r7.ebuild:
+  Avoid circular dependencies between HAL and X by dropping migration script
+  and py86 dependency, closes bug #225091 by Ster0n <er0trashbox@gmail.com>.
+  Properly ignore Dell recovery partitions, patch supplied by Pacho Ramos
+  <pacho@condmat1.ciencias.uniovi.es> in bug #236784. Stop hiding unmounted
+  partitions, as suggested by Kirill Igorevich Cherniy
+  <kirill_i_cherniy@rambler.ru> in bug #247025. Upstream patch identified by
+  Rafael <rktspm@gmail.com> fixes detection of partitions over ~1.2TB in
+  size, closes bug #253815 by Yar Odin <yarodin@gmail.com>. Cease using
+  deprecated keys in our installed examples, as pointed out by Sebastian
+  Günther <samson@guenther-roetgen.de> in bug #256304.