Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 256304 - sys-apps/hal: all input *.fdi files use deprecated keys
Summary: sys-apps/hal: all input *.fdi files use deprecated keys
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High trivial (vote)
Assignee: Tony Vroon
URL: http://cgit.freedesktop.org/xorg/xser...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-01-25 12:16 UTC by Sebastian Günther
Modified: 2010-11-30 08:28 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Günther 2009-01-25 12:16:23 UTC
All examples and the installed 10-x11-input.fdi use the Legacy Keys.

As stated in the linked document:
         Legacy Keys
	     "input.xkb.rules"
             "input.xkb.model"
             "input.xkb.layout"
             "input.xkb.variant"
             "input.xkb.options"
             
            These keys are deprecated. Use these instead:
	     "input.x11_options.XkbRules"
	     "input.x11_options.XkbModel"
	     "input.x11_options.XkbLayout"
	     "input.x11_options.XkbVariant"
	     "input.x11_options.XkbOptions"


Reproducible: Always

Steps to Reproduce:




Should be fixed sometime. Isn't hard. And works for now.
Comment 1 Tony Vroon gentoo-dev 2009-02-03 13:40:23 UTC
I've used sed statements to make these updates, will release this as patchset number 4. Thank you for your detailed bug report, it made it easy to fix the issue.
Comment 2 Tony Vroon gentoo-dev 2009-02-04 12:46:59 UTC
+*hal-0.5.11-r7 (04 Feb 2009)
+
+  04 Feb 2009; <chainsaw@gentoo.org> metadata.xml, +hal-0.5.11-r7.ebuild:
+  Avoid circular dependencies between HAL and X by dropping migration script
+  and py86 dependency, closes bug #225091 by Ster0n <er0trashbox@gmail.com>.
+  Properly ignore Dell recovery partitions, patch supplied by Pacho Ramos
+  <pacho@condmat1.ciencias.uniovi.es> in bug #236784. Stop hiding unmounted
+  partitions, as suggested by Kirill Igorevich Cherniy
+  <kirill_i_cherniy@rambler.ru> in bug #247025. Upstream patch identified by
+  Rafael <rktspm@gmail.com> fixes detection of partitions over ~1.2TB in
+  size, closes bug #253815 by Yar Odin <yarodin@gmail.com>. Cease using
+  deprecated keys in our installed examples, as pointed out by Sebastian
+  Günther <samson@guenther-roetgen.de> in bug #256304.
Comment 3 Dominik Kozaczko 2009-02-05 10:41:50 UTC
Um... dropping migration script causes X to load a standard us keyboard. That's strange, because I have not removed Input section for keyboard from /etc/X11/xorg.conf and my keys went crazy after upgrading from hal-0.5.11-r6 to -r7.
Comment 4 Tony Vroon gentoo-dev 2009-02-05 11:48:27 UTC
(In reply to comment #3)
> Um... dropping migration script causes X to load a standard us keyboard.

The migration script will be back later. You should be making your changes in /etc, not /usr/share/hal as they will be overwritten otherwise. Also, you should be opening a new bug for a new problem, not leaving comments in a resolved one.