Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 116933 - xpdf 3.01-r4 can't emerge because of poppler
Summary: xpdf 3.01-r4 can't emerge because of poppler
Status: RESOLVED DUPLICATE of bug 79606
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High blocker (vote)
Assignee: Printing Team
URL:
Whiteboard:
Keywords:
: 116957 117049 117347 117724 117778 118033 118861 118987 119250 (view as bug list)
Depends on:
Blocks:
 
Reported: 2005-12-27 16:53 UTC by ivo welch
Modified: 2006-01-17 01:02 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ivo welch 2005-12-27 16:53:55 UTC
emerge --pretend --update world

These are the packages that I would merge, in order:

Calculating world dependencies /
!!! All ebuilds that could satisfy ">=app-text/poppler-0.4.3-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/poppler-0.4.3-r1 (masked by: ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
!!!    (dependency required by "app-text/xpdf-3.01-r4" [ebuild])



!!! Problem resolving dependencies for app-text/xpdf
!!! Depgraph creation failed.

Portage 2.0.53 (default-linux/amd64/2005.0, gcc-3.4.4, glibc-2.3.5-r2, 2.6.15-rc6 x86_64)
=================================================================
System uname: 2.6.15-rc6 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/lib64/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="POSIX"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa amd64 audiofile avi berkdb bitmap-fonts bzip2 bzlib cdr crypt cups curl dvd dvdr eds emboss encode esd exif expat f77 fam fbcon ffmpeg flac foomaticdb fortran g77 gdbm gif glut gnome gpm gstreamer gtk gtk2 idn imagemagick imlib ipv6 java jpeg kde lcms libwww lzw lzw-tiff mad mng motif mozilla mp3 mpeg ncurses nls nsplugin ogg openal opengl pam pcre pdflib perl png python qt quicktime readline sdl spell ssl tcltk tcpd tetex tiff truetype truetype-fonts type1-fonts udev usb userlocales vorbis xine xml xml2 xmms xpm xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, LANG, LDFLAGS, LINGUAS, PORTDIR_OVERLAY
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2005-12-27 17:00:07 UTC
Both ebuilds are ~amd64, you need to unmask the dependencies by putting them into /etc/portage/package.keywords as with any other ebuild.

Not a bug.
Comment 2 Joshua Jackson (RETIRED) gentoo-dev 2005-12-28 00:56:32 UTC
Unfortunately, on a related note (why this has been reopened) poplar has a !<app-text/xpdf-3.01-r1 in its RDEPEND, thus causing the issue of why its got a not that version. Anyone in app-text able to shed some light on this?
Comment 3 Stefan Schweizer (RETIRED) gentoo-dev 2005-12-28 01:46:16 UTC
The utils have been moved from xpdf to poppler. So it is no longer necessarry to have xpdf installed, you can safely unmerge it.
xpdf depends on poppler for now, so that apps do not break.
Comment 4 Daniel Gryniewicz (RETIRED) gentoo-dev 2005-12-28 09:00:16 UTC
The problem is that new xpdf needs new poppler, and new poppler blocks (installs the same programs as) old xpdf.  This should be resolvable in portage, but blocker resolution is not handled.  Unmerge xpdf, and let it's deps pull it back in, and everything will be fine.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 16:01:26 UTC
Reopen to resolve properly...
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 16:01:39 UTC

*** This bug has been marked as a duplicate of 79606 ***
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 16:03:20 UTC
*** Bug 116957 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2005-12-29 16:04:44 UTC
*** Bug 117049 has been marked as a duplicate of this bug. ***
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-01-01 06:36:32 UTC
*** Bug 117347 has been marked as a duplicate of this bug. ***
Comment 10 mark lybarger 2006-01-03 03:36:05 UTC
just to note, i'm still getting this error.  i uninstalled xpdf, and still have this issue.  

mark@expresso ~/mp3 $ emerge -upDv world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
[ebuild     U ] app-emulation/emul-linux-x86-xlibs-2.2.1 [2.1] +opengl 0 kB
[ebuild     U ] dev-db/libpq-8.0.4 [8.0.3] -kerberos +nls +pam +readline +ssl +zlib 7,641 kB
[ebuild     U ] dev-db/postgresql-8.0.4 [8.0.3] -doc -kerberos -libg++ +nls +pam +perl -pg-hier -pg-intdatetime +python +readline (-selinux) +ssl +tcltk +xml2 +zlib 130 kB
[ebuild  N    ] app-text/xpdf-3.01-r3  +X -motif 0 kB
[ebuild     U ] app-admin/fam-2.7.0-r4 [2.7.0-r2] 0 kB
[ebuild     U ] media-video/mjpegtools-1.8.0-r1 [1.6.2-r4] (-3dnow) +X -dga -dv +gtk (-mmx) +quicktime +sdl (-sse) -v4l -yv12 1,441 kB
[ebuild     U ] media-video/ffmpeg-0.4.9_p20051216 [0.4.9_p20050226-r5] -a52 -aac (-altivec) -debug -doc -dts +encode -ieee1394 +imlib (-mmx) -network +ogg* -oss +sdl -test -theora -threads +truetype* -v4l +vorbis* -xvid +zlib 1,679 kB
[ebuild     U ] media-libs/xine-lib-1.1.1-r3 [1.1.1-r2] +X -a52 -aac -aalib +alsa (-altivec) -arts -asf -cle266 -debug -directfb -dts +dvd -dxr3 +esd -fbcon +ffmpeg -flac +gnome -i8x0 +imagemagick +ipv6 -libcaca +mad +mng +nls -nvidia +opengl -oss +samba +sdl -speex -theora -v4l -vcd (-vidix) +vorbis (-win32codecs) -xinerama +xv -xvmc 8 kB
[ebuild     U ] media-video/transcode-0.6.14-r3 [0.6.14-r2] (-3dnow) +X -a52 (-altivec) -dv -dvdread +encode -fame +gtk +imagemagick* +jpeg -lzo -mjpeg (-mmx) +mpeg -network +ogg* +quicktime +sdl (-sse) (-sse2) -theora +truetype* -v4l +vorbis* +xml2 -xvid 2 kB
[ebuild     U ] net-wireless/ndiswrapper-1.7 [1.5] -debug 0 kB
[ebuild     U ] app-emulation/qemu-user-0.8.0 [0.7.2] 0 kB
[ebuild     U ] app-emulation/qemu-softmmu-0.8.0 [0.7.2] -kqemu +sdl 0 kB
[ebuild     U ] app-emulation/qemu-0.8.0 [0.7.2] 0 kB
[ebuild     U ] media-video/nvidia-kernel-1.0.8178 [1.0.8174-r1] 0 kB
[ebuild     U ] media-video/nvidia-glx-1.0.8178 [1.0.8174-r1] -dlloader 0 kB
[ebuild     U ] net-analyzer/ethereal-0.10.14 [0.10.13-r2] -adns +gtk +ipv6 -kerberos -snmp +ssl 0 kB
[ebuild     U ] app-text/poppler-0.4.3-r1 [0.4.3] -cairo +gtk +jpeg +qt +zlib 45 kB

Total size of downloads: 10,949 kB

my portage is uptodate.  this bug should be reopened.
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-01-04 04:51:45 UTC
*** Bug 117724 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-01-04 05:01:08 UTC
(In reply to comment #10)
> [ebuild  N    ] app-text/xpdf-3.01-r3  +X -motif 0 kB

> my portage is uptodate.  this bug should be reopened.

No, it shouldn't. Mixing stable and unstable packages won't work. You need to put xpdf, poppler and cups into /etc/portage/package.keywords. 
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-01-04 12:58:04 UTC
*** Bug 117778 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2006-01-06 06:38:12 UTC
*** Bug 118033 has been marked as a duplicate of this bug. ***
Comment 15 DEMAINE Benoît-Pierre, aka DoubleHP 2006-01-09 03:49:10 UTC
after 
emerge -Cav poppler xpdf
then
emerge -av poppler xpdf

did work fine. Readed about that in an other bug. Strange fix, but works for me
on ~x86
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2006-01-13 03:07:52 UTC
*** Bug 118861 has been marked as a duplicate of this bug. ***
Comment 17 Kerin Millar 2006-01-14 06:38:15 UTC
*** Bug 118987 has been marked as a duplicate of this bug. ***
Comment 18 Jakub Moc (RETIRED) gentoo-dev 2006-01-17 01:02:40 UTC
*** Bug 119250 has been marked as a duplicate of this bug. ***