Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 728592 - dev-lang/duktape: missing keywords for www-client/netsurf
Summary: dev-lang/duktape: missing keywords for www-client/netsurf
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Keywording (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Ian Whyman (thev00d00)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 728994
  Show dependency tree
 
Reported: 2020-06-17 21:17 UTC by Michael Orlitzky
Modified: 2020-06-27 10:07 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (2.4.0, ppc64) (duktape-2.4.0:20200621-185705.log,2.74 KB, text/plain)
2020-06-21 19:06 UTC, ernsteiswuerfel
no flags Details
build.log (2.4.0, ppc) (duktape-2.4.0:20200621-185547.log,2.76 KB, text/plain)
2020-06-21 19:07 UTC, ernsteiswuerfel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Orlitzky gentoo-dev 2020-06-17 21:17:17 UTC
www-client/netsurf uses duktape, but it's missing the dependency right now. The cynic in me thinks someone saw some repoman warnings, didn't know what to do with them, and then just ignored the problem. Well, the problem is that netsurf has keywords for arm, ppc, and ppc64 keywords, while duktape doesn't.

I see you've already added entries to arch/arm{,64}/package.use.mask to account for those keywords in other packages.

Does duktape fail to build on them? If it works, this is me asking that we just add the keywords and get it over with. Otherwise, we'll have to add package.mask entries for www-client/netsurf as well.
Comment 1 Larry the Git Cow gentoo-dev 2020-06-21 12:18:04 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca7819ae8a75cab9e401e3106415a6528cdd1f52

commit ca7819ae8a75cab9e401e3106415a6528cdd1f52
Author:     Michael Orlitzky <mjo@gentoo.org>
AuthorDate: 2020-06-21 01:43:05 +0000
Commit:     Michael Orlitzky <mjo@gentoo.org>
CommitDate: 2020-06-21 12:17:03 +0000

    www-client/netsurf: new version 3.10.
    
    This new version (bug 727882) combined with the removal of the old
    versions fixes some outstanding issues:
    
      * Fixes the mixup between ED/D (and EROOT, variously) throughout
        the build system (bug 489542).
    
      * Adds a dependency on dev-lang/duktape, but as a result, has to
        drop keywords for arm, ppc, and ppc64 (bugs 698650, 728592).
    
      * Adds a patch to fix the location of utf8proc.h (bug 721318)
    
      * Adds a patch to disable failing tests (bug 687378).
    
      * Drops the broken USE=pdf-writer flag (bug 625770).
    
      * Apparently fixes the test failure with USE="-gtk2", since the
        test suite now passes (bug 672812).
    
      * Eliminates another test failure in v3.8 (bug 701322).
    
    Bug: https://bugs.gentoo.org/489542
    Closes: https://bugs.gentoo.org/625770
    Closes: https://bugs.gentoo.org/672812
    Closes: https://bugs.gentoo.org/687378
    Closes: https://bugs.gentoo.org/698650
    Closes: https://bugs.gentoo.org/701322
    Closes: https://bugs.gentoo.org/721318
    Closes: https://bugs.gentoo.org/727882
    Bug: https://bugs.gentoo.org/728592
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Michael Orlitzky <mjo@gentoo.org>

 www-client/netsurf/Manifest                        |   1 +
 .../files/netsurf-3.10-disable-failing-tests.patch |  42 +++++++
 ...rf-3.10-julia-libutf8proc-header-location.patch |  34 ++++++
 www-client/netsurf/netsurf-3.10.ebuild             | 131 +++++++++++++++++++++
 4 files changed, 208 insertions(+)
Comment 2 ernsteiswuerfel 2020-06-21 19:06:56 UTC
Created attachment 645550 [details]
build.log (2.4.0, ppc64)

Builds fine on ppc64.
Comment 3 ernsteiswuerfel 2020-06-21 19:07:26 UTC
Created attachment 645552 [details]
build.log (2.4.0, ppc)

Builds fine on ppc.
Comment 4 Sam James archtester gentoo-dev Security 2020-06-25 21:25:31 UTC
Builds fine on arm64.
Comment 5 Michael Orlitzky gentoo-dev 2020-06-25 21:41:49 UTC
Thanks guys. Unless Ian objects soon, I'll add these keywords to both duktape-2.4.0 and netsurf-3.10 where I was forced to drop them.
Comment 6 Larry the Git Cow gentoo-dev 2020-06-27 10:07:25 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=de63736b4534e0b72f620ab5ce64e6f199cd1cb2

commit de63736b4534e0b72f620ab5ce64e6f199cd1cb2
Author:     Ian Whyman <thev00d00@gentoo.org>
AuthorDate: 2020-06-27 10:06:36 +0000
Commit:     Ian Whyman <thev00d00@gentoo.org>
CommitDate: 2020-06-27 10:07:17 +0000

    dev-lang/duktape: Version bump, add arch, respect CC
    
    Closes: https://bugs.gentoo.org/721792
    Closes: https://bugs.gentoo.org/727864
    Closes: https://bugs.gentoo.org/728592
    Package-Manager: Portage-2.3.103, Repoman-2.3.23
    Signed-off-by: Ian Whyman <thev00d00@gentoo.org>

 dev-lang/duktape/Manifest                                  |  2 +-
 .../duktape/{duktape-2.2.1.ebuild => duktape-2.5.0.ebuild} | 14 ++++++++++----
 2 files changed, 11 insertions(+), 5 deletions(-)