Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 687378 - www-client/netsurf-3.8-r2 : [TEST] make: *** [test/Makefile:<snip>: bloom_test] Error 1
Summary: www-client/netsurf-3.8-r2 : [TEST] make: *** [test/Makefile:<snip>: bloom_tes...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Philipp Ammann
URL: https://bugs.netsurf-browser.org/mant...
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2019-06-04 18:50 UTC by Toralf Förster
Modified: 2020-06-21 12:17 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,19.94 KB, text/plain)
2019-06-04 18:50 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,119.49 KB, text/plain)
2019-06-04 18:50 UTC, Toralf Förster
Details
environment (environment,65.75 KB, text/plain)
2019-06-04 18:50 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,12.97 KB, application/x-bzip)
2019-06-04 18:50 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,34.65 KB, application/x-bzip)
2019-06-04 18:50 UTC, Toralf Förster
Details
www-client:netsurf-3.8-r2:20190604-175508.log (www-client:netsurf-3.8-r2:20190604-175508.log,859.57 KB, text/plain)
2019-06-04 18:50 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2019-06-04 18:50:32 UTC
test/bloom.c:56:S:Match:bloom_match_test:0: Assertion 'dictf != ((void *)0)' failed
test/bloom.c:56:S:False positive rate:bloom_falsepositive_test:0: Assertion 'dictf != ((void *)0)' failed
make: *** [test/Makefile:199: bloom_test] Error 1
 * ERROR: www-client/netsurf-3.8-r2::gentoo failed (test phase):
 *   emake failed
 * 

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.1-desktop-plasma_test_20190531-023321

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-7.3.1
 [2] x86_64-pc-linux-gnu-8.3.1
 [3] x86_64-pc-linux-gnu-9.1.0 *

Available Python interpreters, in order of preference:
  [1]   python3.7
  [2]   python3.6
  [3]   python2.7 (fallback)

Available Rust versions:
  [1]   rust-1.35.0 *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.12.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm

emerge -qpvO www-client/netsurf
[ebuild  N    ] www-client/netsurf-3.8-r2  USE="bmp duktape gif gtk javascript jpeg mng png psl rosprite svg svgtiny truetype webp -fbcon -fbcon_frontend_sdl -fbcon_frontend_vnc -fbcon_frontend_x -gtk2 -pdf-writer"
Comment 1 Toralf Förster gentoo-dev 2019-06-04 18:50:35 UTC
Created attachment 578794 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2019-06-04 18:50:38 UTC
Created attachment 578796 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2019-06-04 18:50:40 UTC
Created attachment 578798 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2019-06-04 18:50:43 UTC
Created attachment 578800 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2019-06-04 18:50:45 UTC
Created attachment 578802 [details]
temp.tbz2
Comment 6 Toralf Förster gentoo-dev 2019-06-04 18:50:48 UTC
Created attachment 578804 [details]
www-client:netsurf-3.8-r2:20190604-175508.log
Comment 7 Michael Orlitzky gentoo-dev 2020-06-17 22:10:16 UTC
This is reproducible in 3.10, and if I patch out the bloom test, I get the next failure...

RUN TEST: hashtable
LD_LIBRARY_PATH=build/Linux-test/ build/Linux-test/hashtable
Running suite(s): hash table filter
86%: Checks: 15, Failures: 2, Errors: 0
test/hashtable.c:102:S:small table dictionary:hashtable_dict_test:0: Assertion 'dictf != ((void *)0)' failed
test/hashtable.c:102:S:large table dictionary:hashtable_dict_test:0: Assertion 'dictf != ((void *)0)' failed
make: *** [test/Makefile:204: hashtable_test] Error 1

Will report upstream soon. In the meantime, I'll see how many tests I have to patch out to get it working.
Comment 8 Michael Orlitzky gentoo-dev 2020-06-17 22:14:11 UTC
Those look to be the only two that I have to patch out, but this doesn't look quite right either:

RUN TEST: nsurl
LD_LIBRARY_PATH=build/Linux-test/ build/Linux-test/nsurl
Running suite(s): nsurl
nsurl: utils/nsurl/parse.c:1274: nsurl_create: Assertion `url_s != NULL' failed.
nsurl: utils/nsurl/nsurl.c:75: nsurl_ref: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:86: nsurl_unref: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:105: nsurl_compare: Assertion `url1 != NULL' failed.
nsurl: utils/nsurl/nsurl.c:106: nsurl_compare: Assertion `url2 != NULL' failed.
nsurl: utils/nsurl/nsurl.c:184: nsurl_get: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:194: nsurl_get_component: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:232: nsurl_get_component: Assertion `0' failed.
nsurl: utils/nsurl/nsurl.c:251: nsurl_has_component: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:308: nsurl_has_component: Assertion `0' failed.
nsurl: utils/nsurl/nsurl.c:318: nsurl_access: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:404: nsurl_access_leaf: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:434: nsurl_length: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:443: nsurl_hash: Assertion `url != NULL' failed.
nsurl: utils/nsurl/parse.c:1356: nsurl_join: Assertion `base != NULL' failed.
nsurl: utils/nsurl/parse.c:1357: nsurl_join: Assertion `rel != NULL' failed.
nsurl: utils/nsurl/nsurl.c:455: nsurl_defragment: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:523: nsurl_refragment: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:524: nsurl_refragment: Assertion `frag != NULL' failed.
nsurl: utils/nsurl/nsurl.c:594: nsurl_replace_query: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:595: nsurl_replace_query: Assertion `query != NULL' failed.
nsurl: utils/nsurl/nsurl.c:595: nsurl_replace_query: Assertion `query != NULL' failed.
nsurl: utils/nsurl/nsurl.c:776: nsurl_nice: Assertion `url != NULL' failed.
nsurl: utils/nsurl/nsurl.c:881: nsurl_parent: Assertion `url != NULL' failed.
Comment 9 Michael Orlitzky gentoo-dev 2020-06-18 22:23:18 UTC
Reported upstream at $URL.
Comment 10 Larry the Git Cow gentoo-dev 2020-06-21 12:17:44 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca7819ae8a75cab9e401e3106415a6528cdd1f52

commit ca7819ae8a75cab9e401e3106415a6528cdd1f52
Author:     Michael Orlitzky <mjo@gentoo.org>
AuthorDate: 2020-06-21 01:43:05 +0000
Commit:     Michael Orlitzky <mjo@gentoo.org>
CommitDate: 2020-06-21 12:17:03 +0000

    www-client/netsurf: new version 3.10.
    
    This new version (bug 727882) combined with the removal of the old
    versions fixes some outstanding issues:
    
      * Fixes the mixup between ED/D (and EROOT, variously) throughout
        the build system (bug 489542).
    
      * Adds a dependency on dev-lang/duktape, but as a result, has to
        drop keywords for arm, ppc, and ppc64 (bugs 698650, 728592).
    
      * Adds a patch to fix the location of utf8proc.h (bug 721318)
    
      * Adds a patch to disable failing tests (bug 687378).
    
      * Drops the broken USE=pdf-writer flag (bug 625770).
    
      * Apparently fixes the test failure with USE="-gtk2", since the
        test suite now passes (bug 672812).
    
      * Eliminates another test failure in v3.8 (bug 701322).
    
    Bug: https://bugs.gentoo.org/489542
    Closes: https://bugs.gentoo.org/625770
    Closes: https://bugs.gentoo.org/672812
    Closes: https://bugs.gentoo.org/687378
    Closes: https://bugs.gentoo.org/698650
    Closes: https://bugs.gentoo.org/701322
    Closes: https://bugs.gentoo.org/721318
    Closes: https://bugs.gentoo.org/727882
    Bug: https://bugs.gentoo.org/728592
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Michael Orlitzky <mjo@gentoo.org>

 www-client/netsurf/Manifest                        |   1 +
 .../files/netsurf-3.10-disable-failing-tests.patch |  42 +++++++
 ...rf-3.10-julia-libutf8proc-header-location.patch |  34 ++++++
 www-client/netsurf/netsurf-3.10.ebuild             | 131 +++++++++++++++++++++
 4 files changed, 208 insertions(+)