Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 625770 - www-client/netsurf-3.6 will not build with USE pdf-writer: ./desktop/font_haru.h:30:26: fatal error: desktop/font.h: No such file or directory
Summary: www-client/netsurf-3.6 will not build with USE pdf-writer: ./desktop/font_har...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal with 1 vote (vote)
Assignee: Philipp Ammann
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-21 00:46 UTC by deference
Modified: 2020-06-21 12:17 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build-netsurf.txt,143.03 KB, text/plain)
2017-07-21 00:46 UTC, deference
Details
emerge --info (emergeinfo-netsurf.txt,31.98 KB, text/plain)
2017-07-21 00:46 UTC, deference
Details

Note You need to log in before you can comment on or make changes to this bug.
Description deference 2017-07-21 00:46:11 UTC
rm -f build-Linux-framebuffer/deps/desktop_font_haru.d
rm -f build-Linux-framebuffer/desktop_font_haru.o
x86_64-pc-linux-gnu-gcc -W -Wall -Wundef -Wpointer-arith -Wcast-align -Wwrite-strings -Wmissing-declarations -Wuninitialized -Wno-unused-parameter -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -I. -Iinclude -Ibuild-Linux-framebuffer -Ifrontends -Icontent/handlers -pipe -O2  -DWITH_JPEG -DWITH_PDF_EXPORT -DLIBICONV_PLUG     -DUTF8PROC_EXPORTS  -I/usr/kerberos/include  -DWITH_CURL -I/usr/kerberos/include  -DWITH_OPENSSL -I/usr/include/libpng16  -DWITH_PNG -I/usr/include/  -DWITH_BMP  -DWITH_GIF  -DWITH_NS_SVG  -DWITH_NSSPRITE  -DWITH_NSPSL -DNETSURF_UA_FORMAT_STRING=\""NetSurf/%d.%d (%s)"\" -DNETSURF_HOMEPAGE=\""about:welcome"\" -Dnsframebuffer  '-DNETSURF_FB_RESPATH="${HOME}/.netsurf/:${NETSURFRES}:/usr/share/netsurf/:./frontends/framebuffer/res"' '-DNETSURF_FB_FONTPATH="/usr/share/fonts/dejavu"' '-DNETSURF_FB_FONT_SANS_SERIF="DejaVuSans.ttf"' '-DNETSURF_FB_FONT_SANS_SERIF_BOLD="DejaVuSans-Bold.ttf"' '-DNETSURF_FB_FONT_SANS_SERIF_ITALIC="DejaVuSans-Oblique.ttf"' '-DNETSURF_FB_FONT_SANS_SERIF_ITALIC_BOLD="DejaVuSans-BoldOblique.ttf"' '-DNETSURF_FB_FONT_SERIF="DejaVuSerif.ttf"' '-DNETSURF_FB_FONT_SERIF_BOLD="DejaVuSerif-Bold.ttf"' '-DNETSURF_FB_FONT_MONOSPACE="DejaVuSansMono.ttf"' '-DNETSURF_FB_FONT_MONOSPACE_BOLD="DejaVuSansMono-Bold.ttf"' '-DNETSURF_FB_FONT_CURSIVE="Comic_Sans_MS.ttf"' '-DNETSURF_FB_FONT_FANTASY="Impact.ttf"' -std=c99 -Dsmall -D_BSD_SOURCE -D_DEFAULT_SOURCE -D_XOPEN_SOURCE=600 -D_POSIX_C_SOURCE=200809L -D_GNU_SOURCE=1 -D_REENTRANT -I/usr/include/SDL  -DFB_USE_FREETYPE -I/usr/include/freetype2 -pipe -O2 -MMD -MT 'build-Linux-framebuffer/deps/desktop_font_haru.d build-Linux-framebuffer/desktop_font_haru.o' -MF build-Linux-framebuffer/deps/desktop_font_haru.d -o build-Linux-framebuffer/desktop_font_haru.o -c desktop/font_haru.c
In file included from desktop/font_haru.c:40:0:
./desktop/font_haru.h:30:26: fatal error: desktop/font.h: No such file or directory
 #include "desktop/font.h"
                          ^
compilation terminated.
make: *** [Makefile:832: build-Linux-framebuffer/desktop_font_haru.o] Error 1

[ebuild   R   ] www-client/netsurf-3.6  USE="bmp fbcon fbcon_frontend_sdl gif gstreamer gtk javascript jpeg mng pdf-writer* png psl rosprite svg svgtiny truetype webp -debug -duktape -fbcon_frontend_able -fbcon_frontend_linux -fbcon_frontend_vnc -fbcon_frontend_x -gtk2 -gtk3" ABI_X86="(64) -32 (-x32)"
Comment 1 deference 2017-07-21 00:46:28 UTC
Created attachment 486142 [details]
build.log
Comment 2 deference 2017-07-21 00:46:39 UTC
Created attachment 486144 [details]
emerge --info
Comment 3 Susan Wilson 2017-09-23 22:20:55 UTC
I can reproduce this bug for `www-client/netsurf-3.6`. The bug only manifests when `netsurf` is compiled with the `pdf-writer` useflag, otherwise build completes fine.
Comment 4 Virgil Dupras gentoo-dev 2018-12-02 03:07:52 UTC
I'm discovering the "pdf-writer" situation and it seems that upstream doesn't care much about its "HARU_PDF" option. We already significantly patch the code from bug 555906 and now it breaks again from what looks like a commit from 2016: http://source.netsurf-browser.org/netsurf.git/commit/?id=974a4a21e16a2da85a66aae9b80eeca15ca26dd6

Building with NETSURF_USE_HARU_PDF=YES simply doesn't work. If upstream can leave this option broken for so long, I wonder if it's a good idea to force this feature in through patching.

I'm tempted to get rid of the USE flag in the next bump.
Comment 5 Larry the Git Cow gentoo-dev 2020-06-21 12:17:56 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=ca7819ae8a75cab9e401e3106415a6528cdd1f52

commit ca7819ae8a75cab9e401e3106415a6528cdd1f52
Author:     Michael Orlitzky <mjo@gentoo.org>
AuthorDate: 2020-06-21 01:43:05 +0000
Commit:     Michael Orlitzky <mjo@gentoo.org>
CommitDate: 2020-06-21 12:17:03 +0000

    www-client/netsurf: new version 3.10.
    
    This new version (bug 727882) combined with the removal of the old
    versions fixes some outstanding issues:
    
      * Fixes the mixup between ED/D (and EROOT, variously) throughout
        the build system (bug 489542).
    
      * Adds a dependency on dev-lang/duktape, but as a result, has to
        drop keywords for arm, ppc, and ppc64 (bugs 698650, 728592).
    
      * Adds a patch to fix the location of utf8proc.h (bug 721318)
    
      * Adds a patch to disable failing tests (bug 687378).
    
      * Drops the broken USE=pdf-writer flag (bug 625770).
    
      * Apparently fixes the test failure with USE="-gtk2", since the
        test suite now passes (bug 672812).
    
      * Eliminates another test failure in v3.8 (bug 701322).
    
    Bug: https://bugs.gentoo.org/489542
    Closes: https://bugs.gentoo.org/625770
    Closes: https://bugs.gentoo.org/672812
    Closes: https://bugs.gentoo.org/687378
    Closes: https://bugs.gentoo.org/698650
    Closes: https://bugs.gentoo.org/701322
    Closes: https://bugs.gentoo.org/721318
    Closes: https://bugs.gentoo.org/727882
    Bug: https://bugs.gentoo.org/728592
    Package-Manager: Portage-2.3.99, Repoman-2.3.22
    Signed-off-by: Michael Orlitzky <mjo@gentoo.org>

 www-client/netsurf/Manifest                        |   1 +
 .../files/netsurf-3.10-disable-failing-tests.patch |  42 +++++++
 ...rf-3.10-julia-libutf8proc-header-location.patch |  34 ++++++
 www-client/netsurf/netsurf-3.10.ebuild             | 131 +++++++++++++++++++++
 4 files changed, 208 insertions(+)