Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 682558 - =media-video/ffmpeg-4.1.3: stabilization
Summary: =media-video/ffmpeg-4.1.3: stabilization
Status: IN_PROGRESS
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: ffmpeg-4 681368 678146 681494 684522 686452 686456 686594 688808
Blocks: 628186 681496
  Show dependency tree
 
Reported: 2019-04-04 23:22 UTC by Aaron Bauman
Modified: 2019-08-31 21:20 UTC (History)
14 users (show)

See Also:
Package list:
media-video/ffmpeg-4.1.3 media-libs/gegl-0.2.0-r6 media-plugins/gst-plugins-libav-1.14.4.4.1.3_p20190329 media-libs/codec2-0.8.1 media-libs/libaom-1.0.0-r2 media-plugins/frei0r-plugins-1.6.1 hppa media-libs/nv-codec-headers-8.1.24.2 x86
Runtime testing required: No
stable-bot: sanity-check+


Attachments
tatt-tests + rdeps (ppc64) (ffmpeg-682558.report,13.29 KB, text/plain)
2019-08-29 15:10 UTC, ernsteiswuerfel
no flags Details
tatt-tests + rdeps (ppc) (ffmpeg-682558.report,13.61 KB, text/plain)
2019-08-31 21:20 UTC, ernsteiswuerfel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-04-04 23:22:43 UTC
Two final bugs left in the ffmpeg-4.x tracker.  Both of which are masked.  Moving forward.

@arches, please stabilize.
Comment 1 Frank Krömmelbein 2019-04-05 07:25:34 UTC
1) Please add media-libs/nv-codec-headers-8.1.24.2 or -9.0.18.1 to the list, from ffmpeg-4.1.x ebuild
video_cards_nvidia? ( >=media-libs/nv-codec-headers-8.1.24.2[${MULTILIB_USEDEP}] )

2) Also media-plugins/gst-plugins-libav-1.14.4.4.1.3_p20190329.ebuild needs to be stabilized too. Current stable version requires <media-video/ffmpeg-4.

diff -ruN gst-plugins-libav-1.14.4.3.4.5.ebuild gst-plugins-libav-1.14.4.4.1.3_p20190329.ebuild 

-       !libav? (
-               >=media-video/ffmpeg-3.2.6:0=[${MULTILIB_USEDEP}]
-               <media-video/ffmpeg-4 )
+       !libav? ( >=media-video/ffmpeg-4:0=[${MULTILIB_USEDEP}] )


You may need further more stabilizations...
Comment 2 Mart Raudsepp gentoo-dev 2019-04-05 08:18:56 UTC
Please handle things gracefully for stabilization at least, not like what happened with unmasking.
First off I spot missing gst-plugins-libav, so people will yet again get cycles from something wanting to upgrade to ffmpeg-4, and stable gst-plugins-libav remaining at ffmpeg-3 requiring version.
As I doubt this is the only problem, I am taking the liberty of removing arches from CC, as if even that wasn't checked, I have a hard time believing the rest is clean (comment #1 already mentions another).

I also do not see any maintainer ACKs on this.
Comment 3 Alexis Ballier gentoo-dev 2019-04-05 08:59:20 UTC
This needs a tinderbox run with bugs found being added as blockers before moving forward.

Toralf, could you please handle this ?
Comment 4 Andreas Sturmlechner gentoo-dev 2019-05-15 21:00:44 UTC
Adding bug 685260 to at least try some coordination to minimise qtwebengine rebuilds.
Comment 5 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-05-21 05:27:22 UTC
let's CC some folks now and see what stablebot has to say...
Comment 6 Stabilization helper bot gentoo-dev 2019-05-21 06:04:29 UTC
An automated check of this bug failed - repoman reported dependency errors (197 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 7 Stabilization helper bot gentoo-dev 2019-05-21 07:04:53 UTC
An automated check of this bug failed - repoman reported dependency errors (139 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 8 Frank Krömmelbein 2019-05-21 07:20:00 UTC
Wrong arch was stabilized for media-plugins/gst-plugins-libav-1.14.4.4.1.3_p20190329, comment says for amd64 but arm64 was stabilized:
https://github.com/gentoo/gentoo/commit/0bb503f681e14923c9b3c636ab4a42ad633fbb2f
media-plugins/gst-plugins-libav: amd64 stable
but:
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
Comment 9 Stabilization helper bot gentoo-dev 2019-05-21 09:04:43 UTC
An automated check of this bug failed - repoman reported dependency errors (139 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 10 Stabilization helper bot gentoo-dev 2019-05-21 10:05:00 UTC
An automated check of this bug failed - repoman reported dependency errors (139 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 11 Stabilization helper bot gentoo-dev 2019-05-21 18:05:02 UTC
An automated check of this bug failed - repoman reported dependency errors (139 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 12 Stabilization helper bot gentoo-dev 2019-05-21 19:04:44 UTC
An automated check of this bug failed - repoman reported dependency errors (136 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: arm(default/linux/arm/17.0) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-plugins/frei0r-plugins', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-plugins/frei0r-plugins', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: ia64(default/linux/ia64/17.0) ['media-libs/codec2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/libaom-1.0.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lv2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'media-libs/lilv[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=media-libs/zimg-2.7.4:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=media-libs/sratom-0.6.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
Comment 13 Stabilization helper bot gentoo-dev 2019-05-22 02:05:49 UTC
An automated check of this bug failed - repoman reported dependency errors (315 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: arm(default/linux/arm/17.0) ['media-plugins/frei0r-plugins', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['media-plugins/frei0r-plugins', '>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: ia64(default/linux/ia64/17.0) ['>=net-libs/srt-1.3.0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/lilv/lilv-0.24.2-r2.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=dev-libs/serd-0.28.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-libs/sord-0.16.0-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-libs/sratom/sratom-0.6.0-r1.ebuild: DEPEND: alpha(default/linux/alpha/17.0) ['>=dev-libs/serd-0.28.0-r1', '>=dev-libs/sord-0.16.0-r1']
> dependency.bad media-libs/sratom/sratom-0.6.0-r1.ebuild: RDEPEND: alpha(default/linux/alpha/17.0) ['>=dev-libs/serd-0.28.0-r1', '>=dev-libs/sord-0.16.0-r1']
> dependency.bad media-libs/sratom/sratom-0.6.0-r1.ebuild: DEPEND: alpha(default/linux/alpha/17.0/desktop) ['>=dev-libs/serd-0.28.0-r1', '>=dev-libs/sord-0.16.0-r1']
Comment 14 Stabilization helper bot gentoo-dev 2019-05-22 03:07:05 UTC
An automated check of this bug failed - repoman reported dependency errors (80 lines truncated): 

> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: x86(default/linux/x86/17.0) ['>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: RDEPEND: x86(default/linux/x86/17.0) ['>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-video/ffmpeg/ffmpeg-4.1.3.ebuild: DEPEND: x86(default/linux/x86/17.0/desktop) ['>=media-libs/nv-codec-headers-8.1.24.2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]']
> dependency.bad media-plugins/frei0r-plugins/frei0r-plugins-1.6.1.ebuild: DEPEND: arm(default/linux/arm/17.0) ['>=media-libs/opencv-2.3.0:=', '>=media-libs/gavl-1.2.0']
> dependency.bad media-plugins/frei0r-plugins/frei0r-plugins-1.6.1.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['>=media-libs/opencv-2.3.0:=', '>=media-libs/gavl-1.2.0']
> dependency.badindev media-plugins/frei0r-plugins/frei0r-plugins-1.6.1.ebuild: DEPEND: arm(default/linux/arm/17.0/armv4) ['>=media-libs/opencv-2.3.0:=', '>=media-libs/gavl-1.2.0']
Comment 15 Stabilization helper bot gentoo-dev 2019-05-22 04:07:52 UTC
An automated check of this bug failed - repoman reported dependency errors (61 lines truncated): 

> dependency.bad media-libs/opencv/opencv-3.4.1-r5.ebuild: DEPEND: arm(default/linux/arm/17.0) ['sci-libs/hdf5', 'sci-libs/gdal:=', '>=virtual/jre-1.6:*', 'app-text/tesseract[opencl=]', 'dev-cpp/tbb[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'dev-cpp/eigen:3', '>=virtual/jdk-1.6', '>=dev-java/java-config-2.2.0-r3', '>=dev-java/ant-core-1.8.2:0', '>=dev-java/javatoolkit-0.3.0-r2']
> dependency.bad media-libs/opencv/opencv-3.4.1-r5.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['sci-libs/hdf5', 'sci-libs/gdal:=', '>=virtual/jre-1.6:*', 'app-text/tesseract[opencl=]', 'dev-cpp/tbb[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', '>=dev-java/java-config-2.2.0-r3']
> dependency.badindev media-libs/opencv/opencv-3.4.1-r5.ebuild: DEPEND: arm(default/linux/arm/17.0/armv4) ['sci-libs/hdf5', 'sci-libs/gdal:=', '>=virtual/jre-1.6:*', 'app-text/tesseract[opencl=]', 'dev-cpp/tbb[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_riscv_lp64d(-)?,abi_riscv_lp64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]', 'dev-cpp/eigen:3', '>=virtual/jdk-1.6', '>=dev-java/java-config-2.2.0-r3', '>=dev-java/ant-core-1.8.2:0', '>=dev-java/javatoolkit-0.3.0-r2']
Comment 16 Stabilization helper bot gentoo-dev 2019-05-22 05:00:30 UTC
An automated check of this bug failed - the following invalid arches are referenced in the atom list:

dev-cpp/tbb-2017.20161128
app-text/tesseract-3.05.01
dev-java/ant-core-1.10.5-r2
virtual/jre-1.8.0-r2
virtual/jdk-1.8.0-r3
sci-libs/gdal-2.4.1
dev-java/java-config-2.2.0-r4
Comment 17 Stabilization helper bot gentoo-dev 2019-05-22 06:09:53 UTC
An automated check of this bug failed - repoman reported dependency errors (180 lines truncated): 

> dependency.bad sci-libs/hdf5/hdf5-1.10.5.ebuild: DEPEND: arm(default/linux/arm/17.0) ['virtual/szip']
> dependency.bad sci-libs/hdf5/hdf5-1.10.5.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['virtual/szip']
> dependency.badindev sci-libs/hdf5/hdf5-1.10.5.ebuild: DEPEND: arm(default/linux/arm/17.0/armv4) ['virtual/szip']
> dependency.bad sci-libs/gdal/gdal-2.4.1.ebuild: DEPEND: arm(default/linux/arm/17.0) ['sci-libs/libgeotiff', 'sci-libs/armadillo:=[lapack]', 'sci-libs/netcdf:=', 'sci-libs/ogdi', 'dev-db/spatialite', 'dev-libs/freexl']
> dependency.bad sci-libs/gdal/gdal-2.4.1.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['sci-libs/libgeotiff', 'sci-libs/armadillo:=[lapack]', 'sci-libs/netcdf:=', 'sci-libs/ogdi', 'dev-db/spatialite', 'dev-libs/freexl']
> dependency.badindev sci-libs/gdal/gdal-2.4.1.ebuild: DEPEND: arm(default/linux/arm/17.0/armv4) ['sci-libs/libgeotiff', 'sci-libs/armadillo:=[lapack]', 'sci-libs/netcdf:=', 'sci-libs/ogdi', 'dev-db/spatialite', 'dev-libs/freexl']
> dependency.bad virtual/jdk/jdk-1.8.0-r3.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['dev-java/icedtea-bin:8']
> dependency.badindev virtual/jdk/jdk-1.8.0-r3.ebuild: RDEPEND: arm(default/linux/arm/17.0/armv4) ['dev-java/icedtea-bin:8']
> dependency.badindev virtual/jdk/jdk-1.8.0-r3.ebuild: RDEPEND: arm(default/linux/arm/17.0/armv4/desktop) ['dev-java/icedtea-bin:8']
> dependency.bad dev-java/java-config/java-config-2.2.0-r4.ebuild: RDEPEND: arm(default/linux/arm/17.0) ['sys-apps/baselayout-java']
> dependency.badindev dev-java/java-config/java-config-2.2.0-r4.ebuild: RDEPEND: arm(default/linux/arm/17.0/armv4) ['sys-apps/baselayout-java']
> dependency.badindev dev-java/java-config/java-config-2.2.0-r4.ebuild: RDEPEND: arm(default/linux/arm/17.0/armv4/desktop) ['sys-apps/baselayout-java']
Comment 18 Alexis Ballier gentoo-dev 2019-05-22 09:28:29 UTC
(In reply to Alexis Ballier from comment #3)
> This needs a tinderbox run with bugs found being added as blockers before
> moving forward.
> 
> Toralf, could you please handle this ?


What was not clear about this ?
Comment 19 Larry the Git Cow gentoo-dev 2019-05-22 10:47:59 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=324f100d6da10b54d48adbc22a4982c1d5b20602

commit 324f100d6da10b54d48adbc22a4982c1d5b20602
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2019-05-22 10:30:11 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2019-05-22 10:38:22 +0000

    profiles: arm: Extend media-video/ffmpeg[frei0r] stable-mask
    
    Bug: https://bugs.gentoo.org/682558
    Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>

 profiles/arch/arm/package.use.stable.mask | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 20 Andreas Sturmlechner gentoo-dev 2019-05-22 10:59:22 UTC
We need net-libs/srt-1.3.2 stable not just for alpha.
Comment 21 Andreas Sturmlechner gentoo-dev 2019-05-23 12:07:51 UTC
Moved lilv deps to lilv stabilisation in bug 686594.
Comment 22 Andreas Sturmlechner gentoo-dev 2019-06-06 19:53:32 UTC
Adding media-libs/gegl-0.2.0-r6, same case as media-plugins/gst-plugins-libav-1.14.4.4.1.3_p20190329 (blocks ffmpeg-4-stable and depends on ffmpeg-4-stable at the same time).
Comment 23 Pacho Ramos gentoo-dev 2019-06-30 12:00:52 UTC
it seems this was stabilized in some arches (I see amd64 and arm64) but not the others... also, I don't know what bug has been used finally for that to CC the other arches, does anyone know? I guess we should finally CC the other arches there too
Comment 24 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2019-07-05 16:07:09 UTC
(In reply to Pacho Ramos from comment #23)
> it seems this was stabilized in some arches (I see amd64 and arm64) but not
> the others... also, I don't know what bug has been used finally for that to
> CC the other arches, does anyone know? I guess we should finally CC the
> other arches there too

I used this bug to track it and stabilize ffmpeg.  It has been stable for quite some time.  The other arches can proceed once dependent bugs are cleared for their arches.
Comment 25 Pacho Ramos gentoo-dev 2019-07-06 19:46:19 UTC
we need to CC remaining arches then to proceed when they do blocking bugs as soom need to be done at the same time as newer ffmpeg
Comment 26 Andreas Sturmlechner gentoo-dev 2019-07-07 18:52:43 UTC
(In reply to Pacho Ramos from comment #25)
> we need to CC remaining arches then to proceed when they do blocking bugs as
> soom need to be done at the same time as newer ffmpeg

Actually all that need to be at the same time as ffmpeg are already put together in this bug, not in blocking bugs.
Comment 27 Thomas Deutschmann gentoo-dev Security 2019-07-08 12:15:06 UTC
x86 stable
Comment 28 Andreas Sturmlechner gentoo-dev 2019-07-16 11:49:25 UTC
How was x86 stabilised without bug 686456 solved?
Comment 29 tt_1 2019-07-22 09:30:53 UTC
May I ask, why was ffmpeg-4.1.4 stabilized without noticing https://bugs.gentoo.org/690128 ?
Comment 30 tt_1 2019-07-22 09:35:50 UTC
Oh, I'm terribly sorry, I must have missread the git log. It's 3.4.6-r1 that was stabilized today.
Comment 31 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2019-07-28 13:53:34 UTC
arm stable
Comment 32 ernsteiswuerfel 2019-08-29 15:10:07 UTC
Created attachment 588508 [details]
tatt-tests + rdeps (ppc64)

Looking good on ppc64.

Failed packages: gegl-0.2.0-r6 (bug #639986)
Failed rdeps: gimp-2.8.22-r1 (bug #669080)
Blocked packages due to libav.
Comment 33 ernsteiswuerfel 2019-08-31 21:20:20 UTC
Created attachment 588604 [details]
tatt-tests + rdeps (ppc)

Looking good on ppc.

Failed packages: gegl-0.2.0-r6 (bug #639986), USE='rubberband -gpl' ffmpeg (bug #693218).