Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 639986 - media-libs/gegl-0.2.0-r2 - src_test(): buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.0'
Summary: media-libs/gegl-0.2.0-r2 - src_test(): buffer-test.o: undefined reference to ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: PPC Linux
: Normal normal (vote)
Assignee: Sergey Torokhov
URL:
Whiteboard:
Keywords: TESTFAILURE
Depends on:
Blocks:
 
Reported: 2017-12-05 22:04 UTC by ernsteiswuerfel
Modified: 2020-01-05 13:27 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_639986.txt,6.11 KB, text/plain)
2017-12-05 22:04 UTC, ernsteiswuerfel
Details
build.log (gegl_build.log,514.20 KB, text/plain)
2017-12-05 22:05 UTC, ernsteiswuerfel
Details
emerge --info (file_639986.txt,5.68 KB, text/plain)
2018-01-21 20:25 UTC, ernsteiswuerfel
Details
build.log (media-libs/gegl-0.2.0-r5) (build.log,455.93 KB, text/plain)
2018-01-21 20:26 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2017-12-05 22:04:39 UTC
Created attachment 508442 [details]
emerge --info

/usr/lib/gcc/powerpc-unknown-linux-gnu/6.4.0/../../../../powerpc-unknown-linux-gnu/bin/ld: buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.0'
/lib/libm.so.6: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make[5]: *** [Makefile:484: buffer-test] Error 1
make[5]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.2.0-r2/work/gegl-0.2.0/tests/buffer'
make[4]: *** [Makefile:805: check-am] Error 2
make[4]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.2.0-r2/work/gegl-0.2.0/tests/buffer'
make[3]: *** [Makefile:528: check-recursive] Error 1
make[3]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.2.0-r2/work/gegl-0.2.0/tests/buffer'
make[2]: *** [Makefile:808: check] Error 2
make[2]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.2.0-r2/work/gegl-0.2.0/tests/buffer'
make[1]: *** [Makefile:426: check-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-libs/gegl-0.2.0-r2/work/gegl-0.2.0/tests'
make: *** [Makefile:544: check-recursive] Error 1
 * ERROR: media-libs/gegl-0.2.0-r2::gentoo failed (test phase):
Comment 1 ernsteiswuerfel 2017-12-05 22:05:57 UTC
Created attachment 508444 [details]
build.log
Comment 2 ernsteiswuerfel 2018-01-21 20:25:17 UTC
media-libs/gegl-0.2.0-r5 also affected.
Comment 3 ernsteiswuerfel 2018-01-21 20:25:48 UTC
Created attachment 515758 [details]
emerge --info
Comment 4 ernsteiswuerfel 2018-01-21 20:26:55 UTC
Created attachment 515760 [details]
build.log (media-libs/gegl-0.2.0-r5)
Comment 5 Sergei Trofimovich gentoo-dev 2018-02-18 21:10:38 UTC
Same happens on ia64 when building tests:

libtool: link: ia64-unknown-linux-gnu-gcc -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/babl-0.1 -O2 -pipe -fdiagnostics-show-option -frecord-gcc-switches -Wall
-Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -DG_LOG_DOMAIN=\"GEGL-\"__FILE__ -Wl,-O1 -Wl,--hash-style=gnu -o .
libs/buffer-test buffer-test.o -Wl,--export-dynamic -pthread -pthread  ../../gegl/.libs/libgegl-0.2.so -lgmodule-2.0 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lbabl-0.1 -pthread
/usr/lib/gcc/ia64-unknown-linux-gnu/6.4.0/../../../../ia64-unknown-linux-gnu/bin/ld: buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.2'
/lib/libm.so.6.1: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
Comment 6 Sergei Trofimovich gentoo-dev 2020-01-05 12:42:57 UTC

*** This bug has been marked as a duplicate of bug 617430 ***
Comment 7 Sergei Trofimovich gentoo-dev 2020-01-05 12:49:13 UTC
Ah, no. Still fails on ia64:
/bin/sh ../../libtool  --tag=CC   --mode=link ia64-unknown-linux-gnu-gcc -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/lib/libffi/include -I/usr/include/glib-2.0 -I/usr/lib/glib
-2.0/include -I/usr/include/babl-0.1 -O2 -pipe -g -fdiagnostics-show-option -frecord-gcc-switches   -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self
-Wpointer-arith -Wold-style-definition -DG_LOG_DOMAIN=\"GEGL-\"__FILE__  -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -Wl,--as-needed -o buffer-test buffer-test.o ../../gegl/libgegl-0.2.la -Wl
,--export-dynamic -lgmodule-2.0 -pthread -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -pthread -lglib-2.0 -lbabl-0.1
libtool: link: ia64-unknown-linux-gnu-gcc -pthread -I/usr/include/libmount -I/usr/include/blkid -I/usr/lib/libffi/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/bab
l-0.1 -O2 -pipe -g -fdiagnostics-show-option -frecord-gcc-switches -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-defin
ition -DG_LOG_DOMAIN=\"GEGL-\"__FILE__ -Wl,-O1 -Wl,--hash-style=gnu -o .libs/buffer-test buffer-test.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ../../gegl/.libs/libgegl-0.2.so -
lgmodule-2.0 -lgio-2.0 -lgobject-2.0 -lgthread-2.0 -lglib-2.0 -lbabl-0.1 -pthread
/usr/lib/gcc/ia64-unknown-linux-gnu/9.2.0/../../../../ia64-unknown-linux-gnu/bin/ld: buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.2'
/usr/lib/gcc/ia64-unknown-linux-gnu/9.2.0/../../../../ia64-unknown-linux-gnu/bin/ld: /lib/libm.so.6.1: error adding symbols: DSO missing from command line
Comment 8 Larry the Git Cow gentoo-dev 2020-01-05 13:27:05 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=385dfbc785aed31726688504959be6e20896716c

commit 385dfbc785aed31726688504959be6e20896716c
Author:     Sergei Trofimovich <slyfox@gentoo.org>
AuthorDate: 2020-01-05 13:26:45 +0000
Commit:     Sergei Trofimovich <slyfox@gentoo.org>
CommitDate: 2020-01-05 13:26:59 +0000

    media-libs/gegl: add missing -lm to tests, bug #639986
    
    The change fixes underlinking on ia64:
    ```
    gnu/bin/ld: buffer-test.o: undefined reference to symbol 'floor@@GLIBC_2.2'
    /usr/lib/gcc/ia64-unknown-linux-gnu/9.2.0/../../../../ia64-unknown-linux-gnu/bin/ld:
        /lib/libm.so.6.1: error adding symbols: DSO missing from command line
    ```
    
    Closes: https://bugs.gentoo.org/639986
    Package-Manager: Portage-2.3.84, Repoman-2.3.20
    Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>

 media-libs/gegl/files/gegl-0.2.0-underlinking.patch | 13 +++++++++++++
 1 file changed, 13 insertions(+)