Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 693218 - media-video/ffmpeg-4.1.3 - configure: librubberband is gpl and --enable-gpl is not specified
Summary: media-video/ffmpeg-4.1.3 - configure: librubberband is gpl and --enable-gpl i...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-08-31 21:16 UTC by ernsteiswuerfel
Modified: 2019-09-02 12:00 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (file_693218.txt,5.99 KB, text/plain)
2019-08-31 21:16 UTC, ernsteiswuerfel
Details
config.log (config.log,56 bytes, text/plain)
2019-08-31 21:16 UTC, ernsteiswuerfel
Details
build.log (ffmpeg-4.1.3:20190831-210111.log,5.78 KB, text/plain)
2019-08-31 21:18 UTC, ernsteiswuerfel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ernsteiswuerfel 2019-08-31 21:16:18 UTC
Created attachment 588598 [details]
emerge --info

[...]
>>> Configuring source in /var/tmp/portage/media-video/ffmpeg-4.1.3/work/ffmpeg-4.1.3 ...
 * .ppc: running multilib-minimal_abi_src_configure
/var/tmp/portage/media-video/ffmpeg-4.1.3/work/ffmpeg-4.1.3/configure --prefix=/usr --libdir=/usr/lib --shlibdir=/usr/lib --docdir=/usr/share/doc/ffmpeg-4.1.3/html --mandir=/usr/share/man --enable-shared --cc=powerpc-unknown-linux-gnu-gcc --cxx=powerpc-unknown-linux-gnu-g++ --ar=powerpc-unknown-linux-gnu-ar --optflags=-O2 -mcpu=7450 -pipe --enable-static --enable-avfilter --enable-avresample --disable-stripping --disable-optimizations --disable-libcelt --disable-encoders --disable-indev=v4l2 --disable-outdev=v4l2 --disable-indev=alsa --disable-indev=oss --disable-indev=jack --disable-outdev=alsa --disable-outdev=oss --enable-version3 --disable-bzlib --disable-runtime-cpudetect --disable-debug --disable-gcrypt --enable-gnutls --enable-gmp --disable-gpl --enable-hardcoded-tables --disable-iconv --disable-libtls --disable-libxml2 --disable-lzma --enable-network --disable-opencl --disable-openssl --disable-postproc --disable-libsmbclient --disable-ffplay --disable-sdl2 --disable-vaapi --disable-vdpau --disable-xlib --disable-libxcb --disable-libxcb-shm --disable-libxcb-xfixes --enable-zlib --disable-libcdio --disable-libiec61883 --disable-libdc1394 --enable-libcaca --enable-openal --enable-opengl --disable-libv4l2 --disable-libpulse --disable-libdrm --disable-libjack --disable-libopencore-amrwb --disable-libopencore-amrnb --enable-libcodec2 --disable-libfdk-aac --enable-libopenjpeg --disable-libbluray --disable-libgme --enable-libgsm --disable-mmal --enable-libmodplug --enable-libopus --enable-libilbc --disable-librtmp --enable-libssh --enable-libspeex --disable-libsrt --enable-librsvg --disable-ffnvcodec --enable-libvorbis --disable-libvpx --enable-libzvbi --disable-appkit --disable-libbs2b --disable-chromaprint --enable-libflite --disable-frei0r --disable-libfribidi --disable-fontconfig --disable-ladspa --disable-libass --enable-lv2 --enable-libfreetype --enable-librubberband --enable-libzmq --disable-libzimg --disable-libsoxr --enable-pthreads --disable-armv5te --disable-armv6 --disable-armv6t2 --disable-neon --disable-vfp --disable-vfpv3 --disable-armv8 --disable-mipsdsp --disable-mipsdspr2 --disable-mipsfpu --disable-altivec --disable-amd3dnow --disable-amd3dnowext --disable-aesni --disable-avx --disable-avx2 --disable-fma3 --disable-fma4 --disable-mmx --disable-mmxext --disable-sse --disable-sse2 --disable-sse3 --disable-ssse3 --disable-sse4 --disable-sse42 --disable-xop --enable-pic --cpu=7450 --enable-doc --enable-htmlpages --enable-manpages
librubberband is gpl and --enable-gpl is not specified.

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "ffbuild/config.log" produced by configure as this will help
solve the problem.
 * ERROR: media-video/ffmpeg-4.1.3::gentoo failed (configure phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  125:  Called src_configure
 *   environment, line 3196:  Called multilib-minimal_src_configure
 *   environment, line 2272:  Called multilib_foreach_abi 'multilib-minimal_abi_src_configure'
 *   environment, line 2499:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2202:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *   environment, line 2200:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *   environment, line  718:  Called multilib-minimal_abi_src_configure
 *   environment, line 2266:  Called multilib_src_configure
 *   environment, line 2816:  Called die
 * The specific snippet of code:
 *       "${@}" || die;
Comment 1 ernsteiswuerfel 2019-08-31 21:16:52 UTC
Created attachment 588600 [details]
config.log
Comment 2 ernsteiswuerfel 2019-08-31 21:18:01 UTC
Created attachment 588602 [details]
build.log
Comment 3 Larry the Git Cow gentoo-dev 2019-09-02 12:00:03 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=fdb58e1242ae735a3a55baaaf9c17a7122b33c4b

commit fdb58e1242ae735a3a55baaaf9c17a7122b33c4b
Author:     Alexis Ballier <aballier@gentoo.org>
AuthorDate: 2019-09-02 11:59:37 +0000
Commit:     Alexis Ballier <aballier@gentoo.org>
CommitDate: 2019-09-02 11:59:50 +0000

    media-video/ffmpeg: add rubberband -> gpl req use.
    
    Closes: https://bugs.gentoo.org/693218
    Package-Manager: Portage-2.3.75, Repoman-2.3.17
    Signed-off-by: Alexis Ballier <aballier@gentoo.org>

 media-video/ffmpeg/ffmpeg-4.1.3.ebuild | 1 +
 media-video/ffmpeg/ffmpeg-4.1.4.ebuild | 1 +
 media-video/ffmpeg/ffmpeg-4.2.ebuild   | 1 +
 media-video/ffmpeg/ffmpeg-9999.ebuild  | 1 +
 4 files changed, 4 insertions(+)