Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 631800 - app-office/scribus-1.5.3-r1 stabilisation request
Summary: app-office/scribus-1.5.3-r1 stabilisation request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 622112 635170 642242 649688
Blocks: qt4-removal poppler-qt4-removal CVE-2017-14975, CVE-2017-14976, CVE-2017-14977 644456
  Show dependency tree
 
Reported: 2017-09-23 02:11 UTC by Michael Palimaka (kensington)
Modified: 2018-12-17 14:04 UTC (History)
2 users (show)

See Also:
Package list:
app-office/scribus-1.5.3-r1 amd64 ppc ppc64 x86 app-text/libmspub-0.1.2 amd64 ppc ppc64 x86 media-libs/libcdr-0.1.4 ppc media-libs/libfreehand-0.1.2 ppc ppc64 media-libs/libpagemaker-0.0.3-r1 ppc ppc64
Runtime testing required: ---
stable-bot: sanity-check+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Palimaka (kensington) gentoo-dev 2017-09-23 02:11:15 UTC
Is it OK to stabilise app-office/scribus-1.5.3 and remove older?
Comment 1 Justin Lecher gentoo-dev 2017-10-29 11:49:20 UTC
Yes, please stabilise.
Comment 2 Stabilization helper bot gentoo-dev 2017-10-30 11:00:38 UTC
An automated check of this bug failed - the following atom is unknown:

app-office/scribus-1.5.3-r1

Please verify the atom list.
Comment 3 Michael Palimaka (kensington) gentoo-dev 2017-10-30 11:02:38 UTC
@jlec, there is no -r1, is that something still to come?
Comment 4 Stabilization helper bot gentoo-dev 2017-10-30 12:00:57 UTC
An automated check of this bug failed - repoman reported dependency errors (29 lines truncated): 

> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: DEPEND: hppa(default/linux/hppa/13.0) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'media-libs/libvisio', 'dev-games/openscenegraph']
> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: RDEPEND: hppa(default/linux/hppa/13.0) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'media-libs/libvisio', 'dev-games/openscenegraph']
> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'dev-games/openscenegraph']
Comment 5 Stabilization helper bot gentoo-dev 2017-10-31 01:00:52 UTC
An automated check of this bug failed - repoman reported dependency errors (27 lines truncated): 

> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'dev-games/openscenegraph']
> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'dev-games/openscenegraph']
> dependency.bad app-office/scribus/scribus-1.5.3.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['app-text/libmspub', 'media-libs/libcdr', 'media-libs/libpagemaker', 'dev-games/openscenegraph']
Comment 6 Stabilization helper bot gentoo-dev 2017-12-14 12:04:07 UTC
An automated check of this bug failed - repoman reported dependency errors (57 lines truncated): 

> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['>=sci-geosciences/liblas-1.8.0']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: RDEPEND: ppc(default/linux/powerpc/ppc32/13.0) ['>=sci-geosciences/liblas-1.8.0']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc(default/linux/powerpc/ppc32/13.0/desktop) ['>=sci-geosciences/liblas-1.8.0']
Comment 7 Andreas Sturmlechner gentoo-dev 2017-12-20 21:11:24 UTC
 * QA Notice: .desktop files with MimeType= were found installed
 * but desktop mimeinfo cache has not been updated:
 *   /usr/share/applications/scribus.desktop
 * Please make sure to call xdg_desktop_database_update()
 * in pkg_postinst() and pkg_postrm() phases of appropriate pkgs.

^ let's please fix this before stabilisation.
Comment 8 Justin Lecher gentoo-dev 2017-12-20 21:35:40 UTC
(In reply to Andreas Sturmlechner from comment #7)
>  * QA Notice: .desktop files with MimeType= were found installed
>  * but desktop mimeinfo cache has not been updated:
>  *   /usr/share/applications/scribus.desktop
>  * Please make sure to call xdg_desktop_database_update()
>  * in pkg_postinst() and pkg_postrm() phases of appropriate pkgs.
> 
> ^ let's please fix this before stabilisation.

ommit de11ac2eb41f0f90829b4a73dc1ac377c30aa195
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Dec 20 21:26:59 2017 +0000

    app-office/scribus: fix eclass function names

    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=de11ac2eb41f0f90829b4a73dc1ac377c30aa195
Comment 9 Stabilization helper bot gentoo-dev 2017-12-20 22:02:23 UTC
An automated check of this bug failed - repoman reported dependency errors (17 lines truncated): 

> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland) ['media-libs/coin']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: RDEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland) ['media-libs/coin']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/13.0/64bit-userland/desktop) ['media-libs/coin']
Comment 10 Andreas Sturmlechner gentoo-dev 2017-12-20 22:19:10 UTC
PS: I've dropped hppa from stabilisation because Qt5 will not be stabilised on it either.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-12-20 22:26:44 UTC
Well that is somewhat escalating.
Comment 12 Stabilization helper bot gentoo-dev 2017-12-20 23:02:39 UTC
An automated check of this bug succeeded - the previous repoman errors are now resolved.
Comment 13 Andreas Sturmlechner gentoo-dev 2017-12-25 15:23:28 UTC
Switched to 1.5.3-r1 with fixed media-libs/libfreehand dependency.
Comment 14 Thomas Deutschmann gentoo-dev Security 2017-12-26 00:33:29 UTC
x86 stopped stabilization due to bug 642242.
Comment 15 Tobias Klausmann gentoo-dev 2018-01-15 19:05:20 UTC
Stable on amd64.
Comment 16 Thomas Deutschmann gentoo-dev Security 2018-01-17 05:11:06 UTC
x86 stable
Comment 17 Andreas Sturmlechner gentoo-dev 2018-02-28 20:56:36 UTC
powerpc ping
Comment 18 Sergei Trofimovich gentoo-dev 2018-03-04 22:14:58 UTC
dev-games/openscenegraph-3.5.1-r2 fails to build on 'unsigned char' platforms: bug #643042

I'll stable dev-games/openscenegraph-3.5.5 on ppc/ppc64 instead.
Comment 19 ernsteiswuerfel 2018-03-04 22:27:55 UTC
ATM I am testing scribus with tatt. Looks good so far. But I guess it will take my G5 a day or two. ;-)
Comment 20 Sergei Trofimovich gentoo-dev 2018-03-04 22:30:30 UTC
ppc stable
Comment 21 Stabilization helper bot gentoo-dev 2018-03-04 23:10:24 UTC
An automated check of this bug failed - repoman reported dependency errors (18 lines truncated): 

> dependency.bad sci-geosciences/liblas/liblas-1.8.1.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland) ['sci-libs/gdal']
> dependency.bad sci-geosciences/liblas/liblas-1.8.1.ebuild: RDEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland) ['sci-libs/gdal']
> dependency.bad sci-geosciences/liblas/liblas-1.8.1.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland/desktop) ['sci-libs/gdal']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland) ['sci-libs/gdal']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: RDEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland) ['sci-libs/gdal']
> dependency.bad dev-games/openscenegraph/openscenegraph-3.5.1-r2.ebuild: DEPEND: ppc64(default/linux/powerpc/ppc64/17.0/64bit-userland/desktop) ['sci-libs/gdal']
Comment 22 Andreas Sturmlechner gentoo-dev 2018-03-05 19:39:07 UTC
Breaking out newer dev-games/openscenegraph-3.5.5 into its own stabilisation bug.
Comment 23 Matt Turner gentoo-dev 2018-03-12 05:37:39 UTC
ppc64 stable
Comment 24 Larry the Git Cow gentoo-dev 2018-03-13 22:50:36 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=44fdb3b5863b58db7b6960d1a869ffdac2355374

commit 44fdb3b5863b58db7b6960d1a869ffdac2355374
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-03-12 18:26:19 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-03-13 22:50:14 +0000

    app-office/scribus: Drop 1.4.6
    
    Bug: https://bugs.gentoo.org/631800
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 app-office/scribus/Manifest                        |   1 -
 .../scribus/files/scribus-1.4.0-minizip.patch      |  60 --------
 app-office/scribus/scribus-1.4.6.ebuild            | 171 ---------------------
 3 files changed, 232 deletions(-)}