Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 622112 - app-office/scribus-1.5.3 : Could not find a package configuration file provided by "OPENSSL" with any
Summary: app-office/scribus-1.5.3 : Could not find a package configuration file prov...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Justin Lecher
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 631800
  Show dependency tree
 
Reported: 2017-06-18 14:30 UTC by Toralf Förster
Modified: 2017-12-20 21:36 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,6.09 KB, text/plain)
2017-06-18 14:30 UTC, Toralf Förster
Details
app-office:scribus-1.5.3:20170617-034447.log (app-office:scribus-1.5.3:20170617-034447.log,11.96 KB, text/plain)
2017-06-18 14:30 UTC, Toralf Förster
Details
CMakeOutput.log (CMakeOutput.log,39.31 KB, text/plain)
2017-06-18 14:30 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,260.72 KB, text/plain)
2017-06-18 14:30 UTC, Toralf Förster
Details
environment (environment,197.04 KB, text/plain)
2017-06-18 14:30 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,25.44 KB, application/x-bzip)
2017-06-18 14:30 UTC, Toralf Förster
Details
logs.tbz2 (logs.tbz2,4.05 KB, application/x-bzip)
2017-06-18 14:30 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,43.92 KB, application/x-bzip)
2017-06-18 14:31 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-06-18 14:30:37 UTC
  CMake did not find one.

  Could not find a package configuration file provided by "OPENSSL" with any
  of the following names:

    OPENSSLConfig.cmake

  -------------------------------------------------------------------

  This is an unstable amd64 chroot image at a tinderbox (==build bot)
  name: 17.0-desktop-plasma_abi32+64_20170611-104510

  -------------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *

Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
  [2]   ruby22 (with Rubygems)
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 3.4.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-bin-8  system-vm
Comment 1 Toralf Förster gentoo-dev 2017-06-18 14:30:40 UTC
Created attachment 476932 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-06-18 14:30:43 UTC
Created attachment 476934 [details]
app-office:scribus-1.5.3:20170617-034447.log
Comment 3 Toralf Förster gentoo-dev 2017-06-18 14:30:46 UTC
Created attachment 476936 [details]
CMakeOutput.log
Comment 4 Toralf Förster gentoo-dev 2017-06-18 14:30:49 UTC
Created attachment 476938 [details]
emerge-history.txt
Comment 5 Toralf Förster gentoo-dev 2017-06-18 14:30:52 UTC
Created attachment 476940 [details]
environment
Comment 6 Toralf Förster gentoo-dev 2017-06-18 14:30:55 UTC
Created attachment 476942 [details]
etc.portage.tbz2
Comment 7 Toralf Förster gentoo-dev 2017-06-18 14:30:58 UTC
Created attachment 476944 [details]
logs.tbz2
Comment 8 Toralf Förster gentoo-dev 2017-06-18 14:31:00 UTC
Created attachment 476946 [details]
temp.tbz2
Comment 9 Justin Lecher gentoo-dev 2017-10-21 20:51:37 UTC
The missing file is part of cmake. I cannot reproduce this and it is also not explainable. Any idea yourself?
Comment 10 Toralf Förster gentoo-dev 2017-10-24 16:33:12 UTC
In the past sometimes the tinderbox was blamed to had have a hickup. Maybe. If it is not ´a real world problem, I think it is safe to ignore it for now.
Comment 11 Andreas Sturmlechner gentoo-dev 2017-12-20 20:39:11 UTC
Arch has a simple patch for that, it's just a case error:

https://aur.archlinux.org/cgit/aur.git/tree/findOpenSSL.patch?h=scribus-devel
Comment 12 Justin Lecher gentoo-dev 2017-12-20 21:36:15 UTC
(In reply to Andreas Sturmlechner from comment #11)
> Arch has a simple patch for that, it's just a case error:
> 
> https://aur.archlinux.org/cgit/aur.git/tree/findOpenSSL.patch?h=scribus-devel

commit baa2b7d340e6636519d069ee235a429bd546d289
Author: Justin Lecher <jlec@gentoo.org>
Date:   Wed Dec 20 21:30:13 2017 +0000

    app-office/scribus: Patch openssl determination in cmake

    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    Package-Manager: Portage-2.3.19, Repoman-2.3.6

    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=baa2b7d340e6636519d069ee235a429bd546d289