Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 59055 - libbonobo-2.6.2 failed to emerge: configure script could not find perl module
Summary: libbonobo-2.6.2 failed to emerge: configure script could not find perl module
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 59144 59407 59785 59917 61351 62038 62922 63060 70806 (view as bug list)
Depends on:
Reported: 2004-07-31 23:58 UTC by Alexandr
Modified: 2005-02-20 07:23 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2004-07-31 23:58:34 UTC
era era $ sudo su
root era # emerge -U world
>>> --upgradeonly implies --update... adding --update to options.
Calculating world dependencies ...done!
>>> emerge (1 of 57) gnome-base/libbonobo-2.6.2 to /
>>> md5 src_uri ;-) libbonobo-2.6.2.tar.bz2
>>> Unpacking source...
>>> Unpacking libbonobo-2.6.2.tar.bz2 to /var/tmp/portage/libbonobo-2.6.2/work
>>> Source unpacked.
 * Patching ${S}/
 *   Applying portage-1.4.1.patch...
 *   Applying max_cmd_len-1.5.0.patch...
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-strip... no
checking for strip... strip
checking whether to enable maintainer-specific portions of Makefiles... no
checking for perl... /usr/bin/perl
configure: error: XML::Parser perl module is required for intltool

!!! ERROR: gnome-base/libbonobo-2.6.2 failed.
!!! Function econf, Line 362, Exitcode 1
!!! econf failed

root era # ls /usr/bin/ | grep perl
root era # emerge -p -v perl

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] dev-lang/perl-5.8.4  +berkdb -debug +doc +gdbm +threads -(uclibc)  0 kB 

Total size of downloads: 0 kB


System uname: 2.6.7-gentoo-r11 i686 Celeron (Coppermine) GenuineIntel
ccache ver.2.3
CFLAGS="-O2 -march=i686"
USE="kde qt gnome gtk alsa samba jabber -svga mmx sse threads doc"

Reproducible: Always
Steps to Reproduce:
Comment 1 bastian voigt 2004-08-01 03:53:27 UTC
got the same problem. Can be solved by installing dev-perl/XML-Parser

However the dependency should be added to the ebuild
Comment 2 Spider (RETIRED) gentoo-dev 2004-08-01 05:22:20 UTC
agh.. Fscking perl issues :-/

from the libbonobo ebuild:
        doc? ( >=dev-util/gtk-doc-1 )"

--- following the intltool :

Which means that we have an implicit dependency on XML::Parser (unless somone decides to "clean out" their system)

However, due to perl updates, and mostly, not runnning the libperl_rebuilder that would reinstall perl packages.

Could you please check the history of perl from /var/log/emerge.log ?  Updated, if so from what version to what version?

I'm inclined to mark this as INVALID because the Gnome dependencies are correct, but I want to get this resolved in some way.  Tagging as Needinfo for now.

Adding perl to CC.

Comment 3 Alexandr 2004-08-01 07:20:32 UTC
Yeah, I've solved the problem by reemergin XML-Parser:
$ USE="perl" emerge XML-Parser
$ emerge libbonobo
all emerged successfully.

History from /var/log/emerge.log:
sys-devel/libperl   5.8.2 --> 5.8.4
dev-lang/perl   5.8.2-r1 --> 5.8.4
dev-perl/XML-Parser   2.34 --> 2.34 (just rebuild)

I'm using Gentoo for about 2 week, so there is not so much updates.
Comment 4 Spider (RETIRED) gentoo-dev 2004-08-01 07:48:52 UTC
well, by doing a quick "qpkg -l XML-Parser" it shows that almost all files are installed in the perl versions subdir, so there isn't much to do there. The package was installed, but not accessible because of the perl upgrade.

perl folks, can -something- be done about this??
Comment 5 Spider (RETIRED) gentoo-dev 2004-08-02 10:43:59 UTC
*** Bug 59144 has been marked as a duplicate of this bug. ***
Comment 6 Ylosar Goer 2004-08-02 11:17:16 UTC
I have an upgrade from perl 5.8.2 to 5.8.4 in my emerge log. And all perl modules are still in 5.8.2 subdirs.

And *now* i see that eerror concerning libperl-rebuilder at the end of perl-5.8.4 ebuild... sorry.
Comment 7 Eric Brown 2004-08-03 05:26:40 UTC
yea i'm getting the same error, i have perl 5.8.4 also.

why don't we mark this as ~ until it's fixed.
Comment 8 Eric Brown 2004-08-03 05:32:57 UTC
I forgot to mention.. i have dev-perl/XML-Parser installed, and I never had perl-5.8.2 on this machine, so I'm not sure how any of this would fix the problem.    (unless dev-perl/XML-Parser has a problem where it didn't install correctly)

I should also note that I've reported other bugs with autoconf not detecting XML packages correctly.. odd
Comment 9 Fletch Hasues 2004-08-03 07:30:59 UTC
I think I know what causes this.  This person upgraded his Perl installation, and needs to re-emerge his XML-parser package.

If he or she will re-emerge dev-perl/XML-Parser, libbonobo will emerge correctly.
Comment 10 Ylosar Goer 2004-08-03 07:36:55 UTC
Better use /usr/portage/dev-lang/perl/files/libperl_rebuilder, as explained in perl-5.8.4.ebuild. This will rebuild *all* perl modules that are still 'attached' to a previous perl version. At least it worked for me.
Comment 11 Spider (RETIRED) gentoo-dev 2004-08-04 19:33:05 UTC
*** Bug 59407 has been marked as a duplicate of this bug. ***
Comment 12 Eric Brown 2004-08-05 21:07:34 UTC
yea that libperl_rebuild script seems to have worked, however it rebuilt tons of packages... took FOREVER ;)

how can we avoid this kind of thing in the future?
Comment 13 foser (RETIRED) gentoo-dev 2004-08-09 03:09:48 UTC
*** Bug 59785 has been marked as a duplicate of this bug. ***
Comment 14 foser (RETIRED) gentoo-dev 2004-08-10 01:47:58 UTC
*** Bug 59917 has been marked as a duplicate of this bug. ***
Comment 15 foser (RETIRED) gentoo-dev 2004-08-24 07:08:33 UTC
*** Bug 61351 has been marked as a duplicate of this bug. ***
Comment 16 foser (RETIRED) gentoo-dev 2004-08-29 05:26:41 UTC
*** Bug 62038 has been marked as a duplicate of this bug. ***
Comment 17 foser (RETIRED) gentoo-dev 2004-09-05 13:58:21 UTC
*** Bug 62922 has been marked as a duplicate of this bug. ***
Comment 18 Leonardo Boshell (RETIRED) gentoo-dev 2004-09-06 23:56:52 UTC
*** Bug 63060 has been marked as a duplicate of this bug. ***
Comment 19 Robert Moss (RETIRED) gentoo-dev 2004-11-11 11:36:21 UTC
*** Bug 70806 has been marked as a duplicate of this bug. ***
Comment 20 foser (RETIRED) gentoo-dev 2004-11-11 11:39:26 UTC
Comment 21 Thomas R. (TRauMa) 2005-02-20 07:23:51 UTC
OK, seems like now there is /usr/portage/dev-lang/perl/files/perl-cleaner to do this.

Am I really supposed to scan my emerge -Duvat world list for occurances of perl, check if minor version number changes, cancel the world update if so and manually upgrade perl with running perl-cleaner afterwards and restarting my world update?