Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 579946 - x11-drivers/xf86-video-virtualbox error: ‘makedev’ was not declared in this scope
Summary: x11-drivers/xf86-video-virtualbox error: ‘makedev’ was not declared in this s...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
: 579970 580544 612850 616296 (view as bug list)
Depends on:
Blocks: glibc-sysmacros glibc-2.26-stable
  Show dependency tree
 
Reported: 2016-04-14 09:48 UTC by Oleksii
Modified: 2018-04-29 21:42 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Please, see in attachment requested log file (build-fails-xf86-video-virtualbox-5.0.16.log.xz,18.59 KB, application/x-xz)
2016-04-14 14:30 UTC, Oleksii
Details
makedev header patch (xf86-video-virtualbox-5-makedev.patch,340 bytes, patch)
2016-04-15 12:35 UTC, Darren Smith
Details | Diff
add patch to ebuild (xf86-video-virtualbox-5.0.16.ebuild,4.56 KB, patch)
2016-04-15 12:37 UTC, Darren Smith
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksii 2016-04-14 09:48:48 UTC
After update to glibc Gentoo 2.23-r1 p4 I am unable compile app-emulation/virtualbox-guest-additions-5.0.16 and x11-drivers:xf86-video-virtualbox-5.0.16


Reproducible: Always




Current configuration - https://bpaste.net/show/c36e4a8e1ed7

The complete build log is
https://bpaste.net/show/285da5016786
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2016-04-14 13:44:25 UTC
Please attach the build.log file to this bug. If bugzilla says it's too big, attach the file xz-compressed.
Comment 2 Oleksii 2016-04-14 14:30:01 UTC
Created attachment 430444 [details]
Please, see in attachment requested log file
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2016-04-14 19:11:27 UTC
There's already bug #579910 about the guest-additions so let's use this bug for the video driver.
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2016-04-14 19:14:00 UTC
*** Bug 579970 has been marked as a duplicate of this bug. ***
Comment 5 Darren Smith 2016-04-15 12:35:24 UTC
Created attachment 430606 [details, diff]
makedev header patch

Add header for makedev to sysfs.cpp.
Comment 6 Darren Smith 2016-04-15 12:37:27 UTC
Created attachment 430608 [details, diff]
add patch to ebuild

Apply makedev patch in ebuild.
Comment 7 Darren Smith 2016-04-15 12:48:13 UTC
I just remembered that the ebuild I posted also includes another fix I've needed to get this package to compile (-Wno-maybe-unitialized added to VBOX_GCC_OPT). Obviously, you may not want to include that officially. I'm not sure why I seem to be the only one with that issue since this package won't compile with gcc 4.8 and 4.9+ generates maybe-unitialized errors on all of my systems.
Comment 8 Oleksii 2016-04-15 14:25:28 UTC
Patch going to reject. Please, can You check why?
Comment 9 Oleksii 2016-04-15 14:42:18 UTC
I have compiled without error. So partially fixed.
But packages app-emulation/virtualbox-guest-additions fails with the same error.
Please, can You make patch for this package?
Thank You
Comment 10 Lars Wendler (Polynomial-C) gentoo-dev 2016-04-19 17:11:43 UTC
*** Bug 580544 has been marked as a duplicate of this bug. ***
Comment 11 Ben Kohler gentoo-dev 2017-08-31 18:38:49 UTC
*** Bug 612850 has been marked as a duplicate of this bug. ***
Comment 12 Ben Kohler gentoo-dev 2017-08-31 18:39:00 UTC
*** Bug 580544 has been marked as a duplicate of this bug. ***
Comment 13 Andreas K. Hüttel gentoo-dev 2017-10-20 20:21:14 UTC
Ping - this is now blocking glibc-2.25 stabilization.
Comment 14 Pacho Ramos gentoo-dev 2017-12-15 22:07:19 UTC
*** Bug 616296 has been marked as a duplicate of this bug. ***
Comment 15 Pacho Ramos gentoo-dev 2017-12-15 22:08:28 UTC
Do we need to keep this package? -> bug 614308
Comment 16 Andreas K. Hüttel gentoo-dev 2018-04-29 21:42:49 UTC
This is already fixed in current stable xf86-video-virtualbox-5.1.32