Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 579910 - app-emulation/virtualbox-guest-additions-5.0.16 fails to build - VBox/Runtime/r3/linux/sysfs.cpp:308:48: error: 'makedev' was not declared in this scope
Summary: app-emulation/virtualbox-guest-additions-5.0.16 fails to build - VBox/Runtime...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2016-04-14 07:19 UTC by Tomáš Mózes
Modified: 2017-06-25 20:02 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.bz2 (build.log.bz2,16.17 KB, application/x-bzip2)
2016-04-14 07:35 UTC, Tomáš Mózes
Details
emerge-info.txt (emerge-info.txt,5.75 KB, text/plain)
2017-03-16 20:51 UTC, Toralf Förster
Details
app-emulation:virtualbox-guest-additions-5.1.18:20170316-204305.log.bz2 (app-emulation:virtualbox-guest-additions-5.1.18:20170316-204305.log.bz2,17.10 KB, application/x-bzip)
2017-03-16 20:51 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,520.59 KB, text/plain)
2017-03-16 20:51 UTC, Toralf Förster
Details
environment (environment,143.42 KB, text/plain)
2017-03-16 20:51 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,37.51 KB, application/x-bzip)
2017-03-16 20:51 UTC, Toralf Förster
Details
temp.tbz2 (temp.tbz2,49.49 KB, application/x-bzip)
2017-03-16 20:51 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomáš Mózes 2016-04-14 07:19:02 UTC
Portage 2.2.28 (python 3.4.3-final-0, default/linux/amd64/13.0, gcc-5.3.0, glibc-2.23-r1, 4.4.7-gentoo x86_64)
=================================================================
System uname: Linux-4.4.7-gentoo-x86_64-Intel-R-_Core-TM-_i5-3570_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:     8174556 total,   6931228 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Thu, 14 Apr 2016 05:00:01 +0000
sh bash 4.3_p42-r2
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r2::gentoo
dev-java/java-config:     2.2.0-r3::gentoo
dev-lang/perl:            5.22.1::gentoo
dev-lang/python:          2.7.11-r2::gentoo, 3.4.3-r7::gentoo, 3.5.1-r2::gentoo
dev-util/cmake:           3.5.1::gentoo
dev-util/pkgconfig:       0.29.1::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.20.5::gentoo
sys-apps/sandbox:         2.10-r2::gentoo
sys-devel/autoconf:       2.69-r2::gentoo
sys-devel/automake:       1.13.4::gentoo, 1.14.1::gentoo, 1.15-r2::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            5.3.0::gentoo
sys-devel/gcc-config:     1.8-r1::gentoo
sys-devel/libtool:        2.4.6-r2::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.5::gentoo (virtual/os-headers)
sys-libs/glibc:           2.23-r1::gentoo

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php7.0/ext-active/ /etc/php/cgi-php7.0/ext-active/ /etc/php/cli-php7.0/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://tux.rainside.sk/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --exclude=/.git"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv mmx mmxext modules multilib ncurses nptl openmp pam pcre readline seccomp session sse sse2 ssl tcpd unicode xattr zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core authz_host dir mime unixd socache_shmcb log_config rewrite vhost_alias log_forensic proxy proxy_fcgi info status deflate filter authn_file authz_user access_compat actions alias authn_alias authn_anon env expires headers mime_magic negotiation reqtimeout setenvif version remoteip" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-0" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Tomáš Mózes 2016-04-14 07:35:58 UTC
Created attachment 430358 [details]
build.log.bz2
Comment 2 Tomáš Mózes 2016-04-14 07:36:59 UTC
The makedev macro is defined in sys/sysmacros.h:

#define makedev(maj, min) gnu_dev_makedev (maj, min)

With this patch it compiles and runs:
--- VirtualBox-5.0.16/src/VBox/Runtime/r3/linux/sysfs.cpp.orig  2016-03-04 19:30:03.000000000 +0000
+++ VirtualBox-5.0.16/src/VBox/Runtime/r3/linux/sysfs.cpp       2016-04-14 07:23:14.659880738 +0000
@@ -43,6 +43,7 @@
 #include <sys/sysctl.h>
 #include <sys/stat.h>
 #include <sys/fcntl.h>
+#include <sys/sysmacros.h>
 #include <errno.h>

 /** @todo r=bird: This whole API should be rewritten to use IPRT status codes.
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2016-04-14 19:12:11 UTC
*** Bug 579970 has been marked as a duplicate of this bug. ***
Comment 4 Lukas Elsner 2016-04-15 12:27:50 UTC
confirming the bug as well as the working patch :)
Comment 5 Oleksii 2016-04-15 12:32:42 UTC
Hello there! Sorry, but how to add fix in mentioned file?
Please help. Thank You
Comment 6 Lukas Elsner 2016-04-15 13:23:19 UTC
https://wiki.gentoo.org/wiki//etc/portage/patches
Comment 7 Toralf Förster gentoo-dev 2017-03-16 20:50:56 UTC
same at the tinderbox image gnome-systemd_20170301-222559
Comment 8 Toralf Förster gentoo-dev 2017-03-16 20:51:00 UTC
Created attachment 467268 [details]
emerge-info.txt
Comment 9 Toralf Förster gentoo-dev 2017-03-16 20:51:03 UTC
Created attachment 467270 [details]
app-emulation:virtualbox-guest-additions-5.1.18:20170316-204305.log.bz2
Comment 10 Toralf Förster gentoo-dev 2017-03-16 20:51:06 UTC
Created attachment 467272 [details]
emerge-history.txt
Comment 11 Toralf Förster gentoo-dev 2017-03-16 20:51:09 UTC
Created attachment 467274 [details]
environment
Comment 12 Toralf Förster gentoo-dev 2017-03-16 20:51:12 UTC
Created attachment 467276 [details]
etc.portage.tbz2
Comment 13 Toralf Förster gentoo-dev 2017-03-16 20:51:16 UTC
Created attachment 467278 [details]
temp.tbz2
Comment 14 Lars Wendler (Polynomial-C) gentoo-dev 2017-06-25 20:02:41 UTC
commit fbb4e03fbd53bd42e46d0ce64e66dca3d8154f79 (HEAD -> master, origin/master, origin/HEAD)
Author: Kacper Kołodziej <kacper@kolodziej.in>
Date:   Wed Jun 14 22:06:17 2017

    x11-drivers/xf86-video-virtualbox: fix bug 579910

    Package-Manager: Portage-2.3.6, Repoman-2.3.2
    Closes: https://github.com/gentoo/gentoo/pull/4932