Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 612850 - x11-drivers/xf86-video-virtualbox-5.1.18 : /.../sysfs.cpp:493:58: error: ‘makedev’ was not declared in this scope
Summary: x11-drivers/xf86-video-virtualbox-5.1.18 : /.../sysfs.cpp:493:58: error: ‘mak...
Status: RESOLVED DUPLICATE of bug 579946
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Lars Wendler (Polynomial-C)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: glibc-sysmacros
  Show dependency tree
 
Reported: 2017-03-16 20:43 UTC by Toralf Förster
Modified: 2017-08-31 18:38 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge-info.txt (emerge-info.txt,5.95 KB, text/plain)
2017-03-16 20:43 UTC, Toralf Förster
Details
emerge-history.txt (emerge-history.txt,326.67 KB, text/plain)
2017-03-16 20:43 UTC, Toralf Förster
Details
environment (environment,127.61 KB, text/plain)
2017-03-16 20:43 UTC, Toralf Förster
Details
etc.portage.tbz2 (etc.portage.tbz2,54.08 KB, application/x-bzip)
2017-03-16 20:43 UTC, Toralf Förster
Details
x11-drivers:xf86-video-virtualbox-5.1.18:20170316-203801.log.bz2 (x11-drivers:xf86-video-virtualbox-5.1.18:20170316-203801.log.bz2,16.70 KB, application/x-bzip)
2017-03-16 20:43 UTC, Toralf Förster
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2017-03-16 20:43:01 UTC
x86_64-pc-linux-gnu-g++ -c -O2 -g -pipe -pedantic -Wshadow -Wall -Wextra -Wno-missing-field-initializers -Wno-unused -Wno-trigraphs -fdiagnostics-show-option -Wno-unused-parameter    -Wlogical-op   -Wno-variadic-macros -Wno-long-long -Wunused-variable -Wunused-function -Wunused-label -Wunused-parameter  -Wno-overloaded-virtual -Wno-variadic-macros -O2 -pipe -march=native -Wall  -fno-omit-frame-pointer -fno-strict-aliasing -fvisibility=hidden -DVBOX_HAVE_VISIBILITY_HIDDEN -DRT_USE_VISIBILITY_DEFAULT -fvisibility-inlines-hidden   -fno-exceptions  -m64 -Iinclude -I/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/src/libs/liblzf-3.4 -I/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/src/libs/kStuff/kStuff/include -I/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release/obj/RuntimeGuestR3/dtrace -I/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/include -I/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release -DVBOX -DVBOX_OSE -DVBOX_WITH_64_BITS_GUESTS -DVBOX_WITH_REM -DVBOX_WITH_RAW_MODE -DRT_OS_LINUX -D_FILE_OFFSET_BITS=64 -DRT_ARCH_AMD64 -D__AMD64__ -DVBOX_WITH_DEBUGGER -DVBOX_WITH_HARDENING -DRTPATH_APP_PRIVATE=\"/opt/VirtualBox\" -DRTPATH_APP_PRIVATE_ARCH=\"/opt/VirtualBox\" -DRTPATH_SHARED_LIBS=\"/opt/VirtualBox\" -DRTPATH_APP_DOCS=\"/opt/VirtualBox\" -DIN_RING3 -DVBOX_WITH_DTRACE -DVBOX_WITH_DTRACE_R3 -DIN_GUEST -DIN_GUEST_R3 -DIN_RT_R3 -DGC_ARCH_BITS=64 -DIN_RT_R3 -DIN_SUP_R3 -DLDR_WITH_NATIVE -DLDR_WITH_ELF32 -DLDR_WITH_PE -DRT_WITH_VBOX -DRT_WITHOUT_NOCRT_WRAPPERS -DNOFILEID -DLDR_WITH_KLDR -DRT_WITH_ICONV_CACHE -DLOG_USE_C99 -DRT_WITHOUT_EXEC_ALLOC -Wp,-MD,/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release/obj/RuntimeGuestR3/r3/linux/sysfs.o.dep -Wp,-MT,/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release/obj/RuntimeGuestR3/r3/linux/sysfs.o -Wp,-MP -o /var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release/obj/RuntimeGuestR3/r3/linux/sysfs.o /var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/src/VBox/Runtime/r3/linux/sysfs.cpp
/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/src/VBox/Runtime/r3/linux/sysfs.cpp: In function ‘int RTLinuxSysFsReadDevNumFileV(dev_t*, const char*, __va_list_tag*)’:
/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/src/VBox/Runtime/r3/linux/sysfs.cpp:493:58: error: ‘makedev’ was not declared in this scope
                         *pDevNum = makedev(u32Maj, u32Min);
                                                          ^
kmk: *** [/var/tmp/portage/x11-drivers/xf86-video-virtualbox-5.1.18/work/VirtualBox-5.1.18/out/linux.amd64/release/obj/RuntimeGuestR3/r3/linux/sysfs.o] Error 1

  -----------------------------------------------------------------

  This is an unstable amd64 chroot image (named plasma-abi32+64_20170309-193709) at a hardened host acting as a tinderbox.

  -----------------------------------------------------------------

gcc-config -l:
 [1] x86_64-pc-linux-gnu-6.3.0 *
llvm-config:
3.9.1
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python3.6 (fallback)
  [3]   python2.7 (fallback)
  [4]   jython2.7 (fallback)
Available Ruby profiles:
  [1]   ruby21 (with Rubygems) *
java-config:
The following VMs are available for generation-2:
*)	IcedTea JDK 7.2.6.9 [icedtea-7]
2)	IcedTea JDK 7.2.6.9 [icedtea-bin-7]
3)	IcedTea JDK 3.3.0 [icedtea-bin-8]
Available Java Virtual Machines:
  [1]   icedtea-7  system-vm
  [2]   icedtea-bin-7 
  [3]   icedtea-bin-8
Comment 1 Toralf Förster gentoo-dev 2017-03-16 20:43:04 UTC
Created attachment 467258 [details]
emerge-info.txt
Comment 2 Toralf Förster gentoo-dev 2017-03-16 20:43:08 UTC
Created attachment 467260 [details]
emerge-history.txt
Comment 3 Toralf Förster gentoo-dev 2017-03-16 20:43:11 UTC
Created attachment 467262 [details]
environment
Comment 4 Toralf Förster gentoo-dev 2017-03-16 20:43:14 UTC
Created attachment 467264 [details]
etc.portage.tbz2
Comment 5 Toralf Förster gentoo-dev 2017-03-16 20:43:17 UTC
Created attachment 467266 [details]
x11-drivers:xf86-video-virtualbox-5.1.18:20170316-203801.log.bz2
Comment 6 Ben Kohler gentoo-dev 2017-08-31 18:38:49 UTC

*** This bug has been marked as a duplicate of bug 579946 ***