Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 382321 - sci-biology/emboss-6.3 runtime functionality missing
Summary: sci-biology/emboss-6.3 runtime functionality missing
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-08 21:29 UTC by Joel Berendzen
Modified: 2015-08-27 13:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Berendzen 2011-09-08 21:29:02 UTC
Sorry to be back with problems in this miserable but useful package. 

The ajax graphics routines that are used for some output do not work for any version currently in portage or science overlay. Raw data output, for example, fails. Portage versions die with a segfault, while the heavily-patched version in the science overlay does not recognize the data output device.

Building the package outside of portage without the --enable-systemlibs configure flag works as expected.

The package does not work with libpcre-8.13.  The internal pcre version seems to be 7.9.  I suspect this discrepancy will only get worse with time.

There has also been a version bump to emboss-6.4.0 and upstream patches to that version. 

Reproducible: Always

Steps to Reproduce:
1. dotpath a.faa b.faa -wordsize 4 -graph data

Results depend on versions of libpcre and emboss installed.  If dev-libs/libpcre-8.13 is installed, the result is:

Draw a non-overlapping wordmatch dotplot of two sequences
Error: Failed to compile regular expression '[.][.]' at position 0: POSIX collating elements are not supported
Segmentation fault

If libpcre-8.12 (the stable version) and emboss-6.3.1_p4 from portage is installed (test both with and without X mysql pdf png use flags), the result is:

Draw a non-overlapping wordmatch dotplot of two sequences
Segmentation fault

With emboss-6.3.1_p4-r1 from science overlay:

Draw a non-overlapping wordmatch dotplot of two sequences
Requested device data not available

...[omitted list of plplot devices]...
Enter device number or keyword:
Comment 1 Justin Lecher gentoo-dev 2015-08-27 13:50:54 UTC
commit 08fae0a30263fd06fe51ac5b75301d574be9e1be
Author: Justin Lecher <jlec@gentoo.org>
Date:   Thu Aug 27 15:47:31 2015 +0200
    
    sci-biology/emboss: Drop old
    
    obsolets multiple bugs
    
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=542274
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=534418
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=521604
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=514014
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=493724
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=406279
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=393311
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=382321
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=378443
    
    Package-Manager: portage-2.2.20.1
    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    
    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=08fae0a30263fd06fe51ac5b75301d574be9e1be