Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 493724 - sci-biology/emboss-6.3.1_p4-r1 - .../work/EMBOSS-6.3.1/ajax/graphics/.libs/libajaxg.so: undefined reference to `c_plwid'
Summary: sci-biology/emboss-6.3.1_p4-r1 - .../work/EMBOSS-6.3.1/ajax/graphics/.libs/li...
Status: RESOLVED OBSOLETE
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Science Biology related packages
URL:
Whiteboard:
Keywords:
: 520280 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-09 07:12 UTC by Juergen Rose
Modified: 2015-08-27 13:50 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,539.07 KB, text/plain)
2013-12-09 07:12 UTC, Juergen Rose
Details
emboss-6.3.1_p4-r1-ajgraph-plplot.patch (emboss-6.3.1_p4-r1-ajgraph-plplot.patch,411 bytes, patch)
2014-07-05 08:15 UTC, Juergen Rose
Details | Diff
an ebuild using the emboss-6.3.1_p4-r1-ajgraph-plplot.patch (emboss-6.3.1_p4-r1.ebuild,3.51 KB, text/plain)
2014-07-05 08:19 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2013-12-09 07:12:57 UTC
Created attachment 364990 [details]
build.log

'emerge emboss' fails with:
...
libtool: link: x86_64-pc-linux-gnu-gcc -I/usr/include/postgresql-9.0 -march=native -O2 -pipe -O2 -DNO_AUTH -D__amd64__ -I/usr/include/mysql -Wl,-O1 -o .libs/acdc acdc.o  -L/usr/lib64/postgresql-9.0/lib64 -Wl,--as-needed -L/usr/lib64/mysql ../nucleus/.libs/libnucleus.so /var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/acd/.libs/libacd.so ../ajax/acd/.libs/libacd.so /var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/graphics/.libs/libajaxg.so /var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/ajaxdb/.libs/libajaxdb.so ../ajax/ajaxdb/.libs/libajaxdb.so /var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/ensembl/.libs/libensembl.so ../ajax/ensembl/.libs/libensembl.so ../ajax/graphics/.libs/libajaxg.so /var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/core/.libs/libajax.so -lplplotd /usr/lib64/libltdl.so -lcsirocsa -lcsironn -lqhull -lqsastime ../ajax/core/.libs/libajax.so -lexpat -lpcre -lpq -lmysqlclient -lpthread -lssl -lcrypto -ldl -lhpdf -lgd -lpng -lz -lm
/var/tmp/portage/sci-biology/emboss-6.3.1_p4-r1/work/EMBOSS-6.3.1/ajax/graphics/.libs/libajaxg.so: undefined reference to `c_plwid'
collect2: error: ld returned 1 exit status
Makefile:2634: recipe for target 'aaindexextract' failed
make[2]: *** [aaindexextract] Error 1





root@lynx:/usr/local/portage/sci-biology(41)# emerge --info '=sci-biology/emboss-6.3.1_p4-r1::gentoo'
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.8.2, glibc-2.17, 3.12.3-gentoo x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.12.3-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8300_@_2.40GHz-with-gentoo-2.2
KiB Mem:     3987136 total,   1279792 free
KiB Swap:   12582908 total,  12578848 free
Timestamp of tree: Sun, 08 Dec 2013 15:30:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.1-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.6, 1.12.6, 1.14
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           4.0
sys-kernel/linux-headers: 3.12 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo x11 sunrise lordvan sage-on-gentoo science local g-cpan g-octave
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage_lynx"
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/sunrise /var/lib/layman/lordvan /var/lib/layman/sage-on-gentoo /var/lib/layman/science /usr/local/portage /var/lib/cpan /var/lib/g-octave"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli cmake consolekit cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3 id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig john jpeg jpeg2k kate kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack laptop latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp mudflap multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp openvg pam pango pcre pda pdf perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm projectx pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline real reiserfs reports rhythmbox rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tcl tcpd tex tex4ht texmacs tgif theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb userlocales utempter v4l vaapi vala valgrind vdpau video virt-network virtualbox visio vorbis vpx wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xemacs xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DRACUT_MODULES="caps lvm syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev synaptics void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler ruby websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


root@lynx:/usr/local/portage/sci-biology(48)# emerge -pqv '=sci-biology/emboss-6.3.1_p4-r1::gentoo'
[ebuild   R   ] sci-biology/emboss-6.3.1_p4-r1 [6.3.1_p4-r1] USE="X doc%* mysql pdf png postgres -minimal -static-libs" 

!!! The following installed packages are masked:
- sci-biology/embassy-cbstools-1.0.0-r3::science (masked by: package.mask)
/var/lib/layman/science/profiles/package.mask:
# Justin Lecher <jlec@gentoo.org> (20 Feb 2012)
# They are broken in one or the other way
# Need to be bumped to emboss-6.4.0

- sci-biology/embassy-domainatrix-0.1.0-r6::science (masked by: package.mask)
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
Comment 1 Iddo 2014-03-19 20:52:13 UTC
Yes, this actually happens.
Comment 2 Jeremy Stent 2014-06-14 02:16:11 UTC
This seems to be a side effect of the latest plplot libraries.
Comment 3 Jeremy Stent 2014-06-14 02:25:39 UTC
edit ajax/graphics/ajgraph.c and replace the two instances of plwid with plwidth, and it should compile.
Comment 4 Martin Mokrejš 2014-07-04 16:49:27 UTC
I added a patch emboss-6.3.1_p4-r2_rename_plwid_to_plwidth.patch to sci overlay but it seems to me it should be ONLY applied if >=plplot-5.9.10 ?

Justin, if you can come up with a proper incarnation of it in ebuilds please fix also the other ones in overlay and in the main tree. Thank you.
Comment 5 Juergen Rose 2014-07-05 07:27:25 UTC
(In reply to Martin Mokrejš from comment #4)
> I added a patch emboss-6.3.1_p4-r2_rename_plwid_to_plwidth.patch to sci
> overlay but it seems to me it should be ONLY applied if >=plplot-5.9.10 ?
> 
> Justin, if you can come up with a proper incarnation of it in ebuilds please
> fix also the other ones in overlay and in the main tree. Thank you.

Where can I find the patch?
Comment 6 Juergen Rose 2014-07-05 08:15:39 UTC
Created attachment 380210 [details, diff]
emboss-6.3.1_p4-r1-ajgraph-plplot.patch
Comment 7 Juergen Rose 2014-07-05 08:19:34 UTC
Created attachment 380212 [details]
an ebuild using the emboss-6.3.1_p4-r1-ajgraph-plplot.patch
Comment 8 Iddo 2014-08-19 22:01:41 UTC
*** Bug 520280 has been marked as a duplicate of this bug. ***
Comment 9 Ted Tanberry 2015-02-05 13:04:17 UTC
Please give emboss-6.6.0 in the science overlay a try, it is properly linked such that all shared objects are properly linked and -Wl,--as-needed works properly on binaries.
Comment 10 Justin Lecher gentoo-dev 2015-08-27 13:50:33 UTC
commit 08fae0a30263fd06fe51ac5b75301d574be9e1be
Author: Justin Lecher <jlec@gentoo.org>
Date:   Thu Aug 27 15:47:31 2015 +0200
    
    sci-biology/emboss: Drop old
    
    obsolets multiple bugs
    
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=542274
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=534418
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=521604
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=514014
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=493724
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=406279
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=393311
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=382321
    Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=378443
    
    Package-Manager: portage-2.2.20.1
    Signed-off-by: Justin Lecher <jlec@gentoo.org>
    
    https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=08fae0a30263fd06fe51ac5b75301d574be9e1be